cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
2819
Views
0
Helpful
14
Replies

failed upgrade ASR 9001

BorislavPenchev0962
Participant
Participant

hi all,
we tried to Update a ASR9001,
but gives an error; could you please advise what we probably need to do ?

here output from how we tried to install new IOS

 

install add disk1:ASR9K-iosxr-px-k9-6.7.1.tar activate

continue:


RP/0/RSP0/CPU0:r101(admin)#install add
disk1:ASR9K-iosxr-px-k9-6.7.1.tar ac$
Tue Aug 11 06:40:08.288 MEST
Install operation 19 '(admin) install add /disk1:ASR9K-iosxr-px-k9-6.7.1.tar
activate' started by user 'admin' via CLI at 06:40:08 MEST Tue Aug 11 2020.
Warning: The following file has the suffix '.tar' and will be treated
as a tar
Warning: file:
Warning: /disk1:ASR9K-iosxr-px-k9-6.7.1.tar
Warning: If a file should not be treated as tar file:
RP/0/RSP0/CPU0:Aug 11 06:40:10.492 : instdir[259]:
%INSTALL-INSTMGR-4-INSTALL_OPERATION_WARNING : A warning occurred during
install operation 19. See 'show install log 19 detail' for more
informaWarning: - change the file extension.
tion.
Warning: To stop this message being displayed:
Warning: - use the tar keyword to explicitly specify a tar file.
| 1% complete: The operation can still be aborted (ctrl-c for
options)RP/0/RSP0/CPU0:Aug 11 06:40:47.732 : SSHD_[67544]:
%SECURITY-SSHD-4-INFO_FAILURE : Failed authentication attempt by user
'root' from 'https://protect-eu.mimecast.com/.domain=41.81.11.11' on 'vty0'
RP/0/RSP0/CPU0:Aug 11 06:40:52.110 : SSHD_[67545]:
%SECURITY-SSHD-4-INFO_FAILURE : Failed authentication attempt by user
'root' from 'https://protect-eu.mimecast.com.domain=211.97.7.20' on 'vty0'
RP/0/RSP0/CPU0:Aug 11 06:41:01.548 : SSHD_[67544]: %SECURITY-SSHD-4-

[ ... ]

Info: The following files were extracted from the tar file
Info: '/disk1:ASR9K-iosxr-px-k9-6.7.1.tar' and will be added to the
entire
Info: router:
Info:
Info: README-ASR9K-iosxr-px-k9-6.7.1.txt (skipped - not a pie)
Info: asr9k-video-px.pie-6.7.1
Info: asr9k-services-px.pie-6.7.1
Info: asr9k-services-infra-px.pie-6.7.1
Info: asr9k-optic-px.pie-6.7.1
Info: asr9k-mpls-px.pie-6.7.1
Info: asr9k-mini-px.pie-6.7.1
Info: asr9k-mgbl-px.pie-6.7.1
Info: asr9k-mcast-px.pie-6.7.1
Info: asr9k-li-px.pie-6.7.1
Info: asr9k-k9sec-px.pie-6.7.1
Info: asr9k-fpd-px.pie-6.7.1
Info: asr9k-doc-px.pie-6.7.1
Info: asr9k-bng-px.pie-6.7.1
Info: asr9k-asr9000v-nV-px.pie-6.7.1
Info:
Part 1 of 2 (add software): Started
The install operation will continue asynchronously.
RP/0/RSP0/CPU0:r101(admin)#RP/0/RSP0/CPU0:Aug 11 06:46:45.428 :
sam_server[417]: %SECURITY-SAM-4-WARNING_NO_BACKUP_LOG : SAM log backup
file is not present. Creating a new one
RP/0/RSP0/CPU0:Aug 11 06:47:08.935 : SSHD_[67543]:
%SECURITY-SSHD-4-INFO_FAILURE : Failed authentication attempt by user
'root' from 'https://protect-eu.mimecast.com/s/?domain=41.81.11.11' on 'vty0'

[ ... ]

the Router then had logged out:

*
* The idle timeout is soon to expire on this line
*

we checked the status with show install


went to 10%, and throw a message no active Install-Prozess
please verify "show install log:

sh install log
[ ... ]
--------------------------------------------------------------------------------

Install operation 19 started by user 'admin' via CLI at 06:40:08 MEST
Tue Aug 11 2020.
(admin) install add /disk1:ASR9K-iosxr-px-k9-6.7.1.tar activate
Install operation 19 failed at 07:26:28 MEST Tue Aug 11 2020.

--------------------------------------------------------------------------------

 

we found the following:


RP/0/RSP0/CPU0:Aug 11 07:21:20.656 : licmgr[319]:
%LICENSE-LICMGR-4-PACKAGE_LICENSE_INVALID : Package requesting
A9K-LI-LIC license is activated on Rack0 and node node0_RSP0_CPU0
without a valid license/ valid configuration

 

we have license , it was working fine with it before;
we do we get such a messages ?

1 Accepted Solution

Accepted Solutions

You should be able to go straight to 6.3.3 or 6.4.2 or 6.5.1 and then to 6.7.1, however cluster was last supported on 5.3.4. You can still configure it, but if you open a TAC case we can't guarantee RCA for any issues seen.

You can turboboot however only the mini is copied and you have to copy over the other packages after turboboot. If you don't use the format option then the config will still exist but portions of it won't be loaded due to missing the base packages for the CLI itself.

 

https://www.cisco.com/c/en/us/products/collateral/routers/asr-9000-series-aggregation-services-routers/eos-eol-notice-c51-739355.html

 

Sam

View solution in original post

14 Replies 14

smilstea
Cisco Employee
Cisco Employee

Can you give the show install log detail?

It should tell me the error reason.

 

Sam

Hi Sam,

 

l attached the log here

The install failed because you needed to respond to a prompt.

 

Info: Install operation 19 is paused as the user must answer a question.

Info: Please continue the operation using one the following steps:

Info: - run the command '(admin) install operation 19 attach synchronous' and then answer the query.

Info: - run the command '(admin) install attach 19' and then answer the query.

 

Error: The install operation failed due to a system error. Please collect diagnostic information using 'show

Error: tech-support install' and pass this information to your TAC representative for support. (details: 'Install

Error: Manager' detected the 'informational' condition 'The Install operation timed out waiting for user input')

 

 

Sam

Hi Sam,

 

we tried as you advised:

 

install attach 19 synchronous

 

 

RP/0/RSP0/CPU0:r101(admin)#

RP/0/RSP0/CPU0:r101(admin)#install attach 19 synchronous

Tue Sep  2 09:23:50.426 MEST

Error:    Cannot proceed with 'install attach 19' because 19 is not a valid

Error:    operation id.

Error:    Suggested steps to resolve this:

Error:     - use 'show install request' to see the state of the current

install

Error:       operation.

Error:     - use 'show install log' to see the results of previous install

Error:       operations.

 

 

 

we applied the commands:

show install request - no requests message

any ideas what we did wrong ?

 

RP/0/RSP0/CPU0:r101(admin)#

RP/0/RSP0/CPU0:r101(admin)#show install request

Tue Sep  2 09:23: MEST

There are no install requests in operation.

 

----

 

sh install log below:

 

install operation 3 started by user 'root' via CLI at 10:45:04 UTC Sat

Dec 17

2016.

(admin) install add /https://protect-eu.mimecast.com/ activate

synchronous

Install operation 3 completed successfully at 10:47:40 UTC Sat Dec

17 2016.


--------------------------------------------------------------------------------


Install operation 4 started by user 'root' via CLI at 10:47:45 UTC Sat

Dec 17

2016.

(admin) install commit

Install operation 4 completed successfully at 10:47:52 UTC Sat Dec

17 2016.


--------------------------------------------------------------------------------


Install operation 5 started by user 'admin' via CLI at 02:18:08 UTC Tue

Feb 07

2017.

(admin) install add /https://protect-eu.mimecast.com/s/

Install operation 5 failed at 02:21:39 UTC Tue Feb 07 2017.


--------------------------------------------------------------------------------


Install operation 6 started by user 'admin' via CLI at 23:07:03 UTC Wed

Feb 08

2017.

(admin) install verify packages

Install operation 6 completed successfully at 23:11:56 UTC Wed Feb

08 2017.


--------------------------------------------------------------------------------


Install operation 7 started by user 'admin' via CLI at 23:13:50 UTC Wed

Feb 08

2017.

(admin) install add tar /harddisk:ASR9K-iosxr-px-k9-6.1.2.tar activate

Install operation 7 failed at 23:44:28 UTC Wed Feb 08 2017.


--------------------------------------------------------------------------------


Install operation 8 started by user 'admin' via CLI at 01:05:59 UTC Thu

Feb 09

2017.

(admin) install add tar /harddisk:ASR9K-iosxr-px-k9-6.1.2.tar activate

synchronous

Install operation 8 completed successfully at 01:24:50 UTC Thu Feb

09 2017.


--------------------------------------------------------------------------------


Install operation 9 started by user 'admin' via CLI at 01:33:18 UTC Thu

Feb 09

2017.

(admin) install commit

Install operation 9 failed at 01:33:20 UTC Thu Feb 09 2017.


--------------------------------------------------------------------------------


Install operation 10 started by user 'admin' via CLI at 01:33:49 UTC Thu

Feb 09

2017.

(admin) install commit

Install operation 10 failed at 01:33:51 UTC Thu Feb 09 2017.


--------------------------------------------------------------------------------


Install operation 11 started by user 'admin' via CLI at 01:35:36 UTC Thu

Feb 09

2017.

(admin) install commit

Install operation 11 completed successfully at 01:35:46 UTC Thu Feb 09

2017.


--------------------------------------------------------------------------------


Install operation 12 started by user 'admin' via CLI at 03:59:21 UTC Thu

May 18

2017.

(admin) install remove inactive

Install operation 12 completed successfully at 04:07:22 UTC Thu May 18

2017.


--------------------------------------------------------------------------------


Install operation 13 started by user 'admin' via CLI at 04:08:27 UTC Thu

May 18

2017.

(admin) install add tar /harddisk:/ASR9K-iosxr-px-k9-6.1.3.tar activate

synchronous

Install operation 13 completed successfully at 04:47:26 UTC Thu May 18

2017.


--------------------------------------------------------------------------------


Install operation 14 started by user 'admin' via CLI at 04:57:07 UTC Thu

May 18

2017.

(admin) install commit

Install operation 14 completed successfully at 04:57:17 UTC Thu May 18

2017.


--------------------------------------------------------------------------------


Install operation 15 started by user 'admin' via CLI at 05:09:58 UTC Thu

May 18

2017.

(admin) install remove inactive

Install operation 15 completed

 

attached install-log-detail

 

Regards

attached install-log-detail

It's not working because the install operation is over now, you will need to do the install again.

 

Sam

Hi Sam,


we started the install again but we encountered following errors:


admin
install add tar disk1:ASR9K-iosxr-px-k9-6.7.1.tar activate


we get the error:

The install operation will continue asynchronously.


Proceed with this install operation (y/n)? [y]


nfo: Install Method: Parallel Reload
\ 10% complete: The operation can still be aborted (ctrl-c for options)RP/0/RSP0/CPU0:Sep 12 09:55:23.501 : instdir[259]: %INSTALL-INSTMGR-3-INSTALL_OPERATION_USER_ERROR : User error occurred during install operation 20. See 'show install log 20 detail' for more information.
Error: Cannot proceed with the activation because of the following API
Error: incompatibilities:
Error: Checks failed for RP, ASR9001-RP, RP-GIMLI
Error: 3 APIs with consumers but no producers.


we get also this error:


There is no valid license for the following package:
Warning:
Warning: disk0:asr9k-li-6.7.1


attached show install log detail


any ideas ?


Regards

That's an un-needed package - lawful intercept.

 

You can remove it with the following:

RP/0/RSP0/CPU0:XR# admin install deactivate disk0:asr9k-li-6.7.1

RP/0/RSP0/CPU0:XR# admin install remove disk0:asr9k-li-6.7.1

 

 

The issue isn't with LI package, that is a warning we can ignore, the failure comes due to the API incompatibility.

This is due to CSCvj18407 and can be seen when skipping many versions.

 

<B>Conditions:</B>
The issue applies to all ASR 9000 cards running cXR. It does not apply to eXR.
Current image is lower than 6.3.3, or the current image is 6.4.1
Target image version is higher than 6.6.6

<B>Workaround:</B>
First upgrade to 633/642/651, then upgrade to the target image.
OR, Turboboot upgrade to target image.

 

Thanks,

Sam

Hi Sam

 

so we need to follow this upgrade path ?

6.1.4 -> 6.3.3 ->

6.4.2 -> 6.5.1 -> 6.7.1

if we go for Turboboot , are there any issues with the config when system is upgraded this way ?

we have a cluster , anything we need to take into account?

Regards

You should be able to go straight to 6.3.3 or 6.4.2 or 6.5.1 and then to 6.7.1, however cluster was last supported on 5.3.4. You can still configure it, but if you open a TAC case we can't guarantee RCA for any issues seen.

You can turboboot however only the mini is copied and you have to copy over the other packages after turboboot. If you don't use the format option then the config will still exist but portions of it won't be loaded due to missing the base packages for the CLI itself.

 

https://www.cisco.com/c/en/us/products/collateral/routers/asr-9000-series-aggregation-services-routers/eos-eol-notice-c51-739355.html

 

Sam

Previous installation issue has been resolved ,

however we encountered another error when upgrade from 6.3.3 to 6.7.3; Router could not run the package - Install operation 42* from the Logfile.

then tried to upgrade from Version 6.5.3 , to Upgrade to 6.7.3 didnt worked.(*Install operation 43 and 49*)

attached show install log detail

l think we can upgrade directly 6.3.3 to 6.7.3 versions;

 

 

Hi Sam,

came across this post and want to clarify one thing as were soon to do carry our and upgrade to 9904/RSP880/MOD400 running 6.2.3

our idea is/was to upgrade direct to 6.7.3 as the mop document suggests its possible, however this thread seems to say its not advisable,  due to CSCvj18407

Reading the notes for CSCvj18407 indicates that upgrading to interim release 6.3.3 as a workaround to this issue.

So my question is:  If I install the SMU for CSCvj18407 on 6.2.3,  does this then solve the API incompatibility issue and I can then safely upgrade 6.2.3 + CSCvj18407 to 6.7.3 without interim release ?

or regardless of SMUs on 6.2.3, I cannot go direct to 6.7.3 ?

 

thanks

Mark

 

-

I have not tested an upgrade with this SMU, but that is indeed what it should do/allow.
Sam
Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

Recognize Your Peers