cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
7298
Views
0
Helpful
42
Replies

FN - 63979 - ASR9000, CRS, and XR12000 That Run Cisco IOS-XR 5.3.0 and Earlier - Oct 17, 2015 SW Certificate Expiration - SMU Upgrade

Eddie Chami
Cisco Employee
Cisco Employee

This is a place holder for questions on FN 63979

Details are here: http://www.cisco.com/c/en/us/support/docs/field-notices/639/fn63979.html

Use this thread to ask any questions. 

42 Replies 42

Eddie Chami
Cisco Employee
Cisco Employee

Folks, when installing the post expiry smu, make sure its installed alone, and NOT part of a .TAR which has other SMUs, else you'll see “tar file corrupted”. 

Make sure the steps are followed in the link above. 

Eddie.

Hi Eddie,

Customer has installed ASR9K release 4.3.2 with pre-expiry SMU already. They plan to upgrade the ASR9K to 5.1.3 and add some SMUs on 20th Oct.

The question is:
Do they still need to install post-expiry SMU (#sam add certificate /disk0:/css-root.cer root trust, (admin)# install add /disk0:/asr9k-px-5.1.3.CSCut52232.pie) before they upgrade to 5.1.3 and add new SMUs on 20th Oct?

 

Hi Chatsai,

Very good question. In the case you described, since the pre-expiry SMU is installed on 4.3.2, the install to 5.1.3 will be straight forward. Once on 5.1.3, any further installs will require them to add the SAM.cer and them install add asr9k-px-5.1.3.CSCut52232.pie. 

Eddie.

Eddie,

So customer will upgrade 4.3.2 to 5.1.3 without adding SAM.cer and install add asr9k-px-5.1.3.CSCut52232.pie.

 

My question is:

After 5.1.3 is upgraded, they are going to add a 5.1.3 tar file which has 21 SMUs. Do they need to add SAM.cer and install add asr9k-px-5.1.3.CSCut52232.pie prior to installing the 21-SMU tar file?

Thanks,

Charlie

Your correct Charlie, they will need to install the SAM, take out CSCut52232 from the .TAR, installed it alone first. follow up with installing the .TAR. 

Eddie.

Eddie,

Thanks. It is very helpful. Now I can send these steps to customer:

on 20th Oct 2015:

#1) upgrade 4.3.2 (pre-expiry has installed already) to 5.1.3    (straight upgrade)
#2) (console port) #sam add certificate /disk0:/css-root.cer root trust
#3) (admin)# install add /disk0:/asr9k-px-5.1.3.CSCut52232.pie
#4) (admin)# install add tar disk0:/5.1.3-21SMU.tar sync

 

Thanks,

Charlie

This steps should work too.

0#) ASR9K release 4.3.2 with Pre-Expiry SMU installed already.
1#) install add tar disk0:/ASR9K-iosxr-px-k9-5.1.3-CTL-NPE-PIEand21SMU.tar sync
2#) (console port) #sam add certificate /disk0:/css-root.cer root trust
3#) (admin)# install add /disk0:/asr9k-px-5.1.3.CSCut52232.pie
 

hello team,

We would like to perform a downgrade from 5.3.2 -> 5.1.3, according to our understanding no certificates are required since the current ios xr 5.3.2 is not affected.

So, we can simply downgrade to the desired release using the standard procedure.

Is this correct?

Thanks

The downgrade is straight forward, but do make sure you activate(include) the Post expiry SMU or SP7 + SAM so your golden once running 5.1.3. 

aditya.wisnu
Beginner
Beginner

hi Eddie,

I can't find details on post expiry smu, since it will be available on Oct 18.

Is there any earlier info on post expiry smu impact, is it hit (reload system) or hitless?

I need this to confirm for maintenance window will be needed or not.

 

Aditya

Both will be hitless.

 

Sam

david.kasper
Beginner
Beginner

Hey Eddie,

 

now i have a box running the following :

 

admin show install active summary
Tue Oct 20 08:35:18.652 CET
Default Profile:
  SDRs:
    Owner
  Active Packages:
    disk0:asr9k-mini-px-4.3.4
    disk0:asr9k-base-4.3.4.sp3-1.0.0
    disk0:iosxr-mgbl-4.3.4.sp3-1.0.0
    disk0:iosxr-ce-4.3.4.sp3-1.0.0
    disk0:asr9k-fwding-4.3.4.sp3-1.0.0
    disk0:asr9k-cpp-4.3.4.sp3-1.0.0
    disk0:iosxr-routing-4.3.4.sp3-1.0.0
    disk0:iosxr-fwding-4.3.4.sp3-1.0.0
    disk0:asr9k-os-mbi-4.3.4.sp3-1.0.0
    disk0:iosxr-mpls-4.3.4.sp3-1.0.0
    disk0:iosxr-infra-4.3.4.sp3-1.0.0
    disk0:asr9k-fpd-px-4.3.4
    disk0:asr9k-mgbl-px-4.3.4
    disk0:asr9k-mpls-px-4.3.4
    disk0:asr9k-k9sec-px-4.3.4
    disk0:asr9k-9000v-nV-px-4.3.4
    disk0:asr9k-px-4.3.4.CSCui95665-1.0.0
    disk0:asr9k-px-4.3.4.CSCut30136-1.0.0

 

Pre-Ex-SMU is installed on top of the SP3. Can i now just go ahaed and install SP8 on top of it which should superceed both SP3 and the pre-ex-SMU ?

Cheers,

David

Hi David,

Yes you may do that. 

Eddie.

Hi Guys,

 

I ran into an issue. I am running 4.3.4 IOS XR software on ASR 9010 RSP 440. When I try to install any of the package it says that the .pie file is corrupt. Can you help me here.

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community: