ANNOUNCEMENT - The community will be down for maintenace this Thursday August 13 from 12:00 AM PT to 02:00 AM PT. As a precaution save your work.
cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
177
Views
0
Helpful
4
Replies
Highlighted
Cisco Employee

Golden ISO built failed

When run ./gisobuild.py, below errors seen:

('\n', 'Exception:', <type 'exceptions.RuntimeError'>, RuntimeError("Error CMD=chroot /mnt/hgfs/aaa/tmpfMc211 rpm -qp --qf '%{NAME};%{VERSION};%{RELEASE};%{ARCH};%{PACKAGETYPE};%{PACKAGEPRESENCE};%{PIPD};%{CISCOHW};%{CARDTYPE};%{BUILDTIME};%{GROUP};%{VMTYPE};%{SUPPCARDS};%{PREFIXES};%{XRRELEASE};' asr9k-bng-x64-1.0.0.0-r702.x86_64.rpm returned --->chroot: failed to run command \xe2\x80\x98rpm\xe2\x80\x99: No such file or directory\n",))

Does anyone have ideas?

4 REPLIES 4
Highlighted
Cisco Employee

Re: Golden ISO built failed

Can you provide the following outputs?

 

pwd

ls -l

<command line arguments given to giso python script>

<are you calling the script directly or with python gisobuild.py?>

 

Sam

Highlighted
Cisco Employee

Re: Golden ISO built failed

pwd

/mnt/hgfs/aaa

ls -l

total 1685629
-rwxrwxrwx. 1 root root 0 Jul 27 17:06 1
-rwxrwxrwx. 1 root root 0 Jul 27 17:11 222
-rwxrwxrwx. 1 root root 1655832576 Jul 23 10:07 asr9k-mini-x64-7.0.2.iso
-rwxrwxrwx. 1 root root 2463 Jul 27 15:25 Giso_build.log-2020-07-27:15:03:10.880116
-rwxrwxrwx. 1 root root 2458 Jul 27 21:51 Giso_build.log-2020-07-27:21:21:50.474153
-rwxrwxrwx. 1 root root 141308 Jul 27 12:58 gisobuild.py

 

<command line arguments given to giso python script>

 

 ./gisobuild.py  -i /mnt/hgfs/aaa/asr9k-mini-x64-7.0.2.iso  -r  /mnt/hgfs/aaa/RPM

 

<are you calling the script directly or with python gisobuild.py?>

calling the script directly

 

Thank you

Highlighted
Cisco Employee

Re: Golden ISO built failed

Can you paste the entire build log?

Are you the root user?

Are you using the latest version of the script?

Also there are some hits on google about this error string, so it might be an error with the script:

https://stackoverflow.com/questions/50522550/python-unicode-and-xe2-x80-x98r-xe2-x80-x99-error

 

Sam

 

Highlighted
Cisco Employee

Re: Golden ISO built failed

Hi Sam

The issue already resolved. The problem is due to chroot function, I put the script and .iso file to root directory, then it worked.

 

Thanks for your help!

 

 

Content for Community-Ad