Showing results for 
Search instead for 
Did you mean: 

XRv 5.1.1 - Working/non working features and roadmap

Level 7
Level 7


Cisco recently released Cisco XRv 5.1.1 which is IOS XR running in a VM. I thought it would be nice track features working not working and if Cisco could comment on the roadmap.





Not working:



Control plane is up for EoMPLS and VPLS but no traffic passes through. Post anything you have tested.

Daniel Dib
CCIE #37149

Please rate helpful posts.       

Daniel Dib
CCIE #37149
CCDE #20160011

Please rate helpful posts.
48 Replies 48

no it working with me , subinterfaces with ISIS , OSPF , OSPFv3.0 working fine

Sample Configuration :


router isis 1
 is-type level-2-only
 net 49.0001.0000.0000.0019.00
 address-family ipv4 unicast
  mpls ldp auto-config
 interface Loopback0
  address-family ipv4 unicast
 interface GigabitEthernet0/0/0/0.519
  circuit-type level-2-only
  hello-password hmac-md5 encrypted 05223526127E1B312B
  address-family ipv4 unicast
 interface GigabitEthernet0/0/0/0.619
  circuit-type level-2-only
  hello-password hmac-md5 encrypted 002D202F37695D3E3D
  address-family ipv4 unicast
 interface GigabitEthernet0/0/0/0.1920
  address-family ipv4 unicast




Neighborship status :


RP/0/0/CPU0:XR1# sh isis neighbors
Fri Sep 19 01:42:49.594 UTC

IS-IS 1 neighbors:
System Id      Interface        SNPA           State Holdtime Type IETF-NSF
R6             Gi0/0/0/0.619    ca01.0c14.0008 Up    8        L2   Capable
R5             Gi0/0/0/0.519    ca00.0c14.0008 Up    9        L2   Capable
XR2            Gi0/0/0/0.1920   0800.2722.67b9 Up    28       L2   Capable

Hello, sharawy_2001,

What version are you using.  I'm using XRv 5.1.2 and I simply can't establish any IS-IS adjacency through sub-interfaces.


Through interfaces, it runs smoothly.  Did you make any special configuration to get it running?


Kind regards!


Yes this is a known issue. It is related to PDU MTUs

You can try to change clns mtu or disable hello padding



Sherif Ismail

Hello, Sherif,


Sorry for taking too long to answer.  I just would like to let you know that it was exactly what you said.  It was an issue.  Thanks this plus many other fixed small details, I could correctly study and pass my CCIE SP. :-)


Thank you!

Big congratulations dear :)

Evan Roggenkamp
Level 1
Level 1

SNMPv3 works


Here is my statement:


snmp-server user evanr observium v3 auth md5 Password05$ priv aes 128 Password05$
snmp-server view observium iso included
snmp-server group observium v3 auth read observium write observium


   interface GigabitEthernet0/0/0/0
    allow SNMP peer
     address ipv4

Edit: Tried with sha and aes 128 and it worked with observium

Tried with sha and aes 256 and it would not work. Not sure if this is a limitation of xrv or of observium


Level 1
Level 1

Hello all,

during my tests I experienced that the ethernet OAM, CFM and L2VPN  (Bridge with BVI and PBB) doesn't work on ios-xrv.


Relating on OAM and CFM seem the ios-xrv have not the software module enabled.

Relating on l2vpn we see the packets  arrives on the l2-subint but they aren't sent to the bridge.


Any comments about this ?







I was installed the XRv just a couple of days ago, and would like to report, that I couldn't find a way to activate the  "per-packet load-sharing" feature.


Level 1
Level 1

I've always got core dump whenever try to apply QoS policy on XRv interface. Anyone has the same issues?


Have you tried mVPN with XRv. OIL interface at XRv is always null. Not sure from where is the issue

Please check below for details



Sherif Ismail

Many Thanks

Yup. Same issue here with mVPN.

Many thanks .. that was driving me crazy :)

Level 1
Level 1

class & policy-maps don't seem to work or commit, following on from previous poster who said he gets a core dump when applying the service-policy at the interface level....

RP/0/0/CPU0:XRv(config)#class-map match-all DS-TE
RP/0/0/CPU0:XRv(config-cmap)# match  dscp ef


Thu May 29 18:53:42.171 UTC
% No such configuration item(s)


Thu May 29 18:53:44.041 UTC

% Failed to commit one or more configuration items during a pseudo-atomic operation. All changes made have been reverted. Please issue 'show configuration failed' from this session to view the errors

RP/0/0/CPU0:XRv(config-pmap-c)#do show config failed
Thu May 29 18:54:04.229 UTC


can vinijain confirm?

I also received the same problem when I tried to commit service-policy. Here's a copy of what I did and what I got.


RP/0/0/CPU0:PE1#conf t
Thu Jul  3 14:15:08.434 UTC
RP/0/0/CPU0:PE1(config)#class-map ICMP
RP/0/0/CPU0:PE1(config-cmap)#match protocol ICMP
RP/0/0/CPU0:PE1(config)#policy-map shapeIPv4
RP/0/0/CPU0:PE1(config-pmap)#class ICMP
RP/0/0/CPU0:PE1(config-pmap-c)#shape average 64 kbps

Thu Jul  3 14:15:46.321 UTC

RP/0/0/CPU0:PE1(config)#int g0/0/0/1
RP/0/0/CPU0:PE1(config-if)#service-policy output shapeIPv4

Thu Jul  3 14:16:06.390 UTC
RP/0/0/CPU0:Jul  3 14:16:06.420 : dumper[53]: %OS-DUMPER-4-SIGSEGV : Thread 1 received SIGSEGV - Segmentation Fault
RP/0/0/CPU0:Jul  3 14:16:06.420 : dumper[53]: %OS-DUMPER-4-SIGSEGV_INFO : Accessed BadAddr 0x1 at PC 0x4206ef4. Signal code 1 - SEGV_MAPPER. Address not mapped.
RP/0/0/CPU0:Jul  3 14:16:06.420 : dumper[53]: %OS-DUMPER-4-CRASH_INFO : Crashed pid = 323675 (pkg/bin/netio)

% Failed to commit one or more configuration items during a pseudo-atomic operation. All changes made have been reverted. Please issue 'show configuration failed' from this session to view the errors

RP/0/0/CPU0:PE1(config-if)#show config fail
Thu Jul  3 14:16:11.939 UTC
!! SEMANTIC ERRORS: This configuration was rejected by
!! the system due to semantic errors. The individual
!! errors with each failed configuration command can be
!! found below.

interface GigabitEthernet0/0/0/1
 service-policy output shapeIPv4
!!% 'ifmgr' detected the 'try again' condition 'The operation encountered communication issues with the EA, NetIO or a remote IM. It may be retried'






Level 1
Level 1

BFD Not working also