cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
1161
Views
0
Helpful
9
Replies
Highlighted
Beginner

XRv 9k BGP ORR does not work.

Hi Guys,

I have been trying to get ORR working for ages... Finally I managed to deploy XRv 9k to my ESXi.

I configured it as out of band BGP RR, OSPF as IGP.

When I enable BGP ORR, RR withdraws all routes from the RR client where the feature is applied.

RP/0/RP0/CPU0:vrr1#show orrspf database detail
Sat Jan 21 18:10:46.984 UTC

ORR policy: g1, IPv4, RIB tableid: 0xe0000004
Configured root: primary: 10.0.74.18, secondary: NULL, tertiary: NULL
Actual Root: NULL, Root node: NULL

Actual root is NULL, according to this document below, it should be the same as primary root.

http://www.cisco.com/c/en/us/td/docs/routers/virtual-routers/configuration/guide/b-xrv9k-cg/b-xrv9k-cg_chapter_0110.html

RP/0/RP0/CPU0:vrr1#show bgp update-group 0.2
Sat Jan 21 18:14:12.478 UTC

Update group for IPv4 Unicast, index 0.2:
Attributes:
Neighbor sessions are IPv4
Internal
Common admin
First neighbor AS: 600
Send communities
Send GSHUT community if originated
Send extended communities
Route Reflector Client
4-byte AS capable
Non-labeled address-family capable
Send AIGP
Send multicast attributes
Minimum advertisement interval: 0 secs
Update group desynchronized: 0
Sub-groups merged: 1
Number of refresh subgroups: 0
Messages formatted: 36, replicated: 90
All neighbors are assigned to sub-group(s)
Neighbors in sub-group: 0.3, Filter-Groups num:1
Neighbors in filter-group: 0.3(RT num: 0)
10.0.74.17 10.0.74.19 10.0.74.20

debug bgp update 

debug orrspf all

RP/0/RP0/CPU0:vrr1(config-bgp-nbr-af)#commitRP/0/RP0/CPU0:Jan 21 18:18:06.737 : bgp[1048]: [default-upd] (ip4u): Created update group for table TBL:default (1/1), index 0.1 neighbor 10.0.74.18
RP/0/RP0/CPU0:Jan 21 18:18:06.737 : bgp[1048]: [default-upd] (ip4u): Removed neighbor 10.0.74.18 from update group 0.2 for IPv4 Unicast
RP/0/RP0/CPU0:Jan 21 18:18:06.737 : bgp[1048]: [default-upd] (ip4u): Removing neighbor 10.0.74.18 from update filter-group 0.2 in IPv4 Unicast sub-group 0.2 in updgrp 0.2
RP/0/RP0/CPU0:Jan 21 18:18:06.737 : bgp[1048]: [default-upd]: Compute RT set for neighbor 10.0.74.18 from old filter-group 0.2 rtset 0in subgrp 0.2
RP/0/RP0/CPU0:Jan 21 18:18:06.737 : bgp[1048]: [default-upd]: Allocating filter-group 0.1in TBL:default (1/1)
RP/0/RP0/CPU0:Jan 21 18:18:06.737 : bgp[1048]: [default-upd] (ip4u): Adding neighbor 10.0.74.18 to new filter-group 0.1 in IPv4 Unicast sub-group 0.1 rtset size 0 in updgrp 0.1
RP/0/RP0/CPU0:Jan 21 18:18:06.737 : bgp[1048]: [default-upd] (ip4u): Added neighbor 10.0.74.18 to update filter-group 0.1 in IPv4 Unicast sub-group 0.1
RP/0/RP0/CPU0:Jan 21 18:18:06.737 : bgp[1048]: [default-upd] (ip4u): Added neighbor 10.0.74.18 to update sub-group 0.1 in IPv4 Unicast update-group 0.1
RP/0/RP0/CPU0:Jan 21 18:18:06.737 : bgp[1048]: [default-upd] (ip4u): Added neighbor 10.0.74.18 to update group 0.1 for IPv4 Unicast
RP/0/RP0/CPU0:Jan 21 18:18:06.737 : bgp[1048]: [default-upd] (ip4u): Started updgrp timer for updgrp 0.1:: delay=0.010, delaytype=0
RP/0/RP0/CPU0:Jan 21 18:18:06.747 : bgp[1048]: [default-upd] (ip4u): Starting updgen walk for updgrp 0.1:: targetver=102: tblver=102, labelver=102, minfwdver=102, ackdfwdver=102, standbyver=0
RP/0/RP0/CPU0:Jan 21 18:18:06.747 : bgp[1048]: [default-upd] (ip4u): Computing updates for update sub-group 0.1 (Regular)
RP/0/RP0/CPU0:Jan 21 18:18:06.747 : bgp[1048]: [default-upd]: table-attr walk for table TBL:default (1/1), resume version 0, subgrp version 0, target version 102
RP/0/RP0/CPU0:Jan 21 18:18:06.747 : bgp[1048]: [default-upd] (ip4u): ORR Pelem(0x7f37dc0c4548, id=0) Bestpath Bitfields :0x0; Addpath bitfields 0x0
RP/0/RP0/CPU0:Jan 21 18:18:06.747 : bgp[1048]: [default-upd] (ip4u): process UPDATE for: tbl=TBL:default (1/1), afi=0: ug=0.1, (Regular), pelem (Regular), sg=0.1, ugfl=0x0210418b: bgpctxfl=0x00, tblctxfl=0x00000021, ltblctxfl=0x00000021, sendlab=0: net=8.8.0.0/21, nver=84: PELEM=0x7f37dc0c4548 (lpathid=0, ver=18, fl=0x00000001): PATH=0x7f37dc0b37f8 (10.0.74.17/32,10.0.74.17,0, 0x4000000001040207)::: allowbe=0, isbe=0, allowspurwdr=0, pelem-send=1, pelem-wdr=1
RP/0/RP0/CPU0:Jan 21 18:18:06.747 : bgp[1048]: [default-upd] (ip4u): Created withdraw message 0x0x1826518, for filtergroup 0.1
RP/0/RP0/CPU0:Jan 21 18:18:06.747 : bgp[1048]: [default-upd] (ip4u): Created msg elem 0x0x1929134 (pointing to message 0x0x1826518), for filtergroup 0.1
RP/0/RP0/CPU0:Jan 21 18:18:06.747 : bgp[1048]: [default-upd] (ip4u): Sending UPDATE (creating new msg) to sub-group 0.1 (Regular) pelem (Regular) filter-group0.1 with 8.8.0.0/21 (changedfl=0x0/0x0, bmsgflags=0x00000000, originator 0.0.0.0) unreachable (Path-element is not applicable)
RP/0/RP0/CPU0:Jan 21 18:18:06.747 : bgp[1048]: [default-upd] (ip4u): ORR Pelem(0x7f37dc0c2cc8, id=3) Bestpath Bitfields :0x0; Addpath bitfields 0x0
RP/0/RP0/CPU0:Jan 21 18:18:06.747 : bgp[1048]: [default-upd] (ip4u): ORR Pelem(0x7f37dc0c48c8, id=0) Bestpath Bitfields :0x0; Addpath bitfields 0x0
RP/0/RP0/CPU0:Jan 21 18:18:06.747 : bgp[1048]: [default-upd] (ip4u): process UPDATE for: tbl=TBL:default (1/1), afi=0: ug=0.1, (Regular), pelem (Regular), sg=0.1, ugfl=0x0210418b: bgpctxfl=0x00, tblctxfl=0x00000021, ltblctxfl=0x00000021, sendlab=0: net=21.0.0.0/24, nver=102: PELEM=0x7f37dc0c48c8 (lpathid=0, ver=32, fl=0x00000001): PATH=0x7f37dc0b2fb8 (10.0.74.19/32,10.0.74.19,0, 0x4000000001040207)::: allowbe=0, isbe=0, allowspurwdr=0, pelem-send=1, pelem-wdr=1
RP/0/RP0/CPU0:Jan 21 18:18:06.747 : bgp[1048]: [default-upd] (ip4u): Sending UPDATE (packing existing msg) to sub-group 0.1 (Regular) pelem (Regular) filter-group0.1 with 21.0.0.0/24 (changedfl=0x0/0x0, bmsgflags=0x00000000, originator 0.0.0.0) unreachable (Path-element is not applicable)
RP/0/RP0/CPU0:Jan 21 18:18:06.747 : bgp[1048]: [default-upd] (ip4u): ORR Pelem(0x7f37dc0c4158, id=0) Bestpath Bitfields :0x0; Addpath bitfields 0x0
RP/0/RP0/CPU0:Jan 21 18:18:06.747 : bgp[1048]: [default-upd] (ip4u): process UPDATE for: tbl=TBL:default (1/1), afi=0: ug=0.1, (Regular), pelem (Regular), sg=0.1, ugfl=0x0210418b: bgpctxfl=0x00, tblctxfl=0x00000021, ltblctxfl=0x00000021, sendlab=0: net=8.8.2.0/23, nver=83: PELEM=0x7f37dc0c4158 (lpathid=0, ver=17, fl=0x00000001): PATH=0x7f37dc0b33d8 (10.0.74.17/32,10.0.74.17,0, 0x4000000001040207)::: allowbe=0, isbe=0, allowspurwdr=0, pelem-send=1, pelem-wdr=1
optimal-route-reflection g1RP/0/RP0/CPU0:Jan 21 18:18:06.747 : bgp[1048]: [default-upd] (ip4u): Sending UPDATE (packing existing msg) to sub-group 0.1 (Regular) pelem (Regular) filter-group0.1 with 8.8.2.0/23 (changedfl=0x0/0x0, bmsgflags=0x00000000, originator 0.0.0.0) unreachable (Path-element is not applicable)
RP/0/RP0/CPU0:Jan 21 18:18:06.747 : bgp[1048]: [default-upd] (ip4u): ORR Pelem(0x7f37dc0c40e8, id=0) Bestpath Bitfields :0x0; Addpath bitfields 0x0
RP/0/RP0/CPU0:Jan 21 18:18:06.747 : bgp[1048]: [default-upd] (ip4u): process UPDATE for: tbl=TBL:default (1/1), afi=0: ug=0.1, (Regular), pelem (Regular), sg=0.1, ugfl=0x0210418b: bgpctxfl=0x00, tblctxfl=0x00000021, ltblctxfl=0x00000021, sendlab=0: net=8.8.0.0/23, nver=82: PELEM=0x7f37dc0c40e8 (lpathid=0, ver=16, fl=0x00000001): PATH=0x7f37dc0b3378 (10.0.74.17/32,10.0.74.17,0, 0x4000000001040207)::: allowbe=0, isbe=0, allowspurwdr=0, pelem-send=1, pelem-wdr=1
RP/0/RP0/CPU0:Jan 21 18:18:06.747 : bgp[1048]: [default-upd] (ip4u): Sending UPDATE (packing existing msg) to sub-group 0.1 (Regular) pelem (Regular) filter-group0.1 with 8.8.0.0/23 (changedfl=0x0/0x0, bmsgflags=0x00000000, originator 0.0.0.0) unreachable (Path-element is not applicable)
RP/0/RP0/CPU0:Jan 21 18:18:06.747 : bgp[1048]: [default-upd] (ip4u): ORR Pelem(0x7f37dc0c4778, id=0) Bestpath Bitfields :0x0; Addpath bitfields 0x0
RP/0/RP0/CPU0:Jan 21 18:18:06.747 : bgp[1048]: [default-upd] (ip4u): process UPDATE for: tbl=TBL:default (1/1), afi=0: ug=0.1, (Regular), pelem (Regular), sg=0.1, ugfl=0x0210418b: bgpctxfl=0x00, tblctxfl=0x00000021, ltblctxfl=0x00000021, sendlab=0: net=2.2.0.0/21, nver=74: PELEM=0x7f37dc0c4778 (lpathid=0, ver=8, fl=0x00000001): PATH=0x7f37dc0b3b58 (10.0.74.17/32,10.0.74.17,0, 0x4000000001040207)::: allowbe=0, isbe=0, allowspurwdr=0, pelem-send=1, pelem-wdr=1
RP/0/RP0/CPU0:Jan 21 18:18:06.747 : bgp[1048]: [default-upd] (ip4u): Sending UPDATE (packing existing msg) to sub-group 0.1 (Regular) pelem (Regular) filter-group0.1 with 2.2.0.0/21 (changedfl=0x0/0x0, bmsgflags=0x00000000, originator 0.0.0.0) unreachable (Path-element is not applicable)
RP/0/RP0/CPU0:Jan 21 18:18:06.747 : bgp[1048]: [default-upd] (ip4u): ORR Pelem(0x7f37dc0c3c18, id=0) Bestpath Bitfields :0x0; Addpath bitfields 0x0
RP/0/RP0/CPU0:Jan 21 18:18:06.747 : bgp[1048]: [default-upd] (ip4u): process UPDATE for: tbl=TBL:default (1/1), afi=0: ug=0.1, (Regular), pelem (Regular), sg=0.1, ugfl=0x0210418b: bgpctxfl=0x00, tblctxfl=0x00000021, ltblctxfl=0x00000021, sendlab=0: net=7.7.0.0/21, nver=81: PELEM=0x7f37dc0c3c18 (lpathid=0, ver=15, fl=0x00000001): PATH=0x7f37dc0b3af8 (10.0.74.17/32,10.0.74.17,0, 0x4000000001040207)::: allowbe=0, isbe=0, allowspurwdr=0, pelem-send=1, pelem-wdr=1
RP/0/RP0/CPU0:Jan 21 18:18:06.747 : bgp[1048]: [default-upd] (ip4u): Sending UPDATE (packing existing msg) to sub-group 0.1 (Regular) pelem (Regular) filter-group0.1 with 7.7.0.0/21 (changedfl=0x0/0x0, bmsgflags=0x00000000, originator 0.0.0.0) unreachable (Path-element is not applicable)
RP/0/RP0/CPU0:Jan 21 18:18:06.747 : bgp[1048]: [default-upd] (ip4u): ORR Pelem(0x7f37dc0c3ba8, id=0) Bestpath Bitfields :0x0; Addpath bitfields 0x0
RP/0/RP0/CPU0:Jan 21 18:18:06.747 : bgp[1048]: [default-upd] (ip4u): process UPDATE for: tbl=TBL:default (1/1), afi=0: ug=0.1, (Regular), pelem (Regular), sg=0.1, ugfl=0x0210418b: bgpctxfl=0x00, tblctxfl=0x00000021, ltblctxfl=0x00000021, sendlab=0: net=6.6.0.0/21, nver=78: PELEM=0x7f37dc0c3ba8 (lpathid=0, ver=12, fl=0x00000001): PATH=0x7f37dc0b3a98 (10.0.74.17/32,10.0.74.17,0, 0x4000000001040207)::: allowbe=0, isbe=0, allowspurwdr=0, pelem-send=1, pelem-wdr=1
RP/0/RP0/CPU0:Jan 21 18:18:06.747 : bgp[1048]: [default-upd] (ip4u): Sending UPDATE (packing existing msg) to sub-group 0.1 (Regular) pelem (Regular) filter-group0.1 with 6.6.0.0/21 (changedfl=0x0/0x0, bmsgflags=0x00000000, originator 0.0.0.0) unreachable (Path-element is not applicable)
RP/0/RP0/CPU0:Jan 21 18:18:06.748 : bgp[1048]: [default-upd] (ip4u): ORR Pelem(0x7f37dc0c3b38, id=0) Bestpath Bitfields :0x0; Addpath bitfields 0x0
RP/0/RP0/CPU0:Jan 21 18:18:06.748 : bgp[1048]: [default-upd] (ip4u): process UPDATE for: tbl=TBL:default (1/1), afi=0: ug=0.1, (Regular), pelem (Regular), sg=0.1, ugfl=0x0210418b: bgpctxfl=0x00, tblctxfl=0x00000021, ltblctxfl=0x00000021, sendlab=0: net=1.1.0.0/21, nver=71: PELEM=0x7f37dc0c3b38 (lpathid=0, ver=5, fl=0x00000001): PATH=0x7f37dc0b3a38 (10.0.74.17/32,10.0.74.17,0, 0x4000000001040207)::: allowbe=0, isbe=0, allowspurwdr=0, pelem-send=1, pelem-wdr=1
RP/0/RP0/CPU0:Jan 21 18:18:06.748 : bgp[1048]: [default-upd] (ip4u): Sending UPDATE (packing existing msg) to sub-group 0.1 (Regular) pelem (Regular) filter-group0.1 with 1.1.0.0/21 (changedfl=0x0/0x0, bmsgflags=0x00000000, originator 0.0.0.0) unreachable (Path-element is not applicable)
RP/0/RP0/CPU0:Jan 21 18:18:06.748 : bgp[1048]: [default-upd] (ip4u): ORR Pelem(0x7f37dc0c42a8, id=0) Bestpath Bitfields :0x0; Addpath bitfields 0x0
RP/0/RP0/CPU0:Jan 21 18:18:06.748 : bgp[1048]: [default-upd] (ip4u): process UPDATE for: tbl=TBL:default (1/1), afi=0: ug=0.1, (Regular), pelem (Regular), sg=0.1, ugfl=0x0210418b: bgpctxfl=0x00, tblctxfl=0x00000021, ltblctxfl=0x00000021, sendlab=0: net=70.1.14.0/24, nver=97: PELEM=0x7f37dc0c42a8 (lpathid=0, ver=35, fl=0x00000001): PATH=0x7f37dc0b3498 (10.0.74.17/32,10.0.74.17,0, 0x4000000001040207)::: allowbe=0, isbe=0, allowspurwdr=0, pelem-send=1, pelem-wdr=1
RP/0/RP0/CPU0:Jan 21 18:18:06.748 : bgp[1048]: [default-upd] (ip4u): Sending UPDATE (packing existing msg) to sub-group 0.1 (Regular) pelem (Regular) filter-group0.1 with 70.1.14.0/24 (changedfl=0x0/0x0, bmsgflags=0x00000000, originator 0.0.0.0) unreachable (Path-element is not applicable)
RP/0/RP0/CPU0:Jan 21 18:18:06.748 : bgp[1048]: [default-upd] (ip4u): ORR Pelem(0x7f37dc0c4938, id=0) Bestpath Bitfields :0x0; Addpath bitfields 0x0
RP/0/RP0/CPU0:Jan 21 18:18:06.748 : bgp[1048]: [default-upd] (ip4u): process UPDATE for: tbl=TBL:default (1/1), afi=0: ug=0.1, (Regular), pelem (Regular), sg=0.1, ugfl=0x0210418b: bgpctxfl=0x00, tblctxfl=0x00000021, ltblctxfl=0x00000021, sendlab=0: net=20.0.0.0/24, nver=31: PELEM=0x7f37dc0c4938 (lpathid=0, ver=31, fl=0x00000001): PATH=0x7f37dc0b4818 (10.0.74.20/32,10.0.74.20,0, 0x4000000001040207)::: allowbe=0, isbe=0, allowspurwdr=0, pelem-send=1, pelem-wdr=1
RP/0/RP0/CPU0:Jan 21 18:18:06.748 : bgp[1048]: [default-upd] (ip4u): Sending UPDATE (packing existing msg) to sub-group 0.1 (Regular) pelem (Regular) filter-group0.1 with 20.0.0.0/24 (changedfl=0x0/0x0, bmsgflags=0x00000000, originator 0.0.0.0) unreachable (Path-element is not applicable)
RP/0/RP0/CPU0:Jan 21 18:18:06.748 : bgp[1048]: [default-upd] (ip4u): ORR Pelem(0x7f37dc0c3a58, id=0) Bestpath Bitfields :0x0; Addpath bitfields 0x0
RP/0/RP0/CPU0:Jan 21 18:18:06.748 : bgp[1048]: [default-upd] (ip4u): process UPDATE for: tbl=TBL:default (1/1), afi=0: ug=0.1, (Regular), pelem (Regular), sg=0.1, ugfl=0x0210418b: bgpctxfl=0x00, tblctxfl=0x00000021, ltblctxfl=0x00000021, sendlab=0: net=19.0.0.0/24, nver=30: PELEM=0x7f37dc0c3a58 (lpathid=0, ver=30, fl=0x00000001): PATH=0x7f37dc0b3018 (10.0.74.19/32,10.0.74.19,0, 0x4000000001040207)::: allowbe=0, isbe=0, allowspurwdr=0, pelem-send=1, pelem-wdr=1
RP/0/RP0/CPU0:Jan 21 18:18:06.748 : bgp[1048]: [default-upd] (ip4u): Sending UPDATE (packing existing msg) to sub-group 0.1 (Regular) pelem (Regular) filter-group0.1 with 19.0.0.0/24 (changedfl=0x0/0x0, bmsgflags=0x00000000, originator 0.0.0.0) unreachable (Path-element is not applicable)
RP/0/RP0/CPU0:Jan 21 18:18:06.748 : bgp[1048]: [default-upd] (ip4u): ORR Pelem(0x7f37dc0c4708, id=0) Bestpath Bitfields :0x0; Addpath bitfields 0x0
RP/0/RP0/CPU0:Jan 21 18:18:06.748 : bgp[1048]: [default-upd] (ip4u): process UPDATE for: tbl=TBL:default (1/1), afi=0: ug=0.1, (Regular), pelem (Regular), sg=0.1, ugfl=0x0210418b: bgpctxfl=0x00, tblctxfl=0x00000021, ltblctxfl=0x00000021, sendlab=0: net=18.0.0.0/24, nver=29: PELEM=0x7f37dc0c4708 (lpathid=0, ver=29, fl=0x00000001): PATH=0x7f37dc0b4638 (10.0.74.18/32,10.0.74.18,0, 0x4000000001040207)::: allowbe=0, isbe=0, allowspurwdr=0, pelem-send=1, pelem-wdr=1
RP/0/RP0/CPU0:Jan 21 18:18:06.748 : bgp[1048]: [default-upd] (ip4u): Sending UPDATE (packing existing msg) to sub-group 0.1 (Regular) pelem (Regular) filter-group0.1 with 18.0.0.0/24 (changedfl=0x0/0x0, bmsgflags=0x00000000, originator 0.0.0.0) unreachable (Path-element is not applicable)
RP/0/RP0/CPU0:Jan 21 18:18:06.748 : bgp[1048]: [default-upd] (ip4u): ORR Pelem(0x7f37dc0c3ac8, id=0) Bestpath Bitfields :0x0; Addpath bitfields 0x0
RP/0/RP0/CPU0:Jan 21 18:18:06.748 : bgp[1048]: [default-upd] (ip4u): process UPDATE for: tbl=TBL:default (1/1), afi=0: ug=0.1, (Regular), pelem (Regular), sg=0.1, ugfl=0x0210418b: bgpctxfl=0x00, tblctxfl=0x00000021, ltblctxfl=0x00000021, sendlab=0: net=17.0.0.0/24, nver=28: PELEM=0x7f37dc0c3ac8 (lpathid=0, ver=28, fl=0x00000001): PATH=0x7f37dc0b3858 (10.0.74.17/32,10.0.74.17,0, 0x4000000001040207)::: allowbe=0, isbe=0, allowspurwdr=0, pelem-send=1, pelem-wdr=1
RP/0/RP0/CPU0:Jan 21 18:18:06.748 : bgp[1048]: [default-upd] (ip4u): Sending UPDATE (packing existing msg) to sub-group 0.1 (Regular) pelem (Regular) filter-group0.1 with 17.0.0.0/24 (changedfl=0x0/0x0, bmsgflags=0x00000000, originator 0.0.0.0) unreachable (Path-element is not applicable)
RP/0/RP0/CPU0:Jan 21 18:18:06.748 : bgp[1048]: [default-upd] (ip4u): ORR Pelem(0x7f37dc0c4318, id=0) Bestpath Bitfields :0x0; Addpath bitfields 0x0
RP/0/RP0/CPU0:Jan 21 18:18:06.748 : bgp[1048]: [default-upd] (ip4u): process UPDATE for: tbl=TBL:default (1/1), afi=0: ug=0.1, (Regular), pelem (Regular), sg=0.1, ugfl=0x0210418b: bgpctxfl=0x00, tblctxfl=0x00000021, ltblctxfl=0x00000021, sendlab=0: net=70.1.16.0/24, nver=99: PELEM=0x7f37dc0c4318 (lpathid=0, ver=37, fl=0x00000001): PATH=0x7f37dc0b31f8 (10.0.74.17/32,10.0.74.17,0, 0x4000000001040207)::: allowbe=0, isbe=0, allowspurwdr=0, pelem-send=1, pelem-wdr=1
RP/0/RP0/CPU0:Jan 21 18:18:06.748 : bgp[1048]: [default-upd] (ip4u): Sending UPDATE (packing existing msg) to sub-group 0.1 (Regular) pelem (Regular) filter-group0.1 with 70.1.16.0/24 (changedfl=0x0/0x0, bmsgflags=0x00000000, originator 0.0.0.0) unreachable (Path-element is not applicable)
RP/0/RP0/CPU0:Jan 21 18:18:06.748 : bgp[1048]: [default-upd] (ip4u): ORR Pelem(0x7f37dc0c45b8, id=0) Bestpath Bitfields :0x0; Addpath bitfields 0x0
RP/0/RP0/CPU0:Jan 21 18:18:06.748 : bgp[1048]: [default-upd] (ip4u): process UPDATE for: tbl=TBL:default (1/1), afi=0: ug=0.1, (Regular), pelem (Regular), sg=0.1, ugfl=0x0210418b: bgpctxfl=0x00, tblctxfl=0x00000021, ltblctxfl=0x00000021, sendlab=0: net=70.1.15.0/24, nver=98: PELEM=0x7f37dc0c45b8 (lpathid=0, ver=36, fl=0x00000001): PATH=0x7f37dc0b3198 (10.0.74.17/32,10.0.74.17,0, 0x4000000001040207)::: allowbe=0, isbe=0, allowspurwdr=0, pelem-send=1, pelem-wdr=1
RP/0/RP0/CPU0:Jan 21 18:18:06.748 : bgp[1048]: [default-upd] (ip4u): Sending UPDATE (packing existing msg) to sub-group 0.1 (Regular) pelem (Regular) filter-group0.1 with 70.1.15.0/24 (changedfl=0x0/0x0, bmsgflags=0x00000000, originator 0.0.0.0) unreachable (Path-element is not applicable)
RP/0/RP0/CPU0:Jan 21 18:18:06.748 : bgp[1048]: [default-upd] (ip4u): ORR Pelem(0x7f37dc0c4238, id=0) Bestpath Bitfields :0x0; Addpath bitfields 0x0
RP/0/RP0/CPU0:Jan 21 18:18:06.748 : bgp[1048]: [default-upd] (ip4u): process UPDATE for: tbl=TBL:default (1/1), afi=0: ug=0.1, (Regular), pelem (Regular), sg=0.1, ugfl=0x0210418b: bgpctxfl=0x00, tblctxfl=0x00000021, ltblctxfl=0x00000021, sendlab=0: net=70.1.13.0/24, nver=96: PELEM=0x7f37dc0c4238 (lpathid=0, ver=34, fl=0x00000001): PATH=0x7f37dc0b3138 (10.0.74.17/32,10.0.74.17,0, 0x4000000001040207)::: allowbe=0, isbe=0, allowspurwdr=0, pelem-send=1, pelem-wdr=1
RP/0/RP0/CPU0:Jan 21 18:18:06.748 : bgp[1048]: [default-upd] (ip4u): Sending UPDATE (packing existing msg) to sub-group 0.1 (Regular) pelem (Regular) filter-group0.1 with 70.1.13.0/24 (changedfl=0x0/0x0, bmsgflags=0x00000000, originator 0.0.0.0) unreachable (Path-element is not applicable)
RP/0/RP0/CPU0:Jan 21 18:18:06.748 : bgp[1048]: [default-upd] (ip4u): ORR Pelem(0x7f37dc0c41c8, id=0) Bestpath Bitfields :0x0; Addpath bitfields 0x0
RP/0/RP0/CPU0:Jan 21 18:18:06.748 : bgp[1048]: [default-upd] (ip4u): process UPDATE for: tbl=TBL:default (1/1), afi=0: ug=0.1, (Regular), pelem (Regular), sg=0.1, ugfl=0x0210418b: bgpctxfl=0x00, tblctxfl=0x00000021, ltblctxfl=0x00000021, sendlab=0: net=70.1.12.0/24, nver=95: PELEM=0x7f37dc0c41c8 (lpathid=0, ver=33, fl=0x00000001): PATH=0x7f37dc0b30d8 (10.0.74.17/32,10.0.74.17,0, 0x4000000001040207)::: allowbe=0, isbe=0, allowspurwdr=0, pelem-send=1, pelem-wdr=1
RP/0/RP0/CPU0:Jan 21 18:18:06.748 : bgp[1048]: [default-upd] (ip4u): Sending UPDATE (packing existing msg) to sub-group 0.1 (Regular) pelem (Regular) filter-group0.1 with 70.1.12.0/24 (changedfl=0x0/0x0, bmsgflags=0x00000000, originator 0.0.0.0) unreachable (Path-element is not applicable)
RP/0/RP0/CPU0:Jan 21 18:18:06.748 : bgp[1048]: [default-upd] (ip4u): ORR Pelem(0x7f37dc0c47e8, id=0) Bestpath Bitfields :0x0; Addpath bitfields 0x0
RP/0/RP0/CPU0:Jan 21 18:18:06.748 : bgp[1048]: [default-upd] (ip4u): process UPDATE for: tbl=TBL:default (1/1), afi=0: ug=0.1, (Regular), pelem (Regular), sg=0.1, ugfl=0x0210418b: bgpctxfl=0x00, tblctxfl=0x00000021, ltblctxfl=0x00000021, sendlab=0: net=2.2.2.0/23, nver=73: PELEM=0x7f37dc0c47e8 (lpathid=0, ver=7, fl=0x00000001): PATH=0x7f37dc0b3318 (10.0.74.17/32,10.0.74.17,0, 0x4000000001040207)::: allowbe=0, isbe=0, allowspurwdr=0, pelem-send=1, pelem-wdr=1
RP/0/RP0/CPU0:Jan 21 18:18:06.748 : bgp[1048]: [default-upd] (ip4u): Sending UPDATE (packing existing msg) to sub-group 0.1 (Regular) pelem (Regular) filter-group0.1 with 2.2.2.0/23 (changedfl=0x0/0x0, bmsgflags=0x00000000, originator 0.0.0.0) unreachable (Path-element is not applicable)
RP/0/RP0/CPU0:Jan 21 18:18:06.748 : bgp[1048]: [default-upd] (ip4u): ORR Pelem(0x7f37dc0c3cf8, id=0) Bestpath Bitfields :0x0; Addpath bitfields 0x0
RP/0/RP0/CPU0:Jan 21 18:18:06.748 : bgp[1048]: [default-upd] (ip4u): process UPDATE for: tbl=TBL:default (1/1), afi=0: ug=0.1, (Regular), pelem (Regular), sg=0.1, ugfl=0x0210418b: bgpctxfl=0x00, tblctxfl=0x00000021, ltblctxfl=0x00000021, sendlab=0: net=7.7.2.0/23, nver=80: PELEM=0x7f37dc0c3cf8 (lpathid=0, ver=14, fl=0x00000001): PATH=0x7f37dc0b32b8 (10.0.74.17/32,10.0.74.17,0, 0x4000000001040207)::: allowbe=0, isbe=0, allowspurwdr=0, pelem-send=1, pelem-wdr=1
RP/0/RP0/CPU0:Jan 21 18:18:06.748 : bgp[1048]: [default-upd] (ip4u): Sending UPDATE (packing existing msg) to sub-group 0.1 (Regular) pelem (Regular) filter-group0.1 with 7.7.2.0/23 (changedfl=0x0/0x0, bmsgflags=0x00000000, originator 0.0.0.0) unreachable (Path-element is not applicable)
RP/0/RP0/CPU0:Jan 21 18:18:06.748 : bgp[1048]: [default-upd] (ip4u): ORR Pelem(0x7f37dc0c3c88, id=0) Bestpath Bitfields :0x0; Addpath bitfields 0x0
RP/0/RP0/CPU0:Jan 21 18:18:06.748 : bgp[1048]: [default-upd] (ip4u): process UPDATE for: tbl=TBL:default (1/1), afi=0: ug=0.1, (Regular), pelem (Regular), sg=0.1, ugfl=0x0210418b: bgpctxfl=0x00, tblctxfl=0x00000021, ltblctxfl=0x00000021, sendlab=0: net=7.7.0.0/23, nver=79: PELEM=0x7f37dc0c3c88 (lpathid=0, ver=13, fl=0x00000001): PATH=0x7f37dc0b3258 (10.0.74.17/32,10.0.74.17,0, 0x4000000001040207)::: allowbe=0, isbe=0, allowspurwdr=0, pelem-send=1, pelem-wdr=1
RP/0/RP0/CPU0:Jan 21 18:18:06.748 : bgp[1048]: [default-upd] (ip4u): Sending UPDATE (packing existing msg) to sub-group 0.1 (Regular) pelem (Regular) filter-group0.1 with 7.7.0.0/23 (changedfl=0x0/0x0, bmsgflags=0x00000000, originator 0.0.0.0) unreachable (Path-element is not applicable)
RP/0/RP0/CPU0:Jan 21 18:18:06.748 : bgp[1048]: [default-upd] (ip4u): ORR Pelem(0x7f37dc0c4628, id=0) Bestpath Bitfields :0x0; Addpath bitfields 0x0
RP/0/RP0/CPU0:Jan 21 18:18:06.748 : bgp[1048]: [default-upd] (ip4u): process UPDATE for: tbl=TBL:default (1/1), afi=0: ug=0.1, (Regular), pelem (Regular), sg=0.1, ugfl=0x0210418b: bgpctxfl=0x00, tblctxfl=0x00000021, ltblctxfl=0x00000021, sendlab=0: net=2.2.0.0/23, nver=72: PELEM=0x7f37dc0c4628 (lpathid=0, ver=6, fl=0x00000001): PATH=0x7f37dc0b3bb8 (10.0.74.17/32,10.0.74.17,0, 0x4000000001040207)::: allowbe=0, isbe=0, allowspurwdr=0, pelem-send=1, pelem-wdr=1
RP/0/RP0/CPU0:Jan 21 18:18:06.748 : bgp[1048]: [default-upd] (ip4u): Sending UPDATE (packing existing msg) to sub-group 0.1 (Regular) pelem (Regular) filter-group0.1 with 2.2.0.0/23 (changedfl=0x0/0x0, bmsgflags=0x00000000, originator 0.0.0.0) unreachable (Path-element is not applicable)
RP/0/RP0/CPU0:Jan 21 18:18:06.748 : bgp[1048]: [default-upd] (ip4u): ORR Pelem(0x7f37dc0c44d8, id=0) Bestpath Bitfields :0x0; Addpath bitfields 0x0
RP/0/RP0/CPU0:Jan 21 18:18:06.748 : bgp[1048]: [default-upd] (ip4u): process UPDATE for: tbl=TBL:default (1/1), afi=0: ug=0.1, (Regular), pelem (Regular), sg=0.1, ugfl=0x0210418b: bgpctxfl=0x00, tblctxfl=0x00000021, ltblctxfl=0x00000021, sendlab=0: net=6.6.2.0/23, nver=77: PELEM=0x7f37dc0c44d8 (lpathid=0, ver=11, fl=0x00000001): PATH=0x7f37dc0b39d8 (10.0.74.17/32,10.0.74.17,0, 0x4000000001040207)::: allowbe=0, isbe=0, allowspurwdr=0, pelem-send=1, pelem-wdr=1
RP/0/RP0/CPU0:Jan 21 18:18:06.748 : bgp[1048]: [default-upd] (ip4u): Sending UPDATE (packing existing msg) to sub-group 0.1 (Regular) pelem (Regular) filter-group0.1 with 6.6.2.0/23 (changedfl=0x0/0x0, bmsgflags=0x00000000, originator 0.0.0.0) unreachable (Path-element is not applicable)
RP/0/RP0/CPU0:Jan 21 18:18:06.748 : bgp[1048]: [default-upd] (ip4u): ORR Pelem(0x7f37dc0c4468, id=0) Bestpath Bitfields :0x0; Addpath bitfields 0x0
RP/0/RP0/CPU0:Jan 21 18:18:06.748 : bgp[1048]: [default-upd] (ip4u): process UPDATE for: tbl=TBL:default (1/1), afi=0: ug=0.1, (Regular), pelem (Regular), sg=0.1, ugfl=0x0210418b: bgpctxfl=0x00, tblctxfl=0x00000021, ltblctxfl=0x00000021, sendlab=0: net=6.6.0.0/23, nver=76: PELEM=0x7f37dc0c4468 (lpathid=0, ver=10, fl=0x00000001): PATH=0x7f37dc0b3978 (10.0.74.17/32,10.0.74.17,0, 0x4000000001040207)::: allowbe=0, isbe=0, allowspurwdr=0, pelem-send=1, pelem-wdr=1
RP/0/RP0/CPU0:Jan 21 18:18:06.748 : bgp[1048]: [default-upd] (ip4u): Sending UPDATE (packing existing msg) to sub-group 0.1 (Regular) pelem (Regular) filter-group0.1 with 6.6.0.0/23 (changedfl=0x0/0x0, bmsgflags=0x00000000, originator 0.0.0.0) unreachable (Path-element is not applicable)
RP/0/RP0/CPU0:Jan 21 18:18:06.748 : bgp[1048]: [default-upd] (ip4u): ORR Pelem(0x7f37dc0c43f8, id=0) Bestpath Bitfields :0x0; Addpath bitfields 0x0
RP/0/RP0/CPU0:Jan 21 18:18:06.748 : bgp[1048]: [default-upd] (ip4u): process UPDATE for: tbl=TBL:default (1/1), afi=0: ug=0.1, (Regular), pelem (Regular), sg=0.1, ugfl=0x0210418b: bgpctxfl=0x00, tblctxfl=0x00000021, ltblctxfl=0x00000021, sendlab=0: net=1.1.2.0/23, nver=70: PELEM=0x7f37dc0c43f8 (lpathid=0, ver=4, fl=0x00000001): PATH=0x7f37dc0b3918 (10.0.74.17/32,10.0.74.17,0, 0x4000000001040207)::: allowbe=0, isbe=0, allowspurwdr=0, pelem-send=1, pelem-wdr=1
RP/0/RP0/CPU0:Jan 21 18:18:06.748 : bgp[1048]: [default-upd] (ip4u): Sending UPDATE (packing existing msg) to sub-group 0.1 (Regular) pelem (Regular) filter-group0.1 with 1.1.2.0/23 (changedfl=0x0/0x0, bmsgflags=0x00000000, originator 0.0.0.0) unreachable (Path-element is not applicable)
RP/0/RP0/CPU0:Jan 21 18:18:06.748 : bgp[1048]: [default-upd] (ip4u): ORR Pelem(0x7f37dc0c4388, id=0) Bestpath Bitfields :0x0; Addpath bitfields 0x0
RP/0/RP0/CPU0:Jan 21 18:18:06.749 : bgp[1048]: [default-upd] (ip4u): process UPDATE for: tbl=TBL:default (1/1), afi=0: ug=0.1, (Regular), pelem (Regular), sg=0.1, ugfl=0x0210418b: bgpctxfl=0x00, tblctxfl=0x00000021, ltblctxfl=0x00000021, sendlab=0: net=1.1.0.0/23, nver=69: PELEM=0x7f37dc0c4388 (lpathid=0, ver=3, fl=0x00000001): PATH=0x7f37dc0b38b8 (10.0.74.17/32,10.0.74.17,0, 0x4000000001040207)::: allowbe=0, isbe=0, allowspurwdr=0, pelem-send=1, pelem-wdr=1
RP/0/RP0/CPU0:Jan 21 18:18:06.749 : bgp[1048]: [default-upd] (ip4u): Sending UPDATE (packing existing msg) to sub-group 0.1 (Regular) pelem (Regular) filter-group0.1 with 1.1.0.0/23 (changedfl=0x0/0x0, bmsgflags=0x00000000, originator 0.0.0.0) unreachable (Path-element is not applicable)
RP/0/RP0/CPU0:Jan 21 18:18:06.749 : bgp[1048]: [default-upd] (ip4u): ORR Pelem(0x7f37dc0c4858, id=0) Bestpath Bitfields :0x0; Addpath bitfields 0x0
RP/0/RP0/CPU0:Jan 21 18:18:06.749 : bgp[1048]: [default-upd] (ip4u): process UPDATE for: tbl=TBL:default (1/1), afi=0: ug=0.1, (Regular), pelem (Regular), sg=0.1, ugfl=0x0210418b: bgpctxfl=0x00, tblctxfl=0x00000021, ltblctxfl=0x00000021, sendlab=0: net=3.3.0.0/21, nver=75: PELEM=0x7f37dc0c4858 (lpathid=0, ver=9, fl=0x00000001): PATH=0x7f37dc0b3078 (10.0.74.17/32,10.0.74.17,0, 0x4000000001040207)::: allowbe=0, isbe=0, allowspurwdr=0, pelem-send=1, pelem-wdr=1
RP/0/RP0/CPU0:Jan 21 18:18:06.749 : bgp[1048]: [default-upd] (ip4u): Sending UPDATE (packing existing msg) to sub-group 0.1 (Regular) pelem (Regular) filter-group0.1 with 3.3.0.0/21 (changedfl=0x0/0x0, bmsgflags=0x00000000, originator 0.0.0.0) unreachable (Path-element is not applicable)
RP/0/RP0/CPU0:Jan 21 18:18:06.749 : bgp[1048]: [default-upd] (ip4u): ORR Pelem(0x7f37dc0c4078, id=0) Bestpath Bitfields :0x0; Addpath bitfields 0x0
RP/0/RP0/CPU0:Jan 21 18:18:06.749 : bgp[1048]: [default-upd] (ip4u): process UPDATE for: tbl=TBL:default (1/1), afi=0: ug=0.1, (Regular), pelem (Regular), sg=0.1, ugfl=0x0210418b: bgpctxfl=0x00, tblctxfl=0x00000021, ltblctxfl=0x00000021, sendlab=0: net=11.11.3.128/25, nver=93: PELEM=0x7f37dc0c4078 (lpathid=0, ver=27, fl=0x00000001): PATH=0x7f37dc0b3798 (10.0.74.17/32,10.0.74.17,0, 0x4000000001040207)::: allowbe=0, isbe=0, allowspurwdr=0, pelem-send=1, pelem-wdr=1
RP/0/RP0/CPU0:Jan 21 18:18:06.749 : bgp[1048]: [default-upd] (ip4u): Sending UPDATE (packing existing msg) to sub-group 0.1 (Regular) pelem (Regular) filter-group0.1 with 11.11.3.128/25 (changedfl=0x0/0x0, bmsgflags=0x00000000, originator 0.0.0.0) unreachable (Path-element is not applicable)
RP/0/RP0/CPU0:Jan 21 18:18:06.749 : bgp[1048]: [default-upd] (ip4u): ORR Pelem(0x7f37dc0c4008, id=0) Bestpath Bitfields :0x0; Addpath bitfields 0x0
RP/0/RP0/CPU0:Jan 21 18:18:06.749 : bgp[1048]: [default-upd] (ip4u): process UPDATE for: tbl=TBL:default (1/1), afi=0: ug=0.1, (Regular), pelem (Regular), sg=0.1, ugfl=0x0210418b: bgpctxfl=0x00, tblctxfl=0x00000021, ltblctxfl=0x00000021, sendlab=0: net=11.11.3.0/25, nver=92: PELEM=0x7f37dc0c4008 (lpathid=0, ver=26, fl=0x00000001): PATH=0x7f37dc0b3738 (10.0.74.17/32,10.0.74.17,0, 0x4000000001040207)::: allowbe=0, isbe=0, allowspurwdr=0, pelem-send=1, pelem-wdr=1
RP/0/RP0/CPU0:Jan 21 18:18:06.749 : bgp[1048]: [default-upd] (ip4u): Sending UPDATE (packing existing msg) to sub-group 0.1 (Regular) pelem (Regular) filter-group0.1 with 11.11.3.0/25 (changedfl=0x0/0x0, bmsgflags=0x00000000, originator 0.0.0.0) unreachable (Path-element is not applicable)
RP/0/RP0/CPU0:Jan 21 18:18:06.749 : bgp[1048]: [default-upd] (ip4u): ORR Pelem(0x7f37dc0c3f98, id=0) Bestpath Bitfields :0x0; Addpath bitfields 0x0
RP/0/RP0/CPU0:Jan 21 18:18:06.749 : bgp[1048]: [default-upd] (ip4u): process UPDATE for: tbl=TBL:default (1/1), afi=0: ug=0.1, (Regular), pelem (Regular), sg=0.1, ugfl=0x0210418b: bgpctxfl=0x00, tblctxfl=0x00000021, ltblctxfl=0x00000021, sendlab=0: net=11.11.2.128/25, nver=91: PELEM=0x7f37dc0c3f98 (lpathid=0, ver=25, fl=0x00000001): PATH=0x7f37dc0b36d8 (10.0.74.17/32,10.0.74.17,0, 0x4000000001040207)::: allowbe=0, isbe=0, allowspurwdr=0, pelem-send=1, pelem-wdr=1
RP/0/RP0/CPU0:Jan 21 18:18:06.749 : bgp[1048]: [default-upd] (ip4u): Sending UPDATE (packing existing msg) to sub-group 0.1 (Regular) pelem (Regular) filter-group0.1 with 11.11.2.128/25 (changedfl=0x0/0x0, bmsgflags=0x00000000, originator 0.0.0.0) unreachable (Path-element is not applicable)
RP/0/RP0/CPU0:Jan 21 18:18:06.749 : bgp[1048]: [default-upd] (ip4u): ORR Pelem(0x7f37dc0c3f28, id=0) Bestpath Bitfields :0x0; Addpath bitfields 0x0
RP/0/RP0/CPU0:Jan 21 18:18:06.749 : bgp[1048]: [default-upd] (ip4u): process UPDATE for: tbl=TBL:default (1/1), afi=0: ug=0.1, (Regular), pelem (Regular), sg=0.1, ugfl=0x0210418b: bgpctxfl=0x00, tblctxfl=0x00000021, ltblctxfl=0x00000021, sendlab=0: net=11.11.2.0/25, nver=90: PELEM=0x7f37dc0c3f28 (lpathid=0, ver=24, fl=0x00000001): PATH=0x7f37dc0b3678 (10.0.74.17/32,10.0.74.17,0, 0x4000000001040207)::: allowbe=0, isbe=0, allowspurwdr=0, pelem-send=1, pelem-wdr=1
RP/0/RP0/CPU0:Jan 21 18:18:06.749 : bgp[1048]: [default-upd] (ip4u): Sending UPDATE (packing existing msg) to sub-group 0.1 (Regular) pelem (Regular) filter-group0.1 with 11.11.2.0/25 (changedfl=0x0/0x0, bmsgflags=0x00000000, originator 0.0.0.0) unreachable (Path-element is not applicable)
RP/0/RP0/CPU0:Jan 21 18:18:06.749 : bgp[1048]: [default-upd] (ip4u): ORR Pelem(0x7f37dc0c3eb8, id=0) Bestpath Bitfields :0x0; Addpath bitfields 0x0
RP/0/RP0/CPU0:Jan 21 18:18:06.749 : bgp[1048]: [default-upd] (ip4u): process UPDATE for: tbl=TBL:default (1/1), afi=0: ug=0.1, (Regular), pelem (Regular), sg=0.1, ugfl=0x0210418b: bgpctxfl=0x00, tblctxfl=0x00000021, ltblctxfl=0x00000021, sendlab=0: net=11.11.1.128/25, nver=89: PELEM=0x7f37dc0c3eb8 (lpathid=0, ver=23, fl=0x00000001): PATH=0x7f37dc0b3618 (10.0.74.17/32,10.0.74.17,0, 0x4000000001040207)::: allowbe=0, isbe=0, allowspurwdr=0, pelem-send=1, pelem-wdr=1
RP/0/RP0/CPU0:Jan 21 18:18:06.749 : bgp[1048]: [default-upd] (ip4u): Sending UPDATE (packing existing msg) to sub-group 0.1 (Regular) pelem (Regular) filter-group0.1 with 11.11.1.128/25 (changedfl=0x0/0x0, bmsgflags=0x00000000, originator 0.0.0.0) unreachable (Path-element is not applicable)
RP/0/RP0/CPU0:Jan 21 18:18:06.749 : bgp[1048]: [default-upd] (ip4u): ORR Pelem(0x7f37dc0c3e48, id=0) Bestpath Bitfields :0x0; Addpath bitfields 0x0
RP/0/RP0/CPU0:Jan 21 18:18:06.749 : bgp[1048]: [default-upd] (ip4u): process UPDATE for: tbl=TBL:default (1/1), afi=0: ug=0.1, (Regular), pelem (Regular), sg=0.1, ugfl=0x0210418b: bgpctxfl=0x00, tblctxfl=0x00000021, ltblctxfl=0x00000021, sendlab=0: net=11.11.1.0/25, nver=88: PELEM=0x7f37dc0c3e48 (lpathid=0, ver=22, fl=0x00000001): PATH=0x7f37dc0b35b8 (10.0.74.17/32,10.0.74.17,0, 0x4000000001040207)::: allowbe=0, isbe=0, allowspurwdr=0, pelem-send=1, pelem-wdr=1
RP/0/RP0/CPU0:Jan 21 18:18:06.749 : bgp[1048]: [default-upd] (ip4u): Sending UPDATE (packing existing msg) to sub-group 0.1 (Regular) pelem (Regular) filter-group0.1 with 11.11.1.0/25 (changedfl=0x0/0x0, bmsgflags=0x00000000, originator 0.0.0.0) unreachable (Path-element is not applicable)
RP/0/RP0/CPU0:Jan 21 18:18:06.749 : bgp[1048]: [default-upd] (ip4u): ORR Pelem(0x7f37dc0c3dd8, id=0) Bestpath Bitfields :0x0; Addpath bitfields 0x0
RP/0/RP0/CPU0:Jan 21 18:18:06.749 : bgp[1048]: [default-upd] (ip4u): process UPDATE for: tbl=TBL:default (1/1), afi=0: ug=0.1, (Regular), pelem (Regular), sg=0.1, ugfl=0x0210418b: bgpctxfl=0x00, tblctxfl=0x00000021, ltblctxfl=0x00000021, sendlab=0: net=11.11.0.128/25, nver=87: PELEM=0x7f37dc0c3dd8 (lpathid=0, ver=21, fl=0x00000001): PATH=0x7f37dc0b3558 (10.0.74.17/32,10.0.74.17,0, 0x4000000001040207)::: allowbe=0, isbe=0, allowspurwdr=0, pelem-send=1, pelem-wdr=1
RP/0/RP0/CPU0:Jan 21 18:18:06.749 : bgp[1048]: [default-upd] (ip4u): Sending UPDATE (packing existing msg) to sub-group 0.1 (Regular) pelem (Regular) filter-group0.1 with 11.11.0.128/25 (changedfl=0x0/0x0, bmsgflags=0x00000000, originator 0.0.0.0) unreachable (Path-element is not applicable)
RP/0/RP0/CPU0:Jan 21 18:18:06.749 : bgp[1048]: [default-upd] (ip4u): ORR Pelem(0x7f37dc0c3d68, id=0) Bestpath Bitfields :0x0; Addpath bitfields 0x0
RP/0/RP0/CPU0:Jan 21 18:18:06.749 : bgp[1048]: [default-upd] (ip4u): process UPDATE for: tbl=TBL:default (1/1), afi=0: ug=0.1, (Regular), pelem (Regular), sg=0.1, ugfl=0x0210418b: bgpctxfl=0x00, tblctxfl=0x00000021, ltblctxfl=0x00000021, sendlab=0: net=11.11.0.0/25, nver=86: PELEM=0x7f37dc0c3d68 (lpathid=0, ver=20, fl=0x00000001): PATH=0x7f37dc0b34f8 (10.0.74.17/32,10.0.74.17,0, 0x4000000001040207)::: allowbe=0, isbe=0, allowspurwdr=0, pelem-send=1, pelem-wdr=1
RP/0/RP0/CPU0:Jan 21 18:18:06.749 : bgp[1048]: [default-upd] (ip4u): Sending UPDATE (packing existing msg) to sub-group 0.1 (Regular) pelem (Regular) filter-group0.1 with 11.11.0.0/25 (changedfl=0x0/0x0, bmsgflags=0x00000000, originator 0.0.0.0) unreachable (Path-element is not applicable)
RP/0/RP0/CPU0:Jan 21 18:18:06.749 : bgp[1048]: [default-upd] (ip4u): ORR Pelem(0x7f37dc0c4698, id=0) Bestpath Bitfields :0x0; Addpath bitfields 0x0
RP/0/RP0/CPU0:Jan 21 18:18:06.749 : bgp[1048]: [default-upd] (ip4u): process UPDATE for: tbl=TBL:default (1/1), afi=0: ug=0.1, (Regular), pelem (Regular), sg=0.1, ugfl=0x0210418b: bgpctxfl=0x00, tblctxfl=0x00000021, ltblctxfl=0x00000021, sendlab=0: net=9.9.0.0/21, nver=85: PELEM=0x7f37dc0c4698 (lpathid=0, ver=19, fl=0x00000001): PATH=0x7f37dc0b3438 (10.0.74.17/32,10.0.74.17,0, 0x4000000001040207)::: allowbe=0, isbe=0, allowspurwdr=0, pelem-send=1, pelem-wdr=1
RP/0/RP0/CPU0:Jan 21 18:18:06.749 : bgp[1048]: [default-upd] (ip4u): Sending UPDATE (packing existing msg) to sub-group 0.1 (Regular) pelem (Regular) filter-group0.1 with 9.9.0.0/21 (changedfl=0x0/0x0, bmsgflags=0x00000000, originator 0.0.0.0) unreachable (Path-element is not applicable)
RP/0/RP0/CPU0:Jan 21 18:18:06.749 : bgp[1048]: [default-iowt]: 10.0.74.18 send UPDATE length (incl. header) 171
RP/0/RP0/CPU0:Jan 21 18:18:06.749 : bgp[1048]: [default-iowt]: Send message dump for 10.0.74.18:
RP/0/RP0/CPU0:Jan 21 18:18:06.749 : bgp[1048]: [default-iowt]: ffff ffff ffff ffff ffff ffff ffff ffff
RP/0/RP0/CPU0:Jan 21 18:18:06.749 : bgp[1048]: [default-iowt]: 00ab 0200 9415 0808 0018 1500 0017 0808
RP/0/RP0/CPU0:Jan 21 18:18:06.749 : bgp[1048]: [default-iowt]: 0217 0808 0015 0202 0015 0707 0015 0606
RP/0/RP0/CPU0:Jan 21 18:18:06.749 : bgp[1048]: [default-iowt]: 0015 0101 0018 4601 0e18 1400 0018 1300
RP/0/RP0/CPU0:Jan 21 18:18:06.749 : bgp[1048]: [default-iowt]: 0018 1200 0018 1100 0018 4601 1018 4601
RP/0/RP0/CPU0:Jan 21 18:18:06.749 : bgp[1048]: [default-iowt]: 0f18 4601 0d18 4601 0c17 0202 0217 0707
RP/0/RP0/CPU0:Jan 21 18:18:06.749 : bgp[1048]: [default-iowt]: 0217 0707 0017 0202 0017 0606 0217 0606
RP/0/RP0/CPU0:Jan 21 18:18:06.749 : bgp[1048]: [default-iowt]: 0017 0101 0217 0101 0015 0303 0019 0b0b
RP/0/RP0/CPU0:Jan 21 18:18:06.749 : bgp[1048]: [default-iowt]: 0380 190b 0b03 0019 0b0b 0280 190b 0b02
RP/0/RP0/CPU0:Jan 21 18:18:06.749 : bgp[1048]: [default-iowt]: 0019 0b0b 0180 190b 0b01 0019 0b0b 0080
RP/0/RP0/CPU0:Jan 21 18:18:06.749 : bgp[1048]: [default-iowt]: 190b 0b00 0015 0909 0000 00
RP/0/RP0/CPU0:Jan 21 18:18:06.749 : bgp[1048]: [default-iowt] (ip4u): Deleting msg elem 0x0x1929134 (message 0x0x1826518), for filtergroup 0.1
RP/0/RP0/CPU0:Jan 21 18:18:06.750 : bgp[1048]: [default-iowt] (ip4u): Deleting message 0x0x1826518, from subgroup 0.1

2 ACCEPTED SOLUTIONS

Accepted Solutions
Highlighted

Hi Istvan,

It looks your missing the redistribution of the ORR routes from the IGP into BGP, it needs to be enabled as below:


router ospf xxxx
distribute bgp-ls <<<<<<

10.0.74.18 is the node you want to use as root in your spf calculation.
It has to match a router-id in the IGP link state database.

In ISIS, router-id is carried by default and nothing specific needs to be
added.

In OSPF, by default there is no LSA carrying the router-id.

You must use ospf mpls-te extensions to carry the router-id in a  Type-10
Opaque Link Area  LSA.

Cheers

Mohamed Elsayed

View solution in original post

Highlighted

Hi Istvan,

Configuration on RR looks fine.

on RRC you need to enable mpls traffic-eng globally to start sending LSA type-10

(config)#mpls traffic-eng

Cheers!

Mohamed Elsayed

View solution in original post

9 REPLIES 9
Highlighted
Beginner

? :(

Highlighted

Hi Istvan,

It looks your missing the redistribution of the ORR routes from the IGP into BGP, it needs to be enabled as below:


router ospf xxxx
distribute bgp-ls <<<<<<

10.0.74.18 is the node you want to use as root in your spf calculation.
It has to match a router-id in the IGP link state database.

In ISIS, router-id is carried by default and nothing specific needs to be
added.

In OSPF, by default there is no LSA carrying the router-id.

You must use ospf mpls-te extensions to carry the router-id in a  Type-10
Opaque Link Area  LSA.

Cheers

Mohamed Elsayed

View solution in original post

Highlighted

Hi Mohamed,

May I ask for a bit more explanation? On which device shall I enable what?

What I did so far:

RR config:

router ospf 1
distribute bgp-ls
area 0
mpls traffic-eng
interface Loopback0
!
interface GigabitEthernet0/0/0/0.74
cost 10
!
!
mpls traffic-eng router-id Loopback0

router bgp 600
bgp router-id 60.60.0.0
address-family ipv4 unicast
optimal-route-reflection g1 10.0.74.18
!
af-group IPV4U address-family ipv4 unicast
route-reflector-client
!
session-group RRCLI
remote-as 600
update-source Loopback0
!
neighbor 10.0.74.17
use session-group RRCLI
address-family ipv4 unicast
use af-group IPV4U
!
!
neighbor 10.0.74.18
use session-group RRCLI
address-family ipv4 unicast
use af-group IPV4U
optimal-route-reflection g1
!
!
neighbor 10.0.74.19
use session-group RRCLI
address-family ipv4 unicast
use af-group IPV4U
!
!
neighbor 10.0.74.20
use session-group RRCLI
address-family ipv4 unicast
use af-group IPV4U

RRC config:

router ospf 1
distribute bgp-ls
router-id 10.0.74.18
area 0
mpls traffic-eng
interface Loopback0
!
interface GigabitEthernet0/0/0/0.74
cost 100
!
interface GigabitEthernet0/0/0/0.1718
!
interface GigabitEthernet0/0/0/0.1820
!
!
mpls traffic-eng router-id Loopback0

RP/0/RP0/CPU0:vrr1#show orrspf database detail
Fri Feb 3 13:00:44.000 CET

ORR policy: g1, IPv4, RIB tableid: 0xe0000003
Configured root: primary: 10.0.74.18, secondary: NULL, tertiary: NULL
Actual Root: NULL, Root node: NULL

Thanks in advance!

Highlighted

Hi Istvan,

Configuration on RR looks fine.

on RRC you need to enable mpls traffic-eng globally to start sending LSA type-10

(config)#mpls traffic-eng

Cheers!

Mohamed Elsayed

View solution in original post

Highlighted

Thank so much! worked!

Highlighted

Hi Mohamed,

 

Thank you for the nice tricks to get ORR running, but it would be great if those where part of the official documentation:

http://www.cisco.com/c/en/us/td/docs/routers/virtual-routers/configuration/guide/b-xrv9k-cg/b-xrv9k-cg_chapter_0110.html#id_20200

 

I’d like to ask now how can I get a backup path(s) to RR-clients (considering I’m using type-1 RDs so all paths are available).

Should that happen automatically or do I need to specify backup SPF root for group “g1” please?

What if I’d like to advertise two alternate paths in addition to the ORR-best-path, is that possible please?

 

Also are there any plans to implement dynamic/automatic primary and alternate SPF root selection (as per the IETF draft)?

–i.e. every RR-client to be considered as SPF root automatically (or even better automatically make root selection optimizations based on topology).

 

Thank you

 

adam

adam
Highlighted

Hi Adam,

I think PIC EDGE is better choice than ORR. If RR sends 2 or more paths, RRC will chose the best from its perspective. ORR is only useful if you do not want to use PIC or mpath.

Correct me if I am wrong.

Highlighted

Actually I see this misconception in many forums

 

ORR was defined so that PIC EDGE can function without the need to distribute all paths (using Type-1 RDs) or small but not optimal set of paths(using Add-Path) to all PEs, but instead to allow RRs to compute and advertise only a small subset (e.g. best primary and best backup path –from client’s perspective) to each given RR-client.

 

 

adam

 

netconsultings.com

::carrier-class solutions for the telecommunications industry::

adam
Highlighted

Hi Adam,

I found a use case.

Let's say RR receives 3 paths from 3 different edge router. RR is not in the forwarding path, so all 3 paths look equal down to the IGP cost. Tiebraker is lower router ID. RR therefore sends its best(path1) and second best path(path2). However, from RRC's point of view path3 would be the best and path2 the backup based on the IGP cost.

ORR+PIC EDGE together will solve this case. Please see RR and RRC config.


RP/0/RP0/CPU0:vrr1#sh run
Fri Feb 10 01:49:53.750 CET
Building configuration...
!! IOS XR Configuration version = 6.1.2
!! Last configuration change at Fri Feb 10 01:48:59 2017 by admin
!
hostname vrr1
clock timezone CET Europe/Zurich
logging monitor debugging
telnet vrf MG ipv4 server max-servers 100
domain name vrr1.lab.local
username admin
group root-lr
group cisco-support
secret 5 $1$fORX$totdORAefoIH7suhTpdCH/
!
vrf MG
address-family ipv4 unicast
!
!
line template SSH
exec-timeout 0 0
transport input all
!
vty-pool default 0 99 line-template SSH
ntp
server vrf MG 62.76.96.4
server vrf MG 193.171.23.163 prefer
server vrf MG 193.225.121.161
!
call-home
service active
contact smart-licensing
profile CiscoTAC-1
active
destination transport-method http
!
!
interface Loopback0
ipv4 address 10.0.74.1 255.255.255.255
!
interface MgmtEth0/RP0/CPU0/0
vrf MG
ipv4 address 10.128.2.131 255.255.254.0
!
interface GigabitEthernet0/0/0/0.74
ipv4 address 10.74.0.1 255.255.255.0
encapsulation dot1q 74
!
interface GigabitEthernet0/0/0/1
shutdown
!
interface GigabitEthernet0/0/0/2
shutdown
!
interface GigabitEthernet0/0/0/3
shutdown
!
ospf-area-set 1
0
end-set
!
route-policy PIC
set path-selection backup 1 advertise
end-policy
!
route-policy BGP_ONLY
drop
end-policy
!
router static
vrf MG
address-family ipv4 unicast
0.0.0.0/0 MgmtEth0/RP0/CPU0/0 10.128.3.254
!
!
!
router ospf 1
distribute bgp-ls
area 0
interface Loopback0
!
interface GigabitEthernet0/0/0/0.74
cost 10
!
!
mpls traffic-eng router-id Loopback0
!
router bgp 600
bgp router-id 60.60.0.1
bgp cluster-id 60.60.0.0
bgp graceful-restart purge-time 60
bgp graceful-restart restart-time 60
bgp graceful-restart graceful-reset
bgp graceful-restart stalepath-time 60
bgp graceful-restart
address-family ipv4 unicast
optimal-route-reflection g1 10.0.74.18
table-policy BGP_ONLY
additional-paths send
additional-paths selection route-policy PIC
!
af-group IPV4U address-family ipv4 unicast
route-reflector-client
!
session-group RRCLI
remote-as 600
update-source Loopback0
!
neighbor 10.0.74.2
use session-group RRCLI
address-family ipv4 unicast
use af-group IPV4U
!
!
neighbor 10.0.74.3
use session-group RRCLI
address-family ipv4 unicast
use af-group IPV4U
!
!
neighbor 10.0.74.17
use session-group RRCLI
address-family ipv4 unicast
use af-group IPV4U
!
!
neighbor 10.0.74.18
use session-group RRCLI
address-family ipv4 unicast
use af-group IPV4U
optimal-route-reflection g1
!
!
neighbor 10.0.74.19
use session-group RRCLI
address-family ipv4 unicast
use af-group IPV4U
!
!
neighbor 10.0.74.20
use session-group RRCLI
address-family ipv4 unicast
use af-group IPV4U
!
!
!
mpls traffic-eng
!
ssh server v2
ssh server vrf MG
end

RP/0/RP0/CPU0:XRv9k_2#sh run
Fri Feb 10 01:54:46.073 CET
Building configuration...
!! IOS XR Configuration version = 6.1.2
!! Last configuration change at Thu Feb 9 22:36:35 2017 by admin
!
hostname XRv9k_2
clock timezone CET Europe/Zurich
logging monitor debugging
telnet vrf MG ipv4 server max-servers 100
domain name vrr1.lab.local
username admin
group root-lr
group cisco-support
secret 5 $1$fORX$totdORAefoIH7suhTpdCH/
!
vrf MG
address-family ipv4 unicast
!
!
line template SSH
exec-timeout 0 0
transport input all
!
vty-pool default 0 99 line-template SSH
ntp
server vrf MG 62.76.96.4
server vrf MG 193.171.23.163 prefer
server vrf MG 193.225.121.161
!
call-home
service active
contact smart-licensing
profile CiscoTAC-1
active
destination transport-method http
!
!
interface Loopback0
ipv4 address 10.0.74.18 255.255.255.255
!
interface Loopback1
ipv4 address 18.0.0.1 255.255.255.0
!
interface MgmtEth0/RP0/CPU0/0
vrf MG
ipv4 address 10.128.2.134 255.255.254.0
!
interface GigabitEthernet0/0/0/0.30
ipv4 address 30.0.30.92 255.255.255.0
encapsulation dot1q 30
!
interface GigabitEthernet0/0/0/0.74
ipv4 address 10.74.0.18 255.255.255.0
encapsulation dot1q 74
!
interface GigabitEthernet0/0/0/0.1518
ipv4 address 10.15.18.18 255.255.255.0
encapsulation dot1q 1518
!
interface GigabitEthernet0/0/0/0.1718
ipv4 address 10.17.18.18 255.255.255.0
encapsulation dot1q 1718
!
interface GigabitEthernet0/0/0/0.1820
ipv4 address 10.18.20.18 255.255.255.0
encapsulation dot1q 1820
!
interface GigabitEthernet0/0/0/0.2992
ipv4 address 35.29.92.92 255.255.255.0
encapsulation dot1q 2992
!
interface GigabitEthernet0/0/0/1
shutdown
!
interface GigabitEthernet0/0/0/2
shutdown
!
interface GigabitEthernet0/0/0/3
shutdown
!
route-policy NHS
if as-path neighbor-is '1000' then
set next-hop self
else
done
endif
end-policy
!
route-policy PIC
set path-selection backup 1 install
end-policy
!
router static
vrf MG
address-family ipv4 unicast
0.0.0.0/0 MgmtEth0/RP0/CPU0/0 10.128.3.254
!
!
!
router ospf 1
distribute bgp-ls
router-id 10.0.74.18
area 0
mpls traffic-eng
interface Loopback0
!
interface GigabitEthernet0/0/0/0.74
cost 100
!
interface GigabitEthernet0/0/0/0.1718
!
interface GigabitEthernet0/0/0/0.1820
!
!
mpls traffic-eng router-id Loopback0
!
router bgp 600
bgp router-id 10.0.74.18
bgp graceful-restart purge-time 60
bgp graceful-restart restart-time 60
bgp graceful-restart graceful-reset
bgp graceful-restart stalepath-time 60
bgp graceful-restart
bgp unsafe-ebgp-policy
address-family ipv4 unicast
additional-paths receive
additional-paths selection route-policy PIC
network 18.0.0.0/24
!
neighbor 10.0.74.1
remote-as 600
update-source Loopback0
address-family ipv4 unicast
route-policy NHS out
!
!
neighbor 10.0.74.2
remote-as 600
update-source Loopback0
address-family ipv4 unicast
route-policy NHS out
!
!
neighbor 30.0.30.17
remote-as 1000
address-family ipv4 unicast
!
!
neighbor 10.15.18.15
remote-as 1000
ebgp-multihop 255
address-family ipv4 unicast
!
!
neighbor 35.29.92.29
remote-as 29
address-family ipv4 unicast
!
!
!
mpls traffic-eng
!
ssh server v2
ssh server vrf MG
end

PIC EDGE only:


RP/0/RP0/CPU0:XRv9k_2#sh ip bgp 21.0.0.0
Fri Feb 10 01:47:28.516 CET
BGP routing table entry for 21.0.0.0/24
Versions:
Process bRIB/RIB SendTblVer
Speaker 681506 681506
Last Modified: Feb 10 01:44:02.961 for 00:03:28
Paths: (2 available, best #2)
Advertised to update-groups (with more than one peer):
0.3
Path #1: Received by speaker 0
Not advertised to any peer
65010
10.0.74.3 (metric 101) from 10.0.74.1 (10.0.74.3)
Origin IGP, metric 0, localpref 100, valid, internal, backup, add-path
Received Path ID 0, Local Path ID 1, version 681506
Originator: 10.0.74.3, Cluster list: 60.60.0.0
Path #2: Received by speaker 0
Advertised to update-groups (with more than one peer):
0.3
65010
10.0.74.19 (metric 3) from 10.0.74.1 (10.0.74.19)
Origin IGP, metric 0, localpref 100, valid, internal, best, group-best
Received Path ID 5, Local Path ID 0, version 681506
Originator: 10.0.74.19, Cluster list: 60.60.0.0

PIC EDGE+ORR:


RP/0/RP0/CPU0:XRv9k_2#sh ip bgp 21.0.0.0
Fri Feb 10 01:49:22.717 CET
BGP routing table entry for 21.0.0.0/24
Versions:
Process bRIB/RIB SendTblVer
Speaker 681508 681508
Last Modified: Feb 10 01:49:05.961 for 00:00:19
Paths: (2 available, best #1)
Advertised to update-groups (with more than one peer):
0.3
Path #1: Received by speaker 0
Advertised to update-groups (with more than one peer):
0.3
65010
10.0.74.20 (metric 2) from 10.0.74.1 (10.0.74.20)
Origin IGP, metric 0, localpref 100, valid, internal, best, group-best
Received Path ID 3, Local Path ID 0, version 681508
Originator: 10.0.74.20, Cluster list: 60.60.0.0
Path #2: Received by speaker 0
Not advertised to any peer
65010
10.0.74.19 (metric 3) from 10.0.74.1 (10.0.74.19)
Origin IGP, metric 0, localpref 100, valid, internal, backup, add-path
Received Path ID 5, Local Path ID 1, version 681508
Originator: 10.0.74.19, Cluster list: 60.60.0.0