cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
233
Views
5
Helpful
1
Replies

Cisco IOS XE Software, Version 16.09.05----------IOS-XE bundle 16.09.05 json file is not available

Hi Boss,

 

I haven't found XE version 16.9.5 in this portal.

https://github.com/YangModels/yang/tree/master/vendor/cisco/xe

 

 

Does it mean IOS-XE bundle 16.09.05 json file is not available now. So I am not able to run YDK python program  to my switches (16.9.5) very well. it may has some potential problems. If I use 16.9.11 or 16.9.3 json ?

 

Any idea , thank you

 

 

 

yang/vendor/cisco/xe/

Jacky Zhang
Global Telecom
1 ACCEPTED SOLUTION

Accepted Solutions
yangorelik
Participant

Hi Jacky

It seems that you are trying to create a bundle of XE version under development, because it is currently not available in the official public YANG repository. Only 16.9.3 is available. If it is not testing of new XE release, I would recommend to use existing bundle for 16.9.3. That would be good approximation, but not guaranteed to work on all the models, as I believe 16.9.5 models are slightly different. For new models you would need to get the 16.9.5 Cisco internal repository and generate the bundle yourself.

Yan Gorelik
YDK Solutions

View solution in original post

1 REPLY 1
yangorelik
Participant

Hi Jacky

It seems that you are trying to create a bundle of XE version under development, because it is currently not available in the official public YANG repository. Only 16.9.3 is available. If it is not testing of new XE release, I would recommend to use existing bundle for 16.9.3. That would be good approximation, but not guaranteed to work on all the models, as I believe 16.9.5 models are slightly different. For new models you would need to get the 16.9.5 Cisco internal repository and generate the bundle yourself.

Yan Gorelik
YDK Solutions

View solution in original post

Content for Community-Ad