キャンセル
次の結果を表示 
次の代わりに検索 
もしかして: 
cancel
24892
閲覧回数
46
いいね!
15
返信

JPNE 「v6プラス」固定IPサービスへのIOSルータ接続(IPv6パススルー編: ひかり電話を契約していない場合)

ywatanab
Cisco Employee
Cisco Employee

日本ネットワークイネーブラー株式会社(JPNE)が提供する「v6プラス」固定IPサービスへ弊社IOSルータを接続するためのサンプル設定を公開します。

※ 「v6プラス」固定IPサービスについては、こちら: https://www.jpne.co.jp/service/v6plus-static/

 

設定には、JPNEより提供される各種IPアドレスが必要です。以下のIOSサンプル設定を参考にしてください。

 

==========
 sample config
==========

### ブリッジ関連設定 (Global Configuration Mode) ###
bridge irb
bridge 1 protocol ieee
bridge 1 route ip
access-list 200 permit 0x86DD 0x0000

!

### ipv6 unicast routing 設定  (Global Configuration Mode) ###
ipv6 unicast-routing
ipv6 cef
!

### WAN側物理インターフェース設定 ###
interface GigabitEthernet0/5
 no ip address
 duplex auto
 speed auto
 bridge-group 1
 bridge-group 1 input-type-list 200
!

### LAN側物理インターフェース設定 ###
interface GigabitEthernet0/0
 no ip address
 bridge-group 1
!

### BVIインターフェース設定 ###
interface BVI1
 ip address 10.10.10.1 255.255.255.128  (LAN側のIPv4アドレス)
 ip nat inside
 ipv6 address FE80::'ISPより指定されたインタフェイスID(IFID)' link-local
 ipv6 address autoconfig
 ipv6 enable
 ipv6 nd autoconfig default-route
 ipv6 nd ra suppress all
!

### トンネルインターフェース設定 ###
interface Tunnel0
 ip address ‘固定IPアドレス x.x.x.x’ 'サブネットマスク y.y.y.y'
 ip nat outside
 ip virtual-reassembly in
 ip tcp adjust-mss 1300
 tunnel source BVI1
 tunnel mode ipv6
 tunnel destination ‘BRのIPv6アドレス'
!

### NAT(PAT)設定 ###
ip nat inside source list 23 interface Tunnel0 overload
access-list 23 permit 10.10.10.0 0.0.0.127

### ルーティング設定 ###
ip route 0.0.0.0 0.0.0.0 Tunnel0

### kron(スケジューラ)設定 ###
※v6Plus.tclを定期的に実行するIOSスケジューラ
※下記はc891FJの場合。c841MJの場合はflashをsdflash指定にする
kron occurrence v6plus_update in 15 recurring system-startup
policy-list v6plus_policy
!
kron policy-list v6plus_policy
 cli tclsh flash:v6plus.tcl
!

### TCL設定 ###
(以下、891FJの場合。841Mの場合はflashのところをsdflashで指定)
C891FJ#tclsh
C891FJ(tcl)#puts [open flash:/v6plus.tcl w+] {
+> more http://(ISPから指定のURL)?user=(ISPから指定の再設定ユーザ名)&pass=(ISPから指定の再設定パスワード)
+>}
C891FJ(tcl)#exit
C891FJ#more flash:v6plus.tcl
 more http://(ISPから指定のURL)?user=(ISPから指定の再設定ユーザ名)&pass=(ISPから指定の再設定パスワード)

※上記URLはJPNE指定のものを利用する

15件の返信15

livecodec
Level 1
Level 1

IPv6パススルーを実施したうえで、IPv6インターネット側の第三者によるアクセスを制限する方法はありますでしょうか?

■V6プラスで固定IP契約がない場合の
設定方法もありましたらご指導ください

memeng
Cisco Employee
Cisco Employee

上記の設定について、C841M-4X-JAIS/K9とC841M-8X-JAIS/K9で動作できますが、
C841M-4X-JSEC/K9で動作できません。

 

C841M-4X-JSEC/K9は「DHCPv6-PD編: ひかり電話を契約している場合」で動作できます。
詳細について、下記のリンク先をご参照ください。

 

------------
JPNE 「v6プラス」固定IPサービスへのIOSルータ接続(DHCPv6-PD編: ひかり電話を契約している場合)
https://community.cisco.com/t5/-/-/ta-p/3725950
------------

 

ご利用者の皆様は十分ご注意ください。

C841M-4X-JSEC/K9を使用している者です。

 

上記の設定がJSEC/K9では使用できないとのことですが、

ひかり電話を契約していなくともDHCPv6-PD編の設定を投入して、IPv6で通信させることはできますか?

 

提示いただいているリンク先の設定では、割当てられている固定IPv4アドレスでの通信はできますが、IPv6での通信ができていないようです。

これが不可である場合、JSEC/K9でIPv6パススルーを実現するサンプル設定についても提供いただければ幸いです。

ひかり電話契約が無い場合、DHCPv6-PDによるアドレス取得はできずRAによる取得となります。
JSEC/K9では、RA(IPv6パススルー)が未サポートとなります。JAIS/K9のモデルが必要です。

 

JSEC/K9: DHCPv6-PD サポート / IPv6パススルー 未サポート

JAIS/K9: DHCPv6-PD サポート / IPv6パススルー サポート

 

ひかり電話契約の有無によるIPv6アドレスの取得方法

あり: HGWからDHCPv6-PD or HGWからRA

なし: RA

ご担当者様

 

早速のご回答いただきありがとうございます。

IPv6パススルー未サポートとのこと、承知いたしました。

 

「v6プラス」固定IPサービスへの接続が可能ということですので、あらためて聞くまでもないこととは思いますが、

IPv6 IPoE+IPv4 over IPv6への接続は公式にサポートしているという理解でよろしいでしょうか?

v6プラスの固定IPサービスでの IPv6 IPoE + IPv4 over IPv6 トンネル接続をサポートしております。

ただし、IOSルータの場合は IPv4 over IPv6トンネルをProcess 処理するため最大30Mbps程度のスループットとなりますのでご注意ください。

IPv6はCEF処理ですのでその限りではございません。


IOS-XEルータではIPv4 over IPv6トンネルもCEFでの処理となりますのでお勧めです。

 

こんばんは。横から突然すみません。

"IOSルータの場合は IPv4 over IPv6トンネルをProcess 処理するため最大30Mbps程度のスループットとなります"とありますが、こちらはCCO(Cisco.com)のどこかに記載がありますでしょうか。可能であれば情報ソース(出典元)をご教示いただけないでしょうか。

また、IOSルータの場合とありますが、Cisco 841Mだけでなく、後継機のCisco 921JやCisco 891FJ/892FSPなども同様でしょうか。

あと、IPv4 over IPv6トンネルであれば、IPoEを使用していなくてもProcess処理になるのでしょうか。

 

30Mbpsまでにスループットが落ちてしまう場合の条件として、どの機能をどのような感じで使用すると条件に一致するかを知りたく思っていますので、ご回答いただけますと幸いです。

CCOに記載はございません。実機でのスループット測定結果とプロセス処理していることを確認しております。

こちらはIOSルータの場合の実装です。IOSルータのCisco921JやCisco891FJ/892FSPも同様です。

 

"tunnel mode ipv6" 

この設定を行った際プロセス処理となります。

IOS-XEルータの場合はCEFで処理されます。

 

### トンネルインターフェース設定 ###
interface Tunnel0
ip address ‘固定IPアドレス x.x.x.x’ 'サブネットマスク y.y.y.y'
ip nat outside
ip virtual-reassembly in
ip tcp adjust-mss 1300
tunnel source BVI1
tunnel mode ipv6   <<< ここです
tunnel destination ‘BRのIPv6アドレス'
!

 

>あと、IPv4 over IPv6トンネルであれば、IPoEを使用していなくてもProcess処理になるのでしょうか。

IPv6トンネルであればProcess処理となります。つまり "tunnel mode ipv6"の時がProcess処理です。

"IPoEを使用していなくても" の真意が読み取れていないかもしれませんが、何れにせよIPv6トンネルなのでアンダーレイはIPv6となります。IPv6 over IPv6も同様です。

因みに、gre ipv6 の場合は CEF処理となります。

 

早速のご回答誠にありがとうございます。

また、問い合わせ文の一部に意図が汲み取りにくい箇所がありました事、お詫び申し上げます。

非常に具体的かつ丁寧なご回答をいただいており、大変勉強になります。

さて、いただいた内容について返答させていただきます。

 

実機で検証されたとの事なので間違いなさそうですね。ちなみに、30Mbpsというのは受信時でしょうか、それとも送信時でしょうか、はたまた受信と送信の合計値でしょうか。

あと、CCOに記載がないというのは何とかならないものかと思います。というのも、機種選定をする際に判断/根拠となる重要情報だと思いますので、実際に実機を購入して検証または導入してからスペックが不足していたというのが分かると、設計者としてはとても困ると思います。Cisco製品への不信感が増長する事にもつながりかねませんので、是非とも改善をお願いしたいところです。

 

IPoEであれば~~と質問させていただいたのは、 tunnel mode ipv6 の設定が施されている場合はという意図でしたので、Process処理になるという事で理解しました。

ところで、"tunnel mode ipv6"の時がProcess処理ですが、gre ipv6 の場合は CEF処理になるとありますが、FlexVPNの場合はどちらが該当しますでしょうか。当方環境ではIPv6を利用したFlexVPNをCisco892FSPで使用しておりまして、具体的なコンフィグは下記になります。

interface Tunnel100
  ip address 10.0.0.1 255.255.255.255
  tunnel source GigabitEthernet9
  tunnel mode gre ipv6
  tunnel destination dynamic
  tunnel protection ipsec profile IPSEPROF_FLEXVPN

 

tunnel mode ipv6 ではなく、tunnel mode gre ipv6 なので、ご教授いただいた内容からはCEF処理になる?と思うのですが如何でしょうか。

 

あれこれと質問しまして恐縮ですが、ご回答を賜りたく、伏してお願い申し上げます。

 

スループット約30Mbpsというのは送受信合計です。

RFC2544試験でのNDR(Non Drop Rate)です。

双方向に負荷をかけた状態でのNDRとなります。

 

tunnel mode gre ipv6 の場合は CEF処理となります。

 

 

早速のご回答、誠にありがとうございます。

いただいた内容について承知しました。

 

突然の投稿にも関わらず、迅速にご対応いただけましたこと、厚く御礼申し上げます。

Shinji Fujii
Level 1
Level 1

【使用機器】
C1111-8P
Cisco IOS XE Software, Version 16.09.03


JPNE「v6プラス」固定IPサービスへC1111を接続するにあたり、DNS設定を入れようとしています。
JPNEから提供されるDNS情報がIPv6であり(下記の<参照用DNS_プライマリ/セカンダリIP>)、
またUplink側にTunnel、Downlink側にNATを利用していることから、DNS情報をIPv6→IPv4へ変換したいのですが、
どのようなconfigを作成すればいいか教えて下さい。

現状では、下記configの<参照用DNS_プライマリIP> <参照用DNS_セカンダリIP>部分にIPv4しか設定できません。

#DHCPアドレスプールの設定
ip dhcp pool local
network xxx.xxx.xxx.xxx yyy.yyy.yyy.yyy
default-router zzz.zzz.zzz.zzz
dns-server <参照用DNS_プライマリIP> <参照用DNS_セカンダリIP>


(参考:下記の通りTunnelとNATを設定しています)
#Tunnel設定(論理上位接続)
interface Tunnel0
ip address <IPv4アドレス> <IPv4アドレスサブネット255.255.x.x>
no ip redirects
no ip unreachables
ip nat outside
ip tcp adjust-mss 1300
tunnel source GigabitEthernet0/0/0
tunnel mode ipv6
tunnel destination <BRアドレス>
tunnel path-mtu-discovery
ip virtual-reassembly

#Gi0/0/0番の設定(物理上位接続)
interface GigabitEthernet0/0/0
no ip address
no ip redirects
no ip unreachables
no shutdown
negotiation auto
no cdp enable
ipv6 address <インターフェイスID> link-local
ipv6 address autoconfig
ipv6 enable
ipv6 nd autoconfig default-route
ipv6 nd ra suppress all
ip virtual-reassembly
exit

#Gi0/1/0番の設定(物理下位接続)
interface GigabitEthernet0/1/0
switchport trunk allowed vlan 1,23
switchport mode trunk
exit

# VLAN1 の設定(論理下位接続)
interface Vlan1
ip address aaa.aaa.aaa.aaa 255.255.x.x
ip nat inside
ip virtual-reassembly
ip access-group 101 in
exit

#ACL1番の設定 
access-list 1 permit bbb.bbb.bbb.bbb ccc.ccc.ccc.ccc

#NAT設定
ip nat inside source list 1 interface Tunnel0 overload
ip forward-protocol nd
no ip http server
ip http authentication local
no ip http secure-server
ip route 0.0.0.0 0.0.0.0 Tunnel0

 

broadcast_storm
Level 1
Level 1

サンプルconfigを提供いただきありがとうございます。

つきましてはconfigについて質問がございます。

 

提供いただいたサンプルconfigについて、以下のパラメータには何を入力すればよろしいでしょうか?

また、どこのサイトで情報を取得することが可能でしょうか?

 

==========
 sample config
==========


### トンネルインターフェース設定 ###
interface Tunnel0
 ip address ‘固定IPアドレス x.x.x.x’ 'サブネットマスク y.y.y.y'
 tunnel destination ‘BRのIPv6アドレス'

### TCL設定 ###
(以下、891FJの場合。841Mの場合はflashのところをsdflashで指定)
C891FJ#tclsh
C891FJ(tcl)#puts [open flash:/v6plus.tcl w+] {
+> more http://(ISPから指定のURL)?user=(ISPから指定の再設定ユーザ名)&pass=(ISPから指定の再設定パスワード)
+>}

お客様固有の情報となりますので、これらはご契約されているISP様より入手いただけると思います。

v6プラス固定IPアドレスサービスでご契約された場合、固定IPv4アドレスが個別に割り当てられますので情報はISP様より入手ください。