取消
显示结果 
搜索替代 
您的意思是: 
cancel
7393
查看次数
12
有帮助
7
回复

IP default-network 命令的问题

gongym
Beginner
Beginner
EIGRP中配置默认路由的命令是
IP default-network
但是我做了这么就没有用呢,就是无法通告默认路由出去
IP default-network 172.16.1.0
其中172.16.1.1 是我的一个环回口的地址:
inter loop 0
ip add 172.16.1.1 255.255.255.0
其他的VPN的配置很多,应该都没有问题,也和EIGRP应该是没有关系的
换了几个7200的IOS都不行,确定不是版本和模拟器的问题
1 个已接受解答

已接受的解答

suzhouxiaoniu
Advocate
Advocate
解决方法,把loopback接口的地址做一下手工汇总就可以了:(当然也可以开启自动汇总,不建议)
原因楼上已经说过了:
给你一个参考文档:(网上的)
EIGRP传递默认路由方法总结:
以下现象要和RIP对比记忆
1:写一条默认路由,network到EIGRP进程
ip route 0.0.0.0 0.0.0.0 interface(接口必须是up而且要有address,或者是 null0)
router eigrp AS
network 0.0.0.0 缺点.会在宣告的路由器上,将所有接口激活.包括你不想激活的接口
注意在RIP中创建的默认路由不会从所跟的接口和能到达下跳地址的接口传递出去但是EIGRP可以这个是因为水平分割在RIP中是默认关闭的而EIGRP不是。
2:写一条默认路由,重分布静态到EIGRP进程
ip route 0.0.0.0 0.0.0.0 interface(接口必须是up而且要有address或者是null0)
router eirp AS
redistribute static 默认路由出现的形式D*EX AD=170
和RIP的对比和第1种方法一样。
3:接口下手工汇总 ip summary-address eirp 90 0.0.0.0 0.0.0.0
0.0.0.0的默认路由会传递给接口连接的邻居(不在乎auto/no auto-summary/也不需要写静态)
缺点:具有方向性.具有抑制明细的特点。
RIP必须创建默认路由。
4、ip default-network x.x.x.x(必须有类的输入) 并且这条路由要能出现在本地路由表和整个网络中 (不需要静态路由)
因此需要作auto-summary 或者手工汇总
邻居的路由表里也必须是汇总路由
如果将学到路由当作传递的缺省网络.此时路由条目必须是主类
(传递的要求是主类路由带有"D*")
EIGRP不会产生0.0.0.0的默生路由,而是借用带有D*的路由的下一跳做为缺省下一跳。
RIP传递是一条0.0.0.0/0的默认路由。
在EIGRP中Default-information 不是用来传递默认路由而是用来控制(但是RIP是)
Default-information allow in 是默认在进程中开启
允许所有可传递的默认网络进入本路由器
Default-information allow out 是默认在进程中开启
允许所有可传递的默认网络传递出本路由器
命令前+NO跟OUT或者IN.表示不允许进入默认路由或者传递默认路由,而不是NO掉此命令
可选参数:调用ACL.来匹配ACL中的默认路由网络

在原帖中查看解决方案

7 条回复7

suzhouxiaoniu
Advocate
Advocate
解决方法,把loopback接口的地址做一下手工汇总就可以了:(当然也可以开启自动汇总,不建议)
原因楼上已经说过了:
给你一个参考文档:(网上的)
EIGRP传递默认路由方法总结:
以下现象要和RIP对比记忆
1:写一条默认路由,network到EIGRP进程
ip route 0.0.0.0 0.0.0.0 interface(接口必须是up而且要有address,或者是 null0)
router eigrp AS
network 0.0.0.0 缺点.会在宣告的路由器上,将所有接口激活.包括你不想激活的接口
注意在RIP中创建的默认路由不会从所跟的接口和能到达下跳地址的接口传递出去但是EIGRP可以这个是因为水平分割在RIP中是默认关闭的而EIGRP不是。
2:写一条默认路由,重分布静态到EIGRP进程
ip route 0.0.0.0 0.0.0.0 interface(接口必须是up而且要有address或者是null0)
router eirp AS
redistribute static 默认路由出现的形式D*EX AD=170
和RIP的对比和第1种方法一样。
3:接口下手工汇总 ip summary-address eirp 90 0.0.0.0 0.0.0.0
0.0.0.0的默认路由会传递给接口连接的邻居(不在乎auto/no auto-summary/也不需要写静态)
缺点:具有方向性.具有抑制明细的特点。
RIP必须创建默认路由。
4、ip default-network x.x.x.x(必须有类的输入) 并且这条路由要能出现在本地路由表和整个网络中 (不需要静态路由)
因此需要作auto-summary 或者手工汇总
邻居的路由表里也必须是汇总路由
如果将学到路由当作传递的缺省网络.此时路由条目必须是主类
(传递的要求是主类路由带有"D*")
EIGRP不会产生0.0.0.0的默生路由,而是借用带有D*的路由的下一跳做为缺省下一跳。
RIP传递是一条0.0.0.0/0的默认路由。
在EIGRP中Default-information 不是用来传递默认路由而是用来控制(但是RIP是)
Default-information allow in 是默认在进程中开启
允许所有可传递的默认网络进入本路由器
Default-information allow out 是默认在进程中开启
允许所有可传递的默认网络传递出本路由器
命令前+NO跟OUT或者IN.表示不允许进入默认路由或者传递默认路由,而不是NO掉此命令
可选参数:调用ACL.来匹配ACL中的默认路由网络

one-time
Expert
Expert
谁能帮gongym看看问题呢?奖金多多哦:P

exCCNA
Beginner
Beginner
本帖最后由 exCCNA 于 2015-6-23 15:03 编辑
IP default-network 这个命令后面必须跟主网号,不允许写子网或IP地址,并且它后面引用的主网号在路由表中必须出现。注意必须是主网路由,如果路由表中只有该主网的某个或某些子网路由,这条命令仍然无法生效。在满足上述条件的前提下,还必须将此命令后面的主网号通告到EIGRP协议中,这样才能通过EIGRP协议自动传播默认路由。
关于EIGRP协议中这条命令的详细解释,可参考<<路由篇-网络故障分析-(下册)>>这本书,其中对这个命令解释的比较详细。
顺便说一句,一般情况下通过EIGRP传播默认路由不建议用这条命令,建议通过重分发静态默认路由来实现。

gongym
Beginner
Beginner
suzhouxiaoniu 发表于 2015-6-23 12:21 back.gif
解决方法,把loopback接口的地址做一下手工汇总就可以了:(当然也可以开启自动汇总,不建议)
原因楼上 ...

做手工汇总果然是可以的:handshake

gongym
Beginner
Beginner
exCCNA 发表于 2015-6-19 17:07 back.gif
IP default-network 这个命令后面必须跟主网号,不允许写子网或IP地址,并且它后面引用的主网号在路由表中必 ...

那么这个命令,还有什么意义呢。不好用,也不建议用的话。

exCCNA
Beginner
Beginner
gongym 发表于 2015-6-24 10:26 back.gif
那么这个命令,还有什么意义呢。不好用,也不建议用的话。

我之所以说不建议使用使用这条命令就是因为它的前提要求比较苛刻:路由表中必须包含相应的主网路由。这个条件在实际网络环境中不一定能得到满足,因此为了使用这条命令就必须想方设法满足这个要求,例如写一条指向NULL0接口的主网静态路由等方法。而相比之下通过重分发静态默认路由就比较方便。我所说的建议与不建议就是从实现是否容易的角度讲的,毕竟越复杂的系统越容易出问题。但ip default-network命令并非没有意义,当不方便用重分发命令时采用ip default-network命令所实现的效果是相同的。

gongym
Beginner
Beginner
exCCNA 发表于 2015-6-24 13:08 back.gif
我之所以说不建议使用使用这条命令就是因为它的前提要求比较苛刻:路由表中必须包含相应的主网路由。这个 ...

谢谢了,现在终于明白了
入门指南

使用上面的搜索栏输入关键字、短语或问题,搜索问题的答案。

我们希望您在这里的旅程尽可能顺利,因此这里有一些链接可以帮助您快速熟悉思科社区:





认可您的同行
快捷链接