cancelar
Mostrar resultados para 
Pesquisar em vez de 
Queria dizer: 
cancel
801
Apresentações
4
Útil
4
Comentários
Assis Teixeira
Spotlight
Spotlight

Estou trabalhando em um laboratório de rede baseado em uma topologia de 3 camadas (Core, Distribuição e Acesso) para praticar conceitos fundamentais de redes. Abaixo está um resumo da configuração e tecnologias utilizadas:

- Estrutura de 3 camadas:
- Camada de Core para roteamento principal.
- Camada de Distribuição onde configurei DHCP para fornecer endereços IP automaticamente aos hosts na camada de acesso.
- Camada de Acesso conectada aos hosts através de VLANs.

- VLANs:
- Criei 2 VLANs diferentes, uma para cada grupo de hosts conectados na camada de acesso.

- DHCP:
- O servidor DHCP foi configurado na Camada de Distribuição, e está fornecendo IPs dinamicamente para os hosts nas duas VLANs.

- Port-channel:
- Usei Port-channel em L2 e L3 para agregar links entre switches, melhorando a redundância e a performance.

- Spanning-tree:
- Habilitei o Spanning-tree para evitar loops na rede.

- OSPF:
- Configurei o protocolo de roteamento dinâmico OSPF para garantir conectividade entre as camadas e entre os dispositivos internos.

- NAT:
- Configurei NAT (Network Address Translation) para que os hosts possam acessar a internet.

- Conectividade Externa:
- Os hosts têm conectividade com um IP externo (8.8.8.8), o que confirma que o NAT está funcionando corretamente e o OSPF está propagando as rotas corretamente.

Este laboratório simula um cenário nível CCNA e cobre várias tecnologias essenciais, como VLANs, OSPF, Port-channel, Spanning-tree, NAT, e DHCP. O objetivo é testar a configuração e conectividade entre as camadas, além de garantir o acesso externo.

Segue a Topologia usada:

Topologia-CCNA.jpg

 

Configuração dos equipamentos:

SW-ACCESS-01

enable
conf t
hostname SW-ACCESS-01
line con 0
logging synchronous
password cisco
login local
exec-timeout 5 0
exit

line vty 0 4
logging synchronous
exec-timeout 5 0
password cisco
login local
transport input ssh
exit

service password-encryption
enable secret cisco
! no ip domain-lookup (Opcional)
ip domain-name transdata.com
username admin privilege 15 secret admin

crypto key generate rsa
1024

ip ssh version 2

ip name-server 8.8.8.8

spanning-tree mode rapid-pvst

vlan 11
name DIRETORIA
exit
!
vlan 12
name MARKETING
exit
!


interface vlan 11
no shutdown
ip address 10.1.1.5 255.255.255.0
exit
!
interface vlan 12
no shutdown
ip address 10.1.2.5 255.255.255.0
exit
!

interface FastEthernet0/10
switchport access vlan 11
switchport mode access
switchport port-security maximum 3
switchport port-security violation restrict
switchport port-security mac-address sticky
switchport port-security
!

interface FastEthernet0/11
switchport access vlan 12
switchport mode access
switchport port-security maximum 3
switchport port-security violation restrict
switchport port-security mac-address sticky
switchport port-security
!

interface FastEthernet0/1
switchport mode trunk
switchport trunk allowed vlan 1,11,12

interface FastEthernet0/2
switchport mode trunk
switchport trunk allowed vlan 1,11,12

end
wr

-----------------------------

SW-ACCESS-02

enable
conf t
hostname SW-ACCESS-02
line con 0
logging synchronous
password cisco
login local
exec-timeout 5 0
exit

line vty 0 4
logging synchronous
exec-timeout 5 0
password cisco
login local
transport input ssh
exit

service password-encryption
enable secret cisco
no ip domain-lookup
ip domain-name transdata.com
username admin privilege 15 secret admin

crypto key generate rsa
1024

ip ssh version 2

ip name-server 8.8.8.8

spanning-tree mode rapid-pvst

vlan 11
name DIRETORIA
exit
!
vlan 12
name MARKETING
exit
!

interface vlan 11
no shutdown
ip address 10.1.1.6 255.255.255.0
exit
!
interface vlan 12
no shutdown
ip address 10.1.2.6 255.255.255.0
exit
!

interface FastEthernet0/10
switchport access vlan 11
switchport mode access
switchport port-security maximum 3
switchport port-security violation restrict
switchport port-security mac-address sticky
switchport port-security
!

interface FastEthernet0/11
switchport access vlan 12
switchport mode access
switchport port-security maximum 3
switchport port-security violation restrict
switchport port-security mac-address sticky
switchport port-security
!

interface FastEthernet0/1
switchport mode trunk
switchport trunk allowed vlan 1,11,12

interface FastEthernet0/2
switchport mode trunk
switchport trunk allowed vlan 1,11,12

end
wr

-------------------------------

SW-DIST-01

enable
conf t
hostname SW-DIST-01
line con 0
logging synchronous
password cisco
login local
exec-timeout 5 0
exit

line vty 0 4
logging synchronous
exec-timeout 5 0
password cisco
login local
transport input ssh
exit

service password-encryption
enable secret cisco
no ip domain-lookup
ip domain-name transdata.com
username admin privilege 15 secret admin

crypto key generate rsa
1024

ip ssh version 2

ip name-server 8.8.8.8

spanning-tree mode rapid-pvst

vlan 11
name DIRETORIA
exit
!
vlan 12
name MARKETING
exit
!


interface vlan 11
no shutdown
ip address 10.1.1.3 255.255.255.0
exit
!
interface vlan 12
no shutdown
ip address 10.1.2.3 255.255.255.0
exit
!

interface Port-channel2
switchport trunk encapsulation dot1q
switchport mode trunk
!
interface Port-channel4
switchport trunk encapsulation dot1q
switchport mode trunk
!
interface FastEthernet0/1
switchport trunk encapsulation dot1q
switchport mode trunk
channel-group 4 mode active
!
interface FastEthernet0/2
switchport trunk encapsulation dot1q
switchport mode trunk
channel-group 4 mode active
!
interface FastEthernet0/3
switchport trunk encapsulation dot1q
switchport mode trunk
channel-group 2 mode passive
!
interface FastEthernet0/4
switchport trunk encapsulation dot1q
switchport mode trunk
channel-group 2 mode passive
!
interface FastEthernet0/5
switchport trunk encapsulation dot1q
switchport mode trunk
!
interface FastEthernet0/6
switchport trunk encapsulation dot1q
switchport mode trunk
!

!DHCP

ip dhcp excluded-address 10.1.1.1 10.1.1.10
ip dhcp excluded-address 10.1.2.1 10.1.2.10
!
ip dhcp pool REDE-11-DIRETORIA
network 10.1.1.0 255.255.255.0
default-router 10.1.1.1
exit

ip dhcp pool REDE-12-MARKETING
network 10.1.2.0 255.255.255.0
default-router 10.1.2.1
exit


ip route 0.0.0.0 0.0.0.0 10.1.1.1
ip route 0.0.0.0 0.0.0.0 10.1.2.1

end
wr

-------------------------------

SW-DIST-02

enable
conf t
hostname SW-DIST-02
line con 0
logging synchronous
password cisco
login local
exec-timeout 5 0
exit

line vty 0 4
logging synchronous
exec-timeout 5 0
password cisco
login local
transport input ssh
exit

service password-encryption
enable secret cisco
no ip domain-lookup
ip domain-name transdata.com
username admin privilege 15 secret admin

crypto key generate rsa
1024

ip ssh version 2

ip name-server 8.8.8.8

spanning-tree mode rapid-pvst

vlan 11
name DIRETORIA
exit
!
vlan 12
name MARKETING
exit
!


interface vlan 11
no shutdown
ip address 10.1.1.4 255.255.255.0
exit
!
interface vlan 12
no shutdown
ip address 10.1.2.4 255.255.255.0
exit
!

interface Port-channel2
switchport trunk encapsulation dot1q
switchport mode trunk
!
interface Port-channel4
switchport trunk encapsulation dot1q
switchport mode trunk
!
interface FastEthernet0/1
switchport trunk encapsulation dot1q
switchport mode trunk
channel-group 4 mode active
!
interface FastEthernet0/2
switchport trunk encapsulation dot1q
switchport mode trunk
channel-group 4 mode active
!
interface FastEthernet0/3
switchport trunk encapsulation dot1q
switchport mode trunk
channel-group 2 mode passive
!
interface FastEthernet0/4
switchport trunk encapsulation dot1q
switchport mode trunk
channel-group 2 mode passive
!
interface FastEthernet0/5
switchport trunk encapsulation dot1q
switchport mode trunk
!
interface FastEthernet0/6
switchport trunk encapsulation dot1q
switchport mode trunk
!

!DHCP

ip dhcp excluded-address 10.1.1.1 10.1.1.10
ip dhcp excluded-address 10.1.2.1 10.1.2.10
!
ip dhcp pool REDE-11-DIRETORIA
network 10.1.1.0 255.255.255.0
default-router 10.1.1.1
exit

ip dhcp pool REDE-12-MARKETING
network 10.1.2.0 255.255.255.0
default-router 10.1.2.1
exit


ip route 0.0.0.0 0.0.0.0 10.1.1.1
ip route 0.0.0.0 0.0.0.0 10.1.2.1

end
wr

-------------------------------

SW-CORE-01

enable
conf t
hostname SW-CORE-01
line con 0
logging synchronous
password cisco
login local
exec-timeout 5 0
exit

line vty 0 4
logging synchronous
exec-timeout 5 0
password cisco
login local
transport input ssh
exit

service password-encryption
enable secret cisco
no ip domain-lookup
ip domain-name transdata.com
username admin privilege 15 secret admin

crypto key generate rsa
1024

ip ssh version 2

ip name-server 8.8.8.8

spanning-tree mode rapid-pvst

vlan 11
name DIRETORIA
exit
!
vlan 12
name MARKETING
exit
!

interface Vlan11
no shutdown
ip address 10.1.1.1 255.255.255.0
!
interface Vlan12
no shutdown
ip address 10.1.2.1 255.255.255.0
!

interface Port-channel1
no switchport
ip address 10.0.0.1 255.255.255.252
!
interface Port-channel2
switchport trunk encapsulation dot1q
switchport mode trunk
!
interface FastEthernet0/1
no switchport
no ip address
channel-group 1 mode active
duplex auto
speed auto
!
interface FastEthernet0/2
no switchport
no ip address
channel-group 1 mode active
duplex auto
speed auto
!
interface FastEthernet0/3
switchport trunk encapsulation dot1q
switchport mode trunk
channel-group 2 mode active
!
interface FastEthernet0/4
switchport trunk encapsulation dot1q
switchport mode trunk
channel-group 2 mode active
!
interface FastEthernet0/5
no switchport
ip address 10.0.0.6 255.255.255.252
duplex auto
speed auto
!
interface FastEthernet0/6
no switchport
ip address 10.0.0.14 255.255.255.252
duplex auto
speed auto
!

!
router ospf 1
router-id 10.0.0.6
network 10.0.0.0 0.255.255.255 area 0
!

-------------------------------

SW-CORE-02

enable
conf t
hostname SW-CORE-02
line con 0
logging synchronous
password cisco
login local
exec-timeout 5 0
exit

line vty 0 4
logging synchronous
exec-timeout 5 0
password cisco
login local
transport input ssh
exit

service password-encryption
enable secret cisco
no ip domain-lookup
ip domain-name transdata.com
username admin privilege 15 secret admin

crypto key generate rsa
1024

ip ssh version 2

ip name-server 8.8.8.8

spanning-tree mode rapid-pvst

vlan 11
name DIRETORIA
exit
!
vlan 12
name MARKETING
exit
!

interface Vlan11
no shutdown
ip address 10.1.1.2 255.255.255.0
!
interface Vlan12
no shutdown
ip address 10.1.2.2 255.255.255.0
!

interface Port-channel1
no switchport
ip address 10.0.0.2 255.255.255.252
!
interface Port-channel3
switchport trunk encapsulation dot1q
switchport mode trunk
!
interface FastEthernet0/1
no switchport
no ip address
channel-group 1 mode passive
duplex auto
speed auto
!
interface FastEthernet0/2
no switchport
no ip address
channel-group 1 mode passive
duplex auto
speed auto
!
interface FastEthernet0/3
switchport trunk encapsulation dot1q
switchport mode trunk
channel-group 3 mode active
!
interface FastEthernet0/4
switchport trunk encapsulation dot1q
switchport mode trunk
channel-group 3 mode active
!
interface FastEthernet0/5
no switchport
ip address 10.0.0.18 255.255.255.252
duplex auto
speed auto
!
interface FastEthernet0/6
no switchport
ip address 10.0.0.10 255.255.255.252
duplex auto
speed auto
!

!
router ospf 1
router-id 10.0.0.10
network 10.0.0.0 0.255.255.255 area 0
!

-------------------------------

RT-Edge-01

enable
conf t
hostname RT-Edge-01
line con 0
logging synchronous
password cisco
login local
exec-timeout 5 0
exit

line vty 0 4
logging synchronous
exec-timeout 5 0
password cisco
login local
transport input ssh
exit

service password-encryption
enable secret cisco
no ip domain-lookup
ip domain-name transdata.com
username admin privilege 15 secret admin

crypto key generate rsa
1024

ip ssh version 2

interface FastEthernet0/0
ip address 10.0.0.5 255.255.255.252
ip nat inside
duplex auto
speed auto
!
interface FastEthernet0/1
ip address 10.0.0.17 255.255.255.252
ip nat inside
duplex auto
speed auto
!
interface Ethernet0/1/0
no ip address
duplex auto
speed auto
shutdown
!
interface Ethernet0/3/0
no ip address
duplex auto
speed auto
shutdown
!
interface FastEthernet1/0
ip address 200.36.1.2 255.255.255.252
ip nat outside
duplex auto
!
router ospf 1
router-id 10.0.0.5
network 10.0.0.0 0.255.255.255 area 0
default-information originate
exit
!
ip nat inside source list 1 interface FastEthernet1/0 overload
!
ip route 0.0.0.0 0.0.0.0 200.36.1.1
!
access-list 1 permit 10.0.0.0 0.255.255.255
!

end
wr

-------------------------------

RT-Edge-02

enable
conf t
hostname RT-Edge-02
line con 0
logging synchronous
password cisco
login local
exec-timeout 5 0
exit

line vty 0 4
logging synchronous
exec-timeout 5 0
password cisco
login local
transport input ssh
exit

service password-encryption
enable secret cisco
no ip domain-lookup
ip domain-name transdata.com
username admin privilege 15 secret admin

crypto key generate rsa
1024

ip ssh version 2

interface FastEthernet0/0
ip address 10.0.0.13 255.255.255.252
ip nat inside
duplex auto
speed auto
!
interface FastEthernet0/1
ip address 10.0.0.9 255.255.255.252
ip nat inside
duplex auto
speed auto
!
interface FastEthernet1/1
ip address 200.36.10.2 255.255.255.252
ip nat outside
duplex auto
speed auto
!
router ospf 1
router-id 10.0.0.9
network 10.0.0.0 0.255.255.255 area 0
!
ip nat inside source list 1 interface FastEthernet1/1 overload
!
ip route 0.0.0.0 0.0.0.0 200.36.10.1
!
!
access-list 1 permit 10.0.0.0 0.255.255.255
!
end
wr

-------------------------------

ISP-1

interface Loopback0
ip address 8.8.8.8 255.255.255.255
!
interface FastEthernet1/0
ip address 200.36.1.1 255.255.255.252
duplex auto
speed auto
!
interface FastEthernet1/1
ip address 200.36.10.1 255.255.255.252
duplex auto
speed auto
!

Comentários
Janderson Pontes
Spotlight
Spotlight

Excelente @Assis Teixeira! Lab na veia, conteúdo 100% prático. 

tomy.tim
VIP Alumni
VIP Alumni

@Assis Teixeira Excelente trabalho, Parabéns pelo conteúdo compartilhado. Abs

CostaClaudia
Level 1
Level 1

Gratidão @Assis Teixeira,   por sua disponibilidade e boa vontade em compartilhar. Ganhamos todos e nos inspiramos a seguir seus passos. Boas Festas! 

Assis Teixeira
Spotlight
Spotlight

Obrigado @CostaClaudia Boas Festas para todos nós, que 2025 seja melhor ainda. Tudo de Bom!

Primeiros Passos

Encontre respostas, faça perguntas e conecte-se com nossa comunidade de especialistas da Cisco de todo o mundo.

Estamos felizes por você estar aqui! Participe de conversas e conecte-se com sua comunidade.