cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

3191
Views
4
Helpful
12
Replies
nowcommsupport
Beginner

eUnknownFailure when using Sample.html (Jabber SDK)

Hello all,

I am trying to get the Jabber SDK working using the Sample.html web page. The integration with Call Manager is fine, I can enter the user's ID, password and the CUCM server that I want to connect to which brings up a list of devices that is associated with this users, this works for either softphone and deskphones that are associated with the user. However, when I select the CSF Jabber softphone and click connect, I get the error: "Unable to login: Login Error eUnknownFailure". I have made sure I have changed the prefix within the cwic.js file to no avail.

I was wondering if anyone could suggest anything that could get this integration working, or if anyone had encountered this issue before and got it working?

Thanks,

James.

1 ACCEPTED SOLUTION

Accepted Solutions
tinghche
Contributor

James,

It could be the problem of DNS resolution. Can you check your softphone.log, can be located under

  • Windows XP C:\Documents and Settings\{username}\Local Settings\Application Data\CiscoWebCommunicator\softphone.log
  • Windows 7 C:\Users\{username}\AppData\Local\CiscoWebCommunicator\softphone.log
  • Mac OS X /Users/{username}/Library/Application Support/CiscoWebCommunicator/softphone.log

Search for "<processNodeName>" to find out your CUCM's hostname.
ex: <processNodeName>your_cucm_hostname</processNodeName>

Then, try to ping the hostname from your machine to see if the name can be resolved. If not, then you need to add this hostname into your local hosts file under C:\Windows\System32\drivers\etc\hosts

Add a ip/hostname pair to it. ex: 1.1.1.1    cucm_hostname

This should solve your problem.

If this is not the case, please share your softphone.log here, we can do more analysis to find out why.

Howard

View solution in original post

12 REPLIES 12
tinghche
Contributor

James,

It could be the problem of DNS resolution. Can you check your softphone.log, can be located under

  • Windows XP C:\Documents and Settings\{username}\Local Settings\Application Data\CiscoWebCommunicator\softphone.log
  • Windows 7 C:\Users\{username}\AppData\Local\CiscoWebCommunicator\softphone.log
  • Mac OS X /Users/{username}/Library/Application Support/CiscoWebCommunicator/softphone.log

Search for "<processNodeName>" to find out your CUCM's hostname.
ex: <processNodeName>your_cucm_hostname</processNodeName>

Then, try to ping the hostname from your machine to see if the name can be resolved. If not, then you need to add this hostname into your local hosts file under C:\Windows\System32\drivers\etc\hosts

Add a ip/hostname pair to it. ex: 1.1.1.1    cucm_hostname

This should solve your problem.

If this is not the case, please share your softphone.log here, we can do more analysis to find out why.

Howard

Thank you Howard, that did just the trick. Tested a phone call and it works from the web client. Many thanks for your help!

s.sitthichai
Beginner

I checked processNodeName is IP address but still have the problem. I'm not sure what is the problem because my labtop is running Windows8 and I try to test on another labtop, it's work.

Please help me check softphone.log.

Thank you.

What version of plugin are you using on Win8? The official support for Win8 is only available on the latest release 3.0.6

https://developer.cisco.com/site/collaboration/jabber/websdk/develop-and-test/voice-and-video/downloads-and-docs/release-notes-6/

Could you please start a new post with your softphone.log if the latest version is still facing the same problem.

Regards,

Howard

s.sitthichai
Beginner

I try to upgrade plugin to version 3.0.6 "JabberSDK-browser_plugin_for_Windows-WebVersion9.2_MR6"

But still have the same problem.

Picture.jpg

Peeking around the foreground window, it looks like the plugin version being loaded is MR6, but the cwic version is an old one - MR2.  Can you try with the latest version of the cwic/javascript portion of the code?

Note, one of the recent changes to the SDK+plugin, is that apps must specifically indicate if they do _not_ want certificate verification against UCM when logging in (see the 'validate cert' checkbox in the sample.html in the latest SDK.)

I'm not sure. How to download cwic latest version ?

Please provide link or URL for download. Thank you.

s.sitthichai
Beginner

Thank you very much.

I think that link have a problem. It display as picture.

Picture.jpg

That seems like a SSO connection problem. Maybe caused due to network problem. Could you please try again.

Thanks,

Howard

s.sitthichai
Beginner

I try to download again today but still have the problem on that link.

If you have source file, Please upload files to me.

Thank you.

Could you please send an email to jabber-dev-support@cisco.com?

Thanks,

Howard

Create
Recognize Your Peers
Content for Community-Ad