cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
2043
Views
16
Helpful
8
Replies

EasyQos Beta - Does it really works?

Khurram Noor
Beginner
Beginner

Folks,

I was testing deployment of easyqos beta of APIC-EM 1.2.0.1594. When i tested it on a 3750x and 2960x, it doesn't completely deploys the QoS. I found some of the class-maps and ACLs empty, plus i couldnt see all 1323 apps being matches in ACLs (many of them are missing, when i applied the policy) I wanted to apply Qos in production but these results have stopped me from proceeding. Has anyone noticed something similar?

Regards,

-KN

1 Accepted Solution

Accepted Solutions

Hi Tim,

That's great explanation in the slide. I wasn't aware of the reasoning.

Regards,

-KN

View solution in original post

8 Replies 8

aradford
Cisco Employee
Cisco Employee

Hi Khurram,

did you deploy the default CVD policy?  You would expect that default applications would not be matched. 

Tim Szigeti's excellent CiscoLive presentation (BRKRST-2046 SDN QoS Deep Dive) goes into the details of how this works.  Bear in mind the rendering will be different on different platforms due to TCAM resources etc.

Here is a screen shot of one of the main slides.

Screen Shot 2016-10-20 at 11.31.20 AM.png

Thanks Adam (and thanks too for bringing this to my attention).

Yes - this is correct. EasyQoS will always implement an instantiation of the expressed business-intent to the maximum of a given platform's capabilities.

What this means is: you might configure a policy for 1323 applications (our NBAR2 library). However, not all of our platforms support NBAR. As such, rather than doing nothing on, say a Catalyst 3750 access-switch (which does not support NBAR), APIC-EM will parse the NBAR library and sift out all the apps that CAN be classified using L4 ACLs  (incidentally there are only about 200 apps that can be identified via static ACLs), and then constructs and programs these ACLs into the platform, until we hit the TCAM (memory) limits of the box.

In addition to this access-edge policy, which represents the "best that the C3750 can do", EasyQoS will also push out another policy-enforcement-point at the LAN edge of any ASR or ISR router that supports the full NBAR library. At this edge then, apps that were NOT classified at the campus access-edge will ALSO be classified and marked.

(Side Note: As you may know, NBAR has recently been released on the Catalyst 3650 and 3850 platforms; as such, we will be adding this support to EasyQoS in the next few months as well).

As for the ACLs that were not populated by default (i.e. the Voice and Video ACLs), these will be populated by APIC-EM as it discovers Cisco devices via CDP (e.g. IP Phones, Cisco TelePresence Systems, Cisco IP Video Surveillance Cameras and/or Cisco Digital Media Players) AND/OR when APIC-EM receives dynamic QoS requests via the Northbound API from EasyQoS to applications like CallManager and/or MS-Lync, etc.)

More explicit and gory detail (like the slide above) can be found at:

PPT: https://cisco.box.com/v/SDN-QoS

VoD: https://www.ciscolive.com/online/connect/sessionDetail.ww?SESSION_ID=90876&backBtn=true

So - short summary: yes, EasyQoS *really* works. We've tested the crap out of it ;-)

HTH. Cheers!

-tim

Hi szigeti,

Thanks for your reply, i was helpful to understand more in depth about easy qos. I am attaching the QoS which made me confused here, what i am trying to understand is that what ACL it is refering to ...to match voice and video traffic on a per interface bases policy. I dont see any #DYN_VOICE__acl having any permit statements to match traffic.... how would it identify the voice /video traffic and assign it in the priority queue...this was taken from a 3750x switch.

mls qos map cos-dscp 0 8 16 26 32 46 48 56

mls qos map dscp-mutation REWRITE-DSCP 12 14 16 to 8

mls qos map dscp-mutation REWRITE-DSCP 20 22 24 to 16

mls qos map dscp-mutation REWRITE-DSCP 28 30 32 to 26

mls qos map dscp-mutation REWRITE-DSCP 36 38 40 to 34

mls qos srr-queue input bandwidth 70 30

mls qos srr-queue input threshold 1 80 90

mls qos srr-queue input priority-queue 2 bandwidth 30

mls qos srr-queue input cos-map queue 1 threshold 2 3

mls qos srr-queue input cos-map queue 1 threshold 3 6 7

mls qos srr-queue input cos-map queue 2 threshold 1 4

mls qos srr-queue input dscp-map queue 1 threshold 2 24

mls qos srr-queue input dscp-map queue 1 threshold 3 48 56

mls qos srr-queue input dscp-map queue 2 threshold 3 32 40 46

mls qos srr-queue output cos-map queue 1 threshold 3 4 5

mls qos srr-queue output cos-map queue 2 threshold 1 2

mls qos srr-queue output cos-map queue 2 threshold 2 3

mls qos srr-queue output cos-map queue 2 threshold 3 6 7

mls qos srr-queue output cos-map queue 4 threshold 3 1

mls qos srr-queue output dscp-map queue 1 threshold 3 32 40 46

mls qos srr-queue output dscp-map queue 2 threshold 1 16 18 20 22 26 28 30 34

mls qos srr-queue output dscp-map queue 2 threshold 1 36 38

mls qos srr-queue output dscp-map queue 2 threshold 2 24

mls qos srr-queue output dscp-map queue 2 threshold 3 48 56

mls qos srr-queue output dscp-map queue 3 threshold 3 0 1 2 3 4 5 6 7

mls qos srr-queue output dscp-map queue 3 threshold 3 9 11 13 15 17 19 21 23

mls qos srr-queue output dscp-map queue 3 threshold 3 25 27 29 31 33 35 37 39

mls qos srr-queue output dscp-map queue 3 threshold 3 41 42 43 44 45 47 49 50

mls qos srr-queue output dscp-map queue 3 threshold 3 51 52 53 54 55 57 58 59

mls qos srr-queue output dscp-map queue 3 threshold 3 60 61 62 63

mls qos srr-queue output dscp-map queue 4 threshold 1 8 14

mls qos srr-queue output dscp-map queue 4 threshold 2 12

mls qos srr-queue output dscp-map queue 4 threshold 3 10

mls qos queue-set output 1 threshold 1 100 100 100 100

mls qos queue-set output 1 threshold 2 80 90 100 400

mls qos queue-set output 1 threshold 3 100 100 100 400

mls qos queue-set output 1 threshold 4 60 80 100 400

mls qos queue-set output 1 buffers 15 30 35 20

mls qos

!

!

class-map match-any prm-DYN-Gig1/0/39#DYN_VIDEO

  match access-group name prm-DYN-Gig1/0/39#DYN_VIDEO__acl

class-map match-any prm-DYN-Gig1/0/28#DYN_VIDEO

  match access-group name prm-DYN-Gig1/0/28#DYN_VIDEO__acl

class-map match-any prm-DYN-Gig1/0/38#DYN_VIDEO

  match access-group name prm-DYN-Gig1/0/38#DYN_VIDEO__acl

class-map match-any prm-DYN-Gig1/0/29#DYN_VIDEO

  match access-group name prm-DYN-Gig1/0/29#DYN_VIDEO__acl

class-map match-any prm-DYN-Gig1/0/19#DYN_VIDEO

  match access-group name prm-DYN-Gig1/0/19#DYN_VIDEO__acl

class-map match-any prm-DYN-Gig1/0/18#DYN_VIDEO

  match access-group name prm-DYN-Gig1/0/18#DYN_VIDEO__acl

class-map match-any prm-DYN-Gig1/0/18#DYN_VOICE

  match access-group name prm-DYN-Gig1/0/18#DYN_VOICE__acl

class-map match-any prm-DYN-Gig1/0/19#DYN_VOICE

  match access-group name prm-DYN-Gig1/0/19#DYN_VOICE__acl

class-map match-any prm-DYN-Gig1/0/38#DYN_VOICE

  match access-group name prm-DYN-Gig1/0/38#DYN_VOICE__acl

class-map match-any prm-DYN-Gig1/0/29#DYN_VOICE

  match access-group name prm-DYN-Gig1/0/29#DYN_VOICE__acl

class-map match-any prm-DYN-Gig1/0/39#DYN_VOICE

  match access-group name prm-DYN-Gig1/0/39#DYN_VOICE__acl

class-map match-any prm-DYN-Gig1/0/28#DYN_VOICE

  match access-group name prm-DYN-Gig1/0/28#DYN_VOICE__acl

class-map match-any prm-DYN-Gig1/0/46#DYN_VIDEO

  match access-group name prm-DYN-Gig1/0/46#DYN_VIDEO__acl

class-map match-any prm-DYN-Gig1/0/20#DYN_VIDEO

  match access-group name prm-DYN-Gig1/0/20#DYN_VIDEO__acl

class-map match-any prm-DYN-Gig1/0/31#DYN_VIDEO

  match access-group name prm-DYN-Gig1/0/31#DYN_VIDEO__acl

class-map match-any prm-DYN-Gig1/0/13#DYN_VIDEO

  match access-group name prm-DYN-Gig1/0/13#DYN_VIDEO__acl

class-map match-any prm-DYN-Gig1/0/41#DYN_VOICE

  match access-group name prm-DYN-Gig1/0/41#DYN_VOICE__acl

class-map match-any prm-DYN-Gig1/0/27#DYN_VOICE

  match access-group name prm-DYN-Gig1/0/27#DYN_VOICE__acl

class-map match-any prm-DYN-Gig1/0/14#DYN_VOICE

  match access-group name prm-DYN-Gig1/0/14#DYN_VOICE__acl

class-map match-any prm-DYN-Gig1/0/36#DYN_VOICE

  match access-group name prm-DYN-Gig1/0/36#DYN_VOICE__acl

class-map match-any prm-DYN-Gig1/0/37#DYN_VOICE

  match access-group name prm-DYN-Gig1/0/37#DYN_VOICE__acl

class-map match-any prm-DYN-Gig1/0/15#DYN_VOICE

  match access-group name prm-DYN-Gig1/0/15#DYN_VOICE__acl

class-map match-any prm-DYN-Gig1/0/26#DYN_VOICE

  match access-group name prm-DYN-Gig1/0/26#DYN_VOICE__acl

class-map match-any prm-DYN-Gig1/0/30#DYN_VIDEO

  match access-group name prm-DYN-Gig1/0/30#DYN_VIDEO__acl

class-map match-any prm-DYN-Gig1/0/47#DYN_VIDEO

  match access-group name prm-DYN-Gig1/0/47#DYN_VIDEO__acl

class-map match-any prm-DYN-Gig1/0/12#DYN_VIDEO

  match access-group name prm-DYN-Gig1/0/12#DYN_VIDEO__acl

class-map match-any prm-DYN-Gig1/0/40#DYN_VOICE

  match access-group name prm-DYN-Gig1/0/40#DYN_VOICE__acl

class-map match-any prm-DYN-Gig1/0/21#DYN_VIDEO

  match access-group name prm-DYN-Gig1/0/21#DYN_VIDEO__acl

class-map match-any prm-DYN-Gig1/0/25#DYN_VOICE

  match access-group name prm-DYN-Gig1/0/25#DYN_VOICE__acl

class-map match-any prm-DYN-Gig1/0/11#DYN_VIDEO

  match access-group name prm-DYN-Gig1/0/11#DYN_VIDEO__acl

class-map match-any prm-DYN-Gig1/0/34#DYN_VOICE

  match access-group name prm-DYN-Gig1/0/34#DYN_VOICE__acl

class-map match-any prm-DYN-Gig1/0/16#DYN_VOICE

  match access-group name prm-DYN-Gig1/0/16#DYN_VOICE__acl

class-map match-any prm-DYN-Gig1/0/22#DYN_VIDEO

  match access-group name prm-DYN-Gig1/0/22#DYN_VIDEO__acl

class-map match-any prm-DYN-Gig1/0/44#DYN_VIDEO

  match access-group name prm-DYN-Gig1/0/44#DYN_VIDEO__acl

class-map match-any prm-DYN-Gig1/0/33#DYN_VIDEO

  match access-group name prm-DYN-Gig1/0/33#DYN_VIDEO__acl

class-map match-any prm-DYN-Gig1/0/43#DYN_VOICE

  match access-group name prm-DYN-Gig1/0/43#DYN_VOICE__acl

class-map match-any prm-DYN-Gig1/0/42#DYN_VOICE

  match access-group name prm-DYN-Gig1/0/42#DYN_VOICE__acl

class-map match-any prm-DYN-Gig1/0/23#DYN_VIDEO

  match access-group name prm-DYN-Gig1/0/23#DYN_VIDEO__acl

class-map match-any prm-DYN-Gig1/0/10#DYN_VIDEO

  match access-group name prm-DYN-Gig1/0/10#DYN_VIDEO__acl

class-map match-any prm-DYN-Gig1/0/45#DYN_VIDEO

  match access-group name prm-DYN-Gig1/0/45#DYN_VIDEO__acl

class-map match-any prm-DYN-Gig1/0/24#DYN_VOICE

  match access-group name prm-DYN-Gig1/0/24#DYN_VOICE__acl

class-map match-any prm-DYN-Gig1/0/35#DYN_VOICE

  match access-group name prm-DYN-Gig1/0/35#DYN_VOICE__acl

class-map match-any prm-DYN-Gig1/0/32#DYN_VIDEO

  match access-group name prm-DYN-Gig1/0/32#DYN_VIDEO__acl

class-map match-any prm-DYN-Gig1/0/17#DYN_VOICE

  match access-group name prm-DYN-Gig1/0/17#DYN_VOICE__acl

class-map match-any prm-DYN-Gig1/0/42#DYN_VIDEO

  match access-group name prm-DYN-Gig1/0/42#DYN_VIDEO__acl

class-map match-any prm-DYN-Gig1/0/23#DYN_VOICE

  match access-group name prm-DYN-Gig1/0/23#DYN_VOICE__acl

class-map match-any prm-DYN-Gig1/0/10#DYN_VOICE

  match access-group name prm-DYN-Gig1/0/10#DYN_VOICE__acl

class-map match-any prm-DYN-Gig1/0/45#DYN_VOICE

  match access-group name prm-DYN-Gig1/0/45#DYN_VOICE__acl

class-map match-any prm-DYN-Gig1/0/24#DYN_VIDEO

  match access-group name prm-DYN-Gig1/0/24#DYN_VIDEO__acl

class-map match-any prm-DYN-Gig1/0/35#DYN_VIDEO

  match access-group name prm-DYN-Gig1/0/35#DYN_VIDEO__acl

class-map match-any prm-DYN-Gig1/0/32#DYN_VOICE

  match access-group name prm-DYN-Gig1/0/32#DYN_VOICE__acl

class-map match-any prm-DYN-Gig1/0/17#DYN_VIDEO

  match access-group name prm-DYN-Gig1/0/17#DYN_VIDEO__acl

class-map match-any prm-DYN-Gig1/0/25#DYN_VIDEO

  match access-group name prm-DYN-Gig1/0/25#DYN_VIDEO__acl

class-map match-any prm-DYN-Gig1/0/11#DYN_VOICE

  match access-group name prm-DYN-Gig1/0/11#DYN_VOICE__acl

class-map match-any prm-DYN-Gig1/0/34#DYN_VIDEO

  match access-group name prm-DYN-Gig1/0/34#DYN_VIDEO__acl

class-map match-any prm-DYN-Gig1/0/16#DYN_VIDEO

  match access-group name prm-DYN-Gig1/0/16#DYN_VIDEO__acl

class-map match-any prm-DYN-Gig1/0/22#DYN_VOICE

  match access-group name prm-DYN-Gig1/0/22#DYN_VOICE__acl

class-map match-any prm-DYN-Gig1/0/44#DYN_VOICE

  match access-group name prm-DYN-Gig1/0/44#DYN_VOICE__acl

class-map match-any prm-DYN-Gig1/0/33#DYN_VOICE

  match access-group name prm-DYN-Gig1/0/33#DYN_VOICE__acl

class-map match-any prm-DYN-Gig1/0/43#DYN_VIDEO

  match access-group name prm-DYN-Gig1/0/43#DYN_VIDEO__acl

class-map match-any prm-DYN-Gig1/0/37#DYN_VIDEO

  match access-group name prm-DYN-Gig1/0/37#DYN_VIDEO__acl

class-map match-any prm-DYN-Gig1/0/15#DYN_VIDEO

  match access-group name prm-DYN-Gig1/0/15#DYN_VIDEO__acl

class-map match-any prm-DYN-Gig1/0/26#DYN_VIDEO

  match access-group name prm-DYN-Gig1/0/26#DYN_VIDEO__acl

class-map match-any prm-DYN-Gig1/0/30#DYN_VOICE

  match access-group name prm-DYN-Gig1/0/30#DYN_VOICE__acl

class-map match-any prm-DYN-Gig1/0/47#DYN_VOICE

  match access-group name prm-DYN-Gig1/0/47#DYN_VOICE__acl

class-map match-any prm-DYN-Gig1/0/12#DYN_VOICE

  match access-group name prm-DYN-Gig1/0/12#DYN_VOICE__acl

class-map match-any prm-DYN-Gig1/0/40#DYN_VIDEO

  match access-group name prm-DYN-Gig1/0/40#DYN_VIDEO__acl

class-map match-any prm-DYN-Gig1/0/21#DYN_VOICE

  match access-group name prm-DYN-Gig1/0/21#DYN_VOICE__acl

class-map match-any prm-DYN-Gig1/0/46#DYN_VOICE

  match access-group name prm-DYN-Gig1/0/46#DYN_VOICE__acl

class-map match-any prm-DYN-Gig1/0/20#DYN_VOICE

  match access-group name prm-DYN-Gig1/0/20#DYN_VOICE__acl

class-map match-any prm-DYN-Gig1/0/31#DYN_VOICE

  match access-group name prm-DYN-Gig1/0/31#DYN_VOICE__acl

class-map match-any prm-DYN-Gig1/0/13#DYN_VOICE

  match access-group name prm-DYN-Gig1/0/13#DYN_VOICE__acl

class-map match-any prm-DYN-Gig1/0/41#DYN_VIDEO

  match access-group name prm-DYN-Gig1/0/41#DYN_VIDEO__acl

class-map match-any prm-DYN-Gig1/0/27#DYN_VIDEO

  match access-group name prm-DYN-Gig1/0/27#DYN_VIDEO__acl

class-map match-any prm-DYN-Gig1/0/14#DYN_VIDEO

  match access-group name prm-DYN-Gig1/0/14#DYN_VIDEO__acl

class-map match-any prm-DYN-Gig1/0/36#DYN_VIDEO

  match access-group name prm-DYN-Gig1/0/36#DYN_VIDEO__acl

class-map match-any prm-APIC_QOS_IN#TRANS_DATA

  match access-group name prm-APIC_QOS_IN#TRANS_DATA__acl

class-map match-any prm-DYN-Ten1/1/2#DYN_VOICE

  match access-group name prm-DYN-Ten1/1/2#DYN_VOICE__acl

class-map match-any prm-DYN-Ten1/1/1#DYN_VOICE

  match access-group name prm-DYN-Ten1/1/1#DYN_VOICE__acl

class-map match-any prm-DYN-Ten1/1/1#DYN_VIDEO

  match access-group name prm-DYN-Ten1/1/1#DYN_VIDEO__acl

class-map match-any prm-DYN-Ten1/1/2#DYN_VIDEO

  match access-group name prm-DYN-Ten1/1/2#DYN_VIDEO__acl

class-map match-any prm-DYN-Gig1/0/8#DYN_VIDEO

  match access-group name prm-DYN-Gig1/0/8#DYN_VIDEO__acl

class-map match-any prm-DYN-Gig1/0/9#DYN_VIDEO

  match access-group name prm-DYN-Gig1/0/9#DYN_VIDEO__acl

class-map match-any prm-DYN-Gig1/0/9#DYN_VOICE

  match access-group name prm-DYN-Gig1/0/9#DYN_VOICE__acl

class-map match-any prm-DYN-Gig1/0/8#DYN_VOICE

  match access-group name prm-DYN-Gig1/0/8#DYN_VOICE__acl

class-map match-any prm-DYN-Gig1/1/4#DYN_VOICE

  match access-group name prm-DYN-Gig1/1/4#DYN_VOICE__acl

class-map match-any prm-DYN-Gig1/0/2#DYN_VIDEO

  match access-group name prm-DYN-Gig1/0/2#DYN_VIDEO__acl

class-map match-any prm-DYN-Gig1/1/3#DYN_VIDEO

  match access-group name prm-DYN-Gig1/1/3#DYN_VIDEO__acl

class-map match-any prm-DYN-Gig1/0/5#DYN_VOICE

  match access-group name prm-DYN-Gig1/0/5#DYN_VOICE__acl

class-map match-any prm-DYN-Gig1/0/3#DYN_VIDEO

  match access-group name prm-DYN-Gig1/0/3#DYN_VIDEO__acl

class-map match-any prm-DYN-Gig1/1/2#DYN_VIDEO

  match access-group name prm-DYN-Gig1/1/2#DYN_VIDEO__acl

class-map match-any prm-DYN-Gig1/0/4#DYN_VOICE

  match access-group name prm-DYN-Gig1/0/4#DYN_VOICE__acl

class-map match-any prm-APIC_QOS_IN#TUNNELED

  match access-group name prm-APIC_QOS_IN#TUNNELED__acl

class-map match-any prm-DYN-Gig1/1/1#DYN_VIDEO

  match access-group name prm-DYN-Gig1/1/1#DYN_VIDEO__acl

class-map match-any prm-DYN-Gig1/0/7#DYN_VOICE

  match access-group name prm-DYN-Gig1/0/7#DYN_VOICE__acl

class-map match-any prm-DYN-Gig1/0/6#DYN_VOICE

  match access-group name prm-DYN-Gig1/0/6#DYN_VOICE__acl

class-map match-any prm-DYN-Gig1/0/1#DYN_VIDEO

  match access-group name prm-DYN-Gig1/0/1#DYN_VIDEO__acl

class-map match-any prm-DYN-Gig1/0/6#DYN_VIDEO

  match access-group name prm-DYN-Gig1/0/6#DYN_VIDEO__acl

class-map match-any prm-DYN-Gig1/0/1#DYN_VOICE

  match access-group name prm-DYN-Gig1/0/1#DYN_VOICE__acl

class-map match-any prm-DYN-Gig1/1/1#DYN_VOICE

  match access-group name prm-DYN-Gig1/1/1#DYN_VOICE__acl

class-map match-any prm-DYN-Gig1/0/7#DYN_VIDEO

  match access-group name prm-DYN-Gig1/0/7#DYN_VIDEO__acl

class-map match-any prm-DYN-Gig1/0/3#DYN_VOICE

  match access-group name prm-DYN-Gig1/0/3#DYN_VOICE__acl

class-map match-any prm-DYN-Gig1/1/2#DYN_VOICE

  match access-group name prm-DYN-Gig1/1/2#DYN_VOICE__acl

class-map match-any prm-DYN-Gig1/0/4#DYN_VIDEO

  match access-group name prm-DYN-Gig1/0/4#DYN_VIDEO__acl

class-map match-any prm-DYN-Gig1/1/4#DYN_VIDEO

  match access-group name prm-DYN-Gig1/1/4#DYN_VIDEO__acl

class-map match-any prm-DYN-Gig1/0/2#DYN_VOICE

  match access-group name prm-DYN-Gig1/0/2#DYN_VOICE__acl

class-map match-any prm-DYN-Gig1/1/3#DYN_VOICE

  match access-group name prm-DYN-Gig1/1/3#DYN_VOICE__acl

class-map match-any prm-DYN-Gig1/0/5#DYN_VIDEO

  match access-group name prm-DYN-Gig1/0/5#DYN_VIDEO__acl

class-map match-any prm-APIC_QOS_IN#REALTIME

class-map match-any prm-DYN-Gig1/0/37#DYN_REALTIME

class-map match-any prm-DYN-Gig1/0/15#DYN_REALTIME

class-map match-any prm-DYN-Gig1/0/26#DYN_REALTIME

class-map match-any prm-DYN-Gig1/0/40#DYN_REALTIME

class-map match-any prm-DYN-Gig1/0/41#DYN_REALTIME

class-map match-any prm-DYN-Gig1/0/27#DYN_REALTIME

class-map match-any prm-DYN-Gig1/0/14#DYN_REALTIME

class-map match-any prm-DYN-Gig1/0/36#DYN_REALTIME

class-map match-any prm-DYN-Gig1/0/42#DYN_REALTIME

class-map match-any prm-DYN-Gig1/0/24#DYN_REALTIME

class-map match-any prm-DYN-Gig1/0/35#DYN_REALTIME

class-map match-any prm-DYN-Gig1/0/17#DYN_REALTIME

class-map match-any prm-DYN-Gig1/0/25#DYN_REALTIME

class-map match-any prm-DYN-Gig1/0/34#DYN_REALTIME

class-map match-any prm-DYN-Gig1/0/16#DYN_REALTIME

class-map match-any prm-DYN-Gig1/0/43#DYN_REALTIME

class-map match-any prm-DYN-Gig1/0/11#DYN_REALTIME

class-map match-any prm-DYN-Gig1/0/22#DYN_REALTIME

class-map match-any prm-DYN-Gig1/0/44#DYN_REALTIME

class-map match-any prm-DYN-Gig1/0/33#DYN_REALTIME

class-map match-any prm-DYN-Gig1/0/23#DYN_REALTIME

class-map match-any prm-DYN-Gig1/0/10#DYN_REALTIME

class-map match-any prm-DYN-Gig1/0/45#DYN_REALTIME

class-map match-any prm-DYN-Gig1/0/32#DYN_REALTIME

class-map match-any prm-DYN-Gig1/0/46#DYN_REALTIME

class-map match-any prm-DYN-Gig1/0/20#DYN_REALTIME

class-map match-any prm-DYN-Gig1/0/31#DYN_REALTIME

class-map match-any prm-DYN-Gig1/0/13#DYN_REALTIME

class-map match-any prm-DYN-Gig1/0/30#DYN_REALTIME

class-map match-any prm-DYN-Gig1/0/47#DYN_REALTIME

class-map match-any prm-DYN-Gig1/0/12#DYN_REALTIME

class-map match-any prm-DYN-Gig1/0/21#DYN_REALTIME

class-map match-any prm-DYN-Gig1/0/19#DYN_REALTIME

class-map match-any prm-DYN-Gig1/0/18#DYN_REALTIME

class-map match-any prm-DYN-Gig1/0/39#DYN_REALTIME

class-map match-any prm-DYN-Gig1/0/28#DYN_REALTIME

class-map match-any prm-DYN-Gig1/0/38#DYN_REALTIME

class-map match-any prm-DYN-Gig1/0/29#DYN_REALTIME

class-map match-any prm-DYN-Gig1/0/4#DYN_REALTIME

class-map match-any prm-DYN-Gig1/1/4#DYN_REALTIME

class-map match-any prm-DYN-Gig1/0/5#DYN_REALTIME

class-map match-any prm-DYN-Gig1/0/6#DYN_REALTIME

class-map match-any prm-DYN-Gig1/0/7#DYN_REALTIME

class-map match-any prm-DYN-Gig1/1/1#DYN_REALTIME

class-map match-any prm-DYN-Gig1/0/1#DYN_REALTIME

class-map match-any prm-DYN-Gig1/0/2#DYN_REALTIME

class-map match-any prm-DYN-Gig1/1/3#DYN_REALTIME

class-map match-any prm-APIC_QOS_IN#VOICE

class-map match-any prm-DYN-Gig1/0/3#DYN_REALTIME

class-map match-any prm-DYN-Gig1/1/2#DYN_REALTIME

class-map match-any prm-APIC_QOS_IN#MM_CONF

  match access-group name prm-APIC_QOS_IN#MM_CONF__acl

class-map match-any prm-DYN-Gig1/0/8#DYN_REALTIME

class-map match-any prm-APIC_QOS_IN#SCAVENGER

  match access-group name prm-APIC_QOS_IN#SCAVENGER__acl

class-map match-any prm-DYN-Gig1/0/9#DYN_REALTIME

class-map match-any prm-APIC_QOS_IN#SIGNALING

  match access-group name prm-APIC_QOS_IN#SIGNALING__acl

class-map match-any prm-APIC_QOS_IN#BROADCAST

  match access-group name prm-APIC_QOS_IN#BROADCAST__acl

class-map match-any prm-APIC_QOS_IN#BULK_DATA

  match access-group name prm-APIC_QOS_IN#BULK_DATA__acl

class-map match-any prm-DYN-Ten1/1/2#DYN_REALTIME

class-map match-any prm-DYN-Ten1/1/1#DYN_REALTIME

class-map match-any prm-APIC_QOS_IN#MM_STREAM

  match access-group name prm-APIC_QOS_IN#MM_STREAM__acl

class-map match-any prm-APIC_QOS_IN#OAM

  match access-group name prm-APIC_QOS_IN#OAM__acl

!

policy-map prm-DYN-Gig1/0/41

class prm-DYN-Gig1/0/41#DYN_VOICE

   set dscp ef

class prm-DYN-Gig1/0/41#DYN_REALTIME

   set dscp cs4

class prm-DYN-Gig1/0/41#DYN_VIDEO

   set dscp af41

policy-map prm-DYN-Gig1/0/40

class prm-DYN-Gig1/0/40#DYN_VOICE

   set dscp ef

class prm-DYN-Gig1/0/40#DYN_REALTIME

   set dscp cs4

class prm-DYN-Gig1/0/40#DYN_VIDEO

   set dscp af41

policy-map prm-DYN-Gig1/0/43

class prm-DYN-Gig1/0/43#DYN_VOICE

   set dscp ef

class prm-DYN-Gig1/0/43#DYN_REALTIME

   set dscp cs4

class prm-DYN-Gig1/0/43#DYN_VIDEO

   set dscp af41

policy-map prm-DYN-Gig1/0/42

class prm-DYN-Gig1/0/42#DYN_VOICE

   set dscp ef

class prm-DYN-Gig1/0/42#DYN_REALTIME

   set dscp cs4

class prm-DYN-Gig1/0/42#DYN_VIDEO

   set dscp af41

policy-map prm-DYN-Gig1/0/45

class prm-DYN-Gig1/0/45#DYN_VOICE

   set dscp ef

class prm-DYN-Gig1/0/45#DYN_REALTIME

   set dscp cs4

class prm-DYN-Gig1/0/45#DYN_VIDEO

   set dscp af41

policy-map prm-DYN-Gig1/0/44

class prm-DYN-Gig1/0/44#DYN_VOICE

   set dscp ef

class prm-DYN-Gig1/0/44#DYN_REALTIME

   set dscp cs4

class prm-DYN-Gig1/0/44#DYN_VIDEO

   set dscp af41

policy-map prm-DYN-Gig1/0/47

class prm-DYN-Gig1/0/47#DYN_VOICE

   set dscp ef

class prm-DYN-Gig1/0/47#DYN_REALTIME

   set dscp cs4

class prm-DYN-Gig1/0/47#DYN_VIDEO

   set dscp af41

policy-map prm-DYN-Gig1/0/46

class prm-DYN-Gig1/0/46#DYN_VOICE

   set dscp ef

class prm-DYN-Gig1/0/46#DYN_REALTIME

   set dscp cs4

class prm-DYN-Gig1/0/46#DYN_VIDEO

   set dscp af41

policy-map prm-APIC_QOS_IN

class prm-APIC_QOS_IN#VOICE

   set dscp ef

class prm-APIC_QOS_IN#BROADCAST

   set dscp cs5

class prm-APIC_QOS_IN#REALTIME

   set dscp cs4

class prm-APIC_QOS_IN#MM_CONF

   set dscp af41

class prm-APIC_QOS_IN#MM_STREAM

   set dscp af31

class prm-APIC_QOS_IN#SIGNALING

   set dscp cs3

class prm-APIC_QOS_IN#OAM

   set dscp cs2

class prm-APIC_QOS_IN#TRANS_DATA

   set dscp af21

class prm-APIC_QOS_IN#BULK_DATA

   set dscp af11

class prm-APIC_QOS_IN#SCAVENGER

   set dscp cs1

class prm-APIC_QOS_IN#TUNNELED

class class-default

   set dscp default

policy-map prm-DYN-Gig1/0/29

class prm-DYN-Gig1/0/29#DYN_VOICE

   set dscp ef

class prm-DYN-Gig1/0/29#DYN_REALTIME

   set dscp cs4

class prm-DYN-Gig1/0/29#DYN_VIDEO

   set dscp af41

policy-map prm-DYN-Gig1/0/28

class prm-DYN-Gig1/0/28#DYN_VOICE

   set dscp ef

class prm-DYN-Gig1/0/28#DYN_REALTIME

   set dscp cs4

class prm-DYN-Gig1/0/28#DYN_VIDEO

   set dscp af41

policy-map prm-DYN-Gig1/0/27

class prm-DYN-Gig1/0/27#DYN_VOICE

   set dscp ef

class prm-DYN-Gig1/0/27#DYN_REALTIME

   set dscp cs4

class prm-DYN-Gig1/0/27#DYN_VIDEO

   set dscp af41

policy-map prm-DYN-Gig1/0/26

class prm-DYN-Gig1/0/26#DYN_VOICE

   set dscp ef

class prm-DYN-Gig1/0/26#DYN_REALTIME

   set dscp cs4

class prm-DYN-Gig1/0/26#DYN_VIDEO

   set dscp af41

policy-map prm-DYN-Gig1/0/25

class prm-DYN-Gig1/0/25#DYN_VOICE

   set dscp ef

class prm-DYN-Gig1/0/25#DYN_REALTIME

   set dscp cs4

class prm-DYN-Gig1/0/25#DYN_VIDEO

   set dscp af41

policy-map prm-DYN-Gig1/0/24

class prm-DYN-Gig1/0/24#DYN_VOICE

   set dscp ef

class prm-DYN-Gig1/0/24#DYN_REALTIME

   set dscp cs4

class prm-DYN-Gig1/0/24#DYN_VIDEO

   set dscp af41

policy-map prm-DYN-Gig1/0/23

class prm-DYN-Gig1/0/23#DYN_VOICE

   set dscp ef

class prm-DYN-Gig1/0/23#DYN_REALTIME

   set dscp cs4

class prm-DYN-Gig1/0/23#DYN_VIDEO

   set dscp af41

policy-map prm-DYN-Gig1/0/22

class prm-DYN-Gig1/0/22#DYN_VOICE

   set dscp ef

class prm-DYN-Gig1/0/22#DYN_REALTIME

   set dscp cs4

class prm-DYN-Gig1/0/22#DYN_VIDEO

   set dscp af41

policy-map prm-DYN-Gig1/0/21

class prm-DYN-Gig1/0/21#DYN_VOICE

   set dscp ef

class prm-DYN-Gig1/0/21#DYN_REALTIME

   set dscp cs4

class prm-DYN-Gig1/0/21#DYN_VIDEO

   set dscp af41

policy-map prm-DYN-Gig1/0/20

class prm-DYN-Gig1/0/20#DYN_VOICE

   set dscp ef

class prm-DYN-Gig1/0/20#DYN_REALTIME

   set dscp cs4

class prm-DYN-Gig1/0/20#DYN_VIDEO

   set dscp af41

policy-map prm-DYN-Gig1/0/7

class prm-DYN-Gig1/0/7#DYN_VOICE

   set dscp ef

class prm-DYN-Gig1/0/7#DYN_REALTIME

   set dscp cs4

class prm-DYN-Gig1/0/7#DYN_VIDEO

   set dscp af41

policy-map prm-DYN-Gig1/0/6

class prm-DYN-Gig1/0/6#DYN_VOICE

   set dscp ef

class prm-DYN-Gig1/0/6#DYN_REALTIME

   set dscp cs4

class prm-DYN-Gig1/0/6#DYN_VIDEO

   set dscp af41

policy-map prm-DYN-Gig1/0/5

class prm-DYN-Gig1/0/5#DYN_VOICE

   set dscp ef

class prm-DYN-Gig1/0/5#DYN_REALTIME

   set dscp cs4

class prm-DYN-Gig1/0/5#DYN_VIDEO

   set dscp af41

policy-map prm-DYN-Gig1/0/4

class prm-DYN-Gig1/0/4#DYN_VOICE

   set dscp ef

class prm-DYN-Gig1/0/4#DYN_REALTIME

   set dscp cs4

class prm-DYN-Gig1/0/4#DYN_VIDEO

   set dscp af41

policy-map prm-DYN-Gig1/0/3

class prm-DYN-Gig1/0/3#DYN_VOICE

   set dscp ef

class prm-DYN-Gig1/0/3#DYN_REALTIME

   set dscp cs4

class prm-DYN-Gig1/0/3#DYN_VIDEO

   set dscp af41

policy-map prm-DYN-Gig1/0/2

class prm-DYN-Gig1/0/2#DYN_VOICE

   set dscp ef

class prm-DYN-Gig1/0/2#DYN_REALTIME

   set dscp cs4

class prm-DYN-Gig1/0/2#DYN_VIDEO

   set dscp af41

policy-map prm-DYN-Gig1/0/1

class prm-DYN-Gig1/0/1#DYN_VOICE

   set dscp ef

class prm-DYN-Gig1/0/1#DYN_REALTIME

   set dscp cs4

class prm-DYN-Gig1/0/1#DYN_VIDEO

   set dscp af41

policy-map prm-DYN-Gig1/0/9

class prm-DYN-Gig1/0/9#DYN_VOICE

   set dscp ef

class prm-DYN-Gig1/0/9#DYN_REALTIME

   set dscp cs4

class prm-DYN-Gig1/0/9#DYN_VIDEO

   set dscp af41

policy-map prm-DYN-Gig1/0/8

class prm-DYN-Gig1/0/8#DYN_VOICE

   set dscp ef

class prm-DYN-Gig1/0/8#DYN_REALTIME

   set dscp cs4

class prm-DYN-Gig1/0/8#DYN_VIDEO

   set dscp af41

policy-map prm-DYN-Gig1/1/4

class prm-DYN-Gig1/1/4#DYN_VOICE

   set dscp ef

class prm-DYN-Gig1/1/4#DYN_REALTIME

   set dscp cs4

class prm-DYN-Gig1/1/4#DYN_VIDEO

   set dscp af41

policy-map prm-DYN-Gig1/1/2

class prm-DYN-Gig1/1/2#DYN_VOICE

   set dscp ef

class prm-DYN-Gig1/1/2#DYN_REALTIME

   set dscp cs4

class prm-DYN-Gig1/1/2#DYN_VIDEO

   set dscp af41

policy-map prm-DYN-Gig1/1/3

class prm-DYN-Gig1/1/3#DYN_VOICE

   set dscp ef

class prm-DYN-Gig1/1/3#DYN_REALTIME

   set dscp cs4

class prm-DYN-Gig1/1/3#DYN_VIDEO

   set dscp af41

policy-map prm-DYN-Gig1/1/1

class prm-DYN-Gig1/1/1#DYN_VOICE

   set dscp ef

class prm-DYN-Gig1/1/1#DYN_REALTIME

   set dscp cs4

class prm-DYN-Gig1/1/1#DYN_VIDEO

   set dscp af41

policy-map prm-DYN-Gig1/0/12

class prm-DYN-Gig1/0/12#DYN_VOICE

   set dscp ef

class prm-DYN-Gig1/0/12#DYN_REALTIME

   set dscp cs4

class prm-DYN-Gig1/0/12#DYN_VIDEO

   set dscp af41

policy-map prm-DYN-Gig1/0/13

class prm-DYN-Gig1/0/13#DYN_VOICE

   set dscp ef

class prm-DYN-Gig1/0/13#DYN_REALTIME

   set dscp cs4

class prm-DYN-Gig1/0/13#DYN_VIDEO

   set dscp af41

policy-map prm-DYN-Gig1/0/10

class prm-DYN-Gig1/0/10#DYN_VOICE

   set dscp ef

class prm-DYN-Gig1/0/10#DYN_REALTIME

   set dscp cs4

class prm-DYN-Gig1/0/10#DYN_VIDEO

   set dscp af41

policy-map prm-DYN-Gig1/0/11

class prm-DYN-Gig1/0/11#DYN_VOICE

   set dscp ef

class prm-DYN-Gig1/0/11#DYN_REALTIME

   set dscp cs4

class prm-DYN-Gig1/0/11#DYN_VIDEO

   set dscp af41

policy-map prm-DYN-Gig1/0/16

class prm-DYN-Gig1/0/16#DYN_VOICE

   set dscp ef

class prm-DYN-Gig1/0/16#DYN_REALTIME

   set dscp cs4

class prm-DYN-Gig1/0/16#DYN_VIDEO

   set dscp af41

policy-map prm-DYN-Gig1/0/17

class prm-DYN-Gig1/0/17#DYN_VOICE

   set dscp ef

class prm-DYN-Gig1/0/17#DYN_REALTIME

   set dscp cs4

class prm-DYN-Gig1/0/17#DYN_VIDEO

   set dscp af41

policy-map prm-DYN-Gig1/0/14

class prm-DYN-Gig1/0/14#DYN_VOICE

   set dscp ef

class prm-DYN-Gig1/0/14#DYN_REALTIME

   set dscp cs4

class prm-DYN-Gig1/0/14#DYN_VIDEO

   set dscp af41

policy-map prm-DYN-Gig1/0/15

class prm-DYN-Gig1/0/15#DYN_VOICE

   set dscp ef

class prm-DYN-Gig1/0/15#DYN_REALTIME

   set dscp cs4

class prm-DYN-Gig1/0/15#DYN_VIDEO

   set dscp af41

policy-map prm-DYN-Gig1/0/18

class prm-DYN-Gig1/0/18#DYN_VOICE

   set dscp ef

class prm-DYN-Gig1/0/18#DYN_REALTIME

   set dscp cs4

class prm-DYN-Gig1/0/18#DYN_VIDEO

   set dscp af41

policy-map prm-DYN-Gig1/0/19

class prm-DYN-Gig1/0/19#DYN_VOICE

   set dscp ef

class prm-DYN-Gig1/0/19#DYN_REALTIME

   set dscp cs4

class prm-DYN-Gig1/0/19#DYN_VIDEO

   set dscp af41

policy-map prm-DYN-Ten1/1/1

class prm-DYN-Ten1/1/1#DYN_VOICE

   set dscp ef

class prm-DYN-Ten1/1/1#DYN_REALTIME

   set dscp cs4

class prm-DYN-Ten1/1/1#DYN_VIDEO

   set dscp af41

policy-map prm-DYN-Ten1/1/2

class prm-DYN-Ten1/1/2#DYN_VOICE

   set dscp ef

class prm-DYN-Ten1/1/2#DYN_REALTIME

   set dscp cs4

class prm-DYN-Ten1/1/2#DYN_VIDEO

   set dscp af41

policy-map prm-DYN-Gig1/0/38

class prm-DYN-Gig1/0/38#DYN_VOICE

   set dscp ef

class prm-DYN-Gig1/0/38#DYN_REALTIME

   set dscp cs4

class prm-DYN-Gig1/0/38#DYN_VIDEO

   set dscp af41

policy-map prm-DYN-Gig1/0/39

class prm-DYN-Gig1/0/39#DYN_VOICE

   set dscp ef

class prm-DYN-Gig1/0/39#DYN_REALTIME

   set dscp cs4

class prm-DYN-Gig1/0/39#DYN_VIDEO

   set dscp af41

policy-map prm-DYN-Gig1/0/34

class prm-DYN-Gig1/0/34#DYN_VOICE

   set dscp ef

class prm-DYN-Gig1/0/34#DYN_REALTIME

   set dscp cs4

class prm-DYN-Gig1/0/34#DYN_VIDEO

   set dscp af41

policy-map prm-DYN-Gig1/0/35

class prm-DYN-Gig1/0/35#DYN_VOICE

   set dscp ef

class prm-DYN-Gig1/0/35#DYN_REALTIME

   set dscp cs4

class prm-DYN-Gig1/0/35#DYN_VIDEO

   set dscp af41

policy-map prm-DYN-Gig1/0/36

class prm-DYN-Gig1/0/36#DYN_VOICE

   set dscp ef

class prm-DYN-Gig1/0/36#DYN_REALTIME

   set dscp cs4

class prm-DYN-Gig1/0/36#DYN_VIDEO

   set dscp af41

policy-map prm-DYN-Gig1/0/37

class prm-DYN-Gig1/0/37#DYN_VOICE

   set dscp ef

class prm-DYN-Gig1/0/37#DYN_REALTIME

   set dscp cs4

class prm-DYN-Gig1/0/37#DYN_VIDEO

   set dscp af41

policy-map prm-DYN-Gig1/0/30

class prm-DYN-Gig1/0/30#DYN_VOICE

   set dscp ef

class prm-DYN-Gig1/0/30#DYN_REALTIME

   set dscp cs4

class prm-DYN-Gig1/0/30#DYN_VIDEO

   set dscp af41

policy-map prm-DYN-Gig1/0/31

class prm-DYN-Gig1/0/31#DYN_VOICE

   set dscp ef

class prm-DYN-Gig1/0/31#DYN_REALTIME

   set dscp cs4

class prm-DYN-Gig1/0/31#DYN_VIDEO

   set dscp af41

policy-map prm-DYN-Gig1/0/32

class prm-DYN-Gig1/0/32#DYN_VOICE

   set dscp ef

class prm-DYN-Gig1/0/32#DYN_REALTIME

   set dscp cs4

class prm-DYN-Gig1/0/32#DYN_VIDEO

   set dscp af41

policy-map prm-DYN-Gig1/0/33

class prm-DYN-Gig1/0/33#DYN_VOICE

   set dscp ef

class prm-DYN-Gig1/0/33#DYN_REALTIME

   set dscp cs4

class prm-DYN-Gig1/0/33#DYN_VIDEO

   set dscp af41

!

ip access-list extended prm-APIC_QOS_IN#BROADCAST__acl

remark dmp

permit tcp any any eq 7777

ip access-list extended prm-APIC_QOS_IN#BULK_DATA__acl

remark pop3

permit tcp any any eq pop3

remark nsiiops

permit tcp any any eq 261

permit udp any any eq 261

remark smtp

permit tcp any any eq smtp

permit tcp any any eq 587

permit udp any any eq 25

remark microsoftds

permit tcp any any eq 445

permit udp any any eq 445

remark lotus-notes

permit tcp any any eq 1352

permit udp any any eq 1352

remark gridftp

permit tcp any any eq 2811

remark synergy

permit tcp any any eq 24800

remark secure-smtp

permit tcp any any eq 465

permit udp any any eq 465

remark rsync

permit tcp any any eq 873

permit udp any any eq 873

remark corba-iiop-ssl

permit tcp any any eq 684

permit udp any any eq 684

remark msexch-routing

permit tcp any any eq 691

permit udp any any eq 691

remark secure-imap

permit tcp any any eq 993

permit udp any any eq 993

remark mcafee-update

permit tcp any any eq 8801

remark gsiftp

permit udp any any eq 2811

remark ftp

permit tcp any any eq ftp

permit tcp any any eq 21000

remark imap

permit tcp any any eq 143

permit tcp any any eq 220

permit udp any any eq 143

permit udp any any eq 220

remark capwap-data

permit udp any any eq 5246

permit udp any any eq 5247

remark iscsi

permit tcp any any eq 860

permit udp any any eq 860

permit udp any any eq 3260

remark sftp

permit tcp any any eq 115

permit udp any any eq 115

remark ms-sms

permit tcp any any eq 2701

permit tcp any any eq 2702

permit tcp any any eq 2703

permit tcp any any eq 2704

remark secure-pop3

permit tcp any any eq 995

permit udp any any eq 995

remark nfs

permit tcp any any eq sunrpc

permit tcp any any eq 371

permit tcp any any eq 2049

permit udp any any eq sunrpc

permit udp any any eq 371

permit udp any any eq 2049

remark ftp-data

permit tcp any any eq ftp-data

permit udp any any eq 20

ip access-list extended prm-APIC_QOS_IN#MM_CONF__acl

remark apple-remote-desktop

permit tcp any any eq 3283

permit udp any any eq 3283

remark timbuktu

permit tcp any any eq 407

permit udp any any eq 407

remark webex-app-sharing

permit udp any any eq 9000

remark xwindows

permit tcp any any eq 6000

permit tcp any any eq 6001

permit tcp any any eq 6002

permit tcp any any eq 6003

remark citrix

permit tcp any any eq 1494

permit tcp any any eq 2598

remark gotodevice

permit tcp any any eq 2217

permit udp any any eq 2217

remark pcoip

permit tcp any any eq 4172

remark skype

permit tcp any any eq 33033

remark radmin-port

permit tcp any any eq 4899

permit udp any any eq 4899

remark citrix-static

permit tcp any any eq 1604

permit tcp any any eq 2512

permit tcp any any eq 2513

permit udp any any eq 1604

permit udp any any eq 2512

permit udp any any eq 2513

remark ms-wbt

permit tcp any any eq 3389

remark pcanywhere

permit tcp any any eq 5631

permit tcp any any eq 65301

permit udp any any eq 22

permit udp any any eq 5632

ip access-list extended prm-APIC_QOS_IN#MM_STREAM__acl

remark vmware-vmotion

permit tcp any any eq 8000

remark shockwave

permit tcp any any eq 1626

permit udp any any eq 1626

remark vnc

permit tcp any any eq 5800

permit tcp any any eq 5900

permit tcp any any eq 5901

permit udp any any eq 5800

permit udp any any eq 5900

permit udp any any eq 5901

ip access-list extended prm-APIC_QOS_IN#OAM__acl

remark syslog

permit udp any any eq syslog

remark active-directory

permit tcp any any eq 389

permit udp any any eq 389

remark at-nbp

permit tcp any any eq 202

permit udp any any eq 202

remark kerberos

permit tcp any any eq 88

permit udp any any eq 88

remark secure-ldap

permit tcp any any eq 636

permit udp any any eq 636

remark cisco-fna

permit tcp any any eq 130

permit udp any any eq 130

remark login

permit tcp any any eq login

remark dhcpv6-server

permit tcp any any eq 547

permit udp any any eq 547

remark cisco-sys

permit tcp any any eq 132

permit udp any any eq 132

remark dhcp-failover2

permit tcp any any eq 847

permit udp any any eq 847

remark finger

permit tcp any any eq finger

permit udp any any eq 79

remark ssh

permit tcp any any eq 22

remark exec

permit tcp any any eq exec

remark telnet

permit tcp any any eq telnet

remark ntp

permit udp any any eq ntp

remark rsvp-encap-1

permit tcp any any eq 1698

permit udp any any eq 1698

remark shell

permit tcp any any eq cmd

remark dhcp

permit udp any any eq bootps

permit udp any any eq bootpc

remark tacacs

permit tcp any any eq tacacs

permit tcp any any eq 65

permit udp any any eq tacacs

permit udp any any eq 65

remark echo

permit tcp any any eq echo

permit udp any any eq echo

remark msft-gc-ssl

permit tcp any any eq 3269

permit udp any any eq 3269

remark dhcpv6-client

permit tcp any any eq 546

permit udp any any eq 546

remark rsvp-encap-2

permit tcp any any eq 1699

permit udp any any eq 1699

remark snmp

permit tcp any any eq 161

permit tcp any any eq 162

permit tcp any any eq 1161

permit tcp any any eq 1162

permit udp any any eq snmp

permit udp any any eq snmptrap

remark tftp

permit udp any any eq tftp

remark cisco-tna

permit tcp any any eq 131

permit udp any any eq 131

remark radius

permit udp any any eq 1812

permit udp any any eq 1813

remark dhcp-failover

permit tcp any any eq 647

permit udp any any eq 647

remark aruba-papi

permit udp any any eq 8211

ip access-list extended prm-APIC_QOS_IN#SCAVENGER__acl

remark bittorrent

permit tcp any any eq 3544

permit tcp any any eq 6881

permit tcp any any eq 6882

permit tcp any any eq 6883

permit tcp any any eq 6884

permit tcp any any eq 6885

permit tcp any any eq 6886

permit tcp any any eq 6887

permit tcp any any eq 6888

permit tcp any any eq 6889

permit udp any any eq 3544

permit udp any any eq 3545

remark yahoo-messenger

permit tcp any any eq 5050

permit tcp any any eq 5101

remark nntp

permit tcp any any eq nntp

remark netshow

permit tcp any any eq 1755

remark edonkey

permit tcp any any eq 4662

remark edonkey-static

permit tcp any any eq 4661

permit tcp any any eq 4663

permit tcp any any eq 4664

permit tcp any any eq 4665

permit tcp any any eq 4672

permit tcp any any eq 4673

permit tcp any any eq 4711

permit tcp any any eq 5662

permit tcp any any eq 5773

permit tcp any any eq 5783

permit udp any any eq 4661

permit udp any any eq 4662

permit udp any any eq 4663

permit udp any any eq 4664

permit udp any any eq 4665

permit udp any any eq 4672

permit udp any any eq 4673

permit udp any any eq 4711

permit udp any any eq 5662

permit udp any any eq 5773

permit udp any any eq 5783

ip access-list extended prm-APIC_QOS_IN#SIGNALING__acl

remark snpp

permit tcp any any eq 444

permit udp any any eq 444

remark dnp

permit tcp any any eq 19999

permit tcp any any eq 20000

permit udp any any eq 19999

permit udp any any eq 20000

remark prm-nm

permit tcp any any eq 409

permit udp any any eq 409

remark rsvp_tunnel

permit tcp any any eq 363

permit udp any any eq 363

remark spsc

permit tcp any any eq 478

permit udp any any eq 478

remark ups

permit tcp any any eq 401

permit udp any any eq 401

remark tpip

permit tcp any any eq 594

permit udp any any eq 594

remark svrloc

permit tcp any any eq 427

permit udp any any eq 427

remark netvmg-traceroute

permit udp any any eq 33435

remark skinny

permit tcp any any eq 2000

permit tcp any any eq 2001

permit tcp any any eq 2002

remark sflow

permit tcp any any eq 6343

permit udp any any eq 6343

remark prm-sm

permit tcp any any eq 408

permit udp any any eq 408

remark sgcp

permit tcp any any eq 440

permit udp any any eq 440

remark rtsp

permit tcp any any eq 554

permit tcp any any eq 8554

remark sip-tls

permit tcp any any eq 5061

permit udp any any eq 5061

remark mgcp

permit tcp any any eq 2427

permit tcp any any eq 2428

permit tcp any any eq 2727

permit udp any any eq 2427

permit udp any any eq 2727

remark rpc2portmap

permit tcp any any eq 369

permit udp any any eq 369

remark sip

permit tcp any any eq 3478

permit udp any any eq 3478

remark ss7ns

permit tcp any any eq 477

permit udp any any eq 477

remark rtsps

permit tcp any any eq 322

permit udp any any eq 322

remark h323

permit tcp any any eq 1300

permit tcp any any eq 1718

permit tcp any any eq 1719

permit tcp any any eq 1720

permit tcp any any eq 11720

permit udp any any eq 1300

permit udp any any eq 1718

permit udp any any eq 1719

permit udp any any eq 1720

permit udp any any eq 11720

remark datex-asn

permit tcp any any eq 355

permit udp any any eq 355

remark cisco-jabber-control

permit tcp any any eq 5060

permit udp any any eq 5060

ip access-list extended prm-APIC_QOS_IN#TRANS_DATA__acl

remark ssl

permit tcp any any eq 5222

permit udp any any eq 5222

remark sqlsrv

permit tcp any any eq 156

permit udp any any eq 156

remark sqlserv

permit tcp any any eq 118

permit udp any any eq 118

remark ddm-rdb

permit tcp any any eq 446

permit udp any any eq 446

remark sqlserver

permit tcp any any eq 1433

permit udp any any eq 1433

remark ms-sql-m

permit tcp any any eq 1434

permit udp any any eq 1434

remark ms-iis

permit tcp any any eq 135

remark epmap

permit udp any any eq 135

remark distcc

permit tcp any any eq 3632

permit udp any any eq 3632

remark orbix-cfg-ssl

permit tcp any any eq 3078

permit udp any any eq 3078

remark orbix-loc-ssl

permit tcp any any eq 3077

permit udp any any eq 3077

remark corba-iiop

permit tcp any any eq 683

permit udp any any eq 683

remark ddm-ssl

permit tcp any any eq 448

permit udp any any eq 448

remark dbase

permit tcp any any eq 217

permit udp any any eq 217

remark coauthor

permit tcp any any eq 1529

permit udp any any eq 1529

remark iiop

permit tcp any any eq 535

permit udp any any eq 535

remark sap

permit tcp any any eq 3200

permit tcp any any eq 3300

permit tcp any any eq 3600

remark erpc

permit tcp any any eq 121

permit udp any any eq 121

remark esro-gen

permit tcp any any eq 259

permit udp any any eq 259

remark banyan-rpc

permit tcp any any eq 567

permit udp any any eq 567

remark ddm-dfm

permit tcp any any eq 447

permit udp any any eq 447

remark oracle-sqlnet

permit tcp any any eq 66

remark gds_db

permit tcp any any eq 3050

permit udp any any eq 3050

remark ibm-db2

permit tcp any any eq 523

permit udp any any eq 523

ip access-list extended prm-APIC_QOS_IN#TUNNELED__acl

remark capwap-data

permit udp any any eq 5246

permit udp any any eq 5247

ip access-list extended prm-DYN-Gig1/0/1#DYN_VIDEO__acl

ip access-list extended prm-DYN-Gig1/0/1#DYN_VOICE__acl

ip access-list extended prm-DYN-Gig1/0/10#DYN_VIDEO__acl

ip access-list extended prm-DYN-Gig1/0/10#DYN_VOICE__acl

ip access-list extended prm-DYN-Gig1/0/11#DYN_VIDEO__acl

ip access-list extended prm-DYN-Gig1/0/11#DYN_VOICE__acl

ip access-list extended prm-DYN-Gig1/0/12#DYN_VIDEO__acl

ip access-list extended prm-DYN-Gig1/0/12#DYN_VOICE__acl

ip access-list extended prm-DYN-Gig1/0/13#DYN_VIDEO__acl

ip access-list extended prm-DYN-Gig1/0/13#DYN_VOICE__acl

ip access-list extended prm-DYN-Gig1/0/14#DYN_VIDEO__acl

ip access-list extended prm-DYN-Gig1/0/14#DYN_VOICE__acl

ip access-list extended prm-DYN-Gig1/0/15#DYN_VIDEO__acl

ip access-list extended prm-DYN-Gig1/0/15#DYN_VOICE__acl

ip access-list extended prm-DYN-Gig1/0/16#DYN_VIDEO__acl

ip access-list extended prm-DYN-Gig1/0/16#DYN_VOICE__acl

ip access-list extended prm-DYN-Gig1/0/17#DYN_VIDEO__acl

ip access-list extended prm-DYN-Gig1/0/17#DYN_VOICE__acl

ip access-list extended prm-DYN-Gig1/0/18#DYN_VIDEO__acl

ip access-list extended prm-DYN-Gig1/0/18#DYN_VOICE__acl

ip access-list extended prm-DYN-Gig1/0/19#DYN_VIDEO__acl

ip access-list extended prm-DYN-Gig1/0/19#DYN_VOICE__acl

ip access-list extended prm-DYN-Gig1/0/2#DYN_VIDEO__acl

ip access-list extended prm-DYN-Gig1/0/2#DYN_VOICE__acl

ip access-list extended prm-DYN-Gig1/0/20#DYN_VIDEO__acl

ip access-list extended prm-DYN-Gig1/0/20#DYN_VOICE__acl

ip access-list extended prm-DYN-Gig1/0/21#DYN_VIDEO__acl

ip access-list extended prm-DYN-Gig1/0/21#DYN_VOICE__acl

ip access-list extended prm-DYN-Gig1/0/22#DYN_VIDEO__acl

ip access-list extended prm-DYN-Gig1/0/22#DYN_VOICE__acl

ip access-list extended prm-DYN-Gig1/0/23#DYN_VIDEO__acl

ip access-list extended prm-DYN-Gig1/0/23#DYN_VOICE__acl

ip access-list extended prm-DYN-Gig1/0/24#DYN_VIDEO__acl

ip access-list extended prm-DYN-Gig1/0/24#DYN_VOICE__acl

ip access-list extended prm-DYN-Gig1/0/25#DYN_VIDEO__acl

ip access-list extended prm-DYN-Gig1/0/25#DYN_VOICE__acl

ip access-list extended prm-DYN-Gig1/0/26#DYN_VIDEO__acl

ip access-list extended prm-DYN-Gig1/0/26#DYN_VOICE__acl

ip access-list extended prm-DYN-Gig1/0/27#DYN_VIDEO__acl

ip access-list extended prm-DYN-Gig1/0/27#DYN_VOICE__acl

ip access-list extended prm-DYN-Gig1/0/28#DYN_VIDEO__acl

ip access-list extended prm-DYN-Gig1/0/28#DYN_VOICE__acl

ip access-list extended prm-DYN-Gig1/0/29#DYN_VIDEO__acl

ip access-list extended prm-DYN-Gig1/0/29#DYN_VOICE__acl

ip access-list extended prm-DYN-Gig1/0/3#DYN_VIDEO__acl

ip access-list extended prm-DYN-Gig1/0/3#DYN_VOICE__acl

ip access-list extended prm-DYN-Gig1/0/30#DYN_VIDEO__acl

ip access-list extended prm-DYN-Gig1/0/30#DYN_VOICE__acl

ip access-list extended prm-DYN-Gig1/0/31#DYN_VIDEO__acl

ip access-list extended prm-DYN-Gig1/0/31#DYN_VOICE__acl

ip access-list extended prm-DYN-Gig1/0/32#DYN_VIDEO__acl

ip access-list extended prm-DYN-Gig1/0/32#DYN_VOICE__acl

ip access-list extended prm-DYN-Gig1/0/33#DYN_VIDEO__acl

ip access-list extended prm-DYN-Gig1/0/33#DYN_VOICE__acl

ip access-list extended prm-DYN-Gig1/0/34#DYN_VIDEO__acl

ip access-list extended prm-DYN-Gig1/0/34#DYN_VOICE__acl

ip access-list extended prm-DYN-Gig1/0/35#DYN_VIDEO__acl

ip access-list extended prm-DYN-Gig1/0/35#DYN_VOICE__acl

ip access-list extended prm-DYN-Gig1/0/36#DYN_VIDEO__acl

ip access-list extended prm-DYN-Gig1/0/36#DYN_VOICE__acl

ip access-list extended prm-DYN-Gig1/0/37#DYN_VIDEO__acl

ip access-list extended prm-DYN-Gig1/0/37#DYN_VOICE__acl

ip access-list extended prm-DYN-Gig1/0/38#DYN_VIDEO__acl

ip access-list extended prm-DYN-Gig1/0/38#DYN_VOICE__acl

ip access-list extended prm-DYN-Gig1/0/39#DYN_VIDEO__acl

ip access-list extended prm-DYN-Gig1/0/39#DYN_VOICE__acl

ip access-list extended prm-DYN-Gig1/0/4#DYN_VIDEO__acl

ip access-list extended prm-DYN-Gig1/0/4#DYN_VOICE__acl

ip access-list extended prm-DYN-Gig1/0/40#DYN_VIDEO__acl

ip access-list extended prm-DYN-Gig1/0/40#DYN_VOICE__acl

ip access-list extended prm-DYN-Gig1/0/41#DYN_VIDEO__acl

ip access-list extended prm-DYN-Gig1/0/41#DYN_VOICE__acl

ip access-list extended prm-DYN-Gig1/0/42#DYN_VIDEO__acl

ip access-list extended prm-DYN-Gig1/0/42#DYN_VOICE__acl

ip access-list extended prm-DYN-Gig1/0/43#DYN_VIDEO__acl

ip access-list extended prm-DYN-Gig1/0/43#DYN_VOICE__acl

ip access-list extended prm-DYN-Gig1/0/44#DYN_VIDEO__acl

ip access-list extended prm-DYN-Gig1/0/44#DYN_VOICE__acl

ip access-list extended prm-DYN-Gig1/0/45#DYN_VIDEO__acl

ip access-list extended prm-DYN-Gig1/0/45#DYN_VOICE__acl

ip access-list extended prm-DYN-Gig1/0/46#DYN_VIDEO__acl

ip access-list extended prm-DYN-Gig1/0/46#DYN_VOICE__acl

ip access-list extended prm-DYN-Gig1/0/47#DYN_VIDEO__acl

ip access-list extended prm-DYN-Gig1/0/47#DYN_VOICE__acl

ip access-list extended prm-DYN-Gig1/0/5#DYN_VIDEO__acl

ip access-list extended prm-DYN-Gig1/0/5#DYN_VOICE__acl

ip access-list extended prm-DYN-Gig1/0/6#DYN_VIDEO__acl

ip access-list extended prm-DYN-Gig1/0/6#DYN_VOICE__acl

ip access-list extended prm-DYN-Gig1/0/7#DYN_VIDEO__acl

ip access-list extended prm-DYN-Gig1/0/7#DYN_VOICE__acl

ip access-list extended prm-DYN-Gig1/0/8#DYN_VIDEO__acl

ip access-list extended prm-DYN-Gig1/0/8#DYN_VOICE__acl

ip access-list extended prm-DYN-Gig1/0/9#DYN_VIDEO__acl

ip access-list extended prm-DYN-Gig1/0/9#DYN_VOICE__acl

ip access-list extended prm-DYN-Gig1/1/1#DYN_VIDEO__acl

ip access-list extended prm-DYN-Gig1/1/1#DYN_VOICE__acl

ip access-list extended prm-DYN-Gig1/1/2#DYN_VIDEO__acl

ip access-list extended prm-DYN-Gig1/1/2#DYN_VOICE__acl

ip access-list extended prm-DYN-Gig1/1/3#DYN_VIDEO__acl

ip access-list extended prm-DYN-Gig1/1/3#DYN_VOICE__acl

ip access-list extended prm-DYN-Gig1/1/4#DYN_VIDEO__acl

ip access-list extended prm-DYN-Gig1/1/4#DYN_VOICE__acl

ip access-list extended prm-DYN-Ten1/1/1#DYN_VIDEO__acl

ip access-list extended prm-DYN-Ten1/1/1#DYN_VOICE__acl

ip access-list extended prm-DYN-Ten1/1/2#DYN_VIDEO__acl

ip access-list extended prm-DYN-Ten1/1/2#DYN_VOICE__acl

!

interface GigabitEthernet1/0/1

srr-queue bandwidth share 1 30 35 5

priority-queue out

service-policy input prm-APIC_QOS_IN

Hi Khurram,

Short answer: the dynamic QoS Northbound API (from CUCM or from MS-Lync server) will supply the IP and UDP port information for the voice/video calls. Only at that time will EasyQoS dynamically program the ACEs (i.e. the "permit udp IP Port statements). The reason for the policy-shells (i.e. the empty ACLs, class-maps and policy-maps) in your config is to optimize performance and to ensure that QoS is applied in a non-disruptive manner.

For additional details see:

PPT: https://cisco.box.com/v/SDN-QoS

VoD: https://www.ciscolive.com/online/connect/sessionDetail.ww?SESSION_ID=90876&backBtn=true

Slides 138 through 144 and

Appendix D: Dynamic QoS (Slides 272 through 285).

HTH.

-tim

Hi Tim,

That's great explanation in the slide. I wasn't aware of the reasoning.

Regards,

-KN

Will add one additional comment....

Dynamic Shells are only added if you turn on Dynamic QoS. It is an optional feature, which is still in beta, and Static QoS , which has just been released as GA in 1.3, does not require these dynamic shells to work properly.

Thanks

Ramit

Hi aradford,

I did not deploy the default CVD QoS. But i made some adjustment which makes sense to the business. I have gone through the presentation and it looks pretty nice.

Regards,

-KN

Thanks KN.

we are about to release  1.3 which has a number of EQ enhancements.

should be out in next day or so.

Adam

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

Recognize Your Peers