cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

5088
Views
8
Helpful
11
Replies
Netplace Support
Beginner

Unable to access APIC-EM GUI

we have installed APIC-EM VM and the installation was successful but the GUI is not opening in any browser.

we are able to access Grapevine GUI but username and password showing incorrect . but when we take SSH console it is accessible.

Rama Adav

11 REPLIES 11
yawming
Cisco Employee

If you can access Grapevine UI, is UI service running ?

Maybe re-install again ?

Has this issue been resolved.

I have just install APIC-em on vm and only get the grapevine gui.

Did you see UI service running in grapevine ?

Yeah look ok.

says ui v0.9.5.2155 running.

Just looking in Grapevine.

Should all the services be running, as they are not, and when I try to start one it just sits there doing nowt.

Did you try resetting apic-em ?

http://www.cisco.com/c/en/us/td/docs/cloud-systems-management/application-policy-infrastructure-controller-enterprise-module/1-0-x/deploy-guide/b_apic-em_deploy_guide_v_1_0_0_x.pdf

You can follow the steps in Resetting the Cisco APIC-EM section in this guide.

If you still have problem then run rca command in Creating a Support File for the Cisco APIC-EM section in this file.

Thanks

ddeitsch1
Beginner

So I had this issue to.

Go to https://<ip address> :14141 and under overview make sure there is a green box above ui AND reverse-proxy. If either does not have a green box hit the plus sign in a circle near the right of the screen. This fixed it for me.

Now if I could only figure out when I try to login why it is not authenticating my password...

@David

Managed to get the login screen. but have same issue as you i.e its no authentication my login credentials. have tried re-runing the wizard but same again.

Did you ever fix this issue ?  

I have a feeling that its because I have installed in single host mode but only have 32G of RAM (and not the 64G) but it should still let me login right.

Why are you only using 32G RAM?

In order to build a full cluster, you need 2x32G servers (Physical or virtual) or 1x64G.

In your case only 1/2 the services will be running.  UI might work, but nothing behind it.

If you want to build a small test APIC-EM (20 devices), you install with 16-22G RAM.  That will be fully functioning, but limited number of devices.... which is good for testing.

If you use 16G RAM, you need to have good disk performance (>200MB) or SSD.

daz_efx_2000
Beginner

Thanks aradford

so my suspicions are correct, I need more RAM, would explain why its running like a 3 legged dog.

I will ask the powers that be for a better beefy server.

FYI -  if others are like me and just want login even tho they dont have enough RAM you need to log into grapevine UI and make sure all the services are running as per the above info from David. This will get you to the APIC-EM screen but it wont authenticate. what you need to do next is "Grow" the following services in this order after the above ones. 

cas-service

rbac-service

only when they are successfully grown will you be able to login. It takes some time and you have to keep harvesting and growing the service. at one point i had to SSH to grapevine and run "reset_grapevine" in the "bin" folder.

see the

Resetting the Cisco APIC-EM

section here Cisco Application Policy Infrastructure Controller Enterprise Module Deployment Guide, Release 1.0.x - Troubleshooting …

last words...

must... get... more RAM. Must... get... PNP ...working.

1.2 code will let you run a "demo" version in <22G.  You will have full functionality, but limited to 20 devices.

Great for testing PnP

Create
Recognize Your Peers
Content for Community-Ad