Showing results for 
Search instead for 
Did you mean: 

DNAC re-installation via CIMC and KVM

Level 1
Level 1


I'm trying to re-image a DNAC remotely via CIMC.  I've done this many times before but this is a new DNAC from a Cisco RMA.

I'm booting from a USB key that I have used before.  So I power on the server via CIMC and hit F6, choose to boot from the USB key and I get to the first screen where I get the option to

Start a Cisco DNA Center Cluster

I've done this many times before.  I just hit return here then carry on with the process.  However, on this occasion my keyboard is not responding in the CIMC session.  I've also tried the Virtual keyboard from View - Keyboard but that doesn't respond either.  I've tried both the HTML and the Java based KVM options.

Has anyone seen this issue before?  I can't get to our DC to do the install via a physical KVM for a bit so need to do it over the CIMC.

Thanks for any input, Stephen.

11 Replies 11

Level 1
Level 1

I tried clicking around with the CIMC KVM and when I displayed the virtual keyboard I noticed the Scroll button to the right hand side was depressed.  I clicked to un-press this and the KVM keyboard started working.  A bit of a slow painful process clicking the virtual keyboard to enter data.  Still can't get my laptop keyboard working though.  So I've kicked off the install via inputting the addressing via the virtual keyboard.  Once the initial install is complete I should be able to browse to the DNAC GUI and complete the updates from there.  However, I'd still like to get to the bottom of the laptop keyboard not working if anyone has seen this before.

Thanks, Stephen.

I've managed to rebuild my DNAC using the virtual keyboard on the CIMC HTML KVM.  The DNAC is fully operational again however the KVM session still does not respond to my laptop keyboard.  It does respond to the virtual KVM keyboard however, when I start that up the scroll button is pressed and I need to release it to be able to input characters.

So there is obviously some issue between my laptop keyboard and the KVM session.

Any suggestions would be appreciated.

Thanks, Stephen.

Could it be that your appliance has different (older?) CIMC firmware than your previous working ones?


Here's what I found about minimum CIMC versions in case you wanted to try to upgrade it.

Thanks for taking the time to respond Preston.

I would like to think Cisco wouldn't send me an RMA with versions that are incompatible.  I previously upgraded an ISE in a UCS M5 chassis and TAC said the following

" it is not recommended to upgrade the CIMC "

So I now don't touch the CIMC.

The version the server is running is 4.0(4b). The release notes actually say we should not upgrade any further than this version.

However, as the release notes say, the CIMC is separate from the DNAC software.  At the stage where my keyboard does not respond there is no DNAC version because I have initialized the disks ready for a re-image.  I often re-image and rebuild the DNAC.  I find it easier that trying to delete all the parts of an SD Access test lab.

I have a feeling it's some CIMC or BIOS setting that's maybe causing the issue.  I got round the issue by getting the virtual keyboard working but if I can't resolve the issue next time I need to use the CIMC KVM I'll probably log a TAC case.

Thanks again for your reply.  Any relevant input is appreciated.


Priyanka L
Cisco Employee
Cisco Employee

Hi Stevie,

I have three workarounds for you to try out.


1. in the KVM screen, select the Macros option (on top left) > Manage > New > F6 > Add.

During the boot up, select Macros > User Defined > F6


2. During the boot up, hit F2 and enter the BIOS utility.

USer the right arrow -> to navigate to Boot Options screen and select the boot device.


3. Change the boot order in the CIMC to explicitly boot from the USB


The problem isn’t booting the USB installation image.  I can do that ok.  

Turn on server from CIMC

Hit F6

Choose my USB key

Hit return

That’s all ok.

The problem is once the USB key has booted my laptop keyboard keystrokes don’t work.  So the KVM does not respond to my return key when I try to select the option

Start a DNA Center cluster.

Thanks, Stephen.

Hi Stephan,
Thanks for your response.
The “Macros” on the KVM Screen should work. You can create a user-defined macro for “Enter” and try using it.
I just had a look at the other responses, and believe that you carried out a similar approach.

It could be a common bug, encountered especially for MAC devices. If you ever run into a similar issue again, try using a different browser. Firefox is recommended , else Chrome needs to be on the updated version.


If it still does not work, clear the CMOS. SSH to CIMC IP and run the below commands and proceed with the installation.

Server# scope bios
Server /bios # clear-cmos

This operation will clear the BIOS CMOS.
Note: Server should be in powered off state to clear CMOS.
Continue?[y|n] y


Hope that helps.




1 - Create a bootable PenDrive Using Etcher
2 - Conecte under USB
3 - Press F6
4 - Choice USB Flash Disc
5 - Install maglev
6 - Scadush



by Josinfo

If only that were the question I asked then the info would have been most helpful.

Unfortunately I already knew that part as indicated in the posts above.

The issue is no response from the KVM once I start the maglev install.


Priyanka L
Cisco Employee
Cisco Employee

Hi Stephen,


Following up on this.


Were you able to get it to work?


Did you get a chance to use the Macros option in the KVM screen?

The “Macros” on the KVM Screen should work .  It is a small icon on the top-right.
You can create a user-defined macro for “Enter” and try using it.