Showing results for 
Search instead for 
Did you mean: 

Wi-Fi connection issues with EERO router


We have had multiple reports from remote end users that the wi-fi connection under Secure Client is stuck on Authenticating/Associating when using an EERO router.  Restarting the router and running a Network Repair on Secure Client does not resolve the issue.  The only solution has been to connect the users to the router via Ethernet.  This allows a successful wired connection to the user's home network and then to the company VPN. Three of the four users have Frontier as the ISP and the other has Optimum. We first saw the issue occur with the first user about 2-3 weeks ago. 

15 Replies 15


Same problem here, just started. Anyconnect version 4.10.03104 and eeroOS 7.0.1-64 on eero pro 6e

Hello BillWOhio,

Try disabling WPA3 authentication on the EERP router settings. That worked for me like a charm. I had no need to make any changes to my Cisco AnyConnect client at all. 

Same here. AnyConnect works fine cabled. It's intermittent on Wi-Fi. It had been fine all day until 15:15, then dropped out and stuck in Authenticating loop. Several reboots of the laptop later it connected again like nothing had happened. This is particularly infuriating and a ridiculous carry on that Cisco and Amazon need to sort out PDQ


Hello! I had the same issue, and I was able to fix it by disabling WPA3 authentication on the settings of EERO router. With the latest update to 7.0.XX, this is enabled by default. Give that a try and confirm if it's a fix applicable to all cases.

Hello.  Thank you for that suggestion.  One of the users having the issue is one of my team members and when she checked the EERO app on her phone she found that WPA3 was already disabled.  Are there any additional steps that need to be performed?


Same here - was already disabled. Tried toggling on/off along with router
reboot to no avail.

Signs here are definitely pointing to something between these two components
(AnyConnect and eero). I did note that there was a firmware update on the
eero on Oct 30 but this problem just materialized in the past two days, was
non-existent prior to Nov 8.

WPA3 was also disabled already for me. Since I'm not currently connected I'm not going to mess with it, but I dare say it's not long till me next disconnection



Hi smdrywa1,

If you’re having trouble with your eero or modem connection when setting up your gateway eero, here are a few things to check:

  1. Make sure your gateway eero is connected to your modem via the Ethernet cord provided in the box.
    • It should clip snuggly into your gateway eero and one of the Ethernet ports on your modem. (Note: Be sure to plug the ethernet cord into the correct port on your modem. On a standard modem, it will plug into the "WAN" or "Internet" port. On a modem/router combo device, it will plug into one of the "LAN" or numbered ports)
  2. Try power cycling your modem.
    • If there’s an on/off switch, switch it off and wait for 30 seconds before switching it back on. If there is no on/off switch, unplug the modem and wait for 30 seconds before plugging it back in. Once the lights stabilize on your modem’s display, you’ve successfully powered it back on.
  3. Try power cycling your gateway eero.
    • You can do this by unplugging and replugging it. Once you’ve plugged it back into power, wait for your eero to boot back up. This should take about 2 minutes.
    • For Ring Alarm Pro: This device is equipped with an internal battery. Pressing the reset button for 1 second will power cycle the unit.

If you’re not having any luck, give them a call @ (877) 659-2347 or submit a request @

Best regards
******* If This Helps, Please Rate *******

This is a very specific problem preventing people from working from home. Copying and pasting generic 'turn it off and back on again' help text isn't very helpful I'm afraid.


One of our user tested a theory that it could be due to Wi-Fi password security type by creating a guest Wi-Fi ssid and leave the password blank, this allows my person to connect to the Eero router (then changed it back to have an pw now, but willl have to use it in wired mode for now). What if the guest Wi-Fi has a different type of security than the main ssid and that's what caused it to work? Does Eero app let you change from differently types of WPA levels?

All of the wi-fi networks are running on WPA2 AES which is the current standard.  We already determined that WPA3 is disabled by default in the EERO app. Here are the current EERO app settings for my test user.  They are going to test by turning of IPv6 next.




We recently had a user report with an identical problem come in. They were using AnyConnect NAM v4.10.05095. We moved them to Secure Client v5.0.05040 and it seems to have resolved the issue. 

Oddly enough, I use an eero mesh wifi at home and never had any issues with it on my work PC with either version of Cisco AnyConnect / Secure Client.

EDIT: 6 hours later, the problem returned. Unfortunately, upgrading to the latest release of Secure Client is not the remedy I was hoping for. 


Interesting update... Temporarily pausing 5Ghz in the Eero app allows it to connect; failing again as soon as the 5Ghz is turned back on. My organisation don't want anything to do with it, Eero say they will roll back my firmware (at some time yet to be determined) but it's still not clear who/what is at fault and if anyone actually cares and is actually fixing it.

Meanwhile I can only work in one place in my house, attached with a cable which is a pain in the bum.

Beyond frustrating!

@DjHarPrem  When/if I get my hands on that newer version of Cisco AnyConnect; I like to give that a shot. TY

@peterdowson Wow, that is an interesting trial and error right there. This is what I'm going to test out with one of my user next.

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community: