Showing results for 
Search instead for 
Did you mean: 

Cisco Spark app won't launch

David Parker

After installing Spark and going through the initial email address verification, the Spark app imply won't launch. Nothing happens whatsoever when clicking the launcher. I called Cisco support but that wasn't helpful. Apparently the executable modifies a text file called sparklauncher.txt. Inside it there is a line "Spark executable beside launcher is backlisted". Support indicated that communication to the head end is blocked so the rest of the software isn't installed? They sent me a Network Requirements doc Network Requirements for Cisco Spark Services (... | Cisco Cloud Collaboration Help Central. But in checking that, there is nothing preventing communication outside. It seems to be a design flaw in Spark that there isn't more useful info upon failure to load. Any thoughts?

1 Accepted Solution

Accepted Solutions

Very odd. I finally got the app to launch. I had to uninstall, then browse the installation directories. There was still a directory left "Cisco Spark" that contained a file called "launched.dat". It wasn't until deleting that, then reinstalling the app that the launcher would work.

View solution in original post

19 Replies 19

David Parker

I've removed the proxy from the equation so it isn't interfering. I've also insured any udp/5004 is allowed out the firewall. When I run Wireshark while attempting to launch CiscoSpark, I see no traffic to udp/5004 nor tcp/5004. There is absolutely nothing that I can see that is causing a communication problem. I suspect that the Spark app does not install correctly so the firewall is a non-issue. Isn't there some sort of debug feature that can be enabled that might provide a clue as to why Spark doesn't even launch?

Very odd. I finally got the app to launch. I had to uninstall, then browse the installation directories. There was still a directory left "Cisco Spark" that contained a file called "launched.dat". It wasn't until deleting that, then reinstalling the app that the launcher would work.

I had the same issue, I found that when the installer ran, it did not update windows firewall.  So I uninstalled the application, deleted the launch.dat file, deleted the directory.  Did a clean install, de-selected launch SPARK, on the last install dialog box, hit finish.  Opened control panel, and added SPARK.exe manually to both public and private connections.  Went back and launched SPARK and it worked.

Cisco Employee
Cisco Employee

deleting "launched.dat" and reinstalling the app.. worked for me too.


Deleting the file was all I had to do, I didn't even uninstall first.


I've had a similar problem but the launched.dat doesn't seem to fix, Win7x64 (thanks IT!).  Spark was working, but I had a diskspace issue and was looking for quick, large file deletes and so most likely my fault!

My sparklauncher.txt gives this error. 

Cisco spark launcher started, location: C:\Users\c890698\AppData\Local\Programs\Cisco Spark\CiscoSpark.exe, launcher version: 2.0.7056.0

Spark executable beside launcher is backlisted: 2.0.7056.0

Found 0 further possible locations for Spark installations.

Could not find any Spark executables, giving up.

Exiting launcher.

No amount of scrubbing on reinstall seem to be able to fix this so that the system will download the correct launcher.  Not on official IT support but I use this on a client site!



I am having same issue, Windows 2008 R2

I cannot find launcher.dat at all.

If I do an install I get one run, then the next time I visit the server the same error appears.

I have three servers that it works on, one that it will not.

Look in c:\Users<your user>\AppData\Local\CiscoSpark

Once you delete install.dat, delete the spark directory.

Next re-install Spark, but DO NOT select the start on install box.  Let Spark install.  Once it is complete open Windows firewall, add spark to all domains, exit windows firewall.  Then launch Spark.

Best of luck, this has worked for me on two different PC's

Hello cmarsh,

Thanks yes I did end up finding the launcher.dat.




Hello / Hola

Got the same issue with spark, could create a log in with the website, but when downloaded the app and tried to log in the app never opened, had to delete all folders related to Cisco Spark after unistalling.


Tuve el mismo problema con spark, pude entrar con la versión en linea, pero al descargar la aplicación y tratar de entrar esta nunca se ejecuto, tuve que borrar todos las carpetas relacionadas a "Cisco Spark" después de des-instalar.    


I have uninstalled the Spark app multiple times, deleted all files and reinstalled the app from the cisco spark website. the app will install create the cisco spark folders in my user directory and launches the first time. when I try to relaunch the app from the start menu the 2nd time the app terminates and I'm unable to launch. I looked at the log files in the Spark folder and it has several cryptic messages around missing heartbeats...can I send the log file to Cisco to review and point me to a solution?

Try this :

- Unistall Spark Desktop App

- Delete the Spark Folders Left

- Reboot PC

- Install Spark Desktop App

- DO NOT LUNCH!!!! Spark with the intalation wizard

- Reboot PC

- double click spark quick access on Desktop

sorry...that didn't work. I checked the log files and the log file in the media folder has this error:

"2018-04-03T22:26:35.162Z <Error> [9796] MediaApplication.cpp:107 MediaApplication::initialize::<lambda_f599925fe4dda103bf671878c5001998>::operator ():Missed 7 heart beats. We did not received any heart beat acknowledge from spark client for 6 seconds and will terminate media process."

David Mowery

In case removing the launched.dat file doesn't work for you, update video drivers. My Spark app was launching with my onboard video card, when I switched it to my other vid card it started working properly.

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community: