Showing results for 
Search instead for 
Did you mean: 
Jose Mendez

Monitor your Unified Communications with RTMT in your Linux machine.


Components for this specific howto:

  1. Ubuntu 9.10   2.6.31-14-generic 32 bits running GNOME or

  2. Centos /RedHat / Scientific Linux 6.x 32/64 bits running GNOME
  3. Linuxmint KDE 15 (application launcher instructions below will not apply but you can get the idea)
NOTE: for 64 bits distributions based on RedHat, the following libraries are required before attempting to run the installer:  glibc.i686 and libXtst.i686


If the first one is not installed, the installer will return:


/lib/ bad ELF interpreter: no such file or directory


Once the glibc is installed, the installer will run, but the following error message chunk will be seen


Graphical installers are not supported by the VM. The console mode will be used instead...


Installer User Interface Mode Not Supported

The installer cannot run in this UI mode. To specify the interface mode, use the -i command-line option, followed by the UI mode identifier. The valid UI modes identifiers are GUI, Console, and Silent.



The solution to above errors is to install the libraries:


yum install glibc.i686 libXtst.i686



  1. Java is not really necessary as the installation package is already bundled with a JAVA 1.x archive


  1. Download the plugin from the CallManager administration interface > Plugins > Cisco Unified CM Real-Time Monitoring Tool - Linux
  2. Open a terminal
  3. Change directory to where the binary archive is
  4. Run:  
    • chmod +x CcmServRtmtPlugin.bin
    • sudo ./CcmServRtmtPlugin.bin
  5. Follow the install screens
  6. Create a desktop/menu launcher:
    1. In my case the plugin was installed under /opt/Cisco/CallManager_Serviceability/JRtmt, check during the installation wizard for any possible version changes
    2. Right-click your desktop
    3. Clic on "Create launcher" to create a desktop icon
    4. Java applications need be executed within the directory where they exist, so we would write a simple script:
      1. Create a new text document
      2. Write these 2 lines:  
        • cd /opt/Cisco/CallManager_Serviceability/JRtmt/
        • sh
      3. Save as "", preferrably in the installation folder under /opt (requires root access), but you can choose the location of your own, just make sure the extension is .sh
      4. OPTIONAL: chmod +x (might be necessary to make the script executable)screenshot_008.png
    5. Fill in the blanks as above
    6. Note that we are pointing to our recently created script file, not just the
    7. Note also, that you can customize the shortcut icon by cilcking on the top-left square. Then point to this path: /opt/Cisco/CallManager_Serviceability/JRtmt/shortcut.gif
    8. Collect your daily set of traces for bed-reading =Dscreenshot_005.png
    9. Finally, lets make Browser integration possible. Create a script file named mozilla (no extension) under /usr/local/sbin/, and write "firefox $1" in it, without the quotes, then save it
    10. Run:
      • sudo chmod +x /usr/local/sbin/mozilla
    11. Now you should be able to press F12 in RTMT and open the main administration interface in your Firefox browswer, or any other web page under the Application or Help menus. This is specially useful when openinng RTMT help pages for a particular tool (Help > Help for this Window)


    Bruno Filipe S. C. Teixeira
    Community Member


    In point 9 You said  clearly to create a script file named mozilla (no extension), obviously the chmod +x command in point 10 won't succeed due to the file extension. I wonder if that was a mistype!?...


    Which file under the installation directory calls for mozilla and/or I'm asking just to make sure It calls mozilla and not firefox with and/or wothout a file extension.

    I created a file under /usr/local/sbin and chmod +x the file but the fact is that Fxx and Ctrl+Fxx keys don't really work.

    Can you please advise?

    PS: Ubuntu 11.10+Firefox 7.0.1

    Jose Mendez

    I still need to test latest versions of Ubuntu, however you are right about the mozilla file that should remain without extension, using chmod pointed to /usr/local/sbin/mozilla.

    Bruno Filipe S. C. Teixeira
    Community Member

    RTMT works perfectly, It's only about the browser integration. I did grep -ri mozilla, to the intire directory structure and I only found matches within the jar files which is weird for me, meaning that couldn't find which file calls the so far created mozilla file. Any advise?

    Bruno Filipe S. C. Teixeira
    Community Member

    Goood NEwssssss

    The browser integration works perfectly with no file extension to the mozilla file.

    me@2pacalypse:~$ ls  -lta /usr/local/sbin/mozilla

    -rwxr-xr-x 1 root root 11 2011-10-24 16:58 /usr/local/sbin/mozilla


    Thanks a lot GREAT POST

    Saurabh Agnihotri
    Cisco Employee
    Cisco Employee

    Great document !!! Nicely written. (5 stars for you! )

    Bruno Filipe S. C. Teixeira
    Community Member

    Specifically in Ubuntu 11.10 using gnome-shell, you Won't be able to a create Desktop shortcut unless you do the following:

    gnome-desktop-item-edit ~/Desktop/ –create-new

    make sure you have gnome-panel installed

    I'm trying to install the RTMT on Ubuntu 10.4, 64 bit.  When I get to your step 4 and run the 'sudo ./CcmServRtmtPlugin.bin,' it starts to load, I get a GUI box with a progress bar, but then I get a Fatal Application Error.  It looks like there is some issue with Java.  How do I find out?  What can I do about this?

    This is my Java version

    java version "1.6.0_20"

    OpenJDK Runtime Environment (IcedTea6 1.9.13) (6b20-1.9.13-0ubuntu1~10.04.1)

    OpenJDK 64-Bit Server VM (build 19.0-b09, mixed mode)

    This is what's on my Terminal when I run the command:

    Preparing to install...

    Extracting the JRE from the installer archive...

    Unpacking the JRE...

    Extracting the installation resources from the installer archive...

    Configuring the installer for this system's environment...

    Launching installer...

    Invocation of this Java Application has caused an InvocationTargetException. This application will now exit. (LAX)

    Stack Trace:

    java.lang.NumberFormatException: For input string: "0-b09"

        at java.lang.NumberFormatException.forInputString(


    Under ubuntu 14.04, I get the following error.  I installed java 8, same error.  I installed java 7, same error.  Any advice?  Thanks

    tim@tim-Latitude-E6430:~/Downloads$ sudo ./CcmServRtmtPlugin.bin
    Preparing to install...
    Extracting the JRE from the installer archive...
    Unpacking the JRE...
    Extracting the installation resources from the installer archive...
    Configuring the installer for this system's environment...
    strings: '/lib/': No such file

    Launching installer...

    ./CcmServRtmtPlugin.bin: 2506: exec: /tmp/install.dir.6733/Linux/resource/jre/bin/java: not found


    I made a symlink for /lib/ -> /lib/x86_64-linux-gnu/, which got rid of the 'no such file' error, but error on line 2506 remains.

    Community Member

    I had other similar error due to missing dependencies installed

    Installing package solved it:

    sudo apt-get install icedtea-7-plugin:i386

    Also I had to fix some problems with overwriting files:

    sudo dpkg -i --force-overwrite /var/cache/apt/archives/icedtea-netx_1.5.3-0ubuntu0.14.04.1_i386.deb

    And then

    sudo apt-get -f install
    Dilyan Dimov

    For CentOS 6.7 and RTMT 10.5, except the libraries mentioned above I had to install libXrenderer.




    here's an update for Ubuntu 18.04 LTS:


    Installation needed a parameter:

    sudo ./CcmServRtmtPlugin.bin LAX_VM /usr/bin/java

    Then Install went fine but I couldn't start RTMT.

    I needed to install some packages so 


    sudo apt install libxtst6:i386 libxrender1:i386 libxi6:i386

    did the trick for me.

    Hope that helps anyone :)




    I'm in Lubuntu 19.04 (which is Ubuntu with the lightweight desktop LXDE)


    I couldn't even install until I installed 'iced tea' and used the extra LAX bit at the end.  Thanks Michael Heimann. 


    sudo ./CcmServRtmtPlugin.bin LAX_VM /usr/bin/java



    After install, I got an icon under

    Start>>Accessories>>Cisco Unified RTMT 10.5

    but nothing happens when I click it.


    I also tried running the launcher script above in this thread, and running JRtmt and from the command line.  None of those work. 


    The best clue I can collect is this:



    2478: exec:
    /opt/Cisco/Unified-Rtmt/JRtmt/../JRtmt/jre/bin/java: not found


    Java is *included* with RTMT, right?  Why can't it find the java?


    If it's known to work on Ubuntu (instead of Lubuntu) I guess I could install Ubuntu, but Lubuntu is much easier on the CPU. 



    Any advice on how to troubleshoot this a little more?



    I just checked, and all three of these are already installed:





    I edited the '' file to point to the same location as the LAX argument above (/usr/bin/java) and now

    • RTMT splash comes up,
    • asks for hostname,
    • asks for credentials,
    • starts to fire up,
    • then fizzles out with this:
    Error - RTMT failed to initialize.  Exiting... 


    Getting Started

    Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

    Quick Links