cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
346
Views
1
Helpful
5
Replies

Accounts on DUO Mobile have the same user email address on all devices

jorge-raposo
Level 1
Level 1

I'm one of the administrators of DUO and we use DUO Mobile as a 2FA to valide our users VPN access.

We activate the each user account by sending them an SMS from the DUO Admin console that contains a link to activate their DUO account.

After activating the account each user would have an entry on DUO Mobile with our logo, the user's email address and the name of the service it is used for (on this case "##Company name## VPN").

However something has changed recently because now all the accounts being activated on the device's DUO Mobile app show my own email email address, not the user's email address.

The same occurs when other admins activate user's accounts on their mobile devices, the email shown is always mine even is some other administrator does the activation process.

I suspect someone may have inadvertently changed some settings or policies on the DUO Admin console but I can't find any setting or policy that would replace the user's email address with mine.

Does anyone know what may have happened and how to change this configuration?

1 Accepted Solution

Accepted Solutions

DuoKristina
Cisco Employee
Cisco Employee

Does it show the user's email and also your email instead of the org name ? Or your email and the org name? I can't quite picture what you mean. In the Duo Mobile accounts list the logo and org name come from the Settings page in the Admin Panel). The protected service i.e. "VPN" isn't part of the account list info, because activation is per-user for all apps, not per-user and also per-app.

I don't really want you to post a screenshot of the app here since it would reveal your email, but you can open a case with Duo Support and send the screenshot there in the case so they can see what you're talking about.

I have seen before where the global setting for the Account Name has gotten updated by accident because someone's password manager automatically filled in their Duo admin username into the first field on the Settings page, which happens to be the Account Name.

Duo, not DUO.

View solution in original post

5 Replies 5

DuoKristina
Cisco Employee
Cisco Employee

Does it show the user's email and also your email instead of the org name ? Or your email and the org name? I can't quite picture what you mean. In the Duo Mobile accounts list the logo and org name come from the Settings page in the Admin Panel). The protected service i.e. "VPN" isn't part of the account list info, because activation is per-user for all apps, not per-user and also per-app.

I don't really want you to post a screenshot of the app here since it would reveal your email, but you can open a case with Duo Support and send the screenshot there in the case so they can see what you're talking about.

I have seen before where the global setting for the Account Name has gotten updated by accident because someone's password manager automatically filled in their Duo admin username into the first field on the Settings page, which happens to be the Account Name.

Duo, not DUO.

Unfortunately I can't open a ticket with Duo Support, it rejects my login saying that my account doesn't qualify for it. My Duo Admin account is not the owner of the Duo account, maybe I need to login with that email address instead...

 

However I've checked your suggestions and the problem was exactly on the settings page.

Somehow my email was filled into the first field of the settings page, that also happens to be the Account Name. I changed it back to my Company name and after saving the changes all the devices updated correctly.

 

It was also able to replicate the issue:

As soon as I reopened the Settings page it automatically scrolled down to the last group of the Settings options. 

And sure enough, after scrolling back to the top of the page the Account name was already filled in with my email address, again.

If I had made other changes on the settings page and saved them before checking it, the Account name would have been changed to my email address again.

 

My browser is Microsoft Edge and I don't have any password stored on it (it's disabled by company policy). We do have another online Password manager installed as an addon but I don't use it (don't even login into it).

 

I can't identify the reason for the Account name being automatically populated with my email address, but I'm sure none of the browser password managers are the cause.

I'm more inclined to think the reason for it is related to the one that forces the scroll down to the end of the settings page...

Huh, that's interesting. I am on a Mac but I tried Chrome, Safari, Firefox, and Edge for Mac incognito/private browsing sessions (to disable extensions), and none of them did any automatic scrolling on the Settings page of the Admin Panel or tried to update the "Account name" setting automatically. I usually am working in Chrome, with 1Password extension, and it doesn't update the setting.

If you try accessing the Duo Admin Panel an Edge InPrivate window so all your extensions are disabled do you see the same behavior?

I'll see if I can find a Windows system to test.

Duo, not DUO.

Tested it on the same browser and on an 'InPrivate' window and this time it all went well, no scrolling down when opening the Settings menu and the value of the Account name remains unchanged.

Considering this behavior I can only assume it's some other addon that is provoking this behavior.

 

I don't have permission on my browser's settings to deactivate installed addons (I also can't add any new addon...), but I'll pass this issue to our internal support for them to check what addon is doing this and if it can be corrected.

 

Thanks again for your support !!!

Thanks for doing that additional test!

Since this morning I booted up my personal Windows 11 laptop and gave it a try in Edge and also didn't observe the same scrolling and auto-complete behavior on the Admin Panel's Settings page.

I hope your support team can figure out what might be causing this in your managed Edge browser. If you have other Duo admins in your org you might want to warn them to pay attention when they log into the Admin Panel as well.

Duo, not DUO.
Quick Links