cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
1394
Views
15
Helpful
40
Replies

UC500 no calls through sip trunk

sam2000
Beginner
Beginner

Hello, I am running a problem with the UC500 platform and I am hoping for some advice.

I'm using a UC540W as a small pbx with a variety of internal extensions. The uc540 is connected on a private LAN with NAT access to the Internet, the NAT router also performs SIP ALG.
Directyly attached fxs and isdn phones as well as SIP phones in LAN do work as internal extensions, they can make calls each other.
I have a sip trunk configured (this trunk is working if directly configured on a sip phone on the LAN), but I can't have incoming or outgoing calls on it through the uc540


The sip trunk configuration is this:

sip-ua
credentials number MY_PUBLIC_NUMBER username MY_VOIP_USERNAME password MY_VOIP_PWD realm voip.fastwebnet.it
authentication username MY_VOIP_USERNAME password MY_VOIP_PWD realm voip.fastwebnet.it
no remote-party-id
retry invite 4
timers expires 900000
timers register 100
registrar 2 dns:voip.fastwebnet.it expires 3600 auth-realm voip.fastwebnet.it
connection-reuse

on this I configured two dial-peers, one for incoming calls and one for outgoing calls:

dial-peer voice 11 voip
description *** SIP Trunk towards fastweb ***
translation-profile outgoing FW_OUTBOUND_CID
destination-pattern 33T
session protocol sipv2
session target sip-server
session transport udp
voice-class codec 1
fax protocol t38 version 0 ls-redundancy 0 hs-redundancy 0 fallback pass-through g711alaw
ip qos dscp cs5 media
ip qos dscp cs5 signaling
!
dial-peer voice 10 voip
description *** SIP Trunk Fastweb incoming ***
translation-profile incoming FW_INBOUND_CID
session protocol sipv2
session target sip-server
session transport udp
incoming called-number .%
voice-class codec 1
voice-class sip dtmf-relay force rtp-nte
dtmf-relay rtp-nte
fax protocol t38 version 0 ls-redundancy 0 hs-redundancy 0 fallback pass-through g711alaw
ip qos dscp cs5 media
ip qos dscp cs4 signaling
no vad

translations rules and translation profiles are as follow (incoming calls from sip trunk should ring extension 622):

voice translation-rule 10001
rule 1 /^.*/ /MY_PUBLIC_NUMBER/
!
voice translation-rule 10002
rule 1 /^.*/ /622/
!
!
voice translation-profile FW_INBOUND_CID
translate calling 10002
!
voice translation-profile FW_OUTBOUND_CID
translate calling 10001

when i run the command
sh sip-ua register status

I can see the connection with the sip proxy is registered:

 

--------------------- Registrar-Index 2 ---------------------

Line peer expires(sec) registered P-Associ-URI
================================ ========== ============ ========== ============
MY_PUBLIC_NUMBER -1 399 yes


but I can't get any call through this trunk, neither incoming nor outgoing.
I have enabled debug ccsip message, if I call my SIP number from the cellphone I get these debug messages:

000979: Jan 2 14:12:18.644: //-1/xxxxxxxxxxxx/SIP/Msg/ccsipDisplayMsg:
Received:
INVITE sip:MY_PUBLIC_NUMBER@192.168.1.88:5060 SIP/2.0
Via: SIP/2.0/UDP 85.18.217.100:5060;branch=z9hG4bKmuvim300d865281h6bn0.1
Call-ID: 12dad1a06c2ea01-000f-00ba-0000-0000@10.2.22.199
CSeq: 1 INVITE
To: <sip:MY_PUBLIC_NUMBER@10.247.53.6;lr>
Content-Type: application/sdp
Max-Forwards: 61
Supported: 100rel
Allow: UPDATE,OPTIONS,INFO,REFER,ACK,NOTIFY,INVITE,CANCEL,SUBSCRIBE,MESSAGE,PRACK,BYE
P-Charging-Vector: icid-value="oXcbX51DqfpZ0088";icid-generated-at=10.247.5.40;orig-ioi=10.247.5.40
Accept: application/sdp,application/isup,application/xml
Contact: <sip:MY_CELLPHONE_NUMBER@85.18.217.100:5060;transport=udp>
From: <sip:MY_CELLPHONE_NUMBER0@telecomitalia.it>;tag=582e2469
Content-Length: 271

v=0
o=HPE-AS 47819 1 IN IP4 85.18.217.108
s=IMSS
c=IN IP4 85.18.217.108
t=0 0
m=audio 10156 RTP/AVP 8 18 101
b=AS:80
a=fmtp:18 annexb=no
a=rtpmap:101 telephone-event/8000
a=fmtp:101 0-15
a=sqn:0
a=cdsc:1 image udptl t38
a=sendrecv
a=maxptime:20
a=ptime:20

000980: Jan 2 14:12:18.656: //101/9E2E82A4807B/SIP/Msg/ccsipDisplayMsg:
Sent:
SIP/2.0 100 Trying
Via: SIP/2.0/UDP 85.18.217.100:5060;branch=z9hG4bKmuvim300d865281h6bn0.1
From: <sip:MY_CELLPHONE_NUMBER@telecomitalia.it>;tag=582e2469
To: <sip:MY_PUBLIC_NUMBER@10.247.53.6;lr>
Date: Mon, 02 Jan 2006 14:12:18 GMT
Call-ID: 12dad1a06c2ea01-000f-00ba-0000-0000@10.2.22.199
CSeq: 1 INVITE
Allow-Events: telephone-event
Server: Cisco-SIPGateway/IOS-12.x
Content-Length: 0

Sent:
SIP/2.0 403 Forbidden
Via: SIP/2.0/UDP 85.18.217.100:5060;branch=z9hG4bKmuvim300d865281h6bn0.1
From: <sip:MY_CELLPHONE_NUMBER@telecomitalia.it>;tag=582e2469
To: <sip:MY_PUBLIC_NUMBER@10.247.53.6;lr>;tag=7969E8-960
Date: Mon, 02 Jan 2006 14:12:18 GMT
Call-ID: 12dad1a06c2ea01-000f-00ba-0000-0000@10.2.22.199
CSeq: 1 INVITE
Allow-Events: telephone-event
Server: Cisco-SIPGateway/IOS-12.x
Reason: Q.850;cause=21
Content-Length: 0

000982: Jan 2 14:12:18.668: //-1/xxxxxxxxxxxx/SIP/Msg/ccsipDisplayMsg:
Received:
ACK sip:MY_PUBLIC_NUMBER@192.168.1.88:5060 SIP/2.0
Via: SIP/2.0/UDP 85.18.217.100:5060;branch=z9hG4bKmuvim300d865281h6bn0.1
CSeq: 1 ACK
Call-ID: 12dad1a06c2ea01-000f-00ba-0000-0000@10.2.22.199
To: <sip:MY_PUBLIC_NUMBER@10.247.53.6;lr>;tag=7969E8-960
Max-Forwards: 61
From: <sip:MY_CELLPHONE_NUMBER@telecomitalia.it>;tag=582e2469
Content-Length: 0

I am obviously either missing something or made some misconfiguration, I am at loss here and I don't know what it could be.

Any suggestion is warmly welcome, thanks.

Paolo

1 Accepted Solution

Accepted Solutions

Hi ,

With Paolo we found the solution.

In the invite message the provider requires his domain in the invite message.

In the outgoing dialpeer we shoul apply the following sip profile

voice class sip-profiles 105
request INVITE sip-header From modify "<sip:(PUBLICNUMBER)@(.*)>" "<sip:\1@voip.fastwebnet.it>"

Also in global configuration, being the UC500 behind a NAT, to make audio working in both directions, the following missing commands should be applied :

voice service voip

sip

asymmetric payload full
early-offer forced
midcall-signaling passthru

session refresh

 

HTH

 

Regards

 

Carlo

 

Please rate all helpful posts "The more you help the more you learn"

View solution in original post

40 Replies 40

One thing I noticed is your inbound dial peer, you have an unsupported character "%" . 

incoming called-number .% change to incoming called-number .

Regards, 

Shalid 

Disclaimer:

Responses are based on personal knowledge and experience. Consider them as guidance. Other members may offer different perspectives or better approaches. No responsibility is assumed for outcomes; discretion is advised.

Hi Shalid, on the UC500 platform, the % wildcard means "The preceding digit occurred zero or more times", anyway I tried removing it per your suggestion but it doesn't change the problem, alas.

thanks

 

Paolo

 

It is advisable to use a better match statement than incoming called-number.

Have a look at this document for better options. Explain Cisco IOS and IOS XE Call Routing Out of the listed match options using information in the VIA header is what I would suggest that you use.

Something along the way with this should do.

voice class uri PSTN sip
 host ipv4:85.18.217.100
!
dial-peer voice 10 voip
 no incoming called-number .%
 incoming uri via PSTN


Response Signature


Paolo,

The Q.850 Cause 21 is "Call Rejected" as opposed to unknown number or media negotiation issue. That could be caused by a number of things. 

Would you be able to post a fuller config, showing the local components for phone registration and the like? For IP addresses, please sanitize by 'blanking out' the second and third octets (so something like 10.X.X.43) so we can follow IP address. We will need something similar for phone numbers, so that what is shown includes the country code (since that is part of your dial-peer) and the last few digits (especially any digits that would cause a match to internal extensions).

Maren

Hi Maren, I saved the config as you requested. The IPs in the config were sanitized although it's just a RC1918 LAN. The only phone number in there is the public one provided by the voip provider, I left the two first digits and the last one. Thanks.

Paolo

I see your dial-peers reference "session target sip-server" but I don't see a "sip-server" configured under sip-ua. Can you try changing the dial-peers to be more specific? (Or am I missing something there?)

I also see that you have SIP bound to the VLAN1 interface under voice service voip. In your environment, is that appropriate for your external-facing interface? If not, have you tried binding SIP to the external interface in the external-facing dial-peer?

Maren

Hi Maren, you are indeed right, I added under sip-ua "sip-server dns:voip.fastwebnet.it" and now the outgoing phone calls have a different behavior. This is the debug log (ccsip messages and ccsip error) that I get:


000171: Jan 2 12:40:08.297: //45/B20F498F800F/SIP/Error/sipSPI_ipip_set_history_info_header: ccb->src_addr_str is NULL
SIP: (45) Group (a= group line) attribute, level 65535 instance 1 not found.
000172: Jan 2 12:40:08.305: //45/B20F498F800F/SIP/Msg/ccsipDisplayMsg:
Sent:
INVITE sip:33xxxxxxx0_PSTN_CalledNumber@voip.fastwebnet.it:5060 SIP/2.0
Via: SIP/2.0/UDP 192.168.1.88:5060;branch=z9hG4bKB103B
From: <sip:03xxxxxxx7_MyPublicVoipNumber@192.168.1.88>;tag=250788-4F6
To: <sip:33xxxxxxx0_PSTN_CalledNumber@voip.fastwebnet.it>
Date: Mon, 02 Jan 2006 12:40:08 GMT
Call-ID: BDD5E91C-7AC311DA-8066C52A-75F680A@192.168.1.88
Supported: 100rel,timer,resource-priority,replaces,sdp-anat
Min-SE: 1800
Cisco-Guid: 2987346319-2059604442-2148492288-4049517024
User-Agent: Cisco-SIPGateway/IOS-12.x
Allow: INVITE, OPTIONS, BYE, CANCEL, ACK, PRACK, UPDATE, REFER, SUBSCRIBE, NOTIFY, INFO, REGISTER
CSeq: 101 INVITE
Max-Forwards: 70
Timestamp: 1136205608
Contact: <sip:03xxxxxxx7_MyPublicVoipNumber@192.168.1.88:5060>
Expires: 900
Allow-Events: telephone-event
Content-Type: application/sdp
Content-Disposition: session;handling=required
Content-Length: 250

v=0
o=CiscoSystemsSIP-GW-UserAgent 8682 7927 IN IP4 192.168.1.88
s=SIP Call
c=IN IP4 192.168.1.88
t=0 0
m=audio 19420 RTP/AVP 8 18 19
c=IN IP4 192.168.1.88
a=rtpmap:8 PCMA/8000
a=rtpmap:18 G729/8000
a=fmtp:18 annexb=no
a=rtpmap:19 CN/8000

000173: Jan 2 12:40:08.321: //45/B20F498F800F/SIP/Msg/ccsipDisplayMsg:
Received:
SIP/2.0 100 Trying
Via: SIP/2.0/UDP 192.168.1.88:5060;branch=z9hG4bKB103B
From: <sip:03xxxxxxx7_MyPublicVoipNumber@192.168.1.88:5060>;tag=250788-4F6
To: <sip:33xxxxxxx0_PSTN_CalledNumber@voip.fastwebnet.it>
Call-ID: BDD5E91C-7AC311DA-8066C52A-75F680A@192.168.1.88
CSeq: 101 INVITE
Content-Length: 0


000174: Jan 2 12:40:08.321: //45/B20F498F800F/SIP/Msg/ccsipDisplayMsg:
Received:
SIP/2.0 403 Forbidden
Via: SIP/2.0/UDP 192.168.1.88:5060;branch=z9hG4bKB103B
From: <sip:03xxxxxxx7_MyPublicVoipNumber@192.168.1.88:5060>;tag=250788-4F6
To: <sip:33xxxxxxx0_PSTN_CalledNumber@voip.fastwebnet.it>;tag=aprqngfrt-u5usei30000a6
Call-ID: BDD5E91C-7AC311DA-8066C52A-75F680A@192.168.1.88
CSeq: 101 INVITE
Content-Length: 0


000175: Jan 2 12:40:08.325: //-1/xxxxxxxxxxxx/SIP/Msg/ccsipDisplayMsg:
Sent:
ACK sip:33xxxxxxx0_PSTN_CalledNumber@voip.fastwebnet.it:5060 SIP/2.0
Via: SIP/2.0/UDP 192.168.1.88:5060;branch=z9hG4bKB103B
From: <sip:03xxxxxxx7_MyPublicVoipNumber@192.168.1.88>;tag=250788-4F6
To: <sip:33xxxxxxx0_PSTN_CalledNumber@voip.fastwebnet.it>;tag=aprqngfrt-u5usei30000a6
Date: Mon, 02 Jan 2006 12:40:08 GMT
Call-ID: BDD5E91C-7AC311DA-8066C52A-75F680A@192.168.1.88
Max-Forwards: 70
CSeq: 101 ACK
Allow-Events: telephone-event
Content-Length: 0

as for the VLANs, I intentionally configured everything under VLAN 1 to simplify the configuration. Eventually I will indeed tackle the VLAN issue, but only after the voip part is working as I want it to be.

Thanks

Paolo

You are receiving a 403 forbidden response from the service provider. You’ll need to look at why your service provider is not allowing your call. Contact the service provider and ask them for an explanation.

000174: Jan 2 12:40:08.321: //45/B20F498F800F/SIP/Msg/ccsipDisplayMsg:
Received:
SIP/2.0 403 Forbidden
Via: SIP/2.0/UDP 192.168.1.88:5060;branch=z9hG4bKB103B
From: <sip:03xxxxxxx7_MyPublicVoipNumber@192.168.1.88:5060>;tag=250788-4F6
To: <sip:33xxxxxxx0_PSTN_CalledNumber@voip.fastwebnet.it>;tag=aprqngfrt-u5usei30000a6
Call-ID: BDD5E91C-7AC311DA-8066C52A-75F680A@192.168.1.88
CSeq: 101 INVITE
Content-Length: 0

Apart from that I think that you’ll need to sort out the network connection configuration issue that @Maren Mahoney pointed out before you try to work out your calling setup as it’s not very likely that other services will work as intended if you don’t have the basics in order.



Response Signature


Notice that prior to setting the sip-server command under sip-ua the INVITEs were going to a specific IP address, and after you set that command the INVITEs are going to the FQDN. The fact that you received a 403 Forbidden from your service provider after the change means they did not like something about your message. As the thing that changed was IP-to-FQDN we can assume that might be the issue.

Change your sip-server command under sip-ua to the IP address of the target rather than the FQDN and try again. If that does not work, reach out to your service provider and ask them about the specific format they need to see.

Maren

Hi Maren, I changed the sip-server from dns:voip.fastwebnet.it to ipv4:85.18.217.100 but this didn't solve the issue. Indeed the INVITE message is now going to the IP address instead of the FQDN but that is the only difference

Thanks

Paolo

I agree with @Roger Kallberg  that you will want to contact your Service Provider and ask them why your INVITEs are being rejected. They should be able to tell you what they want to see in your messaging.

Maren

Hi Maren, indeed that option would help a lot but my provider doesn't offer this kind of support, unfortunately.

Thanks

Paolo

They are required to tell you the format they are expecting for SIP messaging. Did they provide documents when you signed your contract that might have SIP-related information in it? For instance, when you set up your realm they would have had to tell you how to configure that.

Maren

Hi Paolo,

As long as I’m based in Italy, I know fastweb contracts and your issue may be addressed based of on what kind of subscrition you have with them.

Can you please specify it?

 

Thanks

Regards

 

Carlo

Please rate all helpful posts "The more you help the more you learn"
Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community: