cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
525
Views
10
Helpful
2
Replies

RSVP-TE tunnel between PE and P router

sachin30720041
Level 1
Level 1

Hello All,

 

I am working on the following setup.

 

CE1---(vrf1)PE5---P6---P7--P8--P9--PE10(vrf1)--CE2

 
 LDP is running on PE5, P6,P7,P8,P9 and P10. BGP VPNv4 session is up between PE5 and PE10. There is an RSVP-TE tunnel between PE5 and P7. I have configured a static route 'ip route 10.10.10.10 255.255.255.255 tunnel1' so that traffic goes through the tunnel. 10.10.10.10 is the loopback of PE10. Traffic goes from CE1 to P7 but P7 drops the traffic. I am not sure why traffic is getting dropped at P7.Am I missing any configuration?
 
CE1
----------------
hostname r1
int gi0/2
ip address 100.10.50.1 255.255.255.0
no sh

int lo0
ip address 1.1.1.1 255.255.255.255

router bgp 1
neighbor 100.10.50.5 remote-as 510
network 1.1.1.1 mask 255.255.255.255


PE5
---------------------------

hostname r5
mpls traffic-eng tunnels

vrf def vrf1
rd 5:5
address-family ipv4 unicast
route-target import 10:10
route-target export 5:5


int gi2
vrf forwarding vrf1
ip address 100.10.50.5 255.255.255.0
no sh


int gi3
ip address 100.50.60.5 255.255.255.0
no sh
ip router isis 1
mpls traffic-eng tunnels
ip rsvp bandwidth percent 75


int lo0
ip address 5.5.5.5 255.255.255.0
no sh

router isis 1
mpls ldp autoconfig
metric-style wide
net 49.0005.5555.5555.5555.00
is-type level-2
mpls traffic-eng level-2
mpls traffic-eng router-id lo0
passive-interface lo0
advertise passive-only

interface tunnel1
ip unnumbered lo0
tunnel destination 7.7.7.7
tunnel mode mpls traffic-eng
tunnel mpls traffic-eng path-option 1 explicit name path1

ip explicit-path name path1
next-address 5.5.5.5
next-address 6.6.6.6
next-address 7.7.7.7

router bgp 510
no bgp default ipv4-unicast
neighbor 10.10.10.10 remote-as 510
neighbor 10.10.10.10 update-source lo0
address-family vpnv4 unicast
neighbor 10.10.10.10 activate
address-family ipv4 vrf vrf1
neighbor 100.10.50.1 remote-as 1

ip route 10.10.10.10 255.255.255.255 tunnel1

P6
---------------------------
hostname r6
mpls traffic-eng tunnels
int gi3
ip address 100.50.60.6 255.255.255.0
no sh
ip router isis 1
ip rsvp bandwidth percent 75
mpls traffic-eng tunnels

int gi1
ip address 100.60.70.6 255.255.255.0
no sh
ip router isis 1
ip rsvp bandwidth percent 75
mpls traffic-eng tunnels
ip rsvp bandwidth percent 75


int lo0
ip address 6.6.6.6 255.255.255.0
no sh

router isis 1
mpls ldp autoconfig
metric-style wide
net 49.0006.6666.6666.6666.00
is-type level-2
mpls traffic-eng level-2
mpls traffic-eng router-id lo0
passive-interface lo0
advertise passive-only

P7
---------------------------
hostname r7
mpls traffic-eng tunnels
int gi2
ip address 100.70.80.7 255.255.255.0
no sh
ip router isis 1
ip rsvp bandwidth percent 75
mpls traffic-eng tunnels

int gi1
ip address 100.60.70.7 255.255.255.0
no sh
ip router isis 1
ip rsvp bandwidth percent 75
mpls traffic-eng tunnels
ip rsvp bandwidth percent 75


int lo0
ip address 7.7.7.7 255.255.255.0
no sh

router isis 1
mpls ldp autoconfig
metric-style wide
net 49.0007.7777.7777.7777.00
is-type level-2
mpls traffic-eng level-2
mpls traffic-eng router-id lo0
passive-interface lo0
advertise passive-only

P8
---------------------------
hostname r8
mpls traffic-eng tunnels
int gi2
ip address 100.70.80.8 255.255.255.0
no sh
ip router isis 1
ip rsvp bandwidth percent 75
mpls traffic-eng tunnels

int gi1
ip address 100.80.90.8 255.255.255.0
no sh
ip router isis 1
ip rsvp bandwidth percent 75
mpls traffic-eng tunnels


int lo0
ip address 8.8.8.8 255.255.255.0
no sh

router isis 1
mpls ldp autoconfig
metric-style wide
net 49.0008.8888.8888.8888.00
is-type level-2
mpls traffic-eng level-2
mpls traffic-eng router-id lo0
passive-interface lo0
advertise passive-only
 
P9
---------------------------
hostname r9
mpls traffic-eng tunnels
int gi1
ip address 100.80.90.9 255.255.255.0
no sh
ip router isis 1
ip rsvp bandwidth percent 75
mpls traffic-eng tunnels

int gi3
ip address 100.90.100.9 255.255.255.0
no sh
ip router isis 1
ip rsvp bandwidth percent 75
mpls traffic-eng tunnels


int lo0
ip address 9.9.9.9 255.255.255.0
no sh

router isis 1
mpls ldp autoconfig
metric-style wide
net 49.0009.9999.9999.9999.00
is-type level-2
mpls traffic-eng level-2
mpls traffic-eng router-id lo0
passive-interface lo0
advertise passive-only

PE10
---------------------------

vrf def vrf1
rd 10:10
address-family ipv4 unicast
route-target import 5:5
route-target export 10:10

hostname r10
mpls traffic-eng tunnels
int gi3
ip address 100.90.100.10 255.255.255.0
no sh
ip router isis 1
ip rsvp bandwidth percent 75
mpls traffic-eng tunnels

int gi1
vrf forwarding vrf1
ip address 100.30.100.10 255.255.255.0
no sh

int lo0
ip address 10.10.10.10 255.255.255.0
no sh

router isis 1
mpls ldp autoconfig
metric-style wide
net 49.0010.1010.1010.1010.00
is-type level-2
mpls traffic-eng level-2
mpls traffic-eng router-id lo0
passive-interface lo0
advertise passive-only

router bgp 510
no bgp default ipv4-unicast
neighbor 5.5.5.5 remote-as 510
neighbor 5.5.5.5 update-source lo0
address-family vpnv4 unicast
neighbor 5.5.5.5 activate
address-family ipv4 vrf vrf1
neighbor 100.30.100.3 remote-as 3



ios3
----------------
int gi0/1
ip address 100.30.100.10 255.255.255.0
no sh

int lo0
ip address 3.3.3.3 255.255.255.255

router bgp 3
neighbor 100.30.100.10 remote-as 510
1 Accepted Solution

Accepted Solutions

Harold Ritter
Cisco Employee
Cisco Employee

Hi @sachin30720041 ,

 

You need to enable LDP over the tunnel interface, so that traffic is labelled end to end.

 

interface tunnel1

mpls ip

!

 

Regards,

Harold Ritter
Sr Technical Leader
CCIE 4168 (R&S, SP)
harold@cisco.com
México móvil: +52 1 55 8312 4915
Cisco México
Paseo de la Reforma 222
Piso 19
Cuauhtémoc, Juárez
Ciudad de México, 06600
México

View solution in original post

2 Replies 2

Follow

Harold Ritter
Cisco Employee
Cisco Employee

Hi @sachin30720041 ,

 

You need to enable LDP over the tunnel interface, so that traffic is labelled end to end.

 

interface tunnel1

mpls ip

!

 

Regards,

Harold Ritter
Sr Technical Leader
CCIE 4168 (R&S, SP)
harold@cisco.com
México móvil: +52 1 55 8312 4915
Cisco México
Paseo de la Reforma 222
Piso 19
Cuauhtémoc, Juárez
Ciudad de México, 06600
México