Showing results for 
Search instead for 
Did you mean: 

Core Issue

If the no service password-recovery command has been configured on a router, the break sequence will no longer work in order to get to ROM Monitor (ROMmon) mode to perform a password recovery. If this feature is enabled,  the following message is displayed at bootup, indicating that the password recovery functionality is disabled.

System Bootstrap, Version 11.1(4675) [kluk 143], INTERIM SOFTWARE
Copyright (c) 1994-1996 by cisco Systems, Inc.
C3600 processor with 32768 Kbytes of main memory
Main memory is configured to 64 bit mode with parity disabled

program load complete, entry point: 0x80008000, size: 0x2733f4

Recovery from this state is possible. However, the startup configuration in NVRAM will be lost.


If a Cisco 1700, 2600, 3600, or 3700 series router has been configured with the no service password-recovery command and the enable password is not known, perform the following steps in order to recover the password:

  1. Boot the system. 

  2. After the Cisco IOS  image decompresses and shows [OK] (as in the example shown), enter a break sequence within five seconds. 


    Self decompressing the following image:



    For information about the correct break sequence, refer to Standard Break Key Sequence Combinations During Password Recovery.


  3. The router then asks if you want to reset it to the factory default configuration with the following message: 



    Do you want to reset the router to factory default

    configuration and proceed [y/n] ? y

    Reset router configuration to factory default.


    The router now boots with no configuration.


  4. If the no service password-recovery command is enabled and no valid Cisco IOS image is in Flash, then the above procedure does not work. If this is the case, a Flash already containing a valid Cisco IOS image must be installed first and then the procedure above may be performed. This is because the xmodem and tftpdnld commands are not available due to the inability to access ROMmon. 

  5. On the Cisco 3640 and 3660 routers only, the NVRAM chip may be removed and reinstalled in order to erase the configuration. This is possible on these models because a separate battery holds the configuration, and when the chip is removed, the configuration is lost. The silkscreen on the motherboard will identify it as "NVRAM". Be sure to use proper anti-static procedures when handling NVRAM. This procedure does not work on the Cisco 1700, 2600, or 3620 models and should be done only as a last resort if no Cisco IOS image is present in Flash.

When Problem Occurs

After software configuration change

Error Messages and Warnings


Community Member

no service password-recovery command has been configured on my router, so the break sequence will no longer work in order to get to ROM Monitor (ROMmon) mode to perform a password recovery. I have followed more Cisco documents that explain the procedure to restore the default factory configuration, but none of them works.

The system doesn't react to the receipt of the command "break".

My router is 877 with IOS 12.4(9)T5, and bootstrap 12.3(8r)Y14.

How can I restore factory configuration?

Thanks in advance.


Hi there! i am unable to enter "y" when router prompts to enter factory default configuration[y/n]. can anyone help. Thanks...


Thanks, I did it calmly and it worked for me,  when the router finished loading the image #### OK, I counted up to 8 or 10 and typed Cntr + Break very slowly and it worked. I clarify that it took me many attempts and hours, but then it was very easy.

Note: do not quickly type CLT + Break

Router 1841 y 1941.

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

Quick Links