Showing results for 
Search instead for 
Did you mean: 

ANI server not running


Hello all,

I am trying to get Campus Manager up and running but whenever I go to run Topology Services it craps out saing that the ANI Server is not running. I look under my servcies for Windows 2000 and see there is no ANI server option there. I go to add a new seed device to teh Server administration and get the same error. WHat do I need to do reinstall is there a way to get this going.

Thanks David



What is ther version of Campus Manager/CW2K?. Is this Win2K Professional/ or Server and SP version?. Was this ever working before?. Any other apps installed on the same server with CW2K?

This is a win2000 machine with sp2. yeah RME and SLM

CD 0ne ver 2.1

Campus manager 3.2 it

From the DOS prompt, do a net stop crmdmgtd. Wait for a few minutes and then do net start crmdmgtd and the try to launch Campus Manager again.


go to server config > admin > process management > start process and go throughthe drop down menu and select aniserver. If you dont see the aniserver there then go to Stop process > stop the ani server and then restart it.

I got the same error when I conected via the lookback http:\\

Yeah when I go to diagnosis ANI server it craps out also giving errors. I have also recevied apache errors when I go to toplogy section of campus manager. CiscoWorks is just not working out. I have have done multilpe installation and it still is not working properly.


I have got the same problem too.

I have installed CW2K on a W2K server, SP2, IE6, Java Plug-in 1.3.1.

ANI server (version 4.1) analyse told me that an error occured:

<< ERROR: An Error occurred communicating with your ANIServer at 18 mars 2003 11:58:03 GMT+01:00

ANIServer may not be running and the information may be incomplete.

AniWrapper>>analyze(SYSTEM) Server Named: ANIServer4.1-cw1 on port: 14004 >>

I have also an error in the events applications log during server power-on about Apache:

<< The Apache service named C:\PROGRA~1\CSCOpx\lib\web\Apache.exe reported the following error:

>>> [Tue Mar 18 09:49:47 2003] [notice] jrApache[init] mod_jrun: JRun Connector v2.3.149 static Apache - Jan 30 2002 17:08:30 <<<

before the error.log file could be opened.

More information may be available in the error.log file. . >>

This error.log file is not much more explicit:

<< Tue Mar 18 09:49:59 CET 2003: JRun Properties Dir: C:\PROGRA~1\CSCOpx\lib\jrun\jsm-cw2000\services\jse\properties>>

Furthemore, ACL manager is not working too ; when I try to launch "Edit Class Definintion" (under RME>Admin>ACL mgt), the screen freezes "Running Class manager...".

When I tried to display the Java console, it seems that the server tries to connect a firewall:

<< The classname is

valid = true:admin:F:MTkyLjE2OC4xLjEw

ManagerBase::init() Authenticating with ClientServices, protocol=http

Connecting with firewall


I have tried many different installs but with no success.

Is Campus manager and ACL ever function under with W2K ?

Guys, try this it worked for me.

Uninstall Java plug in 1.3.1 from windows

reboot server

Connect to ciscoworks http://:1741/

Java plug in will be installed and errors will be cleared

Hope this helps.

This worked, but sometimes the connection problem with the ANI server still occurs. When opening the Topology Services I receive an error that the ANI server is not working. After a few seconds I try again and the ANI server is working and the Toplogy Services shows up. What is causing this?

I already applied the latest Campus IDU. CiscoWorks runs on a WIN2K server.

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community: