cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
734
Views
5
Helpful
8
Replies

DUPLEX_MISMATCH 2924XL

dennisbarnes
Beginner
Beginner

Hi,

I am having issues with Cisco 2924XL switch,

Its keep giving me these messages on console,

00:38:44: %CDP-4-DUPLEX_MISMATCH: duplex mismatch discovered on FastEthernet0/1

(not full duplex), with SIP00036B75B6DE Port 1 (full duplex).

00:39:44: %CDP-4-DUPLEX_MISMATCH: duplex mismatch discovered on FastEthernet0/1

(not full duplex), with SIP00036B75B6DE Port 1 (full duplex).

My current IOS version is "c2900xl-c3h2s-mz.120-5.WC10.bin"..

Please advice me how can I rectify this problem.

Regards,

Dennis

1 ACCEPTED SOLUTION

Accepted Solutions

glen.grant
Advisor
Advisor

Set port f0/1 to full duplex on the 2924.

View solution in original post

8 REPLIES 8

alex.alexander
Beginner
Beginner

Did you check the duplex config. of the device connected on port f0/1?

The device connected to the port 0/1 is Netgear switch, and on my Cisco Switch I put auto, doesn't mean it should negotiate the duplex settings,,

Experience has shown that auto negotiation between different vendors is very hit and miss. Best bet is to hard code the speed and duplex on the Cisco equipment to avoid any conflicts like you are seeing.

The autonegotiation usually works well, but only if both sides support it and are configured for it. If one side is configured auto, and the other side is forced (or does not support auto), then autonegotiation does not take place. In this case, the auto side reverts to the default, which is half-duplex.

The result is that if one side is auto, and the other side is forced full-duplex, then there will be a duplex mismatch. I'm pretty sure that is what was happening here.

Kevin Dorrell

Luxembourg

glen.grant
Advisor
Advisor

Set port f0/1 to full duplex on the 2924.

Glen,

Thanks ....Issue resolved..Can u plz tell me why the port is not working on auto, it should auto negotiate the prot settings.

Better look at the netgear box... Could you verify the auto configuration there, or the fallback procedure for that switch?

andrew.butterworth
Rising star
Rising star

From the message you are receiving it looks like you have another CDP-speaking device connected to the Netgear switch. Your speed/duplex settings may be OK, but what you are seeing is the CDP messages (which are layer-2 multicast) from the device SIP00036B75B6DE that I assume is an IP Phone with SIP software(?) that is running at Full Duplex whilst your FastEthernet0/1 port is running at half duplex.

Andy

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community: