cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
230
Views
0
Helpful
2
Replies

DUO - RDP - LogonExpert

mark-bailey
Level 1
Level 1

I have a number of servers that MUST run an application as the Administrator as soon as the machine restarts for any reason.
I cannot run this application as a Service.

To facilitate this, I use a tool called LogonExpert which logs in as the administrator when the machine reboots and then I use the Windows Task Scheduler to start the required application.

I now want to use DUO to provide MFA for RDP Logins.

On one of the servers, it works perfectly.

But, on another, every time I try and RDP into the machine, the DUO dialog shows up and then immediately shows the following error...

markbailey_0-1711853105787.png

This is strange as I am not getting this problem on the other machines.

Any ideas or suggestions would be greatly appreciated.

 

Cheers,

Mark

 

 

 

2 Replies 2

Pulkit Mittal
Level 1
Level 1

Have a look at this article to see if increasing the timeout setting will help.

https://help.duo.com/s/article/5015?language=en_US

If you find this useful, please mark it helpful and accept the solution.

DuoKristina
Cisco Employee
Cisco Employee

That's a Windows error message, not a message from Duo. Typically a given Windows user can only have one login session active on the machine, and without purchasing additional RDS licenses from MSFT Windows Server imposes a two-user limit on concurrent RDP connections.

Are you...
- making the RDP connection as the same user that LogonExpert logged in as to run the service? Maybe the LogonExpert tool then tries to reconnect its session as that user and therefore disconnects your session?
- possibly encountering the two-user limit on that server?

It might help to compare all the LogonExpert settings between the two servers or contact their support.

Duo, not DUO.
Quick Links