cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
1823
Views
0
Helpful
2
Replies

Can't access USB ports following upgrade (1941 router)

Group IT
Level 1
Level 1

Hi,

I have been using 'dir usbflash0:' etc on a Cisco 1941 router with IOS v15.1 fine.

Today I have upgraded the IOS to c1900-universalk9-mz.SPA.155-1.T.bin and also tried c1900-universalk9-mz.SPA.155-3.M3.bin.

With these new IOS's I am unable to access the USB ports. If I downgrade back to 15.1, they work fine again.

Under 15.5, 'dir ?' doesn't seem to show the filesystems for USB being available:

"

rtr-h001859#dir ?
/all List all files
/recursive List files recursively
all-filesystems List files on all filesystems
archive: Directory or file name
cns: Directory or file name
flash0: Directory or file name
flash1: Directory or file name
flash: Directory or file name
null: Directory or file name
nvram: Directory or file name
system: Directory or file name
tar: Directory or file name
tmpsys: Directory or file name
xmodem: Directory or file name
ymodem: Directory or file name
| Output modifiers
<cr>

"

However I can issue 'show usb' and it shows them active:

"

rtr-h001859#show usb port
Port Number: 0
Status: Disabled
Connection State: Disconnected
Speed: Unknown
Power State: ON

Port Number: 1
Status: Enabled
Connection State: Connected
Speed: High
Power State: ON

"

I have tried running "no hw-module usb disable", saving and reloading, but still nothing.

Do later IOS's really disable use of the USB ports?!

I would really appreciate some insight or advice on how to access the USB ports under 15.5+.

Thank you!

Best Regards,

Elliot

2 Replies 2

Leo Laohoo
Hall of Fame
Hall of Fame

Do later IOS's really disable use of the USB ports?!

This issue is caused by a bug in the IOS code.  I've seen this before.  Nothing you can do except upgrade (or downgrade).

Hi Leo,

Thank you for your reply.

I don't suppose you know of a paper which references all the buggy (or even non-buggy) IOS's do you?

I have now tried the following IOS's and they all have the same issue!

c1900-universalk9-mz.SPA.150-1.M9

c1900-universalk9-mz.SPA.151-1.T.bin

c1900-universalk9-mz.SPA.151-3.T1.bin

c1900-universalk9-mz.SPA.151-4.M7.bin

c1900-universalk9-mz.SPA.152-4.M7.bin

c1900-universalk9-mz.SPA.154-3.M6a.bin

I'm actually wondering if the problem is due to a "default" config setting which one of the later IOS's introduced.

Also, like an idiot, between shuffling all these IOS files about, I have managed to delete the original IOS which was on the device, so now I am unsure exactly which one did work!

Thank you.

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community: