cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
2287
Views
0
Helpful
13
Replies

RV042G FTP still goes through WAN1

Ryan Hendriks
Beginner
Beginner

I have created a protocol binding rule and even a bandwidth rule to make sure outgoing FTP needs to go through WAN2 interface.

But it still goes through WAN1, it only works when I disconnect WAN1

protocolbindingftp.jpgbandwidtmanagementFTP.jpg

13 Replies 13

Ryan Hendriks
Beginner
Beginner

Can somebody please help me with this? It is a bit urgent because my ISP provider on WAN1 does not allow ftp and I need to leave everything on the WAN ports because WAN1 is the fastest line for http and all that kind of stuff.

On WAN2 i have my previous DSL line with fix ip to use for my mailserver and ftp and webserver.

I've got a simillar problem. Because I need a fixed source IP, I need all the FTP traffic to use WAN2. Does somebody have a solution to this problem?

Try setting destination IP 0.0.0.0 for both section of the protocol bind.

-Tom
Please rate helpful posts

-Tom Please mark answered for helpful posts http://blogs.cisco.com/smallbusiness/

Hi Tom,

thanks for your reply. I tried FTP with destination 0.0.0.0-0.0.0.0 and 0.0.0.0-255.255.255.255.

Both have this result:

When I create a rule "all Traffic to destination IP" i get this result:

If the protocol bind is set up correctly, it sounds like the router wan mode is smartlink backup, as the described behavior above is exactly as it should behave using smartlink backup. Double check to see load balance is the mode.

-Tom
Please rate helpful posts

-Tom Please mark answered for helpful posts http://blogs.cisco.com/smallbusiness/

Hi again,

it is on. New ideas?

Try binding all ports Filezilla  uses or whatever your FTP program that you're using.

http://wiki.filezilla-project.org/FAQ

  1. I'm behind a firewall and nobody can connect to my server or transfer files / directory listings
    You have to configure your firewall to allow incoming connections on the  ftp port (default: 21), as well as allowing outgoing connections from  the server. In FTP Active Mode, FileZilla Server tries to use a  port one less than the ftp port for outgoing connections. If that fails  it tries to use a port one larger than the ftp port and after that it  requests a port from windows. It may be best to allow all outgoing  connections from the server. Further you have to allow a port range for incoming connections for  passive mode transfers. You can specify this port range on the "passive  mode settings" page in the settings dialog in the server interface. In  most cases, a range like 5000-5100 is sufficient. With certain firewalls, it may be possible that FileZilla can't  determine the external IP address. In this case you have to enter the IP  address (or your host name) on the passive mode page in the settings  dialog. In case you've a dynamic IP (most dial-up users), you can also  choose to retrieve the ip address from a website.
  2. I'm behind a router and nobody can connect to my server or transfer files / directory listings
    You have to configure your router to forward the ftp port (default: 21)  to the server machine. Further you have to forward a port range for passive mode transfers. You  can specify this port range on the "passive mode settings" page in the  settings dialog in the server interface. In most cases, a range like  5000-5100 is sufficient. Most likely, FileZilla can't determine the external IP address if behind  a router. In this case you have to enter the IP address (or your host  name) on the passive mode page in the settings dialog. In case you've a  dynamic IP (most dial-up users), you can also choose to retrieve the ip  address from a website.

-Tom
Please rate helpful posts

-Tom Please mark answered for helpful posts http://blogs.cisco.com/smallbusiness/

Hi Tom,

I'm on the FTP client side. And I thought this statement:

should request all ports to use WAN2 when connecting to the server at ???.???.138.73

Jan

You are right, all traffic should go to the WAN2 with this statement.

What happens when using built-in FTP on the browser or command prompt?

Have you opened a case number with the support center?

-Tom
Please rate helpful posts

-Tom Please mark answered for helpful posts http://blogs.cisco.com/smallbusiness/

Hi Tom,

sorry for the late answer.

I have tested with build-in FTP and the command prompt. Same result. I'm able to connect, but i can't get a directory list. And I didn't open a case with the support center, because I'm not able to do so unless I have a contract number.

But I found a work around which is enough for me:

I turned the rules around. I'v got a default rule to use WAN2 (thats the one with the fixed IP) and definded additional rules to use WAN1 (the one with the high bandwith) for the most often used and heavy traffic protocols like HTTP, HTTPS, SMTP, POP3, IMAP and DNS.

I think the router has a problem to handle the secondary connections of the FTP protocol. But I'm still wondering why it doesn't work when I specify the rule to use WAN2 for a specific destination IP.

Nevertheless thanks a lot.

Jan

Hi Jan, the SBSC does not require a support contract. Only Cisco TAC does. If there is a problem to create a case, I will create one for you. If the protocol binding for FTP is broken and we can make enough information to prove it, it is really important. I know for sure the binds work for http/https traffic and it is easily prove-able going to external sites which report your IP address.

I can only think there is something coexisting that is interfering somehow. Nonetheless, it is very interesting and it should have a case so we can find a resolution to your problem or document a bug if it is a bug.

-Tom
Please rate helpful posts

-Tom Please mark answered for helpful posts http://blogs.cisco.com/smallbusiness/

It would be great if you could open a case for this because I also have this issue and it is exactly the same as of Jan.
I do not have a workarround. I have to copy the files every night to another server and then from there I have to ftp them to the several ftp sites.
I thought when I bought this beautiful rv042 to have a very good router. But it gave me more brainstormings then before

Ryan

Sent from Cisco Technical Support iPhone App

Hi Tom,

this is my configuration:

The firewall at the FTP server with the IP "fixed IP(b)" just allows FTP-traffic coming from "fixed IP(a)". Therefore I would like to configure the RV042G to use WAN1 for all traffic except the FTP traffic which should be routed over WAN2.

When I configure a rule to use WAN2 for FTP and a second rule to use WAN1 for ALL TRAFFIC, I'm able to connect to the FTP server but not any more.

I assume that the RV042G routes all traffic regarding destination port 21 over WAN2. But not the second connection opened due to the passive FTP to a completely different port (see: http://en.wikipedia.org/wiki/File_Transfer_Protocol#Protocol_overview).

The RV042G should inspect the FTP traffic to recognize the new port told by the FTP server for the second connection and route all traffic regarding this one - for destination IP "fixed IP(b)" - too through WAN2.

All other components can be assumend to work correctly, because when I just disconnect the Cabel-Modem WAN1 (which shouldn't be envolved for FTP) everything works fine.

Hope it helps you.

Regards

Jan

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

Recognize Your Peers