cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
470
Views
0
Helpful
4
Replies

RV320 stuck at firmware 1.3.2.02

Martin23349
Beginner
Beginner

 

Since 2018 I've got a RV320 router which has currently running firmware v1.3.2.02.

I tried to upgrade this several times before, but the upgrade does not seem to work.

Today I finally got round to looking into my firmware upgrade problem again.

What I tried:

  • uploading the latest v1.4;
  • uploading the latest v1.5;
  • Upgrading via USB;

All upgrade methods seem to work, but after reboot the former version 1.3.2.02 is shown again.

 

Anyone any idea?

 

4 Replies 4

marce1000
VIP Mentor VIP Mentor
VIP Mentor

 

 - Check the logs during the upgrade procedure or attach a console and follow up on it. Also keep checking for errors during the initial boot after the upgrade attempt.

 M.

Hello Marce1000,

 

Thanks for the reply. The logs are not showing anything. All boxes were ticked. 

Between loading the USB drivers and reboot nothing is added to the log.

 

2020-02-02, 04:46:32Kernel/sbin/usb_modem[3573]: 0x0781_0x5591-1.usb not exist
2020-02-02, 04:46:32Kernel/sbin/usb_modem[3573]: Unknown usb1 device(0781:5591), add vid/pid for driver
2020-02-02, 13:58:39System Logxlassist : System is up
2020-02-02, 13:58:39System LogFirmware Version : v1.3.2.02
2020-02-02, 13:58:40Kernelkernel: Init model[320-0] system information:

 

Never used a console before, so don't know where to start.

Can I do this by SSH? 

 

Regards, Martin

                             >Never used a console before, so don't know where to start.

   - Check if there is a console port somewhere on  your device (sometimes marked blue - or consult device manual to find the console port); then attach serial cable ; usually uses 9600 baud. Then follow my instructions as stated in initial reply.

 M.

Hello M,

 

Too bad, no console port available on this router.

I'll give support a call tomorrow.

 

Martin

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

Recognize Your Peers