cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
34302
Views
95
Helpful
57
Replies

RV340 - unable to login to admin portal

PlyrStar93
Level 1
Level 1

Hi,

I have been trying to login to the RV340 admin interface lately but it doesn't work. No matter I enter the correct password or the wrong password, the icon next to the login button just keeps spinning indefinitely. If I click on the username field in the meantime, the icon disappears but nothing else really happens.

 

Some other details:

  • I have RV340 in two locations and the routers and both of them are having the same issue
  • Both routers are less than 6 months old
  • Tried multiple browsers, incl. Firefox, Chrome, Edge, Internet Explorer, Safari (iOS), none have worked
  • Firmware is either 1.0.03.18 or 1.0.03.20

 

Has this happened to anyone, and how did you guys solve it?

rv340.png

57 Replies 57

zoom29, I have a large number of these in the field some that were not recoverable, no help from Cisco, to add to the saga they have no replacement for these routers, We have begun to move away from cisco because of this. Sophos has a good line as well as Fortinet.

SlacknetCTA
Level 1
Level 1

Hello! I have the same problem. It's just that it can't be solved with a simple restart. I also reset to default from the button. The router is reset but it still doesn't let me log in to the web interface. the firmware versions are 1.0.03.22 - 24. There is another way to recover my 6 routers? I own over 100 such routers.
Thanks.

Hi there, 

 

My name is Nikola Butlev and I'm a Cisco Engineer.

 

Please try resetting the routers first. If these doesn't help try with different IP  address ( obtained through Change  settings in Network and Sharing Center) .

 

Thanks,

Has any headway been made on this, I have an RV340 that will not respond. power cycle no change reset (NOT Hard reset) same issue. seems to function but I need the web interface to make changes. I too tried several different browsers to no avail. Help is needed. 

I solved the problem. The Cisco Rv340, 345 345p, has a console port.
It is disabled from the software. Which means it is active for 7 seconds until the operating system boots.
Connect to this port with the abrasive cable received in the original box to the router and with a serial
putty with bit rate 115200 at cold restart you will see information. for 7 seconds as boot you have to right
click on the putty bar especially command , break command. You have to do this several times until the corrupt active image appears.
If a corrupt image does not appear, do not let it boot to the end. Restart cold from the button.
And you try until it works. When it appeared the same as in the attached picture, let it boot to the end.
Then he entered the backup image which is not hacked. Then log in to the Web and install version 1.0.03.27.

I was told by a Cisco engineer the console port would not work, however I will try this today 6-29-2022 and report back my findings. Thank you for the input.

Well Thank you, Console worked, I was able to get into the backup image upgrade the firmware to 1.0.03.27, apply all my configurations.

I now have my GUI back and avoided an RMA with CISCO. FYI it did not work first try but did on the second.

 

uloader 2011.06.0 (Feb 28 2017 - 13:10:14)

Board: Mindspeed C2000 900 MHz
nand_probe: comcerto_nand base: 0xc8300000 size: 0x256 MB
ONFI flash detected ... ONFI param page 0 valid
NAND device: Manufacturer ID: 0xc2, Chip ID: 0xda (Unknown MX30LF2G28AC), page s ize: 2048, OOB size: 112
Using default values
Using BCH ECC-24

Copying Barebox from NAND Flash(bootopt=2) @offset = 0x0
Reading ...
Done...Bytes read 0x80000
Image verified and authenticated
## Starting Barebox at 0x01000000 ...


barebox 2011.06.0-dirty (Mar 8 2022 - 01:40:02)

Board: Mindspeed C2000
calling dus_out_of_reset:
c2k_spi_flash_probe: size : 0x00400000
cbus_baseaddr: 9c000000, ddr_baseaddr: 03800000, ddr_phys_baseaddr: 03800000
class init complete
tmu init complete
bmu1 init: done
bmu2 init: done
util init complete
GPI1 init complete
GPI2 init complete
HGPI init complete
HIF rx desc: base_va: 03e80000, base_pa: 03e80000
HIF tx desc: base_va: 03e80400, base_pa: 03e80400
HIF init complete
bmu1 enabled
bmu2 enabled
pfe_hw_init: done
pfe_firmware_init
pfe_load_elf
pfe_load_elf no of sections: 10
pfe_firmware_init: class firmware loaded
pfe_load_elf
pfe_load_elf no of sections: 10
pfe_firmware_init: tmu firmware loaded
pfe_load_elf
pfe_load_elf no of sections: 14
pfe_firmware_init: util firmware loaded
miidev_restart_aneg for PHY5
miidev_restart_aneg for PHY6
ehci@ehci0: USB EHCI 0.01
Using ENV from Fast SPI Flash.
nand_probe: comcerto_nand base: 0xc8300000 size: 0x256 MB
ONFI flash detected ... ONFI param page 0 valid
NAND device: Manufacturer ID: 0xc2, Chip ID: 0xda (Unknown MX30LF2G28AC), page s ize: 2048, OOB size: 112
Using default values
Using BCH ECC-24
Bad block table found at page 131008, version 0x01
Bad block table found at page 130944, version 0x01
nand_read_bbt: Bad block at 0x05160000
nand_read_bbt: Bad block at 0x05bc0000
Malloc space: 0x00800000 -> 0x02000000 (size 24 MB)
Stack space : 0x007f8000 -> 0x00800000 (size 32 kB)
.envfs: wrong magic on /dev/env0
no valid environment found on /dev/env0. Using default environment
running /env/bin/init...
Setting env LAN, WAN1, WAN2...

1.0.02.02
booting kernel of type uimage from /dev/nand0.kernel1.bb
Image verified and authenticated
Verifying Checksum ... OK
Image Name: Linux-4.1.8
Created: 2022-03-07 21:06:23 UTC
Image Type: ARM Linux Kernel Image (uncompressed)
Data Size: 2987320 Bytes = 2.8 MB
Load Address: 03008000
Entry Point: 03008000
OK

Starting kernel ...

Typical Cisco Coverup and BS.  Just fix the god **bleep** thing so it works.  We should not have to play games with the console cable and jump through all of these hoops.  For once make a quality device that works properly.  I have a pile of cisco CRAP in my office from other such devices that Cisco just tried to sweep under the rug and hope that it becomes obsolete before they actually have to fix it.  FIX YOUR STUFF SO IT WORKS.  OWN IT!!!! Come up with a REAL Solution for this issue NOW!!!! This is serious!! There are a ton of RV340's out there with this issue and you are ignoring us all!  

I am going to start a class action lawsuit not only for the cost of these devices but for damages such as labor and loss of productivity in the office if you don't take care of this!!!  That could add up to Millions of dollars!!!! 

I'll hit you right in your pocket book!  So get off your asses and get someone to work on a real soluton for this before you get sued and it goes on the news and your stock price plummets!!!!!!!!!

I too have several that I cannot get into, I did recover several but not a bulk of them, Cisco announced EOL so they refuse to support this. They came with a limited lifetime warranty but once EOL was announced the warranty is void after 90 days. To make matters worse they have no replacement for the SMB market. I looked at moving to Sophos, Fortinet and SonicWALL. Perhaps a Class action is what's needed.

Thanks so much.  This saved us from completely reconfiguring all the devices on the network.  Note:  This requires much patience!  Look at the image, you need to see "active image is corrupted..."  otherwise you have to keep rebooting till you do.  Cheers!

This worked. Thank you so much.

Tengo el mismo problema que el publicador. Todavía no he reiniciado el router porque el equipo tiene carga de trabajo. Cuando lo reinicie aportaré los resultados por si puede ayudar a alguien.