cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
316
Views
4
Helpful
12
Replies

C3560X not learning neighbor's MAC address

Joy3
Level 1
Level 1

Hallo,

I have a C3560X switch that isn't learning the MAC address of our CPE router. At the moment, we're using C9300 with the same config and it is working (we're changing because the network rack is too small that the C9300 doesn't fit). We've updated C3560x's software to the latest 15.2.7E10 but the problem persists. Below is a snippet of the configs:

hostname SW1
!
!
vrf definition Mgmt-vrf
!
!
address-family ipv4
exit-address-family
!
address-family ipv6
exit-address-family
!
ip routing
!
ip vrf MGMT1
!
interface Vlan898
ip vrf forwarding MGMT1
ip address 10.20.30.5 255.255.255.252
no ip redirects
no ip proxy-arp
!
interface GigabitEthernet0/4
switchport trunk allowed vlan 898
switchport mode trunk
service-policy output WAN-EDGE-4-CLASS
ip dhcp snooping trust
!
ip route vrf MGMT1 0.0.0.0 0.0.0.0 10.20.30.6

And because the MAC address to the gateway (CPE) isn't know, the ping also doesn't work. Thanks.

12 Replies 12

ip vrf MGMT1 <<- this need RD to work 

MHM

@MHM Cisco World It has rd, just that I truncated it:

ip vrf vrf MGMT1
rd 898:898
route-target export 898:898
route-target import 898:898

pman
Spotlight
Spotlight

Hi,

 


@Joy3 wrote:

Hallo,

I have a C3560X switch that isn't learning the MAC address of our CPE router


Did you create Vlan898 in the switch?
try  show vlan command

I didn't mean to offend, it's just the first thing that came to my mind

If necessary, just add the vlan:

Switch(config)# vlan 898

Thanks

Can I see 

Show ip interfaces brief

MHM

Joy3
Level 1
Level 1

@pman nothing offensive about your suggestion but the VLAN are there. I have configured the exact same configs in the current running C9300 (as earlier said, it needs to be replaced coz it is too big for the rack) as the C3560CX. The only problem is that the C3560CX doesn't show the mac address of the router to the service provider, so a ping doesn't work as well.

@MHM Cisco World Here it is:

SW1#sh ip int brief
Interface IP-Address OK? Method Status Protocol
Vlan1 unassigned YES NVRAM administratively down down
Vlan100 XXX YES NVRAM up up
Vlan251 XXX YES NVRAM up up
Vlan300 XXX YES NVRAM up down
Vlan804 XXX YES NVRAM up down
Vlan805 XXX YES NVRAM up down
Vlan806 XXX YES NVRAM up down
Vlan898 10.20.30.5 YES NVRAM up up
GigabitEthernet0/1 unassigned YES unset down down
GigabitEthernet0/2 unassigned YES unset down down
GigabitEthernet0/3 unassigned YES unset up up
----------------------------------------------------
GigabitEthernet0/14 unassigned YES unset up up
GigabitEthernet0/15 unassigned YES unset down down
GigabitEthernet0/16 unassigned YES unset down down

There is nothing wrong as I see try

Ping vrf MGMT1 <CPE IP>

Then check show mac address 

MHM

Joy3
Level 1
Level 1

@MHM Cisco World This is exactly why it is surprising. Everything seems correct but it doesn't work. Ping fails and mac-address table doesn't show the CPE's mac.

SW1#ping vrf MGMT1 ip 10.20.30.6
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.30.50.249, timeout is 2 seconds:
.....
Success rate is 0 percent (0/5)

OK, 
SW1#ping vrf MGMT1 ip 10.20.30.6 source vlan898 
if this ping also failed 
I think the CPE is config as router port not as subinterface 
and hence the CPE dont understand the tag frame from your SW
so you need to change the trunk to access port and check ping again 

MHM

Joy3
Level 1
Level 1

But without any change, the C9300 works without any problem so, I don't think the CPE has an issue or needs config change. I highly suspect the C3650CX is the problem.

show arp vrf MGMT1 <<- this need to see if SW learn or not MAC-IP in ARP 

also please run debug arp
then try ping to see if there is response from CPE or not

MHM

Screenshot (565).png

hichamfolk
Level 1
Level 1

hello

Whats the speed of gig0/4 interface?

If 1gbps, could you try fixing the speed to 100M then check if you receive any mac with : show mac add | in 0/4

@MHM Cisco World I tried  @hichamfolk method of changing the interface speed, which eventually learned the MAC of CPE but the ping didn't go through. I have opted to use a C1100 router which is working fine and used the C3650CX as the access switch. Thank you all for your help.

Review Cisco Networking for a $25 gift card