09-08-2023 10:56 AM
I am using a Cisco C1111 ISR w/ 2 L3 interfaces, 8 L2 interfaces.
Interface Vlan601 currently has an IP address assigned to it. I would like to use DHCP to assign the IP address to this interface. However, when I change it to DHCP, the MAC address in the DHCP request is 0000.0000.0000 which is causing the DHCP request to fail.
Starting Point:
Interface IP-Address OK? Method Status Protocol
GigabitEthernet0/1/0 unassigned YES unset up up
Vlan601 192.168.1.50 YES NVRAM up up
interface GigabitEthernet0/1/0
switchport access vlan 601
switchport mode access
interface Vlan601
description PartnerNet1
ip vrf forwarding PARTNER-NET-1
ip address 192.168.1.50 255.255.255.0
ip nat outside
router#ping vrf PARTNER-NET-1 192.168.1.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.1.1, timeout is 2 seconds:
.!!!!
Success rate is 80 percent (4/5), round-trip min/avg/max = 1/1/4 ms
router#show int Gi0/1/0
GigabitEthernet0/1/0 is up, line protocol is up (connected)
Hardware is C1111-ES-8, address is 5c64.f184.b088 (bia 5c64.f184.b088)
MTU 1500 bytes, BW 100000 Kbit/sec, DLY 100 usec,
reliability 255/255, txload 1/255, rxload 1/255
Encapsulation ARPA, loopback not set
Keepalive not supported
Full-duplex, 100Mb/s, link type is auto, media type is 10/100/1000BaseTX
input flow-control is off, output flow-control is unsupported
ARP type: ARPA, ARP Timeout 04:00:00
Last input 00:00:36, output 00:00:13, output hang never
Last clearing of "show interface" counters never
Input queue: 0/375/0/0 (size/max/drops/flushes); Total output drops: 0
Queueing strategy: fifo
Output queue: 0/40 (size/max)
5 minute input rate 1000 bits/sec, 2 packets/sec
5 minute output rate 1000 bits/sec, 2 packets/sec
950 packets input, 76619 bytes, 0 no buffer
Received 24 broadcasts (11 multicasts)
0 runts, 0 giants, 0 throttles
0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
0 watchdog, 11 multicast, 0 pause input
0 input packets with dribble condition detected
933 packets output, 79668 bytes, 0 underruns
Output 2 broadcasts (18 multicasts)
0 output errors, 0 collisions, 1 interface resets
0 unknown protocol drops
0 babbles, 0 late collision, 0 deferred
0 lost carrier, 0 no carrier, 0 pause output
0 output buffer failures, 0 output buffers swapped out
router#show ip int Vlan601
Vlan601 is up, line protocol is up
Internet address is 192.168.1.50/24
Broadcast address is 255.255.255.255
Address determined by non-volatile memory
MTU is 1500 bytes
Helper address is not set
Directed broadcast forwarding is disabled
Outgoing Common access list is not set
Outgoing access list is not set
Inbound Common access list is not set
Inbound access list is not set
Proxy ARP is enabled
Local Proxy ARP is disabled
Security level is default
Split horizon is enabled
ICMP redirects are always sent
ICMP unreachables are always sent
ICMP mask replies are never sent
IP fast switching is enabled
IP Flow switching is disabled
IP CEF switching is enabled
IP CEF switching turbo vector
IP Null turbo vector
VPN Routing/Forwarding "PARTNER-NET-1"
Associated unicast routing topologies:
Topology "base", operation state is UP
IP multicast fast switching is enabled
IP multicast distributed fast switching is disabled
IP route-cache flags are Fast, CEF
Router Discovery is disabled
IP output packet accounting is disabled
IP access violation accounting is disabled
TCP/IP header compression is disabled
RTP/IP header compression is disabled
Probe proxy name replies are disabled
Policy routing is disabled
Network address translation is enabled, interface in domain outside
BGP Policy Mapping is disabled
Input features: Virtual Fragment Reassembly, NAT Outside, MCI Check
Output features: Post-routing NAT Outside
IPv4 WCCP Redirect outbound is disabled
IPv4 WCCP Redirect inbound is disabled
IPv4 WCCP Redirect exclude is disabled
IP Clear Dont Fragment is disabled
I remove the IP address from the Vlan601 interface.
router(config)#int Vlan601
router(config-if)#no ip address
router#show ip int br
Interface IP-Address OK? Method Status Protocol
GigabitEthernet0/1/0 unassigned YES unset up up
Vlan601 unassigned YES manual up up
I then set the IP address to DHCP. I have tried this as just "ip address dhcp" and with the client-id set to the physical interface, and with a hostname set. Showing the last iteration. There are not many options available here.
interface Vlan601
description PartnerNet1
ip vrf forwarding PARTNER-NET-1
ip address dhcp client-id GigabitEthernet0/1/0 hostname Cisco
ip nat outside
end
router#show ip int br
Interface IP-Address OK? Method Status Protocol
GigabitEthernet0/1/0 unassigned YES unset up up
Vlan601 unassigned YES DHCP up up
router(config-if)#ip address dhcp ?
client-id Specify client-id to use
hostname Specify value for hostname option
<cr> <cr>
router(config-if)#ip address dhcp client-id ?
BD-VIF Bridge-Domain Virtual IP interface
BDI Bridge-Domain interface
GigabitEthernet GigabitEthernet IEEE 802.3z
Port-channel Ethernet Channel of interfaces
Vlan Catalyst Vlans
router(config-if)#ip address dhcp client-id GigabitEthernet 0/1/0 ?
hostname Specify value for hostname option
<cr> <cr>
But the ip dhcp debug shows the MAC address being set as all zeros.
Sep 8 17:15:15.174: DHCP: Try 3 to acquire address for Vlan601
Sep 8 17:15:15.177: DHCP: allocate request
Sep 8 17:15:15.177: DHCP: zapping entry in DHC_PURGING state for Vl601
Sep 8 17:15:15.177: DHCP: deleting entry FFFF56A0D0F8 0.0.0.0 from list
Sep 8 17:15:15.177: DHCP: new entry. add to queue, interface Vlan601
Sep 8 17:15:15.177: DHCP: MAC address specified as 0000.0000.0000 (0 0). Xid is 10A945FE
Sep 8 17:15:15.177: DHCP: SDiscover attempt # 1 for entry:
Sep 8 17:15:15.178: DHCP: Scan: Option vendor class Identifier 124
Sep 8 17:15:15.178: Enterprise ID 9
Sep 8 17:15:15.178: vendor-class-data-len 13
Sep 8 17:15:15.178: data: C1111-8PLTEEA
Sep 8 17:15:15.178: DHCP: SDiscover: sending 305 byte length DHCP packet
Sep 8 17:15:15.178: DHCP: SDiscover 305 bytes
Sep 8 17:15:15.178: B'cast on Vlan601 interface from 0.0.0.0
Sep 8 17:15:18.200: DHCP: SDiscover attempt # 2 for entry:
Sep 8 17:15:18.200: DHCP: Scan: Option vendor class Identifier 124
Sep 8 17:15:18.200: Enterprise ID 9
Sep 8 17:15:18.200: vendor-class-data-len 13
Sep 8 17:15:18.201: data: C1111-8PLTEEA
Sep 8 17:15:18.201: DHCP: SDiscover: sending 305 byte length DHCP packet
Sep 8 17:15:18.201: DHCP: SDiscover 305 bytes
Sep 8 17:15:18.201: B'cast on Vlan601 interface from 0.0.0.0
Sep 8 17:15:22.202: DHCP: SDiscover attempt # 3 for entry:
Sep 8 17:15:22.202: DHCP: Scan: Option vendor class Identifier 124
Sep 8 17:15:22.202: Enterprise ID 9
Sep 8 17:15:22.202: vendor-class-data-len 13
Sep 8 17:15:22.202: data: C1111-8PLTEEA
Sep 8 17:15:22.202: DHCP: SDiscover: sending 305 byte length DHCP packet
Sep 8 17:15:22.202: DHCP: SDiscover 305 bytes
Sep 8 17:15:22.202: B'cast on Vlan601 interface from 0.0.0.0
%Unknown DHCP problem.. No allocation possible
Sep 8 17:15:35.657: DHCP: Waiting for 15 seconds on interface Vlan601
How can I set the MAC address to use the MAC address of the Gi0/1/0 or some other viable solution?
09-09-2023 03:02 AM
- You must assign a mac address manually to vlan 601 interface if you want it to acquire an address through dhcp as in :
interface vlan601
ip address dhcp
mac-address <xx:xx:xx:xx:xx:xx>
M.
10-01-2024 10:23 AM
How do you determine what MAC address to assign?
10-01-2024 10:31 AM
For mac 000000 this normal' but are the server direct connect to any port assign to same vlan or to different vlan?
MHM
10-01-2024 11:17 AM
Where is the DHCP Server Located.
Does your VLAN 601 Layer3 aware how to reach DHCP Server ?
Can you post other end DHCP Side configuration and VLAN 601 - Make sure VLAN 601 have helper configuration for the device to get IP address from DHCP Server.
Since you configured static IP you able to reach Gateway, does that not prove that you have reachability to DHCP Server.
10-01-2024 12:44 PM
Sorry, I am not the original person who started the thread. I have a C1111-8PWA-WS that I am setting up for the first time. I cannot get the system to assign IP addresses and noticed this person had the same issue.
I am using VLAN1 which I associated with the WEBUIPool I set up to access the GUI 192.168.1.0
If I assign an ip address in the pool I receive the error message that the IP address is already assigned. I've been struggling to find out how to assign an IP address to the VLAN that will correct the problem. Marce100 said to assign a MAC address instead so I asked which MAC address. I think he said to use 000000 but I am not sure what that means. I can post my configuration and the error log if that is helpful.
Thank you all for your help
10-01-2024 12:50 PM
apologies i have replied to the OP -
if you have access to cli, post show run here (we can look that issue)
If I assign an ip address in the pool I receive the error message that the IP address is already assigned
what IP address assigned ?
10-01-2024 01:04 PM
10-02-2024 09:00 AM
Thanks for posting the running config. I see in it that you have configured a DHCP pool for 192.168.1.0/24. And I see that you have configured interface G0/0/1 with IP 192.168.1.1. So what IP address do you intend to use for vlan 1? Vlan 1 can not use 192.168.1.x because that subnet is already associated with a layer 3 interface on the device. So vlan 1 needs some other subnet.
10-02-2024 09:15 AM
Thanks Rick. That is what I don't understand. Am I supposed to assign an IP address to VLAN1? If so, what address do I use? I tried several but none worked
If you look above, Marce1000 suggested I assign a MAC address to VLAN1. If that is the case I would need to know what MAC address to assign. I don't know how to choose 1
10-02-2024 10:10 AM
We do not have enough information about your environment to be able to give good advice. Can you tell us how you want your device to work?
Your running config suggests that you have a physical interface for outside, a physical interface for inside, and vlan 1. Your inside physical interface and vlan 1 can not use the same IP network/subnet. So what IP network/subnet would you want to be on vlan 1? And is there some reason why you want your vlan 1 to learn its address using DHCP? It would be much more simple to have a separate network/subnet for vlan 1 and to configure an address on vlan 1 for that address/subnet rather than using DHCP.
10-02-2024 10:24 AM
Let me start from scratch. I have a C1111-8PWA-WS that will be replacing an ASUS router I currently use. I have an SG350-28P switch and 2 APs (9120 and 9115). All I want to do is connect my hardwire devices to either one of the 8 ports on the back of the router or one of the 28 ports on the switch. The AP's have to be connected to the switch in order to utilize POE.
If you have a configuration you can suggest I am all ears.
I followed the instructions to access the unit with a PC via the Web GUI which is what I have been using in addition to a Microsoft Surface connected via console cable into the console port using Putty.
10-02-2024 11:23 AM
Thanks for the additional information. First let me say that I have little experience with this particular platform. But the show run that you posted is pretty clear about some things. There are 2 Layer 3 ports (G0/0/0 and G0/0/1). These ports are to be configured with IP addresses (assuming that you want to use both of them). You certainly want the first of those ports to connect to outside. I am not sure that there is much need for an address on the second port, given what you describe of your environment. There are also a group of layer 2 ports (G0/1/0, G0/1/1, G0/1/2 etc). These ports are not configured with IP addresses. They belong to (by default) vlan 1. So you would connect your SG350, APs, etc to the layer 2 ports. The vlan 1 interface is the layer 3 interface for that vlan. I see no reason why you would want to use DHCP to assign that address.
10-02-2024 11:50 AM
All correct. g0/0/0 is used to connect to the modem. g0/0/1 is assigned the ip address 192.168.1.1 and is where I plug in a computer to access the GUI.
"see no reason why you would want to use DHCP to assign that address" did you mean use DHCP to assign the address of VLAN1?
I do use DHCP to assign ip addresses in the pool WEBUIPool which is associated with VLAN1. The GUI allows me to use static or DHCP to assign an ip address to VLAN1. I've tried both with no luck
10-02-2024 12:37 PM
" The vlan 1 interface is the layer 3 interface for that vlan"
Do VLANs sit at layer 3 or layer 2?
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide