cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
1184
Views
4
Helpful
25
Replies

Rip v1 routing

maksunity
Level 1
Level 1

Hello, I have a network topology which will be shown below. Two routers R1 and R4 are connected via Serial ports. The routers will be configured below. My question is why when I build the routing table for R1 (show ip route), in the last two lines I have explicitly the subnet between the routers (10.70.0.2/16) and the port of router R4 (10.70.0.2/32). In all similar cases of connecting two routers via serial ports, this is not the case.

Example show ip route:
r1.lab#show ip route
Codes: C – connected, S – static, R – RIP, M – mobile, B – BGP
10.0.0.0/8 is variably subnetted, 8 subnets, 2 masks
C 10.10.0.0/16 is directly connected, FastEthernet0/0
R 10.30.0.0/16 [120/1] via 10.20.0.2, 00:00:19,FastEthernet0/1

C 10.20.0.0/16 is directly connected, FastEthernet0/1
R 10.40.0.0/16 [120/1] via 10.70.0.2, 00:00:14, Serial0/1/0
R 10.60.0.0/16 [120/2] via 10.70.0.2, 00:00:14,
Serial0/1/0
R 10.50.0.0/16 [120/1] via 10.70.0.2, 00:00:14, Serial0/1/0
C 10.70.0.0/16 is directly connected, Serial0/1/0
C 10.70.0.2/32 is directly connected, Serial0/1/0

maksunity_1-1703533737939.png

 

Network topology

maksunity_0-1703533535177.png

 

Router settings static routing:
R1:
r1.lab#conf t
r1.lab(config)#username r4 privilege 0 password 0 pass
r1.lab(config)#interface FastEthernet0/0
r1.lab(config-if)# ip address 10.10.0.1 255.255.0.0
r1.lab(config-if)# duplex auto
r1.lab(config-if)# speed auto
r1.lab(config-if)#!
r1.lab(config-if)#interface FastEthernet0/1
r1.lab(config-if)# ip address 10.20.0.1 255.255.0.0
r1.lab(config-if)# duplex auto
r1.lab(config-if)# speed auto
r1.lab(config-if)#!
r1.lab(config-if)#interface Serial0/1/0
r1.lab(config-if)# ip address 10.70.0.1 255.255.0.0
r1.lab(config-if)# encapsulation ppp
r1.lab(config-if)# ppp authentication chap
r1.lab(config-if)# ppp chap hostname r1
r1.lab(config-if)# ppp chap password 0 pass

 

R2:
r2.lab#conf t
r2.lab(config)#interface FastEthernet0/0
r2.lab(config-if)# ip address 10.30.0.1 255.255.0.0
r2.lab(config-if)# duplex auto
r2.lab(config-if)# speed auto
r2.lab(config-if)#!
r2.lab(config-if)#interface FastEthernet0/1
r2.lab(config-if)# ip address 10.20.0.2 255.255.0.0
r2.lab(config-if)# duplex auto
r2.lab(config-if)# speed auto
R3:
r3.lab#conf t
r3.lab(config)#interface FastEthernet0/0
r3.lab(config-if)# ip address 10.60.0.1 255.255.0.0
r3.lab(config-if)# duplex auto
r3.lab(config-if)# speed auto
r3.lab(config-if)#!
r3.lab(config-if)#interface FastEthernet0/1
r3.lab(config-if)# ip address 10.50.0.2 255.255.0.0
r3.lab(config-if)# duplex auto
r3.lab(config-if)# speed auto
R4:
r4.lab#conf t
r4.lab(config)#username r1 privilege 0 password 0 pass
r4.lab(config)#interface FastEthernet0/0
r4.lab(config-if)# ip address 10.40.0.1 255.255.0.0
r4.lab(config-if)# duplex auto
r4.lab(config-if)# speed auto
r4.lab(config-if)#!
r4.lab(config-if)#interface FastEthernet0/1
r4.lab(config-if)# ip address 10.50.0.1 255.255.0.0
r4.lab(config-if)# duplex auto
r4.lab(config-if)# speed auto
r4.lab(config-if)#!
r4.lab(config-if)#interface Serial0/1/0
r4.lab(config-if)# ip address 10.70.0.2 255.255.0.0
r4.lab(config-if)# encapsulation ppp
r4.lab(config-if)# clock rate 128000
r4.lab(config-if)# ppp authentication chap

r4.lab(config-if)# ppp chap hostname r4
r4.lab(config-if)# ppp chap password 0 pass
r4.lab(config-if)#clock rate 128000

Configuring RIP v1 on routers:
R1:
r1.lab#conf t
r1.lab(config)#router rip
r1.lab(config-router)#version 1
r1.lab(config-router)#network 10.10.0.0
r1.lab(config-router)#network 10.20.0.0
r1.lab(config-router)#network 10.70.0.0
R2:
r2.lab#conf t
r2.lab(config)#router rip
r2.lab(config-router)#version 1
r2.lab(config-router)#network 10.30.0.0
r2.lab(config-router)#network 10.20.0.0
R3:
r3.lab#conf t
r3.lab(config)#router rip
r3.lab(config-router)#version 1
r3.lab(config-router)#network 10.60.0.0
r3.lab(config-router)#network 10.50.0.0
R4:
r4.lab#conf t
r4.lab(config)#router rip
r4.lab(config-router)#version 1
r4.lab(config-router)#network 10.40.0.0
r4.lab(config-router)#network 10.50.0.0
r4.lab(config-router)#network 10.70.0.0

Thanks in advance!

25 Replies 25

I run lab as you can see there is "C" and "L" and rip only advertise "C"

And hence we can see only one "R" 

In your lab there are two "C" this unusual' so I think it bug.

Thanks 

MHM


@MHM Cisco World wrote:

I run lab as you can see there is "C" and "L" and rip only advertise "C"

And hence we can see only one "R" 

In your lab there are two "C" this unusual' so I think it bug.


Perhaps (very possible) a bug or perhaps that OP's version of software doesn't have a "L" and uses a "C".

I do not recall what was the Cisco usage was decades ago, i.e. whether the two "C" routes were shown as such.

Some links discussing the difference.

https://learningnetwork.cisco.com/s/question/0D53i00000Kt2iuCAB/what-is-the-difference-between-local-and-connected-routes

https://www.quora.com/What-is-difference-between-connected-and-local-routes-in-Cisco-routing-table

https://community.cisco.com/t5/switching/what-is-the-difference-between-local-route-l-and-directly/td-p/2315995

The last reply in the last reference notes the "L" was added for MTR, see https://www.cisco.com/c/en/us/support/docs/ip/ip-routing/116264-technote-ios-00.html.

Thanks for doing such a great job for me, but I still don't understand one thing. Maybe there is some justification in Cisco documentation why the router in the routing table explicitly see the port and subnet of the router (In our case, R1 and R2), if it is connected through the Serial port?

Thank you very much in advance!

You meaning R1 and R4.

All cisco router show add two entry to RIB 

One is C connect which is subnet/mask we add for interface 

Other is L local which is /32 of interface IP

For cisco doc I will search and share it here 

Goodluck friend in your studying 

MHM

Thanks for the reply, I'll look forward to your addition in the form of documentation

Good afternoon, did you manage to find anything from the documentation?


@maksunity wrote:

Thanks for doing such a great job for me, but I still don't understand one thing. Maybe there is some justification in Cisco documentation why the router in the routing table explicitly see the port and subnet of the router (In our case, R1 and R2), if it is connected through the Serial port?


I suspect it's because Cisco, like the OSPF RFC, makes assumptions about certain types of interfaces.  Such as a Serial port provides a p2p link which can only have two devices, and things like ARP aren't necessary to reach the other side.

https://community.cisco.com/t5/switching/quot-show-ip-route-quot-l-local/td-p/1548508

I found this thread and the link above as an answer. Is this an accurate answer to my question a reply from fred cooper?


@maksunity wrote:

https://community.cisco.com/t5/switching/quot-show-ip-route-quot-l-local/td-p/1548508

I found this thread and the link above as an answer. Is this an accurate answer to my question a reply from fred cooper?


Perhaps.  Although I believe in my prior reply, the Cisco TechNote I referenced, better provides the details about the addition of the "L" local route.

maksunity
Level 1
Level 1

Also found another discussion on this topic:
https://learningnetwork.cisco.com/s/question/0D53i00000Kt2iuCAB/what-is-the-difference-between-local-and-connected-routes

That is, the equipment at the university has an old OS on it and that's why it says connection type C twice, instead of C and L. Is the L (local) connection type needed to speed up communication between routers or what?

Thanks in advance!


@maksunity wrote:

Also found another discussion on this topic:
https://learningnetwork.cisco.com/s/question/0D53i00000Kt2iuCAB/what-is-the-difference-between-local-and-connected-routes

That is, the equipment at the university has an old OS on it and that's why it says connection type C twice, instead of C and L. Is the L (local) connection type needed to speed up communication between routers or what?

Thanks in advance!


BTW, that reference link is the same as one of those I provided in a recent reply to @MHM Cisco World.

Review Cisco Networking for a $25 gift card