cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
9432
Views
10
Helpful
7
Replies

Interface port-channel error message

rfuentes1111
Beginner
Beginner

Hi Team,

I'm getting the following error when i try to enter the following command into et3/2 interface on a KN7 any help will be appreciate thank you.

sh run int po105
interface port-channel105
description 10.197 (SS105005)
switchport
switchport mode trunk
switchport access vlan 10
switchport trunk native vlan 10

N7K1(config)# int et3/2
N7K1(config-if)#
N7K1(config-if)# switchport trunk native vlan 10
N7K1(config-if)# switchport mode trunk
N7K1(config-if)# channel-group 105 mode active
command failed: port not compatible [port access VLAN]

** You can use force option to override the port's parameters
** (e.g. "channel-group X force")
** Use "show port-channel compatibility-parameters" to get more information on failure

7 Replies 7

Reza Sharifi
Hall of Fame Expert Hall of Fame Expert
Hall of Fame Expert

Hi,

Try this:

no interface port-channel105

exit

int et3/2

channel-group 105 mode active

exit

interface port-channel105

switchport
switchport mode trunk
switchport trunk native vlan 10

no sh

and test again.

HTH

By doing this it will be deleting the inteface port-channel 105 then it will create the channel again is that correct.

Yes, that is correct.  From that point forward you just add any config line to the Portchannel and the physical interface will inherit it.

HTH

Carlos Villagran
Cisco Employee
Cisco Employee

Hi!

This error appears when you try to bundle two interfaces which has no identical configuration. Please be sure that all links you are trying to bundle into your port-channel 105 have the same configuration.

Have a nice day, best regards!

JC 

GIANRICO FICHERA
Beginner
Beginner

You have a port-channel interface configured like this:

interface port-channel2
  description --- port-channel ---
  switchport
  switchport mode trunk
  switchport trunk allowed vlan 101

Member interfaces must have the same configuration before entering the port channel.
If not, here's what happens.

ITESYS_nexus7400# sh run int eth4/3
interface Ethernet4/3
  description --- port 1A ---
  no shutdown
ITESYS_nexus7400# conf t
Enter configuration commands, one per line.  End with CNTL/Z.
ITESYS_nexus7400(config)# int ethernet 4/3
ITESYS_nexus7400(config-if)# channel-group 2
command failed: port not compatible [switching port]
 ** You can use force option to override the port's parameters
 ** (e.g. "channel-group X force")
 ** Use "show port-channel compatibility-parameters" to get more information on failure

The switch basically tells you that it can do this job for you if you use the force option.
So I try again.

ITESYS_nexus7400# conf t
Enter configuration commands, one per line.  End with CNTL/Z.
ITESYS_nexus7400(config)# int ethernet 4/3
ITESYS_nexus7400(config-if)# channel-group 2 force

No error reports now. But the interface will automatically be configured with the parameters of the port-channel interface:

ITESYS_nexus7400# sh run int ethernet 4/3
interface Ethernet4/3
  description --- port 1A ---
  switchport
  switchport mode trunk
  switchport trunk allowed vlan 101
  channel-group 2
  no shutdown


 

MHM Cisco World
Advisor
Advisor

switchport mode trunk <- this make port trunk 
switchport access vlan 10 <- then you add this command which overrride the above one and make port access port 

hence the PO not work because it see now port as access not trunk 

port channel vs port physical need same mode access or trunking

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

Recognize Your Peers