Showing results for 
Search instead for 
Did you mean: 

Cisco IP Communicator no audio.

Michael Peled

In a new office with no wired connectivity to the LAN, all is wireless. Using Cisco IP Communicator, communicator is working fine on the corporate network, can make and receive calls, audio is fine.

While connected to the corporate network I have the need to VPN to a different network using Cisco Systems VPN Client Version When connected to this VPN my IP communicator stay registered and I can make and receive calls, but audio is not working at either end.


Manish Gogna
Cisco Employee
Cisco Employee

Hi Michael,

You may verify some of the suggestions for similar issue in the following posts




I know this is a old post, but I googled the issue and someone else is going to inevitable google the issue too.


Here is how I solved our issue.


CIPC has two places to select network adapters / IP addresses, for two different reasons. One is for the creation of the device name and the other is for audio traffic.

Run CIPC as administrator. Let it open and configure itself. Click the Menu button at the top of the phone, Exit button is on the right in the row and the Menu is the farthest right in the row.

Click Preferences. 

Now my CIPC crashed each time I did following, but in the end it still worked in the end. Kind of the old 5 ft drop for some radios.

Click the Network tab, ensure the network adapter you chose to create the device name is selected. 

Now click the Audio tab and click the Network button. Click the radial "Use this adapter's address:" if not already selected. Click the drop-down list, you may or may not receive a message appear stating that changing the adapter may crash CIPC, click OK.

Change your adapter to your VPN adapter. For instance we use AnyConnect, so I change the adapter AnyConnect. Click OK and Click OK again to get back to the phone. Now more often than as I stated before the CIPC will crash, so go ahead and open up Task Manager if you are on Windows. Wait for the CIPC to crash then force it to End. Once it closes, open it back up and let it configure itself. Make a test call and you should have audio then.



Thanks to team here for highlighting the issue. Although the above steps and information helped me in troubleshooting but did not solved the problem. I am commenting for better reach and helpfulness to rests...


I also trying to setup CIPC v8.6.6 over VPN and having audio issues one way. CIPC is registered on CUCM v11.5.1SU6. Without VPN there is no issue as system was in production since 3 years above.


Infra details;

  • CUCM v11.5.1 SU6
  • CIPC v8.6.6
  • Cisco Anyconnect VPN v4.2 installed on thin client.
  • SIP, SCCP protocol inspection is enabled for reverse check on firewall.
  • Cisco ASA 5545 firewall.
  • CUBE having ip route to route the traffic. ip route <default GW>
  • QoS applied.
  • SSL VPN. (No L2 VPN, No split tunneling, No NAT).

Customer / Agent Experience: Cannot hear agent voice. Agent can hear customer voice.


Errors seen in initial troubleshooting;

  1. No call signalling issues in CUBE.
  2. CIPC phone registered on VPN as well as with CUCM. CIPC VPN IP address assigned shown in CUCM Admiistration device window.
  3. CUCM SDL logs show CIPC VPN IP Address and port.
  4. CIPC showed 480 temporarily Not Available response TWICE in CUCM SDL Logs.

77745929.002 |10:34:40.561 |AppInfo |SIPTcp - wait_SdlReadRsp: Incoming SIP TCP message from <CIPC>10.108.XXX.XX on port 49899 index 114927 with 488 bytes:
SIP/2.0 480 Temporarily Not Available
Via: SIP/2.0/TCP 192.168.XXX.XXX:5060;branch=z9hG4bK159c7fc3504120c
From: <sip:25342@192.168.XXX.XXX>;tag=1482714275 (Phone extension registered on VPN).
To: <sip:25342@10.108.XXX.XX>;tag=7cd30a13ab4f001f000062b5-00005ff0
Call-ID: e8fd7d80-f021f030-8bc723-8ba5a8c0@192.168.XXX.XXX
Date: Mon, 06 Jul 2020 09:34:40 GMT
CSeq: 101 REFER
Server: Cisco-SIPIPCommunicator/9.1.1
Contact: <sip:1eb7a36a-55c7-7ccc-18c1-2d2d8bfd0548@10.108.XXX.XX:49899;transport=TCP>
Content-Length: 0


     4. SIP REFER message and no response from CIPC


77745928.001 |10:34:40.482 |AppInfo |SIPTcp - wait_SdlSPISignal: Outgoing SIP TCP message to <CIPC>10.108.XXX.XXX on port 49899 index 114927
REFER sip:1eb7a36a-55c7-7ccc-18c1-2d2d8bfd0548@10.108.XXX.XXX:49899;transport=tcp SIP/2.0
Via: SIP/2.0/TCP 192.168.XXX.XXX:5060;branch=z9hG4bK159c7fc3504120c
From: <sip:25342@192.168.XXX.XXX>;tag=1482714275
To: <sip:25342@10.108.XXX.XXX>
Call-ID: e8fd7d80-f021f030-8bc723-8ba5a8c0@192.168.XXX.XXX
CSeq: 101 REFER
Max-Forwards: 70
Contact: <sip:25342@192.168.XXX.XXX:5060;transport=tcp>
User-Agent: Cisco-CUCM11.5
Require: norefersub
Expires: 0
Refer-To: cid:1234567890@192.168.XXX.XXX (CUCM IP ADD)
Content-Id: <1234567890@192.168.XXX.XXX> (CUCM IP ADD)
Content-Type: application/x-cisco-remotecc-request+xml
Referred-By: <sip:25342@>
Content-Length: 346





To benefit the rest others who refer in future, please also follow this steps as well;

  1. Check compatibility of CIPC with VPN client. Check release notes here
  2. Followed the above steps as suggested above in troubleshooting stage;
    1. Set VPN adaptor in CIPC network adaptor settings. Phone did not registered.
    2. Check radio button Same as Adaptor in CIPC > Preference > Audio > Network settings. Did not helped.
    3. Check radio button for low bandwidth settings in CIPC > Preference > Audio. Faced Citrix issues in environment for different integration. Did not helped.
  3. In my scenario, refer to CIPC Administration Document here  and search for "CIPC and Audio IP Address Through VPN" where it has mentioned about VPN IP address at a very low level.

Root Cause: VPN IP schema which was assigned had multiple routes on Firewall. Hence the delay in decision making / FW was confused to route to destination causing one way audio.


Solution: Implement the VPN IP Schema subnet for required VPN host. in my scenario there was require of 500 hosts then we used respective subnet and fixed the issue. IP Schema used was unique and not clashing the other routes which helped firewall in quick decision making.


Although this solution was found by network team and resolved this issue.


*** Please rate helpful post. Please mark as answer if it solves your problem/query.
regards, Ritesh Desai

Nithin Eluvathingal
VIP Mentor VIP Mentor
VIP Mentor

In your case phones are registered and you are able to make calls. only issue you facing is no audio. 


No audio issue are commonly seen due to routing issue. check if you have  routes added  between your voice and CIPC network.





===Please rate all useful posts===

Response Signature

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community: