cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
19556
Views
110
Helpful
24
Replies

Cisco Unity Connection 8.6 - Cannot Upload Greeting

Lalo Nunez
Beginner
Beginner

Hello! I am running Unity Connection 8.6, using VMWare, in my home lab. When I try to upload a greeting to my System Call Handler, I get the following:

Unable to save recording due to SSL Certificate error. Would you like to accept the SSL certificate for this session and attempt to save the recording again?

When I choose OK I receive:
Failed to record name

Site: http://www.cisco.com/c/en/us/support/docs/voice-unified-communications/unity-connection-version-70/110950-unity-wav-issues.html#certerr

I visited the above site and tried importing the certificate into both Firefox and IE, but that did not seem to work. I also looked into Cisco Bug ID CSCto92753, but that also did not work. I looked at the Java Console Log and did a search for "access denied":

com.cisco.unity.mediamaster.MMApplet.stop() - Exception while saving preferences: access denied ("java.io.FilePermission" "C:\Users\Lalo\.cisco\unity\mediamaster\mm.properties" "read")

I modified my java.policy file to include the below, but I get the same error:

grant codeBase "file:${{java.ext.dirs}}/*" {
        permission java.security.AllPermission;
        permission java.io.FilePermission "C:\Users\Lalo\.cisco\unity\mediamaster\mm.properties", "write";
};

At this point and I am stuck. Thanks in advance for reading my post and for your assistance.

Cisco Unity Connection version: 8.6.2ES120.24901-120
Windows 7 Enterprise 32-bit
Browsers: Firefox 28.0 and IE 9
Java Version 7 Update 55 (Also tried Java Runtime Environment 1.6.0.39)

24 Replies 24

George Thomas
Advocate
Advocate

Have you tried changing your Java security settings from Control Panel on your desktop. I would also try hitting Save again even after you get the "Failed to record name" error. It has worked for me at times.

Please rate useful posts.

Thanks George, I will try to change the Java security settings when I get home tonight. I know I have changed them before, but I have uninstalled Java several times, so I will check again. Never thought of hitting Save again, but I will try that  too.

Wanted to update the post. I installed 8.5.1 on a new virtual machine and can upload a greeting successfully therefore, I will use this VM to continue my CCNP studies. In the event anyone has any suggestions I will keep the 8.6.2 machine to see if the issue can be resolved. Thanks!
 

Worked for me too. It is strange that choosing computer as playback didn't work but choosing phone did the trick !!!!1

Worked for me as well :) Thanks a lot !!!