Showing results for 
Search instead for 
Did you mean: 

Cisco Unity Connection 8.6 - Cannot Upload Greeting

Lalo Nunez

Hello! I am running Unity Connection 8.6, using VMWare, in my home lab. When I try to upload a greeting to my System Call Handler, I get the following:

Unable to save recording due to SSL Certificate error. Would you like to accept the SSL certificate for this session and attempt to save the recording again?

When I choose OK I receive:
Failed to record name


I visited the above site and tried importing the certificate into both Firefox and IE, but that did not seem to work. I also looked into Cisco Bug ID CSCto92753, but that also did not work. I looked at the Java Console Log and did a search for "access denied": - Exception while saving preferences: access denied ("" "C:\Users\Lalo\.cisco\unity\mediamaster\" "read")

I modified my java.policy file to include the below, but I get the same error:

grant codeBase "file:${{java.ext.dirs}}/*" {
        permission "C:\Users\Lalo\.cisco\unity\mediamaster\", "write";

At this point and I am stuck. Thanks in advance for reading my post and for your assistance.

Cisco Unity Connection version: 8.6.2ES120.24901-120
Windows 7 Enterprise 32-bit
Browsers: Firefox 28.0 and IE 9
Java Version 7 Update 55 (Also tried Java Runtime Environment

24 Replies 24

Same here. Play back via computer doesn't work, but playback via phone did.

In Unity Connection 9.1.2

Thanks For yours Workaround!

It worked fine for CUC 10.5!

Thanks.. it worked for me :)


Thanks man, this worked great in 10.5.2.  I can't believe Cisco is still using this awful applet after nearly a decade... this should not be such a pain.

Thank you!  Your workaround helped me out greatly!

I got mine to upload successfully by doing what you suggested - 10.5.  

Thank you!

Your workaround helped me out greatly!

I'm having problems with the new Audiotext manager and this workaround just saved my bacon! Nice one!

Thank you for your contribution!

I just wanted to share that I was having similar issues on 10.5.  The problem was corrected by adding the affected Unity Connection IPs to IE's Compatibility View Settings.  This cleared it up. 

"I believe that the greatest work of God has not been in the miraculous, nor in the spectacular, incomprehensible Creation, but rather I believe it was accomplished on the Cross where He Himself purchased the redemption of His Bride... the salvation of m


This worked for me:


Playback via Phone and press play to play audio. Then save while the audio is playing.


Unity Connection 10.6

Hi, I had this problem as will. I have played the music with phone and then hit the save button and it worked.

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

Recognize Your Peers