Showing results for 
Search instead for 
Did you mean: 

CUPI API Issue following Connection 9.1(2) upgrade


Since upgrading Unity Connection from 9.1.(1) to 9.1(2) SU1 I can no longer establish a connection using the CUPI API.

The result code reported by the API is simply:

"Login failed to Connection"

I'm using the .NET CUPI Fast Start API version In order to rule out my own app as the problem I've also attempted to use the CUPIFastStart project and receive the same result.

I've enabled VMREST micro traces on the publisher and collected the following from the Tomcat logs:

23:08:57.577 |12710,,,VMREST,3,DEBUG [http-bio-443-exec-3]  - IMS result code: 0

23:08:57.578 |12710,,,VMREST,3,DEBUG [http-bio-443-exec-3]  - REQUEST GET version

23:08:57.578 |12710,,,VMREST,3,DEBUG [http-bio-443-exec-3]  - executeQuery: query='SELECT FIRST 1 Product FROM tbl_SchemaInformation WHERE IsCurrent=1'

23:08:57.579 |12710,,,VMREST,3,DEBUG [http-bio-443-exec-3]  - getValuesFromQuery: product=

23:08:57.579 |12710,,,VMREST,3,DEBUG [http-bio-443-exec-3]  - RESPONSE filter IN

I interpret the first line of the debug to be a successful login attempt based on the information provided from

From what I can tell this all seems normal. Fiddler also seems to indicate that the JSON response is being sent back to the client application.




Any help would be appreciated.

2 Replies 2


As a further confirmation, I've stood up a new 9.1(0.32) version of Unity Connection and tested both the CUPIFastStart and my own code and it works just fine. Something has definitely changed in 9.1(2).

I also did some further debugging of the ConnectionServerRest API code and found that the WebCallResult for the GetVersionInfo function returned the following:

{    WebCallResults contents:

    URL Sent: https://unitypub:8443/vmrest/version

    Method Sent: GET

    Body Sent:

    Success returned: False

    Status returned 200:Ok

    Error Text: No version version returned logging into Connection server: unitypub, return text={"name":"vmrest","version":""}

    Raw Response Text: {"name":"vmrest","version":""}

    Total object count: 0

    Status description: OK


    ErrorText: "No version version returned logging into Connection server: unitypub, return text={\"name\":\"vmrest\",\"version\":\"\"}"

    JsonDictionary: Count = 2

    Method: "GET"

    Misc: null

    RequestBody: ""

    ResponseText: "{\"name\":\"vmrest\",\"version\":\"\"}"

    ReturnedObjectId: null

    StatusCode: 200

    StatusDescription: "OK"

    Success: false

    TotalObjectCount: 0

    Url: "https://unitypub:8443/vmrest/version"

    XmlElement: null

It seems odd that the StatusCode is 200 yet the Success is false.

I tried to post in the CUPI developer forums however the link is currently dead on

the first item here is why are you running 3.0.38 of the CUPI SDK?  That's from July of 2014.  the latest version out is 3.0.58.  It's easiest to juse use NuGet for keeping the libraries up to date (all my SDKs for notification, CUPI, ODBC etc... are available on NuGet).

Once you have that updated we can look at what's going on with your connection.  

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

Recognize Your Peers