Showing results for 
Search instead for 
Did you mean: 

Unity Connection 8.6 - problem with importing users from LDAP


I have got a problem with importing LDAP (MS Active Directory) users into Unity Connection 8.6.2ES44.

At the beginning of configuration of CUC, I have created LDAP synchronization and authentication. Then I have imported several users from LDAP into CUC for the purposes of testing. Then I have changed various templates, auth. rules, CoS, installed HA node, configured LiveRecord and Visual Voicemail etc. After complete testing I decided to recreate users mailboxes again because of changed templates and user settings.

So I've deleted (from LDAP synchronized) users in CUC and I wanted to create their mailboxes again. But problem is, that after that I can't find previously deleted users in LDAP (Users - Import users) so I can't import them. I can find any user in LDAP which has not been imported before, so synchronization with LDAP is without any problems. I've tried to disable LDAP synchronization and recreate it, but it is still the same.

User account in LDAP still exists, because I can log into CUCM user web pages with username/password of LDAP user and I can still use Jabber (CUCM/CUPS is synch and auth with LDAP).

If I try to create a new user (not synchronized with LDAP or CUCM) I get error message "The Alias has already been assigned to another object in this VMS Location", but there is no user with this alias shown in CUC among users.

Does anyone know, why I cant find LDAP users previously synchronized from LDAP and deleted in CUC?



The issue was solved by TAC case.

It was found that there is some entry in database for every deleted users and that entry protected creating new user. After deleting of remain entry in DB, I was able to import user from LDAP again.

Upgrading to version 8.6.2 SU3 didn't solve the problem.

Had the same issue and had to call TAC too. here is what they did.

run sql select userid, pkid from enduser where userid = ''
  userid         pkid
  ============== ====================================
  '' 83215248-6288-446d-87e2-db5efcca3e98

run sql SELECT fkenduser, fkappserver  FROM enduserappservermap WHERE fkenduser = '83215248-6288-446d-87e2-db5efcca3e98'
  fkenduser                            fkappserver
  ==================================== ====================================
  83215248-6288-446d-87e2-db5efcca3e98 67285943-ff95-4f4f-88c6-e6206cf23551

run sql delete FROM enduserappservermap WHERE fkenduser = '83215248-6288-446d-87e2-db5efcca3e98' and fkappserver = '67285943-ff95-4f4f-88c6-e6206cf23551

My db commands were:

admin:run sql select pkid,firstname, lastname, userid, telephonenumber FROM EndUser u WHERE userid=
pkid                                 firstname lastname userid    telephonenumber
==================================== ========= ======== ========  ===============

admin:run cuc dbquery unitydirdb select * from tbl_user where ldapccmpkid='90667119-9cb4-4e41-b876-d02add3354c7'

No records found

admin:run sql select * from enduserappservermap where fkenduser in (select pkid from enduser where userid = )

pkid                                 fkenduser                            fkappserver                          content

==================================== ==================================== ==================================== ====================================
69a5c38e-c8e0-4352-806c-4633de04f86e 90667119-9cb4-4e41-b876-d02add3354c7 4a24f07b-3aa8-42a2-800a-659b2c2adb06 ad013e36-00eb-4ca3-b604-98400c23ad37

run sql delete from enduserappservermap where fkenduser='90667119-9cb4-4e41-b876-d02add3354c7'

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community: