Showing results for 
Search instead for 
Did you mean: 

Flexflash Controller is in a unhealthy state after firmware upgrade

Jason Flory

Hello Everyone

I am getting an error stating our flexflash is unhealthy after firmware upgrade.  Says it is running old firmware.  I did not even know we had flexflash on our systems and do not see away to upgrade the firmware.  I read that you are supposed to see this in the storage tab but do not see this .  How do i resolve this error?

35 Replies 35

Yes the re seating resolved the issue. Complete power cycle and re acknowledgment resolved the issue. 

Yeah, but hat is not an option on CISCO ASA4110 unit which have the same issue - you cant do that on a ASA4110 unit

FlexFlash Controller 1 on server 1/1 is unhealthy. Reason: Status: FFCH_ERROR_OLD_FIRMWARE_RUNNING


This did trick with me.  thanks!

This worked for me too, with the slight exception that you have to click on the Blade, the Inventory, then the storage tab. 

Thanks, This resolved my error as well. 

Helpful post. 

This worked for me too

This helped to clear the alarm, i don't have FlexCards installed. Thank you


I just fixed it by resetting the flex flash controller on the server inventory options

Same goes for me, we resolved this issue several times by resetting the flex flash controller.

You just have to be patient: after the reset it takes some minutes after the error disappears.

Having similar issue with (UCSB-B200-M4) FlexFlash error below: will resetting wipe out the contents of SDCARD? Will the ESXi Host bootup fine after reset? 


Error Invalid Size

Reseting the Controller is disruptive as the server looses the connection to the SD cards.

But it will not erase the content of the cards. If you want to delete the cards you have to choose "Format SD Cards".

No, the reset Flex Flash controller action will not wipe the SD, but it will lose connectivity very shortly to the SD cards so make sure to turn off the server before performing this. OS will still be installed on the SD cards after the reset

Thanks for the responses! Guess I have one bad SD card, reset only yielded true issue.

Error Invalid Size typically indicates a problem with the SD card themselves.


If you were getting a "flexflash controller unresponsive" then a reset would likely resolve this.

I have also seen this message when the two SD cards being used are not identical. (Different size, etc). The platform requires that the two cards be identical. 

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

Recognize Your Peers