Showing results for 
Search instead for 
Did you mean: 

iSCSI Booting Win2k8R2 on UCS with EqualLogic


We've been testing iSCSI booting on UCS with 2.0(1t) and the Palo M81KR with an EqualLogic PS6010. We are connecting through a 10GbE switch via an uplink port. However, we've hit a snag and want to see if anyone else has gotten around this.

The EQL shows connections from UCS when booting; however, Windows does not have the Palo drivers and doesn't show the target disk. When adding the M81KR driver, the connection gets dropped so Windows still does not show the target disk.

We've tried connecting the array directly to an appliance port on the FI but got some ENM source pinning failed error, a different issue at this point.

We've also tried slipstreaming all UCS drivers into the Windows media but that doesn't let us proceed either.

We've gotten RHEL6 to install so we know the configuration is viable.

15 Replies 15

Cisco Employee
Cisco Employee

Hello Thomas,

The EQL shows connections from UCS when booting; however, Windows does not have the Palo drivers and doesn't show the target disk. When adding the M81KR driver, the connection gets dropped so Windows still does not show the target disk.

There is small trick to make the target disks visible after installing the right drivers. Please make sure that after re-mapping the W2K8 ISO image, click Refresh button on the Installer screen and verify the outcome.

Driver location in driver ISO image


Make sure your uplinks are active,  this will address the "enm pinning source error your seeing at the Appliance Ports.

When getting the enm source pinning failed, it's usually a result of not creating the VLAN under the LAN tab.  With direct connect appliance ports you need to create the VLAN under the "Appliances" and the global fabric "VLAN" sections.



1.4 needs Appliance and global VLAN.

2.0 just need Appliance.

Or at least that is how it seems to be working over here.


My UCS Blog

As soon as I remove the global VLAN (my appliance port uses) my Port goes into "ENM Pinning soure failure".  In my lab I have to have the vlan defined in both the Appliance VLAN and Fabric VLAN sections.

Try it..

I'm also using a beta build of MR1 - 2.0(2), behavior may have changed between 2.0 & 2.0 MR1.


@Robert Burns:

If we are testing *without* a VLAN in this isolated setup, should it still fail? In other words, is a VLAN required for an appliance connection?

Yes, your appliance port is assigned to a VLAN during configuration of the interface.  Otherwise it will be assigned to your default VLAN (usually VLAN 1).



Thanks. We used much of the same process when installing to fibre channel and were successful. It seems like there is something else going on.

When we watch the EqualLogic management portal, the session is fine all the way until we load the card drivers whereupon the session completely drops. Putting the Windows installation ISO back in and hitting refresh did not re-initiate the iSCSI session.

Be sure what ever VLAN you use is checked Native. That hosed me once.


My UCS Blog

@Craig Simpson

We used VLAN1/default since this is an isolated environment right now.

I countered similar problems during my attempts to iSCSI Boot W2k8r2 with UCS blade and Palo M81KR.

I loaded the driver to detect the iSCSI installation LUN, and installation was successful.

Howerver, I get a BSOD when booting into Windows. BSOD doesn't have any useful information (screenshot attached).

If I try booting w2k8r2 into Safe mode, the system hangs on the \windows\system32\DRIVERS\disk.sys and then the blade reboots itself.

Can someone please confirm the iSCSI Adapter Policy I am supposed to use with Windows?

I'm currently using the default iSCSI Adapter Policy and it works for iSCSI booting ESXi4.1u1 and ESX5.0u1.

And what's HBA Mode?


The default Adapter policy is fine.   The M81KR VIC doesn't require any special settings.  Leave them all as-is or unchecked.  Only the Broadcom NIC requires specific settings during install/boot.

When you're doing the Windows installation  -ensure you're ONLY presenting a single path (one iSCSI vNIC). 

Also ensure you're using Windows 2008 R2 SP1 or later.



Thanks, Robert! Removing the 2nd iSCSI vNICs worked and I was able to successfully boot Win2k8r2.

Are there similar pitfalls with RHEL6.1 or SLES11update1?

With RHEL6.1 I'm encountering a Kernel panic during boot. And with SLES11update1 the installer isn't even seeing the iSCSI LUN. With SLES, I included the boot option of 'withiscsi = 1' and that didn't help either.

Sorry if I hijacked OP's thread. Please let me know if I should create a new topic for discussion.

Yeah if its a different equipment and issue, should try to utilize new threads.

With RHEL if you're presenting more than a single path then you have to use the Multipathing driver which is documented by RHEL.  If you want to tshoot further - let's start a new thread.

Also please mark the quesiton as "Answered" so we can close the loop on this portion.



Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

Recognize Your Peers