Showing results for 
Search instead for 
Did you mean: 
Cisco Employee
Cisco Employee

Cisco UCS Platform Emulator, Release 3.1(2ePE1)

CONFIGURATION IMPORT NOTE:  Importing configuration backups (All, System, or Logical) taken from the UCS Platform Emulator (UCSPE) to physical UCS Manager domains is not recommended or supported by Cisco TAC.  UCSPE backups should only be imported to UCSPE domains.

New Features and Significant Changes in Cisco UCS PE, Release 3.1(2ePE1)

  • Note that Release 3.1(2ePE1) is a patch release based on 3.1(2bPE1).  There are limited changes from the previous release:
    • New default HW config to reduce some startup warnings in UCS Manager.
      • Note that an example 2nd Generation Fabric Interconnect (6248 FI) configuration has also been attached below.  The attached UCSPE config can be imported from the UCSPE Equipment page.
    • Bug fixes to avoid chassis and service profile association issues in some cases.
  • UCSPE 3.1(2ePE1) is featured in a Cisco dCloud programmability demo.   The demo includes a comprehensive lab guide including the following content for the Cisco UCS PowerTool and Python SDK:
    • Overviews of PowerShell and Python programming environments with step-by-step usage instructions
    • Code generation examples including code generation with UCS Manager's HTML5 interface
    • Sample script creation and use with UCSPE

Feature Summary of 3.1(2ePE1) based on previous release information:

  • Full scale emulation of UCS Manager 3.1(2e) which features HTML 5 User Interface improvements
    • NOTE: Browser focus follows UCSM when HTML5 UI is launched.  HTML5 UI can be opened in a New Tab/Window if there is a need to continue viewing the PE Configuration page.
  • Software and configuration features include the following:
    • Disk Zoning, Chassis Profiles, and Storage Profiles for C3260 systems
    • Server and Chassis equipment templates for easy addition of emulated resources
    • Numerous emulator stability fixes including fixes for HW discovery across VM reboots

Hardware Feature Summary

See the User Guide for additional details on supported Hardware.  Here is a summary of newly supported Hardware:

  • Cisco UCS C3260 chassis, servers, and storage controllers
  • M4 B-Series and C-Series servers including HX220C and HX240C
  • NVMe-based PCIe storage options

Known Limitations

  • Imported configurations should be manually checked to ensure there are no missing or unsupported components.  If issues are experienced following an import, any unsupported components can be manually deleted and missing components manually added through the Equipment menu on the Navigation pane.
  • Firmware Management and Firmware Auto Install have not been fully validated in this release.
    • If issues are experienced during FW download, please try alternate methods such as API based download (e.g., using PowerTool or Python SDK).
    • If issues are experienced with FW policies, please try excluding all components from the policy.
  • AAA-based authentication (LDAP, RADIUS, TACACs)— The Platform Emulator accepts security configuration changes, but does not enforce local or remote password authentication.  Any username and password combination can successfully log into the Cisco UCS Manger UI with administrator privileges.


  • The Platform Emulator does not save UCSM configuration state across Emulator resets (to avoid consistency issues in UCSM configuration and the emulator HW configuration).  To preserve UCSM state, UCSM backup and import operations can be performed.  See an example backup/import flow here: PythonSDK for backup/restore (import) of UCSM config

Firmware Management: UCS PE supports uploading B-Series and C-Series server firmware bundles.  Because of the large file sizes of the firmware bundles, UCS PE only supports uploading of stripped-down versions (link below).  Stripped-down versions include only the firmware metadata (not the actual firmware binaries).

Alternate Download Location: If you have issues downloading the attached OVA or Zip file, please try the links in the attached file.
MD5 hashes for downloads:

  • OVA: 3422b2d6c4eadcc68837e8325767fefc
  • ZIP: eafd1e66c03eae1069e3c1c52b99c8d1
Community Member

can not download completely both of the two method!!!

Cisco Employee
Cisco Employee

I cant download this file

Level 1
Level 1

This download does not work. The OVA file will only download 335.6 MB and is not complete. There is an issue with this file. I have tried with multiple computers and ISPs to rule out computer or network issues. Hopefully this will get fixed soon.

Level 1
Level 1

I can not download the OVA file. Please let me know if there another download link


Level 1
Level 1

Hi have downloaded both zip and ova OK.

Hi cannot download the files...

Level 1
Level 1

Constant Interruption, download resume also not supported. Unable to download since the last 36 hours,tried the cisco box links as well. Please fix this!!!

Cisco Employee
Cisco Employee

Here's a previous post with some possible fixes for download issues:

"I have seen this happen with various large downloads.  I think what happens is that some cache server between you and Cisco's download site somehow ended up with a corrupted copy.  No matter how many times you download, or what browser you use for downloading, you will continue to reach the same cache server and keep getting the same corrupted copy.

Solution for me and others has been to move to another site, maybe a coffee shop, or maybe just your neighbor's house if they have a different ISP.  You find a different path to Cisco that bypasses the 'bad' cache server and you are okay."

I've just downloaded both ZIP and OVA from box and verified the files are good.

Hi guys,

two questions about UCSPE:

1) It's available NXOS shell?


ucspe# connect nxos

sh: /isan/bin/vsh: No such file or directory

2) It's possible to integrate UCSPE with NXOS emulator (in Virl Nexus 7000 device)?

Best regards

Cisco Employee
Cisco Employee


For #1, NX-OS is not available on UCSPE.

For #2, UCSPE does not have the ability to connect to external devices so there is not integration with other emulators.

Let us know of other questions.


Community Member

David Soper  Hi,

      I use UCSPE have a problem, when UCSPE & UCS-Central integrated , create pools, like uuid-pool, wwpn-pool, but on UCSPE cant use it, casue not have global-pool, just have manual-config, default-pool , cant choose global pool.

Best regards

Matthew Faiello
Cisco Employee
Cisco Employee

This is known problem with the emulator.

You technically should see the Global Pools being referenced in the pull-down with UCSPE, but they do not appear.

There is no known work-around sat this time, as it’s a bug with the Emulator.



Matthew Faiello | UCS Technical Marketing Engineer | .:|:.:|:. Cisco Systems, Inc.<>| Phone: 727-540-1432 | Twitter: @<>mfaiello<> LinkedIn: mfaiello<>

UCS Communities:

UCS Platform Emulator:

UCS Developed Integrations:

Community Member

Hope fix this bug

Thx for your response, Matt.

Best regards

Community Member

Hi Matt,

    This bug maybe or not the drop-down menu window is small, so cant display global-pool?

    This is just my opinion .Hope it is helpful.

Best regards,


Level 1
Level 1

No problems with any of the downloads.

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community: