cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
5296
Views
0
Helpful
5
Replies

Headset Hookswitch Control on CP-7975 and UC500

lawrence.david
Beginner
Beginner

Our understanding was that various models of the Plantronics headsets were compatible with the CP-7975 and UC500 systems.  We have purchased the apropriate Plantronics Universal EHS Adapter (APC-4) to fully enable the features available (receive ring indicator, go onhook/offhook, mute and control volume) with the Plantronics Voyager 510 without a handset lifter.  After connecting them as described, we still have to select Headset and the off hook switch on the Headset.  We have to turn off both to put the phone back on hook.

The only article we could find on this site was for a UC520 and another CP-7900 model stating you needed to add the following to the telephony-service section:

      service phone ehookenable 1

That entry is already in the running config on our UC560, but the phone still indicates the Headset Switch Control is disabled under Settings->Device Configuration->Media Configuration.  We do not see any way to enable this feature in CCA 3.0(1) or CUE with the latest software pack 8.1.0.  We also didn't see it in CUE.

Anyone know how to enable the headset to be fully functional?

1 Accepted Solution

Accepted Solutions

Ok, there is a syntax error here.  the configuration should be 'service phone ehookEnable 1' (Note the capital E in enable).  Unfortunately, since my lab system was configured with CCA, there may be a CCA bug in play here.  Was your system built using CCA, or was it built using CLI?

Cheers,

Dave.

View solution in original post

5 Replies 5

David Trad
Rising star
Rising star

Hi Lawrence,

I have checked the part numbers against my Plantronics compatibility list I have here from our Jabra/Plantronics supplier, and your configuration should work as they are the right parts.

If my understanding of it is correct, you need to press the headset button and then on the screen press the end call soft key, this then leaves the headset light green, indicating that you are operating in headset mode, the HHC should then work as expected.

However if this is not the case then it may be worth while contact SBS support and logging a case with them.

Cheers,

David.

Cheers, David Trad. **When you rate a persons post, you are indicating a thank you or that it helped, but at the same time you are also helping to maintain the community spirit - You don't have to rate posts and you wont be looked down upon :) *

I agree that according to the documentation, this should work.  In looking at the status messages on the phone and at the files in the phones folder of the flash, I'm wondering if the phone is getting the necessary files on start up.  The firmwae is right, but I'm not sure how the hookswitch enable is supposed to get set on the phone..

Anyone have an idea about how that happens?

Dave

There's not all that much to it.  The config line you list in the original post results in an XML tag being adding to the phones config file to enable the functionality.  So long as the phone is running a firmware build that supports this, then it should work ok.  And the firmware builds in the 8.1.0 software bundle are definitely recent enough for this.

So, a couple of things you can check:

1. Go to the phone itself and press the settings button, then navigate to Device Configuration > Media Configuration, and down the bottom of the list should be a parameter called Headset Hookswitch Control, which should be enabled.

2. If you don't see that entry there at all, make sure you actually have a 7975 and not a 7970 or 7971, and also that the firmware the phone is running is current (8.5 or so)

3. If you see it and it is disabled, then there is another issue, and in fact, I have just seen exactly that on my lab setup here.

I'll look into it and figure out why it is not working here all of a sudden.  It certainly was working previously.

Cheers,

Dave.

Ok, there is a syntax error here.  the configuration should be 'service phone ehookEnable 1' (Note the capital E in enable).  Unfortunately, since my lab system was configured with CCA, there may be a CCA bug in play here.  Was your system built using CCA, or was it built using CLI?

Cheers,

Dave.

David Harper,

You have located the error!  I used CLI to modify the setting for the proper capitalization,


UC_560#config t
Enter configuration commands, one per line.  End with CNTL/Z.
UC_560(config)#telephony-service
UC_560(config-telephony)#no service phone ehookenable 1
UC_560(config-telephony)#service phone ehookEnable 1

rebuilt the phone configurations

UC_560(config-telephony)#create cnf
Creating CNF files.
UC_560(config-telephony)#end

and rebooted the phone and the Headset Hookswitch Control setting under Media Configuration settings now shows as Enabled and works as expected (I can control the phone from the headset).

The UC560 went into production between July and September last year, so it is not subject to the CLI ban.  That said, almost all configuration has been performed with CCA using the current version at the time changes were made.  The last round of changes were made using CCA 3.0(1).

There have been a number of Cisco support cases where Cisco techs have modified the configuratuion using CLI.  My own tweaks had to do with turning off the DHCP server for the data LAN so that capability could be provided by the Microsoft SBS on the network. Tier II support recently fixed a BACD issue introduced by CCA 3.0(1) and the 8.1.0 software package that broke BACD capability because the toll fraud firewall entries didn't accept routing to the BACD from inside LAN addresses.

Really nice to have this working.

Dave

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

Recognize Your Peers