Showing results for 
Search instead for 
Did you mean: 

SPA122 does not check for provisioning info with latest stable firmware (1.1.0)



I purchased a couple of SPA122 units yesterday, both with firmware version 1.0.2.

I used the xml provisioning template that worked so well for SPA2102 (after changing the line indices to 0 and 1 from 1 and 2) and all seemed OK, except for the SIP password attribute, which was ignored.

I upgraded the firmware manually to 1.1.0 and generated encrypted files, hoping it will work that way, but now neither one of the two units is checking the http server for updates (be it firmware or configuration).

I tried enabling the logger in debug mode (both local and remote) and I only see a couple of non-relevant messages on local log, no messages whatsoever on syslog server. I changed dns settings manually just to make sure it`s not a dns problem, internet connectivity is there because I have my laptop connected to the LAN side and it can access the Internet without any issues. Also, if I edit the password fields manually the unit will register properly to my SIP gateway.

Any suggestions? I would be happy to try a beta release of the firmware if it fixes the issue.

Thank you.

UPDATE: I managed to get a debug log file from the ATA (attached to this post).

Message was edited by: Cristian Talle

2 Replies 2

Community Member

Hello Christian,

We have addressed this provisioning issue in the latest pre-release of the SPA122 firmware.

Please open a case with our support center who can then provide the latest beta firmware to you.

Information to open a case can be found at the following website:

Best Regards,

-Lance Harper

Cisco Systems, Inc

Thank you very much!

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

Recognize Your Peers