cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
1093
Views
0
Helpful
1
Replies

SPA504G crashing/blocking other networked VOIP Phones

Maggers665161
Beginner
Beginner

Hi All,


I was wondering if anyone could shed some light on this problem.

I have 80+ SPA942 phones running on a 3CX v10.0  SoftPBX system and have had no problems so far.


I was tasked with supplying some new phone but keeping withing the Linksys/ Cisco family so I decided to buy newer versions of the SPA phones. I bought a couple of the SPA504G's (7.4.8a firmware)


The problem is when I plug the SPA504G into the POE port all my other phones suddenly become unregistered and the only solution is to unplug the SPA504G then walk around unplugging the phones for at least 30 seconds then plugging them back in so they re-register.


(If I don't unplug them for at least 30 seconds or if you attempt to resolve the problem with a soft reboot then all that happens is the phones keep rebooting every 30 seconds or so which is annoying to the users)

I have repeated this with 2 New SPA504G phones out of the box, I even reset them to factory defaults even though I hadnt changed any settings.

Has anyone seen this problem if so what was the fix if any ?

1 Reply 1

Patrick Born
Cisco Employee
Cisco Employee

Hi John,

I'm wondering if there's unique with the SPA9xx phones' configuration. Are the SPA9xx phones perhaps listening to the multicast group that the SPA5xx phones join in on when they boot?

Consider trying the following:

1. Enable debug level 3 on the SPA9xx phones

2. Run Wireshark on the SPA9xx subnet (with no filters)

3. Connect a SPA5xx phone

4. Review the Wireshark trace to determine what the SPA9xx is receiving to cause it to unregister

5. It would also be interesting to understand why the SPA9xx phones go into a boot loop

You don't mention the firmware version for the SPA9xx phones, make sure it's the latest available from Cisco.com

Could the issue be related to the PoE switch? The SPA5xx phones support CDP and LLDP which the SPA9xx phones don't. Try disable CDP/LLDP on the switch, if enabled, to isolate the root cause.

Regards,

Patrick

-----------

  Use this reference document to locate SPA phone resources

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

Recognize Your Peers