cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
1117
Views
15
Helpful
15
Replies

Time 3 hours off on new 7965G, why?

bill.roland
Beginner
Beginner

Hi everyone.  I just added a new 7965G to my UC560 system, everything went fine in CCA.  Upon registering though, the phone's time is off exactly 3 hours (behind).  I'm sure this is a time zone issue, but, all my SPA phones are showing the CORRECT time.  I have reset this phone and it made no difference.  Any ideas or pointers?  Thanks in advance!

Bill

1 Accepted Solution

Accepted Solutions

There have been a couple of different ways of determining timezone information across the different phone families over time.  My memory of the details fails me somewhat right now, but the newer 7900s used a different mechanism to the original 7940/60 phones, and it wouldn't surprise me if the SPA500 implementation is different again.  In particular, check that the timezone parameter under telephone-service is set correctly, as that is what governs the newer 7900 series phones.

Cheers,

Dave.

View solution in original post

15 Replies 15

David Trad
Rising star
Rising star

Hi Bill,

When it boots up does it come up with any errors  such as "Auth Error"?

What firmware is the phone running as well?

Cheers,

David.

Cheers, David Trad. **When you rate a persons post, you are indicating a thank you or that it helped, but at the same time you are also helping to maintain the community spirit - You don't have to rate posts and you wont be looked down upon :) *

Hi David.  No errors displayed during boot up.  Its running the version included in SWP 8.1.0 and shows 8.5.4S, in SCCP mode of course.  Thanks.

Bill

Hmmmmmmm...

A puzzle I like puzzles

OK you might hate me for this suggestion and you could have already done it, but is it possible you can reset it to factory defaults and let it rebuild the image again?


Cheers,

David.

Cheers, David Trad. **When you rate a persons post, you are indicating a thank you or that it helped, but at the same time you are also helping to maintain the community spirit - You don't have to rate posts and you wont be looked down upon :) *

Haven't tried that but will try it now and report back shortly.  Wish me luck.

Bill

David Trad
Rising star
Rising star

**CROSSES FINGERS, TOES, ARMS, LEGS & EYES** This better work as it hurts doing this

Cheers,

David.

Cheers, David Trad. **When you rate a persons post, you are indicating a thank you or that it helped, but at the same time you are also helping to maintain the community spirit - You don't have to rate posts and you wont be looked down upon :) *

No good.  When it updates the time right after "Updating Locale" it then goes to the wrong time.  The time is correct, its just 3 hours behind here, as if its using Pacific Time.  The SPA phones aren't having this issue.  Do these 7900's set their time differently?

Hi Bill,

OK a long shot here again

DO you have another UC-500 there that you can plug this particular phone into? If yes let us know what it does with that UC

If not wait a little while whilst I ponder of this a bit more.

Cheers,

David.

Cheers, David Trad. **When you rate a persons post, you are indicating a thank you or that it helped, but at the same time you are also helping to maintain the community spirit - You don't have to rate posts and you wont be looked down upon :) *

There have been a couple of different ways of determining timezone information across the different phone families over time.  My memory of the details fails me somewhat right now, but the newer 7900s used a different mechanism to the original 7940/60 phones, and it wouldn't surprise me if the SPA500 implementation is different again.  In particular, check that the timezone parameter under telephone-service is set correctly, as that is what governs the newer 7900 series phones.

Cheers,

Dave.

And David Harper swoops in for the win!  Indeed it was set to Pacific Time under Telephony-Service.  Changed it to Eastern and had to issue the no

create cnf-files, create cnf-files, rebooted the phone, and now the time zone is correct.

It would appear CCA is ignorant of this setting as well.

CCA is well aware of this setting, and gets it right for me every time (and I am a long way away from the Pacific coast ).  There was definitely no CLI work done on this box at all?  It's a long shot, but I don't suppose you have the CCA logs from when you originally configured the unit still lurking on your PC?

Cheers,

Dave.

Hi David, I'm certainly not trying to argue with a master but can you show me where in CCA you can adjust this setting?  The Time Zone setting for System Time under device properties was already set to the correct time zone (first thing I checked), yet the time zone under telephony-service was set to pacific time.  This is a genuine question; I looked high and low for this setting in CCA and I can't find it, but I may simply be missing it (wouldn't be the first time!). 

I bought this system from a partner and it arrived on my site already having a running config up, so I cannot say for certain it had no CLI setup involved.  It did have some CLI setup after it arrived as CCA couldn't, at that time, could not control some basic features like call park behavior.  I do not have any setup logs, unfortunately. 

Always argue - I make mistakes just like the next man.

The Timezone setting in CCA is what controls this (see screenshots below), so it should have been correct - assuming CCA was used for the initial provisioning of the system.  If there was any CLI work done, then all bets are off I'm afraid.  This particular piece of CLI is one that is easy to overlook, so if the system was entirely or partially configured through CLI, then it could easily have been missed.

Cheers,

Dave.

Hmm.  In my case CCA was reporting Eastern time on that screen, but the setting under telephony service was for Pacific time.  Perhaps there was a partial CLI setup involved, I can't say I wasn't involved at that point.  Still, I was hoping CCA would be able to just read the existing paramater under telephony-service.  In any event, mystery solved :)  I thank you sir for helping me figure it out!

The problem is that while there is only one timezone parameter in the CCA GUI, there are two separate parameters in the underlying CLI.  When CCA parses the CLI config to display the timezone, it only checks the first one since on a CCA configured machine, both parameters will always match.  In principle perhaps, CCA should look for inconsistencies and correct them, but there are so many potential inconsistencies that *could* be present in a CLI config that it would add enormous complexity (and cost in terms of software developers) to CCA for very little benefit.  This is the reason we don't support CCA and CLI simultaneously, and also why the web GUI is being deprecated - it is just too difficult to make a GUI that can accommodate all the different combinations and variations of CLI configuration.

Cheers,

Dave.

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

Recognize Your Peers