cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
6696
Views
0
Helpful
4
Replies

Time is 4 hours off on 7975 phones

lbroering
Beginner
Beginner

The time that shows on our 7975 phones is 4 hours earlier than the system time on our UC520. When I go to configure with the CCA 3.1.1, Device Settings - Time, the time is accurate and in the correct time zone. It is as if the phones think they are in a different time zone than the uc520. Anybody know where to change this setting?

I just added a SPA509 phone to our system and it shows the correct time.

4 Replies 4

John Platts
Enthusiast
Enthusiast

There are three different places in the UC500 configuration where the time zone setting needs to be set:

  • The clock timezone setting in the IOS configuration
  • The time-zone setting under the telephony-service section in the IOS configuration
  • The clock timezone setting in the Cisco Unity Express configuration

The timezone setting needs to be correct in all three of these places. You might need to use CLI to change the setting. The problem you are having is probably being caused by the wrong time-zone setting under the telephony-service section in the UC500 configuration.

Here is how you can change the time-zone setting under the telephony-service section in the UC500 configuration:

test-uc520#

test-uc520#conf t

test-uc520#telephony-service

test-uc520(config-telephony)#time-zone ?

  <1-53>  select timezone name used by IP phones (offset in minutes)

1 Dateline Standard Time -720

2 Samoa Standard Time -660

3 Hawaiian Standard Time -600

4 Alaskan Standard/Daylight Time -540

5 Pacific Standard/Daylight Time -480

6 Mountain Standard/Daylight Time -420

7 US Mountain Standard Time -420

8 Central Standard/Daylight Time -360

9 Mexico Standard/Daylight Time -360

10 Canada Central Standard Time -360

11 SA Pacific Standard Time -300

12 Eastern Standard/Daylight Time -300

13 US Eastern Standard Time -300

14 Atlantic Standard/Daylight Time -240

15 SA Western Standard Time -240

16 Newfoundland Standard/Daylight Time -210

17 E. South America Standard/Daylight Time -180

18 SA Eastern Standard Time -180

19 Mid-Atlantic Standard/Daylight Time -120

20 Azores Standard/Daylight Time -60

21 GMT Standard/Daylight Time +0

22 Greenwich Standard Time +0

23 W. Europe Standard/Daylight Time +60

24 GTB Standard/Daylight Time +60

25 Egypt Standard/Daylight Time +60

26 E. Europe Standard/Daylight Time +60

27 Romance Standard/Daylight Time +120

28 Central Europe Standard/Daylight Time +120

29 South Africa Standard Time +120

30 Jerusalem Standard/Daylight Time +120

31 Saudi Arabia Standard Time +180

32 Russian Standard/Daylight Time +180

33 Iran Standard/Daylight Time +210

34 Caucasus Standard/Daylight Time +240

35 Arabian Standard Time +240

36 Afghanistan Standard Time +270

37 West Asia Standard Time +300

38 Ekaterinburg Standard Time +300

39 India Standard Time +330

40 Central Asia Standard Time +360

41 SE Asia Standard Time +420

42 China Standard/Daylight Time +480

43 Taipei Standard Time +480

44 Tokyo Standard Time +540

45 Cen. Australia Standard/Daylight Time +570

46 AUS Central Standard Time +570

47 E. Australia Standard Time +600

48 AUS Eastern Standard/Daylight Time +600

49 West Pacific Standard Time +600

50 Tasmania Standard/Daylight Time +600

51 Central Pacific Standard Time +660

52 Fiji Standard Time +720

53 New Zealand Standard/Daylight Time +720

 


! In this example, we are setting the time zone to Central Standard/Daylight time.

! Be sure to select the number corresponding to your time zone from the list above.

! In this example, the number corresponding to the Central Standard/Daylight time is 8.

test-uc520(config-telephony)#time-zone 8

Be sure to reset your phones and save your UC520 configuration.

Thanks for the quick response. It looks like my time zone settings are ok. I am on eastern daylight time. Here are my settings -

  • The clock timezone setting in the IOS configuration

clock timezone EST -5 0

  • The time-zone setting under the telephony-service section in the IOS configuration

telephony-service

  time-zone 12

  • The clock timezone setting in the Cisco Unity Express configuratio


clock timezone America/New_York

hostname se-10-1-10-1

line console
  length 0
  width 512

system language preferred "en_US"

ip name-server 207.196.34.50 12.161.104.2

ntp server 207.196.34.50 prefer

Is there more than 1 place to set the actual time? I will double check my ntp server, that is an internal address, but it could also be an internet server.

The above settings are actually correct for Eastern Time. Here is another setting that should be in your UC520 configuration since you are in a timezone that respects daylight savings time:

clock summer-time EDT recurring

The actual time can be manually set on both the IOS side and the CUE side of the UC520. However, NTP can also be used to update the time on both the IOS side and CUE side of the UC520.

The time can be manually changed on the UC520 by using CCA or by using the clock set command.

David Trad
Rising star
Rising star

Hi There,

Have you considered resetting the phone to factory defaults? The phone might actually be stuck in a different time zone and is not updating itself when it does its TFTP update, sometimes putting the phone back into factory defaults resolves this issues.

Just a thought...

Cheers,

David.

Cheers, David Trad. **When you rate a persons post, you are indicating a thank you or that it helped, but at the same time you are also helping to maintain the community spirit - You don't have to rate posts and you wont be looked down upon :) *
Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

Recognize Your Peers