Showing results for 
Search instead for 
Did you mean: 

Issue downloading/uploading WLC config file via FTP


I am attempting to obtain a copy of the WLC config from the controller via FTP from GUI and SSH. Multiple FTP/TFTP servers have been attempted, but we keep getting the following error.


cisco updcode.c:6888 Error FTP file Transfer [ftp_put], <150>, Operation now in progress.


WLC is a 2500 running

Any help is appreciated!





13 Replies 13

Rasika Nayanajith
VIP Mentor VIP Mentor
VIP Mentor

Hi Alex,

What is the output when you try to do this via CLI. Here is FTP command syntax. If it is TFTP you have to change mode to tftp & no username/password required. Other lines remain as it is. These works all the time for me (by the way I haval all 5508 & no 2504 to test it out).

transfer upload datatype config
transfer upload mode ftp
transfer upload serverip x.x.x.x
transfer upload path .
transfer upload filename WLC01-11-02-2015-BACKUP.txt 
transfer upload username xyz
transfer upload password abc123
transfer upload start



**** Pls rate all useful responses ****

Here is the output and error log.

*TransferTask: Feb 10 15:17:09.101: #UPDATE-3-FTP_TRANSFER_FAIL: updcode.c:6888 Error FTP file Transfer [ftp_put], <150>, Operation now in progress.



Hey Alex,
Thank you a lot. I have issue with "file no found" while i tried upload config from GUI. And your CLI commands were very helful. WLC 2500




You'll want to use the Upload File options.  Have you tried TFTP?  What message do you get with tftp if you've tried it?


I have been doing Upload (thought it sounds so backwards :) ). I dont have a public TFTP server to upload this to though, so it has been FTP

Solarwinds has a decent free TFTP server that you could utilize. :-)

My issue is that I have no local access to the controller. I am remote and accessing through PATs

Ahh ok.  So if the FTP transfer starts but just hangs, do you have firewall, ips or any other logs you can check to verify you're not getting blocked?

Very basic stateful firewall onsite. I did confirm the outbound FTP connection is allowed.

Did you ever manage to solve this software upload issue on the Cisco 2504 controller? I have the same issue.

Mohammad Roos

This looks to be a bug,

After few attempt to upgrade the WLC,  I was facing slow connection between the FTP and WLC management.

I stopped the transfer since it was not feasible at all.

After fixing the connectivity I noticed that i can't upgrade any more. can't start new FTP transfer, can't reload!!

Tt looks that WLC thinks transfer still in progress ( specially that , it didn't show up a message that FTP transferred stopped , terminated or so)

Desperately i physically powered on/off and it worked.  it looks risky but no chance.

reset system forced   <-- to get out of this, but...


I got a 8510 as an RMA replacement, running, and ran into this problem exactly. TFTP, FTP, on net, off net, doesn't matter, I can't get code or FUS uploaded to it, it's slow as dirt 2k/s and failes at 3.3M or 5M or so. No doubt it's a bug (maybe related to CSCus48353?) but how to I get past the bug if I can't load any new code on the box?


I'm trying to get my customer to plug in the service port, see if I can do it that way, but so far I'm stuck. TAC case opened, nothing yet. 

Hi. Did you manage to solve this problem? I'm having the same issue on a 2504 WLC.
I tried from the server, from my desktop to the controller via tftp ftp and sftp. None of them work.


*TransferTask: Dec 13 13:54:39.079: #UPDATE-3-FTP_TRANSFER_FAIL: updcode.c:6068 Error FTP file Transfer [ftp_get], <150>, Operation now in progress.
*fp_main_task: Dec 13 13:53:09.201: #RMGR-3-PING_OPER_FAILED: rmgr_utils.c:383 Unable to start ICMP ping to host Phy mgr. send operation failed
*fp_main_task: Dec 13 13:53:09.201: #RMGR-3-PING_OPER_FAILED: rmgr_utils.c:372 Unable to start ICMP ping to host Dft GW. send operation failed



Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

Recognize Your Peers