cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
306
Views
20
Helpful
16
Replies

Lost of Connectivity between WLC 9800 and C9300 Switch

M_Abdelwahed
Beginner
Beginner

Hello,

Recently i am facing and disconnection between my WLC (C9800) and C9300 switch ,after troubleshooting the connectivity between both it has been found that there is an input errors on the C9300 port connecting to the WLC the problem is resolved by shutting and opening the switch port ,but it keep happening regularly, so is there any thoughts ? i am suspecting the port speed between the 2 devices could lead to such problem. 

C9300:

GigabitEthernet1/0/46 is up, line protocol is up (connected)
Hardware is Gigabit Ethernet, address is 44ae.25b8.b02f (bia 44ae.25b8.b02f)
MTU 1500 bytes, BW 1000000 Kbit/sec, DLY 10 usec,
reliability 255/255, txload 1/255, rxload 1/255
Encapsulation ARPA, loopback not set
Keepalive set (10 sec)
Full-duplex, 1000Mb/s, media type is 10/100/1000BaseTX
input flow-control is on, output flow-control is unsupported
ARP type: ARPA, ARP Timeout 04:00:00
Last input 00:58:05, output 00:00:00, output hang never
Last clearing of "show interface" counters 1w4d
Input queue: 0/2000/0/0 (size/max/drops/flushes); Total output drops: 2670
Queueing strategy: fifo
Output queue: 0/40 (size/max)
5 minute input rate 0 bits/sec, 0 packets/sec
5 minute output rate 322000 bits/sec, 276 packets/sec
7759558674 packets input, 5610981036172 bytes, 0 no buffer
Received 38966147 broadcasts (34386580 multicasts)
0 runts, 0 giants, 0 throttles
32550 input errors, 32550 CRC, 0 frame, 0 overrun, 0 ignored
0 watchdog, 34386580 multicast, 0 pause input
0 input packets with dribble condition detected
7864326508 packets output, 5542690353435 bytes, 0 underruns
Output 28925904 broadcasts (0 multicasts)
0 output errors, 0 collisions, 0 interface resets
0 unknown protocol drops
0 babbles, 0 late collision, 0 deferred
0 lost carrier, 0 no carrier, 0 pause output
0 output buffer failures, 0 output buffers swapped out


interface GigabitEthernet1/0/46
switchport mode trunk

 

C9800:

TenGigabitEthernet0/1/0 is up, line protocol is up
Hardware is BUILT-IN-2x10GE-C, address is 687d.b4ff.1430 (bia 687d.b4ff.1430)
MTU 1500 bytes, BW 10000000 Kbit/sec, DLY 10 usec,
reliability 255/255, txload 2/255, rxload 2/255
Encapsulation ARPA, loopback not set
Keepalive not supported
Full Duplex, 10000Mbps, link type is auto, media type is RJ45
output flow-control is unsupported, input flow-control is unsupported
ARP type: ARPA, ARP Timeout 04:00:00
Last input 00:00:06, output 00:00:01, output hang never
Last clearing of "show interface" counters never
Input queue: 0/375/0/0 (size/max/drops/flushes); Total output drops: 0
Queueing strategy: Class-based queueing
Output queue: 0/40 (size/max)
5 minute input rate 94841000 bits/sec, 16504 packets/sec
5 minute output rate 96232000 bits/sec, 16195 packets/sec
8597340016 packets input, 6023026986022 bytes, 0 no buffer
Received 0 broadcasts (0 multicasts)
0 runts, 0 giants, 0 throttles
0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
0 watchdog, 0 multicast, 0 pause input
8480049739 packets output, 6095273578404 bytes, 0 underruns
Output 0 broadcasts (0 multicasts)
0 output errors, 0 collisions, 1 interface resets
0 unknown protocol drops
0 babbles, 0 late collision, 0 deferred
0 lost carrier, 0 no carrier, 0 pause output
0 output buffer failures, 0 output buffers swapped out
7 carrier transitions

interface TenGigabitEthernet0/1/0
switchport mode trunk
negotiation auto
service-policy output AutoQos-4.0-wlan-Port-Output-Policy
end

 

 

16 Replies 16

MHM Cisco World
Advisor
Advisor

The  interconnect is speed mismatch that why this error increase 
I recommend hardCode the Speed. 

C9300:

GigabitEthernet1/0/46 is up, line protocol is up (connected)
Hardware is Gigabit Ethernet, address is 44ae.25b8.b02f (bia 44ae.25b8.b02f)
MTU 1500 bytes, BW 1000000 Kbit/sec, DLY 10 usec,
reliability 255/255, txload 1/255, rxload 1/255
Encapsulation ARPA, loopback not set
Keepalive set (10 sec)
Full-duplex, 1000Mb/s, media type is 10/100/1000BaseTX

C9800:

TenGigabitEthernet0/1/0 is up, line protocol is up
Hardware is BUILT-IN-2x10GE-C, address is 687d.b4ff.1430 (bia 687d.b4ff.1430)
MTU 1500 bytes, BW 10000000 Kbit/sec, DLY 10 usec,
reliability 255/255, txload 2/255, rxload 2/255
Encapsulation ARPA, loopback not set
Keepalive not supported
Full Duplex, 10000Mbps, link type is auto, media type is RJ45

 

On the WLC when i try to remove the line "negotiation auto" to hard code the speed , the link goes down and cant access except through console , any idea?

can you check the exact SFP you use in WLC 9800.



 

I am not using SFP , its copper connection

BUILT-IN-2x10GE-C <<- I know it Copper RJ45 
what is exact WLC platform you have 
are it  
WLC (C9800-L-F) ??

WLC (C9800-L-C)

marce1000
VIP Mentor VIP Mentor
VIP Mentor

 

  -  Review the 9800   configuration with the CLI command : show  tech   wireless , have the output analyzed by  https://cway.cisco.com/tools/WirelessAnalyzer/  , please note do not use classical show tech-support (short version) , use the command denoted in green for Wireless Analyzer.               Checkout all advisories!

 M.

Leo Laohoo
VIP Community Legend VIP Community Legend
VIP Community Legend

On the 9300, post the complete output to the command "sh controll e G1/0/46".

Transmit GigabitEthernet1/0/46 Receive
1012055082630 Total bytes 915060990936 Total bytes
1245709734 Unicast frames 1229287368 Unicast frames
902461669274 Unicast bytes 913825786686 Unicast bytes
616225447 Multicast frames 5048602 Multicast frames
92439674607 Multicast bytes 1152404414 Multicast bytes
160583283 Broadcast frames 505727 Broadcast frames
17153738749 Broadcast bytes 82799836 Broadcast bytes
0 System FCS error frames 0 IpgViolation frames
0 MacUnderrun frames 0 MacOverrun frames
0 Pause frames 0 Pause frames
0 Cos 0 Pause frames 0 Cos 0 Pause frames
0 Cos 1 Pause frames 0 Cos 1 Pause frames
0 Cos 2 Pause frames 0 Cos 2 Pause frames
0 Cos 3 Pause frames 0 Cos 3 Pause frames
0 Cos 4 Pause frames 0 Cos 4 Pause frames
0 Cos 5 Pause frames 0 Cos 5 Pause frames
0 Cos 6 Pause frames 0 Cos 6 Pause frames
0 Cos 7 Pause frames 0 Cos 7 Pause frames
0 Oam frames 0 OamProcessed frames
0 Oam frames 0 OamDropped frames
26887277 Minimum size frames 36392285 Minimum size frames
655559160 65 to 127 byte frames 280209931 65 to 127 byte frames
572252887 128 to 255 byte frames 266656630 128 to 255 byte frames
127414320 256 to 511 byte frames 27004786 256 to 511 byte frames
50574571 512 to 1023 byte frames 36869021 512 to 1023 byte frames
589296840 1024 to 1518 byte frames 587557787 1024 to 1518 byte frames
533409 1519 to 2047 byte frames 157729 1519 to 2047 byte frames
0 2048 to 4095 byte frames 0 2048 to 4095 byte frames
0 4096 to 8191 byte frames 0 4096 to 8191 byte frames
0 8192 to 16383 byte frames 0 8192 to 16383 byte frames
0 16384 to 32767 byte frame 0 16384 to 32767 byte frame
0 > 32768 byte frames 0 > 32768 byte frames
0 Late collision frames 0 SymbolErr frames
312 Excess Defer frames 0 Collision fragments
0 Good (1 coll) frames 0 ValidUnderSize frames
0 Good (>1 coll) frames 0 InvalidOverSize frames
0 Deferred frames 0 ValidOverSize frames
0 Gold frames dropped 6472 FcsErr frames
0 Gold frames truncated
0 Gold frames successful
0 1 collision frames
0 2 collision frames
0 3 collision frames
0 4 collision frames
0 5 collision frames
0 6 collision frames
0 7 collision frames
0 8 collision frames
0 9 collision frames
0 10 collision frames
0 11 collision frames
0 12 collision frames
0 13 collision frames
0 14 collision frames
0 15 collision frames
0 Excess collision frames

LAST UPDATE 4196 msecs AGO

Rich R
VIP Advocate VIP Advocate
VIP Advocate

WLC: 9800-L-C

WLC Firmware : 17.3.3

C9300 Running CAT9K_IOSXE (16.12.4)

When i try to remove the configuration line "negotiation auto" on the WLC it goes down and cant access except through console , any idea ?

 

no need I see exact platform you have, 
I will check point about your SFP and update you 

Rich R
VIP Advocate VIP Advocate
VIP Advocate

I don't know about copper ports but on 9800 fibre ports "negotiation auto" is not supported so they will only work with "no negotiation auto" configured.  You'll see errors in the logs for this either way but if it works with negotiation auto configured then that's probably correct.
But that is not speed or duplex.  While in interface config: speed ? and duplex ? to see what the supported options are.

You didn't answer my questions about the PHY firmware - have you checked and updated as required?

17.3.3 is out of date (I presume you're referring to the IOS-XE SOFTWARE when you say WLC Firmware : 17.3.3) - see TAC recommended link in my signature below.  I'd recommend 17.6.4 as long as you don't need to support any wave 1 APs (1700/2700/3700 etc).

Also see https://community.cisco.com/t5/wireless/9800-l-f-sfp-10g-interfaces-wont-connect/td-p/4662043
He mentions: 'speed nonegotiate' on the switchport brought the trunk into life.

You could also consider updating the switch IOS - 17.6.4 is also a good option for that in my opinion.
Recommended Releases for Catalyst 9200/9300/9400/9500/9600 and Catalyst 3650/3850 Platforms - Cisco

MHM Cisco World
Advisor
Advisor

C9300 support up to 1G 
WLC9800 support up to 10G, but as I read it mG meaning it multi G port,
so can you set the value to 1G in WLC9800 and check again?

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community: