cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
537
Views
0
Helpful
3
Replies
Daniel Ziminski
Beginner

Zoom app on iPhone not marking DSCP or 802.11e when connected to Fastlane AP

I have a strange issue.  We have the Zoom app deployed on our corporate iPhones.  We have a mix of Meraki APs and Cisco APs.  We are trying to verify that QoS is set for all Zoom traffic.  We found doing packet captures that we were seeing QoS marked appropriately on Cisco APs (1142, 3802s, 3602s) coming from Zoom iPhone clients.  When those clients were on Meraki APs, we did not see the traffic marked.  It was almost as though the iPhone detected the access point it was on and stopped marking QoS (both DSCP and 802.11e).

 

We thought it might be Fastlane related as Fastlane is on by default on Meraki and we had it off on our Cisco controllers.  Sure enough, when we enabled Fastlane, the Zoom iOS app stopped marking traffic via DSCP or 802.11e.

 

Anyone seen anything like this?  Other iOS apps such as Facetime seem to mark QoS no matter what.  Also Zoom on Android marked QoS no matter what.

3 REPLIES 3
patoberli
VIP Advisor

Never used Fastlane, but it sounds as if you need to create a special profile for the Apple devices.

Check here: https://www.cisco.com/c/dam/en/us/td/docs/wireless/controller/technotes/8-3/Optimizing_WiFi_Connectivity_and_Prioritizing_Business_Apps.pdf Chapter Prioritized Business Apps and following.

I did see that.  Our MDM is Microsoft Intune which doesn't support QoS network profiles.  I don't think a profile is needed though since the default behavior should be to allow all apps to set QoS.  We've tested Facetime calls and other apps.  They seem to be setting QoS fine on a Fastlane enabled AP.  It's just something with Zoom.

"iOS 10 devices can receive a QoS profile (provisioned using standard Apple profile provisioning techniques).  This QoS profile lists the applications that can be put in a whitelist. Applications in a whitelist are authorized to apply upstream QoS marking using Apple Service Type method. Applications that are not in the Whitelist do not mark upstream QoS in a Fastlane enabled network. By default, all applications are whitelisted (i.e. without a QoS whitelist, all applications can mark QoS; when a whitelist is deployed, only applications in the whitelist will mark QoS using the Service_Type method, other applications will receive best effort or background QoS treatment). When supporting iOS 10 devices, associate to a WLAN that is configured for Fastlane, they apply the QoS profile they previously received. The AP also trusts the iOS QoS marking."

dtaylorgra
Beginner

I am also experiencing this behavior with Apple MacOS laptops connecting through a 3504 WLC. The Zoom client will stop marking packets when connected to a Fastlane enabled WLAN. I switched to a non-Fastlane WLAN and suddenly the DSCP markings were passing through. Not sure what the issue is, but disabling Fastlane seems to fix it. 

Create
Recognize Your Peers
Content for Community-Ad