取消
显示结果 
搜索替代 
您的意思是: 
cancel
2124
查看次数
0
有帮助
6
回复

简单VLAN ping问题

Translator
Community Manager
Community Manager

如何使VPC 3(右下)ping VPC 1(左下)

 

VPC 3 = 192.168.1.3

VPC 1 = 192.168.1.50

 

2.png

 

 

 

Switch D! Left Switch

*Jun 12 06:59:24.724: %SYS-5-CONFIG_I: Configured from console by console
D1#sh run
Building configuration...

Current configuration : 4121 bytes
!
! Last configuration change at 01:59:24 EST Sun Jun 12 2022
!
version 15.2
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
service compress-config
!
hostname D1
!
boot-start-marker
boot-end-marker
!
!
!
no aaa new-model
clock timezone EST -5 0
!
!
!
!
!
!
!
ip dhcp pool THIRD_POOL
network 192.168.3.0 255.255.255.0
default-router 192.168.3.1
!
ip dhcp pool SECOND_POOL
network 192.168.2.0 255.255.255.0
default-router 192.168.2.1
!
ip dhcp pool SECOND_VLAN_POOL
default-router 192.168.2.1
!
ip dhcp pool THIRD_VLAN_POOL
default-router 192.168.3.1
!
!
no ip domain-lookup
ip cef
ipv6 unicast-routing
ipv6 cef
!
!
!
spanning-tree mode pvst
spanning-tree extend system-id
!
vlan internal allocation policy ascending
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Port-channel1
switchport trunk encapsulation dot1q
switchport mode trunk
!
interface GigabitEthernet0/0
media-type rj45
negotiation auto
!
interface GigabitEthernet0/1
switchport trunk encapsulation dot1q
switchport mode trunk
media-type rj45
negotiation auto
channel-group 1 mode on
!
interface GigabitEthernet0/2
switchport trunk encapsulation dot1q
switchport mode trunk
media-type rj45
negotiation auto
channel-group 1 mode on
!
interface GigabitEthernet0/3
media-type rj45
negotiation auto
!
interface GigabitEthernet1/0
media-type rj45
negotiation auto
!
interface GigabitEthernet1/1
switchport access vlan 2
switchport mode access
media-type rj45
negotiation auto
!
interface GigabitEthernet1/2
media-type rj45
negotiation auto
!
interface Vlan1
ip address 192.168.1.1 255.255.255.0
ipv6 address FE80::D1:1 link-local
ipv6 address 2001:DB8:ACAD:1000::1/64
!
interface Vlan2
ip address 192.168.2.1 255.255.255.0
ipv6 address FE80::D1:2 link-local
ipv6 address 2001:DB8:ACAD:2000::1/64
!
interface Vlan3
ip address 192.168.3.1 255.255.255.0
ipv6 address FE80::D1:3 link-local
ipv6 address 2001:DB8:ACAD:3000::1/64
!
ip forward-protocol nd
!
no ip http server
no ip http secure-server
!
!
!
!
!
!
control-plane































Switch E2 Right Switch

Switch#
*Jun 12 06:57:24.905: %SYS-5-CONFIG_I: Configured from console by consolesh run
Building configuration...

Current configuration : 3346 bytes
!
! Last configuration change at 01:57:24 EST Sun Jun 12 2022
!
version 15.2
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
service compress-config
!
hostname Switch
!
boot-start-marker
boot-end-marker
!
!
!
no aaa new-model
clock timezone EST -5 0
!
!
!
!
!
!
!
!
ip cef
no ipv6 cef
!
!
!
spanning-tree mode rapid-pvst
spanning-tree extend system-id
!
vlan internal allocation policy ascending
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Port-channel1
switchport trunk encapsulation dot1q
switchport mode trunk
!
interface GigabitEthernet0/0
media-type rj45
negotiation auto
!
interface GigabitEthernet0/1
switchport trunk encapsulation dot1q
switchport mode trunk
media-type rj45
negotiation auto
channel-group 1 mode on
!
interface GigabitEthernet0/2
switchport trunk encapsulation dot1q
switchport mode trunk
media-type rj45
negotiation auto
channel-group 1 mode on
!
interface GigabitEthernet0/3
media-type rj45
negotiation auto
!
interface GigabitEthernet1/0
media-type rj45
negotiation auto
!
interface GigabitEthernet1/1
media-type rj45
negotiation auto
!
interface GigabitEthernet1/2
media-type rj45
negotiation auto
!
interface Vlan1
ip address 192.168.1.3 255.255.255.0
ipv6 address FE80::A1:1 link-local
ipv6 address 2001:DB8:ACAD:1000::3/64
!
ip forward-protocol nd
!
no ip http server
no ip http secure-server
!
!
!
!
!
!
control-plane


 

 

 

1 个已接受解答

已接受的解答

Translator
Community Manager
Community Manager

中继需要允许VLAN 

我仔细检查您的配置VLAN1的IP地址与PC的IP地址相同?我觉得你在这里搞错了。

在原帖中查看解决方案

6 条回复6

Translator
Community Manager
Community Manager

这是错的 

你需要,

两个软件之间的L2,因为两个软件都连接到同一子网。

您配置了第3层软件,但是 

仅在软件之间配置中继或访问l2,您可以ping

Translator
Community Manager
Community Manager

它是2和2之间的中继端口

 

 

我缺少一些简单的方法,让右下角的VPC通过端口通道发送ping,但我不知道

 

interface GigabitEthernet0/1
switchport trunk encapsulation dot1q
switchport mode trunk
media-type rj45
negotiation auto
channel-group 1 mode on
!
interface GigabitEthernet0/2
switchport trunk encapsulation dot1q
switchport mode trunk
media-type rj45
negotiation auto
channel-group 1 mode on

Translator
Community Manager
Community Manager

中继需要允许VLAN 

我仔细检查您的配置VLAN1的IP地址与PC的IP地址相同?我觉得你在这里搞错了。

Translator
Community Manager
Community Manager

正是这样,谢谢你

Translator
Community Manager
Community Manager

您使用vlan 1时,VLAN不应成为问题。

 但是,请确保VPC能ping通网关

并确保在端口通道上需要dot1q

 

Translator
Community Manager
Community Manager

我这么做了,我觉得是小的地方我配置错了,现在我找不到它,尽管我以为只有我找不到,我快疯了……

快捷链接