cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
339
Views
10
Helpful
3
Replies
Ramesh3
Beginner

DevNet Sandbox- NXOS device connectivity issue

Hello,

I'm having an issue in connecting to NX-OS switches(unable to ping/ssh) in Open NX-OS Sandbox. Please suggest

 

Note: I am able to access DevBox , VMMaestro, VIRL server. Connected to Sandbox using OpenConnect VPN

 

Thanks in advance

1 ACCEPTED SOLUTION

Accepted Solutions
omz
VIP Collaborator VIP Collaborator
VIP Collaborator

Last time I used the sandbox .. and if I remember correctly .. you need to start the simulation on the VIRL server to bring the devices up

View solution in original post

3 REPLIES 3
omz
VIP Collaborator VIP Collaborator
VIP Collaborator

Last time I used the sandbox .. and if I remember correctly .. you need to start the simulation on the VIRL server to bring the devices up

View solution in original post

carlocon
Cisco Employee

I tried to restart NX-OX using virl however servers always are labeled UNRECHEABLE

Here is a list of all the running nodes
╒══════════════╤═════════════╤═════════╤═════════════╤════════════╤══════════════════════╤════════════════════╕
│ Node │ Type │ State │ Reachable │ Protocol │ Management Address │ External Address │
╞══════════════╪═════════════╪═════════╪═════════════╪════════════╪══════════════════════╪════════════════════╡
│ nx-osv9000-4 │ NX-OSv 9000 │ ACTIVE │ UNREACHABLE │ telnet │ 172.16.30.104 │ N/A │
├──────────────┼─────────────┼─────────┼─────────────┼────────────┼──────────────────────┼────────────────────┤
│ nx-osv9000-2 │ NX-OSv 9000 │ ACTIVE │ UNREACHABLE │ telnet │ 172.16.30.102 │ N/A │
├──────────────┼─────────────┼─────────┼─────────────┼────────────┼──────────────────────┼────────────────────┤
│ nx-osv9000-3 │ NX-OSv 9000 │ ACTIVE │ UNREACHABLE │ telnet │ 172.16.30.103 │ N/A │
├──────────────┼─────────────┼─────────┼─────────────┼────────────┼──────────────────────┼────────────────────┤
│ nx-osv9000-1 │ NX-OSv 9000 │ ACTIVE │ UNREACHABLE │ telnet │ 172.16.30.101 │ N/A │
╘══════════════╧═════════════╧═════════╧═════════════╧════════════╧══════════════════════╧════════════════════╛
[developer@devbox sbx_nxos]$

 

Previously this passed from ABSENT to BUILDING and finally ACTIVE but the reachable state always remained UNREACHABLE

Update:

After a while all servers finally transition to reachable state:

 

[developer@devbox sbx_nxos]$virl nodes
Here is a list of all the running nodes
╒══════════════╤═════════════╤═════════╤═════════════╤════════════╤══════════════════════╤════════════════════╕
│ Node │ Type │ State │ Reachable │ Protocol │ Management Address │ External Address │
╞══════════════╪═════════════╪═════════╪═════════════╪════════════╪══════════════════════╪════════════════════╡
│ nx-osv9000-4 │ NX-OSv 9000 │ ACTIVE │ REACHABLE │ telnet │ 172.16.30.104 │ N/A │
├──────────────┼─────────────┼─────────┼─────────────┼────────────┼──────────────────────┼────────────────────┤
│ nx-osv9000-2 │ NX-OSv 9000 │ ACTIVE │ REACHABLE │ telnet │ 172.16.30.102 │ N/A │
├──────────────┼─────────────┼─────────┼─────────────┼────────────┼──────────────────────┼────────────────────┤
│ nx-osv9000-3 │ NX-OSv 9000 │ ACTIVE │ UNREACHABLE │ telnet │ 172.16.30.103 │ N/A │
├──────────────┼─────────────┼─────────┼─────────────┼────────────┼──────────────────────┼────────────────────┤
│ nx-osv9000-1 │ NX-OSv 9000 │ ACTIVE │ REACHABLE │ telnet │ 172.16.30.101 │ N/A │
╘══════════════╧═════════════╧═════════╧═════════════╧════════════╧══════════════════════╧════════════════════╛
[developer@devbox sbx_nxos]$

 

Still after a while server 172.16.30.103 was un reachable but at least I was able to test the rest of the servers !

 

 

 

Content for Community-Ad