cancel
Showing results for 
Search instead for 
Did you mean: 
cancel

Common Installation Problems and Solutions

1484
Views
0
Helpful
4
Comments

Currently Supported Environments

  • Python 3.4.x, 3.5.x, 3.6.x, 64-bit
  • Linux x86_64 or Mac OSX 10.13.3+

Error: Could not find any downloads that satisfy the requirement pyats

make sure you upgrade pip & setuptools to latest versions.

pip install --upgrade pip setuptools

and try again. Also, it may be worth it to try invalidating the pip built-in cache:

pip install pyats --no-cache-dir

In addition, make sure you are running with 64-bit Python executable. 32-bit Python is not supported.

If you've done all the above and your installation still doesn't work, please let us know, and send us the output of the following command in your python environment:

# pip version < v10.0.0

python -c "from pip import pep425tags; [print(i) for i in pep425tags.get_supported()]"

# pip version >= v10.0.0

python -c "from pip._internal import pep425tags; [print(i) for i in pep425tags.get_supported()]"

I cannot find examples & templates folder post-installation

Normally if you installed within a Python virtual environment, the examples and templates folder would be straight under $VIRTUAL_ENV/ root directory. If you installed into the system directly, it most likely would be available under /usr directory

Comments
Beginner

I see this is an old post, however I am having issue installing Pyats and Genie V19.0. How should we submit files?

Cisco Employee

Having this issue when installing 'pip install pyats genie'

---------------------------------

running: ubuntu on vbox on windows 10

(pyats) rod@rod-VirtualBox:~/pyats/bin$ cat /etc/os-release
NAME="Ubuntu"
VERSION="18.04.1 LTS (Bionic Beaver)"

----------------------------------

(pyats) rod@rod-VirtualBox:~/pyats/bin$ python --version
Python 3.6.7
(pyats) rod@rod-VirtualBox:~/pyats/bin$ pip --version
pip 19.1 from /home/rod/pyats/lib/python3.6/site-packages/pip (python 3.6)
(pyats) rod@rod-VirtualBox:~/pyats/bin$ pip list
Package Version
-------------------- -------
Jinja2 2.10.1
junit-xml 1.8
MarkupSafe 1.1.1
pip 19.1
pkg-resources 0.0.0
pyats.async 19.0
pyats.datastructures 19.0
pyats.examples 19.0
pyats.log 19.0.1
pyats.results 19.0
setuptools 41.0.1
six 1.12.0

 

 

error

------------------

creating build/temp.linux-x86_64-3.6/psutil
x86_64-linux-gnu-gcc -pthread -DNDEBUG -g -fwrapv -O2 -Wall -g -fstack-protector-strong -Wformat -Werror=format-security -Wdate-time -D_FORTIFY_SOURCE=2 -fPIC -DPSUTIL_POSIX=1 -DPSUTIL_VERSION=562 -DPSUTIL_LINUX=1 -I/home/rod/pyats/include -I/usr/include/python3.6m -c psutil/_psutil_common.c -o build/temp.linux-x86_64-3.6/psutil/_psutil_common.o
psutil/_psutil_common.c:9:10: fatal error: Python.h: No such file or directory
#include <Python.h>
^~~~~~~~~~
compilation terminated.
error: command 'x86_64-linux-gnu-gcc' failed with exit status 1
----------------------------------------
ERROR: Command "/home/rod/pyats/bin/python3 -u -c 'import setuptools, tokenize;__file__='"'"'/tmp/pip-install-al1c0wcv/psutil/setup.py'"'"';f=getattr(tokenize, '"'"'open'"'"', open)(__file__);code=f.read().replace('"'"'\r\n'"'"', '"'"'\n'"'"');f.close();exec(compile(code, __file__, '"'"'exec'"'"'))' install --record /tmp/pip-record-biuagtum/install-record.txt --single-version-externally-managed --compile --install-headers /home/rod/pyats/include/site/python3.6/psutil" failed with error code 1 in /tmp/pip-install-al1c0wcv/psutil/

Beginner

Hey Rosia,

 

I did figure out the solution to my problem. I had to install the dev kit for the version of python i was using. 

 

sudo apt-get install build-esssential python3.6-dev

 

After that command was run, everything worked as it was intended. Hopefully this helps you too.

Cisco Employee

hi poconnor817,

 

Couldn't seem to find this package. Searched for it in ubuntu as well.

==========

rod@rod-VirtualBox:~$ sudo apt-get install build-esssential python3.6-dev
Reading package lists... Done
Building dependency tree
Reading state information... Done
E: Unable to locate package build-esssential

===========

 

what worked for me eventually was to move down to python 3.4 and redo everything. Finally was able to install both pyats and genie

 

 

 

Content for Community-Ad
August's Community Spotlight Awards
This widget could not be displayed.